Subject: [Rats] Review of draft-birkholz-rats-daa

From: Thomas Fossati <[email-masked]>
Date: Wed, 26 May 2021 12:03:49 +0000

Hi RATS-DAA authors,

I have reviewed draft-birkholz-rats-daa-00 and I think this is a useful
document, plus it is short and sweet.

I may have a few editorial suggestions, but I'd like to ask one meta
question first - apologies if this was brought up in previous
conversations:

Is it really necessary to introduce the new "DAA Issuer" role?

It seems to me that if the JOIN and SIGN phases are considered as two
separate attestation protocols, the Issuer could be mapped to a couple
of well-known RATS roles depending on the phase it is involved in:
* Verifier for JOIN - plus an authorisation RP on top that grants
  the group credentials to the authenticated Attester;
* Endorser for SIGN.

Cheers, thank you.

t

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 26 May 2021 13:58:50 +0000

Hi Henk,

I have not been following the RATS work closely and hence I was wondering whether this document is supposed to become part of the architecture document?
In any case, [DAA] has to be a normative reference. I would also like to see the privacy properties articulated in more detail, particularly when DAA is used with an attestation token that potentially contains a lot of claims.

Ciao
Hannes

-----Original Message-----
From: RATS <[email-masked]> On Behalf Of Thomas Fossati
Sent: Wednesday, May 26, 2021 2:04 PM
To: [email-masked]
Cc: [email-masked]; Thomas Fossati <[email-masked]>
Subject: [Rats] Review of draft-birkholz-rats-daa

Hi RATS-DAA authors,

I have reviewed draft-birkholz-rats-daa-00 and I think this is a useful document, plus it is short and sweet.

I may have a few editorial suggestions, but I'd like to ask one meta question first - apologies if this was brought up in previous
conversations:

It seems to me that if the JOIN and SIGN phases are considered as two separate attestation protocols, the Issuer could be mapped to a couple of well-known RATS roles depending on the phase it is involved in:
* Verifier for JOIN - plus an authorisation RP on top that grants
  the group credentials to the authenticated Attester;
* Endorser for SIGN.

Cheers, thank you.

t

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.
_______________________________________________
RATS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rats
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.