Subject: [Rats] Review for adoptions call to https://datatracker.ietf.org/doc/draft-birkholz-rats-daa/

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Sun, 23 May 2021 21:48:59 +0000

Hello RATS participants, 
The substantive text in https://datatracker.ietf.org/doc/draft-birkholz-rats-daa/ was part of the Interaction Models draft which was already adopted; and this draft is a short read,
I'd like to have a few participants do a quick review as we will need to do a call for adoption for this draft, can I get some volunteers to read and provide feedback?

Thanks, Nancy

On 4/25/21, 11:25 PM, "RATS on behalf of Henk Birkholz" <[email-masked] on behalf of [email-masked]> wrote:

    Hi all,
    
    this submission of the Reference Interaction Models addresses most of 
    the 20+ issues raised during the last rounds of reviews.
    
    While addressing the issues we split the I-D in two parts:
    
    1.) I-D.birkholz-rats-daa-00 now contains the additions to the RATS 
    architecture & the RATS Models that enable the use of direct anonymous 
    attestation:
    
    > https://datatracker.ietf.org/doc/draft-birkholz-rats-daa/
    
    2.) I-D.ietf-rats-reference-interaction-models-02 now includes only what 
    the title says, which are the RATS Models, corresponding information 
    elements, and requirements:
    
    > https://datatracker.ietf.org/doc/draft-ietf-rats-reference-interaction-models/
    
    This way, implementers can unambiguously find the content they are 
    looking for. As the scope and intent of the content about DAA that is 
    now in the new I-D has not changed, we'd like to ask for a call for WGA 
    before the next meeting in the same swoop.
    
    Viele Grüße,
    
    Henk
    
    On 26.04.21 07:49, [email-masked] wrote:
    > 
    > A New Internet-Draft is available from the on-line Internet-Drafts directories.
    > This draft is a work item of the Remote ATtestation ProcedureS WG of the IETF.
    > 
    >          Title           : Reference Interaction Models for Remote Attestation Procedures
    >          Authors         : Henk Birkholz
    >                            Michael Eckel
    >                            Wei Pan
    >                            Eric Voit
    > 	Filename        : draft-ietf-rats-reference-interaction-models-02.txt
    > 	Pages           : 21
    > 	Date            : 2021-04-25
    > 
    > Abstract:
    >     This document describes interaction models for remote attestation
    >     procedures (RATS).  Three conveying mechanisms -- Challenge/Response,
    >     Uni-Directional, and Streaming Remote Attestation -- are illustrated
    >     and defined.  Analogously, a general overview about the information
    >     elements typically used by corresponding conveyance protocols are
    >     highlighted.
    > 
    > 
    > The IETF datatracker status page for this draft is:
    > https://datatracker.ietf.org/doc/draft-ietf-rats-reference-interaction-models/
    > 
    > There is also an HTML version available at:
    > https://www.ietf.org/archive/id/draft-ietf-rats-reference-interaction-models-02.html
    > 
    > A diff from the previous version is available at:
    > https://www.ietf.org/rfcdiff?url2=draft-ietf-rats-reference-interaction-models-02
    > 
    > 
    > Please note that it may take a couple of minutes from the time of submission
    > until the htmlized version and diff are available at tools.ietf.org.
    > 
    > Internet-Drafts are also available by anonymous FTP at:
    > ftp://ftp.ietf.org/internet-drafts/
    > 
    > 
    > _______________________________________________
    > RATS mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/rats
    > 
    
    _______________________________________________
    RATS mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/rats

---

From: Thomas Fossati <[email-masked]>
Date: Tue, 25 May 2021 18:08:02 +0100

Hi Nancy,

> I'd like to have a few participants do a quick review as we will need to do a call for adoption for this draft, can I get some volunteers to read and provide feedback?

I will review.

-- 
Thomas

---

From: Guy Fedorkow <[email-masked]>
Date: Wed, 26 May 2021 16:13:06 +0000

Hi Nancy,
  I don't object, but I also don't know of a use-case for DAA in the kind of gear my employer usually makes.
/guy

Juniper Business Use Only

-----Original Message-----
From: RATS <[email-masked]> On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Sunday, May 23, 2021 5:49 PM
To: [email-masked]
Subject: [Rats] Review for adoptions call to https://datatracker.ietf.org/doc/draft-birkholz-rats-daa/

[External Email. Be cautious of content]

Hello RATS participants,
The substantive text in https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-birkholz-rats-daa/__;!!NEt6yMaO-gk!Wn3K99qKV33R-KJHgvPRIWDo45x5ZHYwe1HCeGe8gdpblOvMaPr1vWvo766_qRft4bI$  was part of the Interaction Models draft which was already adopted; and this draft is a short read, I'd like to have a few participants do a quick review as we will need to do a call for adoption for this draft, can I get some volunteers to read and provide feedback?

Thanks, Nancy

    Hi all,

    attestation:

    > https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-birkholz-rats-daa/__;!!NEt6yMaO-gk!Wn3K99qKV33R-KJHgvPRIWDo45x5ZHYwe1HCeGe8gdpblOvMaPr1vWvo766_qRft4bI$

    2.) I-D.ietf-rats-reference-interaction-models-02 now includes only what
    the title says, which are the RATS Models, corresponding information
    elements, and requirements:

    > https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-rats-reference-interaction-models/__;!!NEt6yMaO-gk!Wn3K99qKV33R-KJHgvPRIWDo45x5ZHYwe1HCeGe8gdpblOvMaPr1vWvo766_fm1IhGo$

    Viele Grüße,

    Henk

    On 26.04.21 07:49, [email-masked] wrote:
    > https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-rats-reference-interaction-models/__;!!NEt6yMaO-gk!Wn3K99qKV33R-KJHgvPRIWDo45x5ZHYwe1HCeGe8gdpblOvMaPr1vWvo766_fm1IhGo$
    >
    > https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-ietf-rats-reference-interaction-models-02.html__;!!NEt6yMaO-gk!Wn3K99qKV33R-KJHgvPRIWDo45x5ZHYwe1HCeGe8gdpblOvMaPr1vWvo766_VTX9TQk$
    >
    > https://urldefense.com/v3/__https://www.ietf.org/rfcdiff?url2=draft-ietf-rats-reference-interaction-models-02__;!!NEt6yMaO-gk!Wn3K99qKV33R-KJHgvPRIWDo45x5ZHYwe1HCeGe8gdpblOvMaPr1vWvo766_D9DRCHQ$
    >
    >
    > https://urldefense.com/v3/__ftp://ftp.ietf.org/internet-drafts/__;!!NEt6yMaO-gk!Wn3K99qKV33R-KJHgvPRIWDo45x5ZHYwe1HCeGe8gdpblOvMaPr1vWvo766_ZcrxIlU$
    >
    >
    > https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/rats__;!!NEt6yMaO-gk!Wn3K99qKV33R-KJHgvPRIWDo45x5ZHYwe1HCeGe8gdpblOvMaPr1vWvo766_quBD-wc$
    >

    _______________________________________________
    RATS mailing list
    [email-masked]
    https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/rats__;!!NEt6yMaO-gk!Wn3K99qKV33R-KJHgvPRIWDo45x5ZHYwe1HCeGe8gdpblOvMaPr1vWvo766_quBD-wc$

_______________________________________________
RATS mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/rats__;!!NEt6yMaO-gk!Wn3K99qKV33R-KJHgvPRIWDo45x5ZHYwe1HCeGe8gdpblOvMaPr1vWvo766_quBD-wc$

---

From: Laurence Lundblade <[email-masked]>
Date: Wed, 26 May 2021 21:21:54 -0700

I think DAA is important for RATS and should eventually be covered in with documents that say exactly how to do it, the actual specific crypto. 

I’m not a DAA expert, but I think there are ways use use DAA other than the architecture in this draft. For example, I think Thomas’s comments are towards this and I think FIDO’s use of DAA is different.

Since endorsements are out of scope per the charter, this seems close to the edge of scope set in the charter.

But, none of this is an objection to adoption. :-)

LL

> On May 23, 2021, at 2:48 PM, Nancy Cam-Winget (ncamwing) <ncamwing=[email-masked]> wrote:
> 
> Hello RATS participants,