Subject: [Rats] Often Attester == Device?

From: Laurence Lundblade <[email-masked]>
Date: Sat, 23 Oct 2021 11:31:42 -0400

Hi,

This is a question of clarification.

Take the example of a mobile phone running Android with a TEE.
- The Attesting Environment is in the TEE
  - The TEE has keys that sign Attestation Evidence
  - The TEE has access to all of Android (but Android has no access to the TEE)
- The Attestation Evidence it produces includes:
  - The version, boot and debug state of Android
  - Measurements (e.g. hashes) of Android system files
  - Measurements of the running Android kernel

The Attester includes *all of Android*, right?

I draw this conclusion based on figure 2 from the RATS Architecture diagram reproduced below. Android is the Target Environment thus making it part of the Attester.

It will be common for the “Attester" to be the whole device (Phone, laptop, car, washing machine...)  or nearly so. This is a little surprising to me, but seems OK.

LL

                    .--------------------------------.
                    |                                |
                    |            Verifier            |
                    |                                |
                    '--------------------------------'
                                            ^
                                            |
                  .-------------------------|----------.
                  |                         |          |
                  |   .----------------.    |          |
                  |   | Target         |    |          |
                  |   | Environment    |    |          |
                  |   |                |    | Evidence |
                  |   '----------------'    |          |
                  |                   |     |          |
                  |                   |     |          |
                  |          Collect  |     |          |
                  |           Claims  |     |          |
                  |                   |     |          |
                  |                   v     |          |
                  |                 .-------------.    |
                  |                 | Attesting   |    |
                  |                 | Environment |    |
                  |                 |             |    |
                  |                 '-------------'    |
                  |               Attester             |
                  '------------------------------------'

                    Figure 2: Two Types of Environments

---

From: "Smith, Ned" <[email-masked]>
Date: Mon, 25 Oct 2021 15:36:01 +0000

@Laurence Lundblade<mailto:[email-masked]> As you have described the use case, the attester role appears to be applied to the ‘whole device’.
There are other use cases where the ‘device’ has multiple roots of trust, multiple attesters and even verifiers.

From: RATS <[email-masked]> on behalf of Laurence Lundblade <[email-masked]>
Date: Saturday, October 23, 2021 at 8:32 AM
To: rats <[email-masked]>
Subject: [Rats] Often Attester == Device?

Hi,

LL

                    |                                |

                    |            Verifier            |

                    |                                |

                                            ^

                                            |

                  |                         |          |

                  |   .----------------.    |          |

                  |   | Target         |    |          |

                  |   | Environment    |    |          |

                  |   |                |    | Evidence |

                  |   '----------------'    |          |

                  |                   |     |          |

                  |                   |     |          |

                  |          Collect  |     |          |

                  |           Claims  |     |          |

                  |                   |     |          |

                  |                   v     |          |

                  |                 .-------------.    |

                  |                 | Attesting   |    |

                  |                 | Environment |    |

                  |                 |             |    |

                  |                 '-------------'    |

                  |               Attester             |