Subject: Re: [Rats] Adoption call to https://datatracker.ietf.org/doc/draft-birkholz-rats-daa/

From: "Smith, Ned" <[email-masked]>
Date: Thu, 28 Oct 2021 00:01:39 +0000

I agree the DAA draft is ready for an adoption call.

However, the draft doesn't do a good job of explaining how the endorsement claims that are supplied to the DAA Issuer are conveyed to the Verifier for subsequent appraisal. Although it may be that the DAA Issuer appraises them as a condition of creating the credential and conveying the group public key. The Verifier may nevertheless expect the Attester to have a particular set of endorsement claims. These could be conveyed to the Verifier in a variety of ways but those ways are not explained (or not in sufficient detail for the reader to reasonably infer). 

Keeping in mind that the value having privacy revealing properties is the Attester credential request. The Endorsement claims do not privacy revealing.

- If Endorsement claims are copied into the credential, the conveyance route through the Attester is exemplary only. It could have been conveyed from DAA Isser directly to Verifier. Since the authority of the credential is from the DAA Issuer and conveyance isn't a goal of the RATS Roles architecture. The conveyance path through the Attester is not the most direct path. Maybe there is a particular conveyance model the authors have in mind but that seems to be overloaded in the roles architecture.

- If the Endorsement claims are associated with the conveyance of the group public key this is not evident either. Given the group public key is something like an X.509 certificate the Endorsement claims might be included with the public key and authorized by a DAA Issuer key. It isn't clear that the Credential couldn't also be an X.509 certificate containing the group public key.

The draft mentions Intel EPID as an example of DAA that also supports revocation. In an EPID flow, the Credential is more correctly represented as a blinded group private key. The Group Public Key is most like an X.509 certificate that is signed by the DAA Issuer and contains the group identity value. It may contain additional attributes. 

These points need to be clarified so that someone familiar with EPID would be able to effectively apply the attestation properties described in the draft to an EPID system. 

-Ned

On 10/26/21, 7:44 PM, "RATS on behalf of Nancy Cam-Winget (ncamwing)" <[email-masked] on behalf of ncamwing=[email-masked]> wrote:

    Hello Rats participants,

    Thank you to the few that have reviewed and provided comments on the list for this draft.  I also noticed that the longer discussion on the roles seems to have been addressed in the new additions of the Privacy and Security consideration sections and a new draft with Dave Thaler as an added author has been submitted.

    With those updates, this is now the call for adoption to draft https://www.ietf.org/archive/id/draft-birkholz-rats-daa-02

    Please provide feedback if you have concerns on adopting this document as a working group draft.  We'll close the adoption call on Nov 12.

    Thanks, Nancy
    (on behalf of the RATS chairs)

    On 5/23/21, 2:49 PM, "RATS on behalf of Nancy Cam-Winget (ncamwing)" <[email-masked] on behalf of ncamwing=[email-masked]> wrote:

        Hello RATS participants, 
        The substantive text in https://datatracker.ietf.org/doc/draft-birkholz-rats-daa/ was part of the Interaction Models draft which was already adopted; and this draft is a short read,
        I'd like to have a few participants do a quick review as we will need to do a call for adoption for this draft, can I get some volunteers to read and provide feedback?

        Thanks, Nancy

        On 4/25/21, 11:25 PM, "RATS on behalf of Henk Birkholz" <[email-masked] on behalf of [email-masked]> wrote:

            Hi all,

            this submission of the Reference Interaction Models addresses most of 
            the 20+ issues raised during the last rounds of reviews.

            While addressing the issues we split the I-D in two parts:

            1.) I-D.birkholz-rats-daa-00 now contains the additions to the RATS 
            architecture & the RATS Models that enable the use of direct anonymous 
            attestation:

            > https://datatracker.ietf.org/doc/draft-birkholz-rats-daa/

            2.) I-D.ietf-rats-reference-interaction-models-02 now includes only what 
            the title says, which are the RATS Models, corresponding information 
            elements, and requirements:

            > https://datatracker.ietf.org/doc/draft-ietf-rats-reference-interaction-models/

            This way, implementers can unambiguously find the content they are 
            looking for. As the scope and intent of the content about DAA that is 
            now in the new I-D has not changed, we'd like to ask for a call for WGA 
            before the next meeting in the same swoop.

            Viele Grüße,

            Henk

            On 26.04.21 07:49, [email-masked] wrote:
            > 
            > A New Internet-Draft is available from the on-line Internet-Drafts directories.
            > This draft is a work item of the Remote ATtestation ProcedureS WG of the IETF.
            > 
            >          Title           : Reference Interaction Models for Remote Attestation Procedures
            >          Authors         : Henk Birkholz
            >                            Michael Eckel
            >                            Wei Pan
            >                            Eric Voit
            > 	Filename        : draft-ietf-rats-reference-interaction-models-02.txt
            > 	Pages           : 21
            > 	Date            : 2021-04-25
            > 
            > Abstract:
            >     This document describes interaction models for remote attestation
            >     procedures (RATS).  Three conveying mechanisms -- Challenge/Response,
            >     Uni-Directional, and Streaming Remote Attestation -- are illustrated
            >     and defined.  Analogously, a general overview about the information
            >     elements typically used by corresponding conveyance protocols are
            >     highlighted.
            > 
            > 
            > The IETF datatracker status page for this draft is:
            > https://datatracker.ietf.org/doc/draft-ietf-rats-reference-interaction-models/
            > 
            > There is also an HTML version available at:
            > https://www.ietf.org/archive/id/draft-ietf-rats-reference-interaction-models-02.html
            > 
            > A diff from the previous version is available at:
            > https://www.ietf.org/rfcdiff?url2=draft-ietf-rats-reference-interaction-models-02
            > 
            > 
            > Please note that it may take a couple of minutes from the time of submission
            > until the htmlized version and diff are available at tools.ietf.org.
            > 
            > Internet-Drafts are also available by anonymous FTP at:
            > ftp://ftp.ietf.org/internet-drafts/
            > 
            > 
            > _______________________________________________
            > RATS mailing list
            > [email-masked]
            > https://www.ietf.org/mailman/listinfo/rats
            > 

            _______________________________________________
            RATS mailing list
            [email-masked]
            https://www.ietf.org/mailman/listinfo/rats

        _______________________________________________
        RATS mailing list
        [email-masked]
        https://www.ietf.org/mailman/listinfo/rats

    _______________________________________________
    RATS mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/rats

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 28 Oct 2021 07:14:47 +0200

Hi Ned,

thank you for the detailed feedback! You are correct, I think, 
especially with your closing remark: if we use EPID as an example, we 
should make sure that we map into a EPID system seamlessly.

I am not sure how to implement the highlighted changes best, actually. 
I'll sync with the co-authors and we'll find out. We might might come 
back with a set of clarifying questions or requests for proposal after 
adoption.

Thanks again & viele Grüße,

Henk