Subject: Re: [Rats] IPR statements about draft-ietf-rats-architecture

From: Dave Thaler <[email-masked]>
Date: Wed, 8 Dec 2021 18:58:59 +0000

My personal opinion is that publication should proceed, especially
since the architecture document is just Informational.

Dave

-----Original Message-----
From: RATS <[email-masked]> On Behalf Of Michael Richardson
Sent: Saturday, November 20, 2021 7:46 AM
To: Kathleen Moriarty <[email-masked]>; Eric Voit (evoit) <[email-masked]>; Hannes Tschofenig <[email-masked]>; [email-masked]
Subject: Re: [Rats] IPR statements about draft-ietf-rats-architecture

Kathleen Moriarty <[email-masked]> wrote:
    > I wouldn’t go by that date as I did a call for IPR and then had to
    > wait. That might have been the trigger, not sure.

    > Hannes, can your lawyers look at what’s been provided so far?

The IPR disclosures on the IETF web site are almost always completely useless.  This one included in my opinion.

Worse, a typo in the markup of the previous version means that the 3.1 heading actually didn't render.  So it's not clear what the IPR claim refers to.

At best the IPR declaration tells us what patent application to look at, and we don't even know if the PTO will even accept all the claims.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Ira McDonald <[email-masked]>
Date: Wed, 8 Dec 2021 16:36:56 -0500

Hi,

I agree w/ Dave Thaler - publish this Informational RATS Architecture as is.

There has already been far too long a delay.

Cheers,
- Ira

*Ira McDonald (Musician / Software Architect)*

*Chair - SAE Trust Anchors and Authentication TF*
*Co-Chair - TCG Trusted Mobility Solutions WG*

*Co-Chair - TCG Metadata Access Protocol SG*

*Chair - Linux Foundation Open Printing WGSecretary - IEEE-ISTO Printer
Working GroupCo-Chair - IEEE-ISTO PWG Internet Printing Protocol WGIETF
Designated Expert - IPP & Printer MIBBlue Roof Music / High North
Inchttp://sites.google.com/site/blueroofmusic
<http://sites.google.com/site/blueroofmusic>http://sites.google.com/site/highnorthinc
<http://sites.google.com/site/highnorthinc>mailto: [email-masked]
<[email-masked]>(permanent) PO Box 221  Grand Marais, MI 49839
906-494-2434*

On Wed, Dec 8, 2021 at 1:59 PM Dave Thaler <dthaler=
[email-masked]> wrote:

> To: Kathleen Moriarty <[email-masked]>; Eric Voit
> (evoit) <[email-masked]>; Hannes Tschofenig <[email-masked]>;
> [email-masked]
> The IPR disclosures on the IETF web site are almost always completely
> useless.  This one included in my opinion.
>
> Worse, a typo in the markup of the previous version means that the 3.1
> heading actually didn't render.  So it's not clear what the IPR claim
> refers to.
>
> At best the IPR declaration tells us what patent application to look at,
> and we don't even know if the PTO will even accept all the claims.
>
> --
> _______________________________________________
> RATS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rats
>

---

From: Thomas Hardjono <[email-masked]>
Date: Wed, 8 Dec 2021 21:46:38 +0000

+1  Agree with Dave.  

Its about time we have a stable set of terminologies & concepts contained in an RFC that we can point to.

--thomas

________________________________________
From: RATS [[email-masked]] on behalf of Dave Thaler [dthaler=[email-masked]]
Sent: Wednesday, December 8, 2021 1:58 PM
To: Michael Richardson; Kathleen Moriarty; Eric Voit (evoit); Hannes Tschofenig; [email-masked]
Subject: Re: [Rats] IPR statements about draft-ietf-rats-architecture

Dave

---

From: "Smith, Ned" <[email-masked]>
Date: Wed, 8 Dec 2021 22:35:11 +0000

The patent application is available to the public (for those who are able to read it) here: (https://appft.uspto.gov/netacgi/nph-Parser?Sect1=PTO1&Sect2=HITOFF&p=1&u=/netahtml/PTO/srchnum.html&r=1&f=G&l=50&d=PG01&s1=20210314365.PGNR.) 
or here (https://patents.google.com/patent/US20210314365A1/)
-Ned

On 12/8/21, 1:58 PM, "RATS on behalf of Thomas Hardjono" <[email-masked] on behalf of [email-masked]> wrote:

    +1  Agree with Dave.  

    --thomas

    Dave

---

From: Guy Fedorkow <[email-masked]>
Date: Wed, 8 Dec 2021 23:04:23 +0000

Of course we're uncomfortable about an unquantifiable IPR risk, but I agree with Ira, we should move forward with the document as-is.
  /guy

Juniper Business Use Only
From: RATS <[email-masked]> On Behalf Of Ira McDonald
Sent: Wednesday, December 8, 2021 4:37 PM
To: Dave Thaler <dthaler=[email-masked]>; Ira McDonald <[email-masked]>
Cc: Michael Richardson <[email-masked]>; Kathleen Moriarty <[email-masked]>; Hannes Tschofenig <[email-masked]>; Eric Voit (evoit) <[email-masked]>; [email-masked]
Subject: Re: [Rats] IPR statements about draft-ietf-rats-architecture

[External Email. Be cautious of content]

Hi,

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - SAE Trust Anchors and Authentication TF
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic<https://urldefense.com/v3/__http:/sites.google.com/site/blueroofmusic__;!!NEt6yMaO-gk!R85wC3uzBNtS9JVpsdUG6yhASb1zHxy0fBSiyxn4lyCbvEu12tWYPkxHS6_2-PeTx3I$>
http://sites.google.com/site/highnorthinc<https://urldefense.com/v3/__http:/sites.google.com/site/highnorthinc__;!!NEt6yMaO-gk!R85wC3uzBNtS9JVpsdUG6yhASb1zHxy0fBSiyxn4lyCbvEu12tWYPkxHS6_2f8uYH3g$>
mailto: [email-masked]<mailto:[email-masked]>
(permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, Dec 8, 2021 at 1:59 PM Dave Thaler <dthaler=[email-masked]<mailto:[email-masked]>> wrote:
My personal opinion is that publication should proceed, especially
since the architecture document is just Informational.

Dave

-----Original Message-----
From: RATS <[email-masked]<mailto:[email-masked]>> On Behalf Of Michael Richardson
Sent: Saturday, November 20, 2021 7:46 AM
To: Kathleen Moriarty <[email-masked]<mailto:[email-masked]>>; Eric Voit (evoit) <[email-masked]<mailto:[email-masked]>>; Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Rats] IPR statements about draft-ietf-rats-architecture

Kathleen Moriarty <[email-masked]<mailto:[email-masked]>> wrote:
    > I wouldn't go by that date as I did a call for IPR and then had to

    > Hannes, can your lawyers look at what's been provided so far?

--
Michael Richardson <[email-masked]<mailto:[email-masked]>>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

_______________________________________________
RATS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rats<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/rats__;!!NEt6yMaO-gk!R85wC3uzBNtS9JVpsdUG6yhASb1zHxy0fBSiyxn4lyCbvEu12tWYPkxHS6_2VurWlfQ$>

---

From: Daniel Migault <[email-masked]>
Date: Wed, 8 Dec 2021 20:13:03 -0500

I checked internally and we would like the document be moved forward.
Yours,
Daniel

On Wed, Dec 8, 2021 at 6:04 PM Guy Fedorkow <gfedorkow=
[email-masked]> wrote:

> Of course we’re uncomfortable about an unquantifiable IPR risk, but I
> agree with Ira, we should move forward with the document as-is.
>
>   /guy
>
>
>
>
>
>
>
> *From:* RATS <[email-masked]> *On Behalf Of * Ira McDonald
> *Sent:* Wednesday, December 8, 2021 4:37 PM
> *To:* Dave Thaler <dthaler=[email-masked]>; Ira McDonald <
> [email-masked]>
> *Cc:* Michael Richardson <[email-masked]>; Kathleen Moriarty <
> [email-masked]>; Hannes Tschofenig <
> [email-masked]>; Eric Voit (evoit) <[email-masked]>;
> [email-masked]
> *Subject:* Re: [Rats] IPR statements about draft-ietf-rats-architecture
>
>
>
> *[External Email. Be cautious of content]*
>
>
>
> Hi,
>
>
>
> *Chair - Linux Foundation Open Printing WG Secretary - IEEE-ISTO Printer
> Working Group Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG IETF
> Designated Expert - IPP & Printer MIB Blue Roof Music / High North Inc
> http://sites.google.com/site/blueroofmusic
> <https://urldefense.com/v3/__http:/sites.google.com/site/blueroofmusic__;!!NEt6yMaO-gk!R85wC3uzBNtS9JVpsdUG6yhASb1zHxy0fBSiyxn4lyCbvEu12tWYPkxHS6_2-PeTx3I$>
> http://sites.google.com/site/highnorthinc
> <https://urldefense.com/v3/__http:/sites.google.com/site/highnorthinc__;!!NEt6yMaO-gk!R85wC3uzBNtS9JVpsdUG6yhASb1zHxy0fBSiyxn4lyCbvEu12tWYPkxHS6_2f8uYH3g$>
> mailto: [email-masked] <[email-masked]> (permanent) PO
> Box 221  Grand Marais, MI 49839  906-494-2434*
>
>
>
>
>
> <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/rats__;!!NEt6yMaO-gk!R85wC3uzBNtS9JVpsdUG6yhASb1zHxy0fBSiyxn4lyCbvEu12tWYPkxHS6_2VurWlfQ$>
>

-- 
Daniel Migault
Ericsson

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 10 Dec 2021 08:59:19 +0100

While the IPR situation if unfortunate, I am in strong support of moving 
forward.

Additionally, I'd like to point out Eric's summary and have to also 
strongly +1 the notion that there is more IPR risk in even more 
unwarranted delay of the architecture document than there is with 
proceeding methodically and quickly from now on:

> https://mailarchive.ietf.org/arch/msg/rats/xihv0yHc9hyc7-32sP4J-NJs_HY

On 09.12.21 02:13, Daniel Migault wrote:
> On Wed, Dec 8, 2021 at 6:04 PM Guy Fedorkow 
> <gfedorkow=[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Of course we’re uncomfortable about an unquantifiable IPR risk, but
>     I agree with Ira, we should move forward with the document as-is.____
> 
>        /guy____
> 
>     __ __
> 
>     __ __
> 
>     __ __
> 
>     Juniper Business Use Only____
> 
>     *From:* RATS <[email-masked] <mailto:[email-masked]>>
>     *On Behalf Of * Ira McDonald
>     *To:* Dave Thaler <dthaler=[email-masked]
>     <mailto:[email-masked]>>; Ira McDonald
>     <[email-masked] <mailto:[email-masked]>>
>     *Cc:* Michael Richardson <[email-masked]
>     <mailto:[email-masked]>>; Kathleen Moriarty
>     <[email-masked]
>     <mailto:[email-masked]>>; Hannes Tschofenig
>     <[email-masked] <mailto:[email-masked]>>; Eric
>     Voit (evoit) <[email-masked] <mailto:[email-masked]>>;
>     [email-masked] <mailto:[email-masked]>
>     *Subject:* Re: [Rats] IPR statements about
>     draft-ietf-rats-architecture____
> 
>     __ __
> 
>     *[External Email. Be cautious of content]____*
> 
>     __ __
> 
>     Hi,____
> 
>     __ __
> 
>     I agree w/ Dave Thaler - publish this Informational RATS
>     Architecture as is.____
> 
>     __ __
> 
>     There has already been far too long a delay.____
> 
>     __ __
> 
>     Cheers,____
> 
>     - Ira____
> 
>     __ __
> 
>     /Ira McDonald (Musician / Software Architect)/____
> 
>     /Chair - SAE Trust Anchors and Authentication TF/____
> 
>     /Co-Chair - TCG Trusted Mobility Solutions WG/____
> 
>     /Co-Chair - TCG Metadata Access Protocol SG/____
> 
>     /Chair - Linux Foundation Open Printing WG
>     mailto: [email-masked] <mailto:[email-masked]>
>     (permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434/____
> 
>     __ __
> 
>     __ __
> 
>     On Wed, Dec 8, 2021 at 1:59 PM Dave Thaler
>     <dthaler=[email-masked]
>     <mailto:[email-masked]>> wrote:____
> 
>         From: RATS <[email-masked]
>         <mailto:[email-masked]>> On Behalf Of Michael Richardson
>         To: Kathleen Moriarty <[email-masked]
>         <mailto:[email-masked]>>; Eric Voit (evoit)
>         <[email-masked] <mailto:[email-masked]>>; Hannes Tschofenig
>         <[email-masked] <mailto:[email-masked]>>;
>         [email-masked] <mailto:[email-masked]>
>         Kathleen Moriarty <[email-masked]
>         <mailto:[email-masked]>> wrote:
>              > I wouldn’t go by that date as I did a call for IPR and
>         then had to
>              > wait. That might have been the trigger, not sure.
> 
>              > Hannes, can your lawyers look at what’s been provided so far?
> 
>         The IPR disclosures on the IETF web site are almost always
>         completely useless.  This one included in my opinion.
> 
>         Worse, a typo in the markup of the previous version means that
>         the 3.1 heading actually didn't render.  So it's not clear what
>         the IPR claim refers to.
> 
>         At best the IPR declaration tells us what patent application to
>         look at, and we don't even know if the PTO will even accept all
>         the claims.
> 
>         --
>         Michael Richardson <[email-masked]
>         <mailto:[email-masked]>>   . o O ( IPv6 IøT consulting )
>         [email-masked] <mailto:[email-masked]>
>         <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/rats__;!!NEt6yMaO-gk!R85wC3uzBNtS9JVpsdUG6yhASb1zHxy0fBSiyxn4lyCbvEu12tWYPkxHS6_2VurWlfQ$>____
> 
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/rats>
> 
> 
> 
> -- 
> Daniel Migault
> Ericsson
>