Subject: Re: [Rats] WGLC for EAT draft

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Fri, 3 Dec 2021 00:35:29 +0000

Hi,
From the repo https://github.com/ietf-rats-wg/eat/issues  there is only 1 outstanding issue that we discussed at IETF 112 relating to TEEP requirements which I believe still has a couple of outstanding tasks remaining and blocking.

However, that is the only feedback and no comments in the open WGLC….can we get at least 3 volunteers to help review the draft and comment on its maturity and readiness for publication?  We’ll have to extend the WGLC as there’s been no feedback.
Can anyone speak to having implemented any or all of the claims defined in EAT?

Best, Nancy
(acting as co-chair)

From: RATS <[email-masked]> on behalf of "Smith, Ned" <[email-masked]>
Date: Friday, November 12, 2021 at 9:17 AM
To: "Nancy Cam-Winget (ncamwing)" <ncamwing=[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Rats] WGLC for EAT draft

Given some of the WGLC discussion will happen on the github for EAT. Would it be possible to identify which issues are LC blocking so participants are able to focus on the most relevant issues?

From: RATS <[email-masked]> on behalf of "Nancy Cam-Winget (ncamwing)" <ncamwing=[email-masked]>
Date: Friday, November 12, 2021 at 8:51 AM
To: "[email-masked]" <[email-masked]>
Subject: [Rats] WGLC for EAT draft

Hello RATs participants,

We had consensus to begin an early working group last call  for https://datatracker.ietf.org/doc/draft-ietf-rats-eat/

This email starts a 3 week WGLC for the draft and will conclude on Dec. 4, 2021

You can review live the progress and issues on the draft are being tracked in https://github.com/ietf-rats-wg/eat

If you can not, then please post your comments and feedback on the mail list.

Thanks, Nancy
(on behalf of all the chairs)

---

From: Michael Richardson <[email-masked]>
Date: Fri, 03 Dec 2021 18:11:15 -0500

Hi Nancy,

I reviewed eat-11 at:
  https://mailarchive.ietf.org/arch/msg/rats/FIClBBHktw3fwKuJzuUgmqojhW0/

If it were my document, I would restructure it significantly.
(But, as discussed over in wgchairs@, not a hill I'm willing to die on)

I raised concerns about section 7,  and I asked if the document was ordered
sensibly.

However, my opinion is that the document is 'good enough', and that waiting
for a longer WGLC will not make it better.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 6 Dec 2021 12:03:05 +0000

Hi Nancy, Hi all,

I have reviewed part of the specification and I do not think it is ready for IESG processing. In general, drafts that contain text marked with "TODO" tend not to be ready for the IESG.

Here are my editorial review comments:
https://diameter-book.info/draft-ietf-rats-eat-11-hannes.pdf

Thomas, Simon and I will provide a few substantive comments in a follow-up email.

Ciao
Hannes

From: RATS <[email-masked]> On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Friday, December 3, 2021 1:35 AM
To: Smith, Ned <[email-masked]>; Nancy Cam-Winget (ncamwing) <ncamwing=[email-masked]>; [email-masked]
Subject: Re: [Rats] WGLC for EAT draft

Hi,

Best, Nancy
(acting as co-chair)

From: RATS <[email-masked]<mailto:[email-masked]>> on behalf of "Smith, Ned" <[email-masked]<mailto:[email-masked]>>
Date: Friday, November 12, 2021 at 9:17 AM
To: "Nancy Cam-Winget (ncamwing)" <ncamwing=[email-masked]<mailto:ncamwing=[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rats] WGLC for EAT draft

From: RATS <[email-masked]<mailto:[email-masked]>> on behalf of "Nancy Cam-Winget (ncamwing)" <ncamwing=[email-masked]<mailto:ncamwing=[email-masked]>>
Date: Friday, November 12, 2021 at 8:51 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Rats] WGLC for EAT draft

Hello RATs participants,

Thanks, Nancy

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Laurence Lundblade <[email-masked]>
Date: Mon, 6 Dec 2021 11:17:49 -0800

> On Dec 3, 2021, at 3:11 PM, Michael Richardson <[email-masked]> wrote:
> 
> 
> Hi Nancy,
> 
> I reviewed eat-11 at:
> I raised concerns about section 7,

You did say you were concerned, but I didn’t see any details.

>  and I asked if the document was ordered
> sensibly.

I filed this in GitHub <https://github.com/ietf-rats-wg/eat/issues/144> and have commented on it.

LL

---

From: Laurence Lundblade <[email-masked]>
Date: Mon, 6 Dec 2021 11:45:21 -0800

> Can anyone speak to having implemented any or all of the claims defined in EAT?

I have implemented about 3/4 of the claims including a fairly complete implementation of submodules.

This C library is Ctoken <https://github.com/laurencelundblade/ctoken>  There is also UNIX command line tool called Xclaim <https://github.com/laurencelundblade/xclaim> that can create/sign/encode and verify/decode. It supports CWT, UCCS, UJCS and eventually JWT. It can translate between the formats.

There is also an implementation of EAT in ARM’s TF-M. It is related to Ctoken, but is just the claims in PSA Token <https://www.ietf.org/archive/id/draft-tschofenig-rats-psa-token-08.txt>. I believe ARM has implemented a verify/decode tool in Python, but don’t have details.

I have not implemented detached EAT bundles (DEBs).

Some claims use CoSWIDs and SUIT manifests. I haven’t implemented those yet. At first the implementation would be simple returning the encoded CoSWID and SUIT manifests for use with an external library. Eventually, I might implement a small part of CoSWID if it became popular and useful.

LL

---

From: Laurence Lundblade <[email-masked]>
Date: Mon, 6 Dec 2021 14:09:14 -0800

> On Dec 6, 2021, at 4:03 AM, Hannes Tschofenig <[email-masked]> wrote:
> 
> Hi Nancy, Hi all, 
>  

I am working on the TODO’s. They mostly have to do with making the CDDL verify against the diagnostic notation examples using the “cddl” tool, particularly for CoSWID.

> https://diameter-book.info/draft-ietf-rats-eat-11-hannes.pdf <https://diameter-book.info/draft-ietf-rats-eat-11-hannes.pdf>
Thank you for these comments! Will work through them.

LL

---

From: Simon Frost <[email-masked]>
Date: Tue, 7 Dec 2021 15:53:43 +0000

> There is also an implementation of EAT in ARM’s TF-M. It is related to Ctoken, but is just the claims in PSA Token<https://www.ietf.org/archive/id/draft-tschofenig-rats-psa-token-08.txt>. I believe ARM has implemented a verify/decode tool in Python, but don’t have details.
The TF PSA profile standalone verification tool can be found at: https://git.trustedfirmware.org/TF-M/trusted-firmware-m.git/tree/tools/iat-verifier

In addition, there is an implementation for verification of an EAT PSA profile within the Veraison project, see repo https://github.com/veraison/psatoken

HTH
Simon

From: Laurence Lundblade <[email-masked]>
Sent: 06 December 2021 19:45
To: Nancy Cam-Winget (ncamwing) <ncamwing=[email-masked]>
Cc: Smith, Ned <[email-masked]>; [email-masked]
Subject: Re: [Rats] WGLC for EAT draft

On Dec 2, 2021, at 4:35 PM, Nancy Cam-Winget (ncamwing) <ncamwing=[email-masked]<mailto:ncamwing=[email-masked]>> wrote:

This C library is Ctoken<https://github.com/laurencelundblade/ctoken>  There is also UNIX command line tool called Xclaim<https://github.com/laurencelundblade/xclaim> that can create/sign/encode and verify/decode. It supports CWT, UCCS, UJCS and eventually JWT. It can translate between the formats.

There is also an implementation of EAT in ARM’s TF-M. It is related to Ctoken, but is just the claims in PSA Token<https://www.ietf.org/archive/id/draft-tschofenig-rats-psa-token-08.txt>. I believe ARM has implemented a verify/decode tool in Python, but don’t have details.

LL