Subject: [Rats] Next steps on draft-ietf-rats-architecture IPR discussion

From: Roman Danyliw <[email-masked]>
Date: Wed, 8 Dec 2021 17:36:00 +0000

Hi!

The cognizant co-chairs and I have been coordinating on how to handle draft-ieft-rats-architecture [1].

This document [1] is through WG Last Call but emerging IPR claims [6] [7] necessitated a WG discussion on how to proceed.  When such claims emerge, it is common practice to explicitly consult the WG on next steps with the document (but not evaluating the merits of the IPR). This consultation was explained during IETF 112 and ran in November [2].  Unfortunately, the results were inconclusive due to almost no feedback being provided.

Specifically, only three parties responded on next steps [3] [4] [5] and among the respondents was a document author [3].  [4] suggested the WG wait for the full patent details (which are not public) in the case of one IPR claim.  [5] indicated support for proceeding with publication as planned.  To repeat, this level of feedback is insufficient consensus on any direct.

If we are to reach resolution on this issue, WG feedback is needed.  As such, WG consultation on the IPR is being re-opened till December 20, 2021.  Please respond to the thread [2].  Consider the existing IPR feedback discussion to date - are you comfortable proceeding to publication with the IPR information that exists? do you need to wait for full details on the IPR claims? are you outright uncomfortable with publication given the IPR information that is published? any other position?

To make best use of the time while we continue to discuss the issue:

** The WG can resolve the early AD review comments [8] shared on November 12.  The next step in the document review process is an AD review where these would be a subset of blocking feedback before IETF LC.

** In response to a request by the document authors, early review by the SECDIR and IOTDIR will also be requested by the chairs.  The WG should keep in mind that this is an "early review".  As is standard practice, another re-review(s) will be triggered in advance of IETF LC and IESG telechat.

Regards,
Roman, Nancy and Kathleen

[1] https://datatracker.ietf.org/doc/draft-ietf-rats-architecture/
[2] https://mailarchive.ietf.org/arch/msg/rats/6FKaaDLry7_PexyhI5jySAOZ3cE/
[3] https://mailarchive.ietf.org/arch/msg/rats/GrDPAPgYWMgmUJUJu3_GBzC2FSQ/
[4] https://mailarchive.ietf.org/arch/msg/rats/lMudsv_xOzBWP_AXvT47P7bz-Dw/

---

From: Michael Richardson <[email-masked]>
Date: Sun, 12 Dec 2021 11:59:31 -0500

> This document [1] is through WG Last Call but emerging IPR claims [6]
    > [7] necessitated a WG discussion on how to proceed.  When such claims
    > emerge, it is common practice to explicitly consult the WG on next
    > steps with the document (but not evaluating the merits of the
    > IPR). This consultation was explained during IETF 112 and ran in
    > November [2].  Unfortunately, the results were inconclusive due to
    > almost no feedback being provided.

I think that you got some feedback on the other thread.
I think that in these cases you need to look only for objections.

Recognize that:
  a) almost none of us even claim to be lawyers.
  b) those of us with captive lawyers probably have 3 to 10 month queues of
     work for them. (from what I'm told)
  c) the captive lawyers often tell people never to read patents.

so almost nobody can actually respond in a really positive way.

    > ** In response to a request by the document authors, early review by
    > the SECDIR and IOTDIR will also be requested by the chairs.  The WG
    > should keep in mind that this is an "early review".  As is standard
    > practice, another re-review(s) will be triggered in advance of IETF LC
    > and IESG telechat.

Thank you.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Jeremy O'Donoghue <[email-masked]>
Date: Mon, 13 Dec 2021 11:06:05 +0000

+1 on all points

Best regards
Jeremy

On 12/12/2021, 16:59, "RATS" <[email-masked]> wrote:

WARNING: This email originated from outside of Qualcomm. Please be wary of any links or attachments, and do not enable macros.

Recognize that:

Thank you.

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 13 Dec 2021 12:29:06 +0100

Hi Roman,

thank you for your summary and pushing this forward! That is really 
appreciated.

To be precise, if I filter the subject "IPR statements about 
draft-ietf-rats-architecture", I count five non-editor/non-chair +1 
votes in support of moving forward, namely (I hope it is okay to point 
out names and emails in a summary, explicitly. It feels useful, but also 
weird. I apologize beforehand): Eric, Ira, Thomas H., Guy, and Daniel.

> https://mailarchive.ietf.org/arch/msg/rats/xihv0yHc9hyc7-32sP4J-NJs_HY
> https://mailarchive.ietf.org/arch/msg/rats/uyRm8z6Rzy0YHz8lLNtTbdtBOoI
> https://mailarchive.ietf.org/arch/msg/rats/37EFdkip0px3tG5OasYRpQvZaUU
> https://mailarchive.ietf.org/arch/msg/rats/bTmHgryO9XXmapTLOTCWqBx3Lm0
> https://mailarchive.ietf.org/arch/msg/rats/JrHQgIlSQR7ihMup3K6BiTYXgIU

I also feel the need to re-iterate MCR's sentiment that most IETF 
members's company policy *does not allow IETF participants to read 
patents*. What I can add to the statements that it was also highlithed 
on the list that the IPR Claims are already public (for a while, actually).

And even against these policy odds, we have five non-editor votes in 
support of publication and two editor's votes in support.

I am not entirely sure what to unpack from MCR's and Jeremy's replies to 
this thread right now. I agree with basically all arguments in these 
replies. But that does not really help the process, effectively ;-)

Are these replies "+1 for publication"? Because I cannot really tell.

Viele Grüße,

Henk

On 08.12.21 18:36, Roman Danyliw wrote:
> _______________________________________________
> RATS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rats
>

---

From: Jeremy O'Donoghue <[email-masked]>
Date: Mon, 13 Dec 2021 11:53:11 +0000

Hi Roman, Henk,

Let me try to state things more clearly.

I generally think the RATS arch document is useful, and in the absence of IPR claims I would support publication.

I am not in a position to make any assessment as to whether the IPR claims would cause me to assess that the document should not be published in its current form. You could call this something like “-0.5” if you like.

I would prefer to see the document modified so that it is non-infringing, and would strongly support this.

Best regards
Jeremy

On 13/12/2021, 11:29, "RATS" <[email-masked]> wrote:

Hi Roman,

Viele Grüße,

Henk

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 13 Dec 2021 13:37:52 +0100

Hi Jeremy,

that makes a lot of sense! Thanks.

There was an analysis done with respect to the IPR situation via 

C&Ping the vital part:

> I am not a lawyer.  And this is not legal advice.   But here are my thoughts:

And now the interesting part:

> * It is possible to look at Intel's IPR reference (to Section 3.0 & 3.1).  And it is possible to see what existed in draft-ietf-rats-architecture prior to Intel's IPR priority date of 2020-06-18.  The only obvious new thing I see is the Reference Value Provider.
> 
> * And if people are worried about the general idea of reference value providers, this idea was also included in other RATS draft prior to the Intel's IPR date.  (E.g., draft-ietf-rats-tpm-based-network-device-attest-00, Section 1.4.)

I've also read the corresponding documents and cannot see how a 
modification of the current document (-14) can solve the hypothetical 
issue framed by:

> https://datatracker.ietf.org/ipr/5042/

Without an actual issue that goes beyond the released IPR details, well 
there is actually not a tangible issue, but the procedural one. If there 
is actually an issue that can be phrased and pointed out, we need 
someone to raise it. Otherwise, we now follow Roman's guidance and 
accumulate more feedback on the list until December the 20th.

Thanks again!

Viele Grüße,

Henk

On 13.12.21 12:53, Jeremy O'Donoghue wrote:
> I generally think the RATS arch document is useful, and in the absence 
> of IPR claims I would support publication.
> 
> I am not in a position to make any assessment as to whether the IPR 
> claims would cause me to assess that the document should not be 
> published in its current form. You could call this something like “-0.5” 
> if you like.
> 
> I would prefer to see the document modified so that it is 
> non-infringing, and would strongly support this.
> 
> Best regards
> 
> Jeremy
> 
> WARNING: This email originated from outside of Qualcomm. Please be wary 
> of any links or attachments, and do not enable macros.
> 
> Hi Roman,
> 
> <https://mailarchive.ietf.org/arch/msg/rats/xihv0yHc9hyc7-32sP4J-NJs_HY>
>  > 
> <https://mailarchive.ietf.org/arch/msg/rats/uyRm8z6Rzy0YHz8lLNtTbdtBOoI>
>  > 
> <https://mailarchive.ietf.org/arch/msg/rats/37EFdkip0px3tG5OasYRpQvZaUU>
>  > 
> <https://mailarchive.ietf.org/arch/msg/rats/bTmHgryO9XXmapTLOTCWqBx3Lm0>
>  > 
> <https://mailarchive.ietf.org/arch/msg/rats/JrHQgIlSQR7ihMup3K6BiTYXgIU>
> 
> emerge, it is common practice to explicitly consult the WG on next steps 
> with the document (but not evaluating the merits of the IPR). This 
> consultation was explained during IETF 112 and ran in November [2].  
> Unfortunately, the results were inconclusive due to almost no feedback 
> being provided.
>  >
>  > Specifically, only three parties responded on next steps [3] [4] [5] 
> and among the respondents was a document author [3].  [4] suggested the 
> WG wait for the full patent details (which are not public) in the case 
> of one IPR claim.  [5] indicated support for proceeding with publication 
> as planned.  To repeat, this level of feedback is insufficient consensus 
> on any direct.
>  >
>  > If we are to reach resolution on this issue, WG feedback is needed.  
> As such, WG consultation on the IPR is being re-opened till December 20, 
> 2021.  Please respond to the thread [2].  Consider the existing IPR 
> feedback discussion to date - are you comfortable proceeding to 
> publication with the IPR information that exists? do you need to wait 
> for full details on the IPR claims? are you outright uncomfortable with 
> publication given the IPR information that is published? any other position?
>  >
>  > ** The WG can resolve the early AD review comments [8] shared on 
> November 12.  The next step in the document review process is an AD 
> review where these would be a subset of blocking feedback before IETF LC.
>  >
> <https://datatracker.ietf.org/doc/draft-ietf-rats-architecture/>
>  > [2] 
> https://mailarchive.ietf.org/arch/msg/rats/6FKaaDLry7_PexyhI5jySAOZ3cE/ 
> <https://mailarchive.ietf.org/arch/msg/rats/6FKaaDLry7_PexyhI5jySAOZ3cE/>
>  > [3] 
> https://mailarchive.ietf.org/arch/msg/rats/GrDPAPgYWMgmUJUJu3_GBzC2FSQ/ 
> <https://mailarchive.ietf.org/arch/msg/rats/GrDPAPgYWMgmUJUJu3_GBzC2FSQ/>
>  > [4] 
> https://mailarchive.ietf.org/arch/msg/rats/lMudsv_xOzBWP_AXvT47P7bz-Dw/ 
> <https://mailarchive.ietf.org/arch/msg/rats/lMudsv_xOzBWP_AXvT47P7bz-Dw/>
>  >
> <https://www.ietf.org/mailman/listinfo/rats>
>  >
> 
> <https://www.ietf.org/mailman/listinfo/rats>
>