Subject: Re: [Rats] Joint RATS SUIT virtual interim in January 2022

From: "Smith, Ned" <[email-masked]>
Date: Fri, 17 Dec 2021 23:47:15 +0000

Reviewing the poll participation, there are only 8 respondents so far from both RATS and SUIT WGs. Should I interpret this as lack of interest or people are taking holiday?

From: RATS <[email-masked]> on behalf of "Smith, Ned" <[email-masked]>
Date: Monday, December 6, 2021 at 8:36 AM
To: "[email-masked]" <[email-masked]>
Subject: [Rats] Joint RATS SUIT virtual interim in January 2022

FYI the RATS and SUIT working groups are planning a joint interim in January to discuss overlapping topics such as draft-birkholz-rats-suit-claims-02 - Trustworthiness Vectors for the Software Updates of Internet of Things (SUIT) Workflow Model (ietf.org)<https://datatracker.ietf.org/doc/draft-birkholz-rats-suit-claims/>

There is a Doodle Poll for identifying your availability in January. Please vote ASAP. We will close voting when everyone who wants to vote has had a chance to do so.

Poll: https://doodle.com/poll/n7us9hkyg9rn6vbw?utm_source=poll&utm_medium=link

Thanks,
RATS / SUIT chairs

---

From: Michael Richardson <[email-masked]>
Date: Sun, 19 Dec 2021 13:16:22 -0500

Smith, Ned <[email-masked]> wrote:
    > Reviewing the poll participation, there are only 8 respondents so far
    > from both RATS and SUIT WGs. Should I interpret this as lack of
    > interest or people are taking holiday?

You did ask some time ago, but maybe it got lost.
I don't remember seeing the original post myself.

Given that you have dates into the end of January, you'll probably have to
wait until the end of the first week of Jan (the 7th) to declare a winner.

Or perhaps, if you think you have some quorum for a date in the first week, then
hold two meetings.

    > ----------------------------------------------------
    > Alternatives:

    > ----------------------------------------------------
    > _______________________________________________
    > RATS mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/rats

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: "Smith, Ned" <[email-masked]>
Date: Mon, 20 Dec 2021 21:42:47 +0000

I don't think I had anything close to quorum when I sent out the reminder. Since then a half dozen others contributed. Still only one chair from RATS WG side. I don't know if a joint meeting requires two chairs, or if they have to be from the same WG. I expect draft authors should be present, but maybe not all?

-Ned 

On 12/19/21, 10:16 AM, "Michael Richardson" <[email-masked]> wrote:

---

From: Michael Richardson <[email-masked]>
Date: Thu, 23 Dec 2021 12:40:51 -0500

Smith, Ned <[email-masked]> wrote:
    > I don't think I had anything close to quorum when I sent out the
    > reminder. Since then a half dozen others contributed. Still only one
    > chair from RATS WG side. I don't know if a joint meeting requires two
    > chairs, or if they have to be from the same WG. I expect draft authors
    > should be present, but maybe not all?
    
I had assumed that you had unicast coordination with SUIT WG chairs about
this.  As Dave Thaler is one chair, I figure if you have him you are set.
It seems that we really need TEEP there as well.  I think that purpose is to
decide in which WG https://datatracker.ietf.org/doc/draft-birkholz-rats-suit-claims
should be progressed.

Wrapped in here (for me) is the extent to which the EAT document is trying to
describe the protocol only (with really well worded IANA considerations), or
whether it is trying to proscribe a useful common subset of claims.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Smith, Ned" <[email-masked]>
Date: Thu, 23 Dec 2021 18:00:11 +0000

I hadn't heard anyone suggesting that it would make sense to consider doing https://datatracker.ietf.org/doc/draft-birkholz-rats-suit-claims work in TEEP. Can the authors comment as to why/why not this should be considered as a third option?

Thx,
Ned

On 12/23/21, 9:41 AM, "Michael Richardson" <[email-masked]> wrote:

---

From: Michael Richardson <[email-masked]>
Date: Thu, 23 Dec 2021 17:43:50 -0500

Smith, Ned <[email-masked]> wrote:
    > I hadn't heard anyone suggesting that it would make sense to consider
    > doing https://datatracker.ietf.org/doc/draft-birkholz-rats-suit-claims
    > work in TEEP. Can the authors comment as to why/why not this should be
    > considered as a third option?

The SUIT claims involved are for remediation via TEEP... It seems to be the
draft that bridges all three groups.

    > Suit mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/suit