Subject: [Rats] Next steps on EAT early allocation

From: Roman Danyliw <[email-masked]>
Date: Fri, 4 Feb 2022 21:26:17 +0000

Hi!

I wanted to check in with the WG on what should be done with the EAT early allocation.  On January 13, I submitted the requested for early allocation of all claims in Section 9.3.1 of draft-ietf-rats-eat-11 on behalf of the WG chairs [1].  Pending a three-week review period, the DE approved this early registry with some changes in allocation ranges on January 14 [2].  These results were brought back to the RATS mail list [3].  On January 20, the chairs reminded the WG that pending the WG declining the proposed allocation approach, these early allocations would be published today (February 4).  Not seeing any objections to the thread on [3] and an-inflight PR to merge these changes per [2], IANA asked and I provided my final approval (which is the process when the allocation is not what's initially requested) on January 25 [6].  I quickly rescinded it [7] because I had not noticed that the document authors had asked IANA to wait [8] the night before.

Today is the day (Feb 4) that the claims in -11 and as listed [2] could have been registered.  They were not registered because the request was held.  I can see an ongoing discussion to add even more claims.  

What would the WG like to see happen:

(a) Provide the approval to release the early allocation as discussed in [2] -- this could be could be  immediately

(b) Continue discussing what additional claims are needed above and beyond those in the -11 EAT draft; and block the early allocation in [2] until this discuss is resolved

(c) something else?

Early allocation doesn't need to be a one-time process.  As such, my recommendation to the WG is that if there is no contention with the allocation proposed per [2], release them for registration and  continue the discussion on any additional claims that were missed in -11.  Ultimately, this timing is a WG decision and I'll await a positive signal on the next steps from the WG chairs.

Regards,
Roman

[1] https://mailarchive.ietf.org/arch/msg/cwt-reg-review/VUTQhDR0wApabsA76HsZdd7K3Dc/
[2] https://mailarchive.ietf.org/arch/msg/cwt-reg-review/Eyya7u9rR1XA5N0KcXiTfolAdTs/
[3] https://mailarchive.ietf.org/arch/msg/rats/SHezocE1vpmfzJgtiD9OPLN74Us/
[4] https://mailarchive.ietf.org/arch/msg/rats/G_6cVHZeyIaput8AIB_SBb7EOeQ/
[5] https://mailarchive.ietf.org/arch/msg/cwt-reg-review/vHyIIiFsBG-eON0VaLxlMDFY9S4/
[6] https://mailarchive.ietf.org/arch/msg/cwt-reg-review/QQKRfsiX3XQEzXvR-EwNnDx-8GA/
[7] https://mailarchive.ietf.org/arch/msg/cwt-reg-review/vHyIIiFsBG-eON0VaLxlMDFY9S4/
[8] https://mailarchive.ietf.org/arch/msg/cwt-reg-review/VsBnIJbwd7tSUqB6vi9PgZmWBrM/

---

From: Laurence Lundblade <[email-masked]>
Date: Mon, 7 Feb 2022 10:51:18 -0800

In a previous email, Roman listed some criteria:

> ==[ snip ]==
>   b.  The format, semantics, processing, and other rules related to
>       handling the protocol entities defined by the code points
>       (henceforth called "specifications") must be adequately described
>       in an Internet-Draft.
> 
>   c.  The specifications of these code points must be stable; i.e., if
>       there is a change, implementations based on the earlier and later
>       specifications must be seamlessly interoperable.
> ==[ snip ]==
> 
> Practically this means no allocation can be requested until it is published into the EAT or some other document; and we're not going to request a change later.

Security-level was part of the original early allocation request. It was at least (tacitly) accepted for early allocation last year. Now there is a discussion about it.

Also, OEMID which was also accepted for early allocation was adjusted some in the most recent draft (-11). The adjustments were the addition of PEN as a format, the addition of a 128-bit random format, and the clarification that it is specifically for HW. 

I would like to see both of these allocated early, but want to be up front about what is going on for them.

It would be good if those that want early allocation speak up or do work here to drive this forward. I only did the work on early allocation because it was requested, not because it was my agenda.

LL

> On Feb 4, 2022, at 1:26 PM, Roman Danyliw <[email-masked]> wrote:
> 
> Hi!
> 
> _______________________________________________
> RATS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rats

---

From: Giridhar Mandyam <[email-masked]>
Date: Mon, 7 Feb 2022 20:23:54 +0000

For what it's worth - I had requested only 2 claims for early allocation:  nonce and ueid.  See my presentation from IETF 109 (https://datatracker.ietf.org/meeting/109/materials/slides-109-rats-sessb-fido-updates-to-rats-00), slide 7.  As far as I am concerned, those have been stable for several versions.

I am going to assume that we can go ahead with the early allocation as reflected by group consensus following IETF 109 as per the claims requests reflected n draft -09.  So  this means that the claim values can be updated in the next version of the spec as per the IANA expert reviewers' recommendations.  If sec level does not meet the criteria as outlined by Roman (and I assume it does not), then it seems that we should not request early allocation and should back this claim out until the we can determine group consensus that there is an adequate description of this claim.  So should it be backed out from early allocation?

As far as I can tell, the rest of the claims that were designated for early allocation have stable definitions and their proposed values can be published in the next draft.

> It would be good if those that want early allocation speak up or do work here to drive this forward. I only did the work on early allocation because it was requested, not because it was my agenda.

You requested 3 additional claims in https://mailarchive.ietf.org/arch/msg/rats/Qmj9bwNGQqCWi3ygCsOOIUpGI1g/.  Does this mean you are no longer interested in early allocation of those claims?  

-----Original Message-----
From: RATS <[email-masked]> On Behalf Of Laurence Lundblade
Sent: Monday, February 7, 2022 10:51 AM
To: Roman Danyliw <[email-masked]>
Cc: rats <[email-masked]>
Subject: Re: [Rats] Next steps on EAT early allocation

WARNING: This email originated from outside of Qualcomm. Please be wary of any links or attachments, and do not enable macros.

LL

> (a) Provide the approval to release the early allocation as discussed 
> in [2] -- this could be could be  immediately
>
> (b) Continue discussing what additional claims are needed above and 
> beyond those in the -11 EAT draft; and block the early allocation in 
> [2] until this discuss is resolved
>
> (c) something else?
>
> [1] 
> https://mailarchive.ietf.org/arch/msg/cwt-reg-review/VUTQhDR0wApabsA76
> HsZdd7K3Dc/ [2] 
> https://mailarchive.ietf.org/arch/msg/cwt-reg-review/Eyya7u9rR1XA5N0Kc
> XiTfolAdTs/ [3] 
> https://mailarchive.ietf.org/arch/msg/rats/SHezocE1vpmfzJgtiD9OPLN74Us
> / [4] 
> https://mailarchive.ietf.org/arch/msg/rats/G_6cVHZeyIaput8AIB_SBb7EOeQ
> / [5] 
> https://mailarchive.ietf.org/arch/msg/cwt-reg-review/vHyIIiFsBG-eON0Va
> LxlMDFY9S4/ [6] 
> https://mailarchive.ietf.org/arch/msg/cwt-reg-review/QQKRfsiX3XQEzXvR-
> EwNnDx-8GA/ [7] 
> https://mailarchive.ietf.org/arch/msg/cwt-reg-review/vHyIIiFsBG-eON0Va
> LxlMDFY9S4/ [8] 
> https://mailarchive.ietf.org/arch/msg/cwt-reg-review/VsBnIJbwd7tSUqB6v
> i9PgZmWBrM/
>