Subject: Re: [Rats] Reminder on RATS scope

From: Henk Birkholz <[email-masked]>
Date: Fri, 11 Feb 2022 22:54:37 +0100

Hi all,

all comments provided agree that the deliverable #7 (that I proposed) is 
actually subsumed by deliverable #5 already.

Please find the most recent re-charter proposal reflected in (with #7 
removed):

> https://github.com/ietf-rats/charter/blob/2nd-RC4/ietf-rats-charter.md

This charter version aggregates all proposal coming from the WG and Roman.

Are there any other comments or change requests? If not, we could 
probably put this version to the test already?

Viele Grüße,

Henk

On 15.01.22 23:59, Michael Richardson wrote:
> 
> Smith, Ned <[email-masked]> wrote:
>      > Does anyone on the list believe item 7 in the Program of Work as stated
>      > here: https://github.com/ietf-rats/charter/compare/2nd-RC2...2nd-RC3
>      > should remain in the Program of Work?
> 
> My opinion is that any greenfield application of RATS that wants to use Epoch
> Distribution, may need a protocol for doing that.
> 
>      > If it is removed, the expectation is that the semantics of 7 are easily
>      > inferred from item 5 in the Program of Work.
> 
> "5. Standardize interoperable protocols to securely convey evidence and attestation results."
> 
> I guess that it could squeak in.
> 
> Here, "protocol" to me could mean PKIX extensions (if we are putting stuff into
> certificates), or could mean some new multicast pub/sub mechanism that
> transported EATs across ethernet (no CoAP, no IP, ...)
> 
> I am not bothered by scope creep here, because I think that our AD can reign
> us in if we start re-inventing LLDP or something.
> (I actually think that extending LLDP might actually be reasonable for some
> environments, btw)
> 
> --
> Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
>             Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Michael Richardson <[email-masked]>
Date: Fri, 11 Feb 2022 17:53:16 -0500

> Are there any other comments or change requests? If not, we could probably
    > put this version to the test already?

I agree that it looks done to me.

I found a nit, where "It" felt like it referred to the *architecture*, when I
think it refers to "The WG"
  https://github.com/ietf-rats/charter/compare/2nd-RC4...mcr:patch-1

other than that, it sure looks cooked to me.

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Fri, 11 Feb 2022 22:55:24 +0000

Agree.  This summary update has what I need in it.   

I especially like the focus upon what the Relying Party needs.  Unless we have a concise language here, Relying Parties won't know what they are actually relying upon.  

Eric

> From: Michael Richardson, February 11, 2022 5:53 PM
> 
> I found a nit, where "It" felt like it referred to the *architecture*, when I think it
> refers to "The WG"