Subject: Re: [Raven] Anonymous taps

From: gustav <[email-masked]>
Date: Fri, 29 Oct 1999 12:15:57 -0700 (PDT)

> > No I want strong, unbreakable, end-to-end encryption for all my
> > communications. Let them tcp dump to their hearts content. <EG>
> 
> Every criminal organisation would like to have that too. If 
> our society allows us to use such means our society would 
> have created places where criminal organisations could 
> effectively hide for law enforcement.

Only as long as their crimes are purely informational.  Real-world
criminal organizations leave real-world evidence of their crimes, like
fingerprints, etc.  Encryption won't hide those.

> Fire arms are regulated and encryption should be 
> accordingly. No assault weapons and no free fully 

You clearly have no idea what you're talking about.  First of all,
"assault weapon" is a legal term, not a technical firearms term.
Assault weapons were legally created in the United States by the 1994
crime bill.  They are functionally identitical to non-assault weapons;
the differences are purely cosmetic.  Banning them did not in any way
contribute to safety, law enforcement effectiveness, criminal
organization effectiveness, or anything else.  It was just as
effective at stopping crime as banning red Ferraris would be at
stopping traffic accidents.  Fine, we'll just paint our Ferraris blue,
if that's what our legislators prefer.

I only bring this up because I suspect that your completely
misinformed reference to firearms sugests that your references to
cryptography may also be misinformed.

_______________________________________________
raven mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/raven

---

From: "Thomas Junker" <[email-masked]>
Date: Sun, 31 Oct 1999 04:47:06 -0600

On 27 Oct 99, at 0:32, Vernon Schryver wrote:

> > From: "Lyal Collins" <[email-masked]>
> 
> > ...
> > Non-subvertable - mostly.  Is perfection what we are seeking?  If so, we are
> > starting at the wrong level of the standards process for that.
> 
> Do you agree that those non-subvertable boxes would be sitting next to and
> connected to the same fibers as existing, subvertable, non-auditing,
> un-monitored, uncertified, non-standard (or at most RMON), ad hoc boxes?

Vernon,

I'm surprised that even you seem to accept chefren's seriously flawed premise 
that a technical standard can somehow dictate government policy.  Does anyone 
seriously think that if a standard calls for "sealed tapping boxes" that 
governments the world over will say, "Gee whiz, we'll just have to live with 
sealed boxes because the IETF says so?"  Does anyone think that because there 
is a standard that all the engineers will fall all over themselves to build 
to, that nothing else will be available in the marketplace?

Aside from your observation that the raw fiber will be right next to the 
theoretical "non-subvertable" box, what makes you think any government will 
*buy* a sealed box?  What's to prevent the FBI or the Cuban secret police from 
simply taking bids for the compliant box minus all the obstacles they don't 
wish to live with?  Won't those same engineers fall all over themselves to 
delete the unwanted features and sell the spooks what they want?

Although it requires strenuous reading between the lines, 
I think chefren and one or two others seem to think that 
if a standard includes features that offer a measure of 
constraint and auditability in wiretapping, that the 
legislatures of the civilized countries *may* take note of 
that and impose those requirements on their LEAs.  Maybe.  
I think it's a reach.  A far reach.  I think protocol 
standards that make provision for wiretapping support 
while also specifying protocol and non-protocol 
constraints against improper use would be like the IETF 
calling for HTTP boxes to be painted orange and FTP boxes 
to be painted blue.  "Oh, gee, we can't load this Web 
server into this box -- it's not orange."  Yeah.  The only 
organizations that would give that part of a standard the 
time of day would be the same ones that write to pencil 
and rubber band suppliers to ask for Y2K certifications.  
Everyone else would scratch their heads for a second, 
shrug, then load the software on whatever color box they 
choose.

Much more significant than any constraints that could be 
written into a protocol standard is the *facilitation* 
that the functional parts of such a standard would afford 
to wiretapping-inclined entities.  In the U.S., for 
instance, CALEA could be amended to require affected 
vendors and carriers to offer wiretap access compliant 
with the IETF-promulgated standard and EXPLICITLY delete 
from the standard as adopted any constraints that the 
Congress in its inscrutable wisdom feels would be an 
annoyance or liability for LEAs.

There is some remote possibility that if wiretap access 
were to be defined in a standard and audit features were 
also included, that legislators *might* respond by 
limiting LEA's wiretapping to the auditable, time- and 
sourc-stamped, digitally signed tap stream speficied in 
the standard.  Maybe.  In some jurisdictions.  Even in the 
country with the most solid constitutional foundation for 
protections of individual rights, though, there is no 
reason to believe that this necessarily would happen.  

All countries would be free to avail themselves of the 
facilitation of wiretapping provided by such a standard 
and ignore the feeble attempts in the standard to provide 
constraints and auditability.  Long before the vendors 
even got started on their engineering projects there would 
be private conferences with LEAs to determine which parts 
of the standard will be ignored in practice in which 
markets.  That is because auditability, authentication, 
verifiability, and "sealed boxes" are administrative 
aspects completely subject to political control.  They are 
not and cannot be intractably embedded in any protocol 
standard.

Take chefrens' "sealed box," for instance.  The notion of 
a "sealed box" and what it contains is a legal notion, not 
a technical or protocol one.  It presupposes a legislative 
and executive policy fabric that specifies classes of 
wiretapping mechanisms to conform to certain standards and 
be certified so by the manufacturers, installed by 
certified technicians, sealed under a specified procedure, 
and imposes penalties for tampering with the sealed 
mechanism.  Maybe that is really done in The Netherlands.  
That would be quite amazing.  Maybe chefren only *thinks* 
it is done that way.  Maybe the law even calls for it but 
is widely understood in LEA circles to be just so much 
word baggage.  That would be more like how things really 
work in this world.  Maybe chefren imagined his sealed box 
entirely.  In any case he would have the IETF telling 
governments how to structure their wiretapping laws, since 
none of what he suggests would have any meaning without 
explicit laws and procedural directives in place in each 
jurisdiction.  We can presume that tyrannies would laugh 
at chefren's or the IETF's attempts in that regard, and we 
can expect that most of the "civilized" countries would 
think it rather childish, too.  *Any* country would be 
free to ignore that part of a standard, since the absence 
of seals or the complete ineffectuality of such seals in 
the absence of supporting laws and procedures would be 
invisible to the box, the protocols in it, and the other 
boxes with which it communicates.  The IETF may as well 
try to tell the users of Internet protocols which side of 
the road to drive on and what voltages and frequencies to 
use in their electric power grids.  Or what flavor of jam 
or syrup to put on their breakfast pancakes or biscuits.

chefren goes beyond mixing technical issues with law and 
procedure over which the IETF neither has any influence 
nor, I'm sure, wishes to try to influence.  As Greg 
Broiles also pointed out, chefren projects his odd view of 
how legal systems work onto the entire world, when it is 
not even clear that he understands his own legal system.  
Much of what chefren presumes about the admissibility of 
evidence is simply specious in the context of the U.S. 
system, and it is so peculiar that we have to wonder if it 
is even valid in The Netherlands.

> The notion of a certified etc. network monitoring
> standard makes as much sense as a certified phone-tap
> tape recorder.  I bet there are such things, but who
> cares?  Their nominal purpose is (or would be) just as
> technically impossible.  It's easier to visit the
> nearest consumer electronics store, and buy an
> uncertified tape recorder, batteries, and clip-leads or
> inductive pick-up. 

You're still accepting chefren's implied point that such 
devices would be the only ones even officially available 
were such nonsense to find its way into an Internet 
standard.  In most places other than chefren's imaginary, 
gentlemanly police state THERE WOULD BE NO SEALED, 
ACCOUNTABLE BOXES, period.  The purchase orders would go 
out for the equipment, but no laws or procedure would be 
put in place to observe the niceties chefren seems to 
think would somehow be imposed on the authorities against 
their will.  The purchase orders would explicitly order 
any accountability be disabled or deleted.  Most if not 
all governments would use the wiretap facility of such 
equipment and require any equipment they buy to OMIT any 
features requiring auditable handshake or encryption or 
timestamping of a nature they do not desire to have.  The 
point is that NO protections will flow from a standard to 
any real-world wiretapping or court scenario against the 
wishes of the government involved.

Since few seem to notice this distinction and too many are 
trying to discuss the fine points of chefren's proposals 
while accepting his premises, let's make it even clearer:

Let's say the IETF thinks the death penalty is an awful 
barbarism, and since wiretapping could lead to convictions 
in death penalty cases, writes a provision into the 
wiretap facilitation standard that no evidence so gathered 
should be used in a capital case.  Does anyone think that 
any government in the world will pay any attention at all 
to that part of the standard?  That's precisely how silly 
the discussion of "sealed boxes" and auditability is.

Then there's the point that all of this and several other 
threads are completely off-topic.  The question before the 
group is a yes/no question concerning policy and NOTHING 
ELSE.  No issues of practicality or implementation or cost 
are on the table.  Several participants who didn't pay 
very much attention to the stated reason for existence of 
this list have evidenced severe confusion as a direct 
result of the storm of off-topic discussion of how many 
wiretapping angels can dance on the head of an alligator 
clip.  chefren, the police state's wet dream, has 
dominated the discussion with 62 posts that have drawn 
entirely too much serious response from people who should 
be able to distinguish between wheat and chaff.

Regards,

Thomas Junker
[email-masked]

The Unofficial Wang VS Information Center
http://www.phoenix.net/~tjunker/wang.html

The Live VS Web Server
http://www.tjunker.com