Subject: Re: [Raven] Anonymous taps

From: "Rick Braddam" <[email-masked]>
Date: Thu, 28 Oct 1999 15:52:25 -0500

----- Original Message -----
From: chefren <[email-masked]>
To: <[email-masked]>; Rick Braddam <[email-masked]>
Sent: Thursday, October 28, 1999 3:27 PM
Subject: Re: [Raven] Anonymous taps

> On 28 Oct 99, at 13:58, Rick Braddam wrote:
>
> >
> > ----- Original Message -----
> > From: chefren <[email-masked]>
> > To: <[email-masked]>; Richard Payne <[email-masked]>
> > Sent: Thursday, October 28, 1999 12:11 PM
> > Subject: Re: [Raven] Anonymous taps
> >
> >
> > > I'm not interested in the useful/useless discussion. I'm
> > > not interested in the data that's transported at all. Thats
> > > up to law-enforcement and not interesting for communication
> > > providers.
> >
> > > Fact is there do exist laws in this world that demand taps
> > > and IETF can make a standard for good, auditable, taps that
> > > respect privacy as much as possible.
> >
> > Fact is that the IETF can't guarantee that any one
> > country, much less all countries, will adhere to the
> > standard or respect privacy.
>
> The same for other IETF standards, IETF can't guarantee
> they won't be misused for a conspiracy to kill the
> president or for a government conspiracy against you.

Agreed.

> > If they make a method available for unlimited taps, there
> > will be unlimited taps.
>
> Not necessary, tcpdump exist.

Do you mean that it is not used covertly by law enforcement to monitor Internet traffic? Is that verifiable?

> > If the information obtained from taps is not used
> > in court directly, but used to develop other information
> > which can be used in court, the tap info is never
> > revealed.
>
> Might well be but if it pops up that information was
> gathered with unlawful means the prosecutor can stop his
> actions. (This is how it works over here...)

It can be *discovered* by unlawful means then *gathered* by lawful means such as a search warrant.

> > If the tap info is used for other than LE uses,
> > such as for financial gain by individuals, where is your
> > respect for privacy then?
>
> We/IETF should make a standard that gives laws all the
> hooks and features necessary to get this kind of misuse out
> of this world as much as possible. Encryption,
> authentication and all kind of basic technic tricks kan
> help here.
>
> > You can't come up with a tapping system which doesn't
> > involve actions by people, and some people are
> > subvertable.
>
> And you cannot come up with a guarantee that everyone who
> uses the Internet won't use it for deeds agains laws.
>
> I have brought in a basic design that makes it possible to
> detect misuse.

Only as long as you can trust all the people doing the detecting.

> > > Taps made with tcpdmp or something like that should be
> > > subsubstandard for any court in this world as soon as
> > > possible
> >
> > It doesn't matter if they are, if an attacker is after credit card numbers.
>
> What has this to do with tapping by law enforcement?
>
You can't ensure that only law enforcement will be able to use the identifying information in the protocol for tapping. If it is
there, people will make ways to use it.

> I have got to find that sig...
>
Don't bother if it also assumes that the people doing the tapping are always completely trustworthy, and that only they will be
*able* to do tapping.

Rick

_______________________________________________
raven mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/raven

---

From: "chefren" <[email-masked]>
Date: Thu, 28 Oct 1999 23:48:00 +0200

On 28 Oct 99, at 15:52, Rick Braddam wrote:

..

> Do you mean that it is not used covertly by law
> enforcement to monitor Internet traffic? Is that
> verifiable? 

It's not verifiable and it shouldn't be used for law 
enforcement just because there is little or no proof in 
just a tcpdump. Everyone can edit the dump for example.

A tap made with respect for law should be verifiable. The 
communication provider shoul de able to say before the 
judge that he set the tap according to a warrant with the 
sealed tapbox.

> It can be *discovered* by unlawful means then *gathered*
> by lawful means such as a search warrant. 

If the "criminal" can prove so because small mistakes were 
made and probably revealed because an IETF standard with 
auditing was used we can get rid of such rotten apples in 
law enforcement.

How can we =ever= get rid of them without good standards 
and laws?

..

> Only as long as you can trust all the people doing the detecting.

Why? The tapbox is both sealed and open source. The 
communication provider has no interest in the date of his 
customer and if the tap is used against someone the same 
person may use the tap to prove he is =not= guilty. Taps 
aren't used for or against someone until a judge has made a 
decision at the end of the process.

Taps often prove someone has nothing to do with a case for 
law enforcement.

> You can't ensure that only law enforcement will be able
> to use the identifying information in the protocol for
> tapping. If it is there, people will make ways to use
> it.  

Might be and the standard or laws can be tightened for that.

> Don't bother if it also assumes that the people doing
> the tapping are always completely trustworthy, and that
> only they will be *able* to do tapping. 

Are you completely trustworthy? And if you were tapped, 
would you like to be tapped with an IETF standard tap with 
verifiable recordings or just an edited tcp dump?

+++chefren

=Large signature follows=

I think we need a simple architecture for a point
to point tap interface that has strong provisions
against misuse.

On one side the communication provider who only
starts tapping a specific customer or IP number
with proper warrants.

On the other side the approved tapping room.
Everything should be organized by the central
"tapping office". This office should provide
keys for strong encryption to both communication
provider and tapping room.

Law and technology should both provide as
much checks and balances as we can come up
with. Law can provide good procedures,
technology can provide technical means to
check them or force them.    

=Large signature ended, please comment me
off-line to make it better=

---

From: Greg Broiles <[email-masked]>
Date: Thu, 28 Oct 1999 15:16:56 -0700

> just a tcpdump. Everyone can edit the dump for example.

Don't confuse your ideas about some technological utopia with actual
courtroom procedure - in the US, at least, "editable" evidence is
perfectly admissible, starting with simple human testimony about events
seen or participated in, which is the ultimate in editable evidence.
Hundreds (if not thousands) of people are convicted in the US every day
based on precisely that sort of evidence.

> judge that he set the tap according to a warrant with the 

This might be nice, but you've now wandered far beyond current law and
into science fiction.

> decision at the end of the process.

Again, you're not just designing a technical standard now, you're
redesigning the entire criminal justice system (which in the US requires
rewriting the Constitution, Title 18 of the US Code, and a few hundred
years' of common law). I'm confident it implies considerable change in
other countries, as well, who may (or may not) be interested in having
their legal systems redesigned by fiat by technical people.

Perhaps that's a little ambitious? 

--
Greg Broiles
[email-masked]

---

From: "William H. Geiger III" <[email-masked]>
Date: Thu, 28 Oct 1999 17:23:31 -0500

In <[email-masked]>, on 10/28/99 

>verifiable recordings or just an edited tcp dump?

No I want strong, unbreakable, end-to-end encryption for all my
communications. Let them tcp dump to their hearts content. <EG>

-- 
---------------------------------------------------------------
William H. Geiger III  http://www.openpgp.net
Geiger Consulting    Cooking With Warp 4.0

Author of E-Secure - PGP Front End for MR/2 Ice
PGP & MR/2 the only way for secure e-mail.
OS/2 PGP 5.0 at: http://www.openpgp.net/pgp.html
Talk About PGP on IRC EFNet Channel: #pgp Nick: whgiii

Hi Jeff!! :)
---------------------------------------------------------------

---

From: "chefren" <[email-masked]>
Date: Fri, 29 Oct 1999 00:55:30 +0200

> communications. Let them tcp dump to their hearts content. <EG>

Every criminal organisation would like to have that too. If 
our society allows us to use such means our society would 
have created places where criminal organisations could 
effectively hide for law enforcement.

On the long term definitely stupid.

Fire arms are regulated and encryption should be 
accordingly. No assault weapons and no free fully 
equiped flying F16's guided by idiots in our societies.  

Let your communication provider use the strongest 
encryption he can get for your data. I have absolutely no 
problems with that but the communication provider should 
lift it if law enforcement needs it to be lifted.

+++chefren

p.s. A guy like Saddam Hussein spends often $100.000.000 a 
month(!) to get things with which he intends to overthrow 
our societies. Free encryption is more or less self-murder 
for a free society...

---

From: "Rick Braddam" <[email-masked]>
Date: Thu, 28 Oct 1999 20:49:29 -0500

----- Original Message -----
From: chefren <[email-masked]>
To: <[email-masked]>; William H. Geiger III <[email-masked]>
Sent: Thursday, October 28, 1999 5:55 PM
Subject: Re: [Raven] Anonymous taps

> effectively hide for law enforcement.

I hate to be the one to have to break this to you, but they already have strong encryption if they want it and designing a tapping
protocol is not going to help break it. It is, for all practical purposes, unbreakable and widely available for free.

> On the long term definitely stupid.

It is not stupid to preserve the rights and freedom of the vast majority of the population at the expense of making it more
difficult to identify and gather evidence against the criminals, who make up a very small minority of the population. It IS stupid
to restrict those rights and freedoms because of the acts of a few.

> equiped flying F16's guided by idiots in our societies.

The mayors of Chicago and New York, among many others, have waited a long time for firearms regulation to cure their
criminals-with-guns problems. One of the problems is that the criminals with guns seem to be ignoring the firearms regulations.

The same thing would happen with prohibition of strong crypto. Ordinary people would lose their privacy and criminals would still
use the strong crypto they have.

If it were possible to regulate cryptography to the extent that criminals simply could not use it, it wouldn't impede their criminal
activities very much. There are other forms of secure communications they can (and do) use.

> lift it if law enforcement needs it to be lifted.
I much prefer my communications provider never *see* my data.

Rick