Subject: Re: [Raven] CESA

From: "Richard Payne" <[email-masked]>
Date: Tue, 9 Nov 1999 09:40:53 -0500

ch*fr*n wrote:

>> Under CESA, _they_ would get to choose what to disclose about the
provenance
>> of information, which would probably be the amount that maximally
>> strengthens their case without revealing any inconvenient facts that
might
>> strengthen yours.
>
>Yes that's all yuck yuck yuck law enforcement or unjustice.
>
>> Your defense attorney would have to take what crumbs they chose to
provide.
>> Even in the Netherlands, I bet that this would be considered prejudicial
to
>> a fair trial.
>>
>> Clear now?
>>
>> Richard Payne
>
>
>Yes. I still think you are convert and just don't seem to
>know or understand it.
>
>We agree about the problem, you seem to say there is no
>solution and I do see one. If you where in The Netherlands

which seems to indicate a fair degree of confusion. Some key points:

1) We do agree that CESA is bad. Yes, sooner or later we had to agree on
something. ;-)

2) CESA is just one instance of what LEA's, even in supposedly free
countries, would like to be able to do in terms of evidence gathering
without effective oversight and in terms of weakening of the rules of
evidence.

The problem is not restricted to the U.S. The UK has tabled Interception of
Communications and Electronic Commerce legislation for discussion, the flaws
in which have been amply discussed elsewhere. Australia's Walsh Report dealt
with the same issues as CESA, in roughly the same way, in one of the
censored sections.

Now I'm willing to stipulate, for purposes of this discussion, that the
Netherlands is a wonderful place where nothing ever happens without proper
authorization. What I'm presenting to you is a list of three "good-guy"
countries where the LEA's do not feel constrained to play by your personal
set of rules. "Bad-guy" countries (i.e. those that don't even pay lip
service to civil liberties) are even less constrained.

Now seriously, don't just say "yuck": how do you reconcile your apparently
boundless faith in the willingness of LEA's to play by your personal set of
rules with these examples?

3) I do not say there is no solution. The solution is obvious, and has been
advocated repeatedly by the IETF in RFC 1984, by other posters to this list,
and by me. I am in favor of widespread use of strong end-to-end encryption
by all users, with no key escrow requirements.

4) Given that 3) is exactly the opposite of what you advocate, thanks for
the compliment (I think) of assuming that I share your point of view, but I
do not.

Richard Payne

_______________________________________________
raven mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/raven

---

From: "chefren" <[email-masked]>
Date: Tue, 9 Nov 1999 17:34:40 +0100

On 9 Nov 99, at 9:40, Richard Payne wrote:

..

> authorization.

For law enforcement yes. Concerning intelligence agencies, 
something that has nothing to do with the point the 
minority tries to address I don't know. Bad taps are 
simple, tcpdump exists. Good taps needs good standards that 
provides guarantees about the gathered evidence. Guarantees 
concerning tampering with the tap-data and concerning 
privacy. Nobody but law-enforcers should have access to the 
data.

> What I'm presenting to you is a list of three "good-guy"

I agree but there is nothing else we can do about it than 
provide standards for GOOD taps, taps that provide security 
against misuse and unnecessary breaches of privacy.

We can just ask them to use the standard, nothing more or 
less.

Laywers can tell the judge that tcpdump-taps can't be taken 
serious in a world with a good IETF tapping standard.

The New IETF standard is to provide defense against misuse 
of taps or bad taps in general is precisely what the 
minority tries to explain to the "masses" here.

> rules with these examples?

If I my family or friends will ever be confronted with taps 
before a judge and they are not auditable I don't want to 
accept those taps.

> by all users, with no key escrow requirements.

Even if you are using that and a message of you is tapped 
it can help you in court: The tap proves you send a 
message. Regardless of decoding. You can decode it in court 
before the judge if you wish or pretend you lost the key. 
It can also be a crypted message of another party that 
described you would receive lots of dollars. The tap will 
prove you received the message and you can decode it.

> the compliment (I think) of assuming that I share your point of view, but I

I didn't advocate for third parties, or other breaches of 
security, nor do I advocate for changes in existing 
protocols or standards. I only write about taps and I'm not 
interested in the data at all, encrypted or not.

Democracies have demanded taps, good citizens have to obey 
that, and IETF can help the citizens by providing a good 
auditable and secure standard for the required taps.

It's very simple, it will be more difficult for law 
enforcers to make taps with the standard the minority 
proposes but the taps will have higher legal and moral 
standards. The citizens that are tapped have maximum 
security about the privacy and the chances of misuse of 
their data.

+++chefren

---

From: Ed Stone <[email-masked]>
Date: Tue, 09 Nov 1999 13:18:43 -0500

At 11:34 AM 11/9/1999 , chefren wrote:
>For law enforcement yes.

I take it that either you refer to the recent time period and your hopes 
for it, or you find that during the 40's, police in the Netherlands did not 
serve tyranny in violation of international law and human rights.

>We can just ask them to use the standard, nothing more or

That is not correct. This is about a *standard* that will affect every 
packet, everywhere on the Internet. Thus, if you facilitate a tapping 
*standard* (regardless of your hopes for its enlightened and fair use) you 
facilitate tapping universally.

You facilitate it for evil no less than you facilitate it for good.

That you hope that governments will use it wisely, that they will create 
good controls and audits that show the legal warrants, and that they will 
honor human civil rights... all of those hopes are nice. Your hopes, 
however, are at odds with the laws, practices and customs in millions of 
square miles of this planet. Sorry.

To defend the proposition that IETF should promote a wiretap standard, you 
have the burden to show the following:

1. tapping can not be done adequately without a standards action by IETF;
2. a tapping standards action by IETF will not enhance the ability of 
miscreant governments to oppress and surveil in furtherance of the 
violation of human rights;
3. a tapping standard action by IETF will *ensure* the control and 
auditability of taps in a manner that *cannot* be done absent such a new 
wiretap-friendly standard.

If you cannot show #1, then we don't need a new standard to provide for 
wiretaps.
If you cannot show #2, then we have no assurance that a new wiretap 
standard makes the world a better place.
If you cannot show #3, then why bother with a new standard?

I assume you'd agree that unless it accomplishes an unmet need, and unless 
it makes the world a better place, and unless it is essential and 
sufficient to accomplish control and auditability of wiretaps, there is NO 
reason for it, and it is a waste of time, if not essentially dangerous to 
the world.

If you can show that the *standard*, if implemented, will not aid miscreant 
governments in oppressing their subjects, only then might you have a case 
to make for a *standard*.  And even then, you must show that without the 
*standard* enlightened governments cannot provide good controls and audit 
trails on their taps.

>serious in a world with a good IETF tapping standard.

You mean that jurisprudence depends not on chain of evidence testimony by 
certified experts against cross examination and submittal of contradictory 
evidence for consideration by a judge and jury, rather it depends on a 
different arrangement of bits that will be available only if IETF makes a 
standards action?

>minority tries to explain to the "masses" here.

Good! Then explain precisely this, and please be SPECIFIC:

How will an IETF standard *ensure* a miscreant-government-proof "defense 
against misuse of taps or bad taps in general"?

I submit that you cannot make such a case. I submit that the technical 
standard describes what bits go where, and that you have no technical 
standard in your wildest imagination that will *ensure* that miscreant 
governments *cannot* abuse the application and use of wiretaps. But if 
you'd like to provide such a technical standard that ties the hands of 
miscreant governments, limiting them to only good use of wiretaps and only 
good taps in general, I'd love to see it.

Futher, I submit that you can make no case that the current standard 
*prevents* a "good" government from creating auditability sufficient for an 
adversarial court proceeding within current Federal Rules of Evidence (in 
the case of the US).

>before a judge and they are not auditable I don't want to

That is understandable. What it is not, however, is an answer to the 
question that was posed to you. Again, "how do you reconcile your 
apparently boundless faith in the willingness of LEA's to play by your 
personal set of rules with these examples?"

The answer you provided appears to say that your boundless faith in the 
willingness of LEAs to play by your personal set of rules (fairness and 
human rights) is based on the fact that if accused, you'd like to have an 
audit of the tap.

You are in circular reasoning. Please break out and tell us a) what 
precisely prevents auditability today of wiretaps, and b) the technical 
standard you'd propose to *ensure* that governments cannot subvert that 
auditability.

>prove you received the message and you can decode it.

Decoding an encrypted intercept is off topic. The question that IESG posed 
to IETF goes to wiretapping and intercepting of packets. What is in the 
intercepted packets is a separate issue.

>interested in the data at all, encrypted or not.

Good.

>auditable and secure standard for the required taps.

Tyrranies have demanded taps; subjects are not consulted, and until you 
give us one simple hint as to how IETF can write a standard for wiretaps 
that *ensures* that miscreant governments cannot subvert the auditability 
you espouse and which you submit as the justifcation for a new standard, or 
at least shows how "good" governments can employ auditability that is 
impossible to employ under the current standards, you are not advancing 
your case one iota.

>proposes

Any proof of that? Isn't a tap a simple, elementary electrical connection 
to a specific wire (or reception of a wireless RF signal) piped into a 
recording ocilloscope or equivalent?

>  but the taps will have higher legal and moral
>standards.

You continue to say this, and you continue to provide NO support for how a 
technical standard will support (i.e., require and ensure) a higher legal 
and moral standard.

>  The citizens that are tapped have maximum

Allow me to point out the obvious: citizens who are tapped have thereby 
*lost* maximum security about privacy of the tapped communication and the 
chances of misuse of their data have just begun.

As you persist in your pollyanna views, please consider that in the most 
populous nation of the world, it is "due process of law" to tap a person 
without a warrant; that if the tap indicates that he has encouraged his 
neighbor to light a white candle on the anniversary of the Tienanmen Square 
massacre, that he can be arrested, convicted in secret in a "court" that 
disallows a defense, shot, and his organs sold abroad.

Have a nice day in the Netherlands.

--
--------------------------
Ed Stone
[email-masked]
--------------------------

---

From: "chefren" <[email-masked]>
Date: Tue, 9 Nov 1999 22:30:52 +0100

On 9 Nov 99, at 13:18, Ed Stone wrote:

..

> facilitate tapping universally.

Why? Is "tcpdump" a utility that affects every packet 
everywhere on the Internet?

Haven't you read a word here? As far as I know nobody asked 
for more than a auditable version of tcpdump.

> You facilitate it for evil no less than you facilitate it for good.

The most facile is using tcpdump, nobody has to download 
it, it exists and is omnipresent, can we agree upon that? 

  (I hope I don't have to explain the working of shells,
  I/O redirection and various mail programs but please
  believe me tapping with tcpdump is a snap and getting the
  data to any spot attached to the Internet only depends on
  bandwith.) 

So what's precisely your problem with the proposal for an 
auditable version of tcpdump?

..
 
> 1. tapping can not be done adequately without a standards action by IETF;

The standard may be written by anyone but the IETF is the 
recognized standard office for Internet standards. So I 
think it's the only adequate organization for it.

> violation of human rights;

Is there any standard of IETF that does? I hope not. 
Technology can probly always used for good and for bad. The 
proposed standard is a way to prevent abuse of tapping and 
keep privacy of the tapped in check.

> wiretap-friendly standard.

If the taps aren't standardized the probably hundreds of 
communication providers in a law enforcement region should 
have to use the standard of that law enforcement region. 
Lots of communication providers also work in other regions 
of this world and there they have to use other equipment 
and other standards. Typically a reason to have one 
standard.

> If you cannot show #3, then why bother with a new standard?

I think the basic idea meets all requirements but I'm 
pretty sure some people here don't think so.

..

> against misuse of taps or bad taps in general"?

That's a wrong question thats equal to "how can we prevent 
that nobody will ever be beaten to death with a piece of 
frozen water".

Probably nobody kan 100% prevent misuse of any technology.

Your specifics have little or nothing to do with IETF 
goals: If IETF was interested in such good/bad items why 
did they ever provided encryption standards without being 
sure organized crime wouldn't use them?

..

> You are in circular reasoning.

You think so because you don't seem to believe in democracy.

I believe in democracy and based upon that is the idea that 
law enforcement people that break laws should be punished 
according to the law. I also want proof in court and that 
cannot be obtained without usable and proven standards.

> Please break out and tell us a) what 
> precisely prevents auditability today of wiretaps,

Everybody can tamper with tcpdump data.

> and b) the technical 

As I explained earlier: We need a standard tapbox, sealed 
and designed according to standard. It needs software that 
does something like tcpdump, packs the data and with 
headers that contain all information about the tap (who has 
set it, date time, bytes, checksum of the bytes, hash of 
the header et cetera). The data should be send to the 
tapping room of law enforcement via a secure channel using 
keys that are given out by a central agency only after 
receiving proper warrants. The tapbox seal may be broken 
for control by other independent organizations. And so on.

..

> Decoding an encrypted intercept is off topic.

Agree, encryption as whole I think.

> The question that IESG posed 

Yes!

..

> impossible to employ under the current standards, you are not advancing 

I don't want to give an answer on your more or less silly 
question. We agree that such a guarantee doesn't exist. So 
I don't need or want an advancement in the direction you 
point at.

> recording ocilloscope or equivalent?

Long time ago yes but now it's substandard, quite some time 
in The Netherlands. Now tapping rooms don't want and even 
accept tapdata of communication providers that don't handle 
the proper DES challenge response upfront.

Please think of it, in The Netherlands the police doesn't 
accept for example a GSM call of a communicationprovider 
without prior bidirectional DES challenge response upfront. 
The digital recorders don't even start for substandard data!

I hope you get the point. These are local standards for 
phonecalls that should be set world wide for IP.

> technical standard will support (i.e., require and ensure) a higher legal 

I hope I proceeded a little...

> chances of misuse of their data have just begun.

They have lost that because their community has decided in 
an accepted democratic way the privacy should be weakend as 
little as possible in order to give law enforcers more 
chance to enforce the law.

..

> Have a nice day in the Netherlands.

We have lots of them, please take a look,

+++chefren

=Large signature follows=

I think we need a simple architecture for a point
to point tap interface that has strong provisions
against misuse.

On one side the communication provider who only
starts tapping a specific customer or IP number
with proper warrants.

On the other side the approved tapping room.
Everything should be organized by the central
"tapping office". This office should provide
keys for strong encryption to both communication
provider and tapping room.

Law and technology should both provide as
much checks and balances as we can come up
with. Law can provide good procedures,
technology can provide technical means to
check them or force them.    

=Large signature ended, please comment me
off-line to make it better=

---

From: Ed Stone <[email-masked]>
Date: Tue, 09 Nov 1999 17:52:55 -0500

>everywhere on the Internet?

So you wish to submit that the ability to tap the net currently exists 
without any new standards action from the IETF. Thanks.

>for more than a auditable version of tcpdump.

And you continue to avoid the question of how can a standard be written (if 
IETF were in a mood to humor you) that *ensures* a) that the tap is 
audited; and b) that the audit process cannot be subverted.

Secondly, you continue to avoid to address what there is about tpcdump that 
disables the ability of one who wished to provide an "audited tap" to do so.

>   data to any spot attached to the Internet only depends on

Again, you agree that there is no need for any new standard in order to tap 
the net...

>auditable version of tcpdump?

MY problem, precisely, is that 1) nothing stands in the way of creating an 
auditable version of tcpdump under current practices (certified expert 
testimony, data collected, description of wire that was tapped, sworn 
testimony), without a new standard, and 2) no one has described how a new 
standard can provide an auditable tap in which the "audit" compromisable by 
the auditor.

>think it's the only adequate organization for it.

You missed it yet again. You tell us who can write standards. You avoid the 
obvious, that tapping can be done adequately now without any new standards 
actions by the IETF.

>keep privacy of the tapped in check.

So will it enhance the ability of miscreant governments to oppress and 
surveil, or not?

>and other standards. Typically a reason to have one

You really don't want to answer the essential question.... Please describe 
how any standard you can imagine will *ensure* auditability, in a manner 
than *cannot* be done absent such a new wiretap-friendly standard.

>that nobody will ever be beaten to death with a piece of

The point is that if the new standard cannot be shown to accomplish the 
function that you put forward to justify it (a reliable audit), then there 
is no reason to make the new standard.

>sure organized crime wouldn't use them?

Encryption is a defensive item, in that it defends the confidentiality of a 
communication. Wiretaps are offensive items, in that they attempt to 
deprive a communicator of the privacy and confidentiality he wished to have.

But yet again, this question is not about encryption. It is about interception.

>You think so because you don't seem to believe in democracy.

Read  John Locke's Second Treatise of Government. Read the US Dec of Ind, 
for a description of inalienable rights. Inalienable means that it doesn't 
matter how many people want otherwise, the rights are inalienable. The view 
of democracy you are describing is two wolves and a sheep deciding what to 
have for dinner, democratically, of course.

>Everybody can tamper with tcpdump data.

Why can NO ONE tamper with data that would come from the "auditable" tap 
you are recommending? What technical features prohibit it?

>for control by other independent organizations. And so on
>
>..
>
>

Here, finally, you seem to agree that your imagined standard cannot 
generate an audit that is not subvertible. Because of that, your 
justification for a new standard fails.

---

From: "chefren" <[email-masked]>
Date: Wed, 10 Nov 1999 00:44:22 +0100

> without any new standards action from the IETF. Thanks.

Secure end to end communication was also possible without 
IETF standards for it...

> audited;

Does the end to end encryption standard of IETF *ensures* 
the use if it?

> and b) that the audit process cannot be subverted.

Yes. I can guarantee that to you if it pleases you. You may 
be the one that handles out the authentication and 
encryption keys and maybe even random session keys. And you 
may receive and log the MD5 hashes that are made from the 
individual taps. The keys will for example (sketch) be used:

To do authentication between the tapbox that's under 
control of the communication provider and the tapping room 
before tapped data may pass between them. The encryption 
and session key could be used to strenghten the contents 
and auditability of the whole tap and the MD5 hash you will 
personally receive.

If someone in court says I doubt the tap, someone has 
tampered with it. I will redirect the to you and you can 
compare the hashes and thus prove nobody has tampered with 
it.

=This was a sketch, I received already some hints to do 
this better and more professionally. Precisely what I 
expected of people dedicated to good IETF standards...=
 
> disables the ability of one who wished to provide an "audited tap" to do so.

Hope the above adresses enough. If you have further 
questions please state them.

> Again, you agree that there is no need for any new standard in order to tap 

But there IS a need for a standard that should be usable in 
courts. Tcpdump is definitely not enough.

> testimony), without a new standard,

That auditable version would be a new standard. Am I wrong 
here?

> and 2) no one has described how a new 

The tapbox is open-source, open architecture and sealed, If 
it's up to me You may check all tapboxes in the world and 
see if the seals are not broken. I hope this helps?

..

> So will it enhance the ability of miscreant governments to oppress and 

It will severely handicap them.

..

..

> you are recommending? What technical features prohibit it?

The open source design of the tapbox, the open source 
protocols, and the administrative protocols around it.

..

+++chefren

= =
ii.nl ontwerpt, bouwt én onderhoudt websites
100 Euro aanbrengpremie: http://www.ii.nl/premie

---

From: "Thomas Junker" <[email-masked]>
Date: Wed, 10 Nov 1999 00:14:06 -0600

> for more than a auditable version of tcpdump.

Haven't you read a word here?  The purpose of this list is 
not to ask for any protocol or suggest any protocol.

You still don't get it.
> it, it exists and is omnipresent, can we agree upon that? 

It's irrelevant to the question beforet this group.

> auditable version of tcpdump?

I can't speak for Ed, but my problem with it is that 
discussion of such a proposal is not the purpose of this 
list.  Your opinions of what the purpose of this list 
should be, insofar as they are inconsistent with the 
stated purpose of this list, are irrelevant here.

> think it's the only adequate organization for it.

Then take it up in the other IETF forums where proposals 
and discussion of protocols are appropriate.  Your more 
than 100 messages here have not contributed to the topical 
discussion -- rather, they have impeded the topical 
discussion, confused some participants about the purpose 
of the list, and led some casual observers to conclude 
erroneously that the IETF *is* discussing protocol 
measures to facilitate wiretapping.

> keep privacy of the tapped in check.

It is *not* a proposed standard.  Go write an draft RFC if 
you wish to propose a standard.  This is not the place to 
propose a standard or suggest what standards should be 
proposed.  You still don't get it.

> and other standards. Typically a reason to have one 

And a reason why many of us oppose the IETF becoming 
involved in setting standards with respect to wiretapping.
To do, or not to do, that is the question.  None of the 
details of any particular idea for how to make wiretapping 
safe for democracy or democracy safe for wiretapping are 
relevant.

> pretty sure some people here don't think so.

You still seem to think you are in a forum where standards 
are proposed.  That is not the case.  This is a forum for 
discussing whether the IETF should even involve itself in 
such standards -- not which would be good, or easy, or 
effective, or cheap.

> > >minority tries to explain to the "masses" here.

Now you're going off the deep end and postulating a 
standard as if it existed?  Do you have any idea what 
confusion and misleading reporting you are causing?

> Probably nobody kan 100% prevent misuse of any technology.

That's not the issue here.

> sure organized crime wouldn't use them?

To facilitate security and privacy.  *You* are the only 
one obsessed with the privacy of data once it is already 
in the hands of authorities, while unconcerned about 
privacy *from* intrusive authorities, rather 180 degrees 
reversed from the common viewpoint.  Most everyone else is 
concerned about not aiding and abetting weakening of 
security and privacy by rolling over for the vendors and 
carriers who wring their hands about not getting the 
helping hand of IETF sanction and standarization in 
facilitating invasions of privacy.

> > >before a judge and they are not auditable I don't want to

What you "want" has little to do with how courts operate, 
even in ideal places like The Netherlands.  Your idealized 
vision of lawyers being able to shoot down unauditable 
evidence is fantasy in almost all jurisdictions in this 
world.  Protections against flawed or uncertain evidence 
vary from *none* (very common) to a spotty *some* (common 
in the "good" countries but very subjective and fickle in 
nature).  And it still has nothing to do with the topic of 
this list.

> You think so because you don't seem to believe in democracy.

The idealized democracy you have described in several 
messages exists only in your imagination and, if we are to 
believe you, in The Netherlands.  When I suggested that 
Lyal needs to get out more, I was not trying to be 
insulting, I was entirely serious.  It applies to you, 
too.  Your view of law and justice is seriously 
provincial, apparently determined by narrow experience in 
a small area of the planet.  You have based many of your 
arguments on the presumption that sanity and high ethical 
and human rights standards prevail in government because 
it is democratic.  Not only is that demontrably false as 
general premise, it also indisputable that the majority of 
the world's population does not even live under putative 
democracy.  And it's still off topic on this list.

> cannot be obtained without usable and proven standards.

You're a lone dog barking about how you should have meat 
for all three meals, while many dogs elsewhere are given 
no meat and are starved or beaten to death.  Your 
statement above has no meaningful context outside the 
place where you live, and I doubt you are even accurate in 
the assertions you have made about conditions where you 
live, since when called on the specifics you produced 
ambiguous, even contradictory material in support of your 
contentions.

> Everybody can tamper with tcpdump data.

That's irrelevant to the purpose of this list.

> for control by other independent organizations. And so on.

This is not a list for proposing such things.  Even so, 
what you state is fatally flawed with nontechnical legal 
issues:

    "sealed" is meaningless unless required and enforced
    by law

    "designed according to standard" is meaningless unless
    required and enforced by law

    "packs the data and with headers that contain all
    information about the tap" is meaningless unless
    required by law and its validation mechanism specified
    and enforced by law

    "data should be send to the tapping room of law
    enforcement via a secure channel" is meaningless 
    unless required and enforced by law

    "using keys that are given out by a central agency
    only after receiving proper warrants" is meaningless
    unless required and enforced by law

    "The tapbox seal may be broken for control by other
    independent organizations" is meaningless unless
    required and enforced by law

An IETF standard is no place to be specifying law.  This 
list is no place to be suggesting an IETF standard be 
considered.

> Agree, encryption as whole I think.

You have brought up encryption and back doors far more 
than anyone else.  You even seem to imagine "back doors" 
where no one has mentioned the topic.

> > intercepted packets is a separate issue.

Not quite.  The question posed by the IESG does NOT "go to 
wiretapping and intercepting of packets" except in the 
limited context of considering whether the IETF should 
involve itself -- not *how* it should involve itself and 
not *which* protocols should be considered.  You have put 
the cart before the horse and spent in excess of 100 
messages proposing and presenting details and arguing 
popular democracy (2400 years after it was shown to be 
defective) and various other off-topic things, utterly 
ignoring the definition of the list and the question put 
to the list.

[Payne wrote:]
> I don't need or want an advancement in the direction you 

Even on the off-topic issues you insist on bringing up, 
you dishonestly dismiss a completely rational and logical 
challenge.  Even in a forum where it would be appropriate 
to advance a proposal for a standard, you would be asked 
virtually the same question as was asked above.  If you 
can't show how your proposal could be enforced on "bad" 
governments and can't show how "good" governments are 
unable to do "the right thing" without your proposal, you 
have *nothing* and few people will be interested in it.

> > >enforcers to make taps with the standard the minority

[Payne wrote:]
> the proper DES challenge response upfront.

Aren't they such perfect gentlemen?  Or is it that they 
have no interest in flawed evidence, since it won't be 
useful for prosecuting anyone?  Could it be that even in 
your utopian Netherlands, the main consideration is not 
protecting the individual but getting the strongest 
evidence possible without regard to considerations of the 
individual?  And it's still off topic.

> The digital recorders don't even start for substandard data!

Only because it won't help them convict someone, possibly 
because The Netherlands courts *do* recognize challenges 
to the defects of evidence.  Still, the concern is not for 
the individual but for convicting the individual.  And 
it's inapplicable as any kind of protection in most of the 
rest of the world.  And it's still off topic.

> phonecalls that should be set world wide for IP.

Then you have considerable lobbying to do with a lot of 
legislatures around the world.  Hopefully you will embark 
on that mission soon, and have little time to post further 
off-topic messages here.

> I hope I proceeded a little...

Whatever that means!

> chance to enforce the law.

Good political philosophy stuff, but wholly inapplicable 
to technical standards, which must *follow* law, not 
precede it, at least where such heavily legally-
intertwined issues are concerned, AND OFF TOPIC ON THIS 
LIST.

> We have lots of them, please take a look,

Good for you.  We're happy for you.  I just wish you would 
stop projecting your Dutch paradise onto the rest of the 
world -- it doesn't work.  Maybe you would understand that 
if you knew anything at all about the rest of the world.  
If you insist on proposing such things, kindly take it to 
a forum where someone gives a crap.  This is not a forum 
for proposing protocols.  It is CERTAINLY NOT a forum for 
telling us how you think the legal systems of the 
countries of the world should work.

Regards,

Thomas Junker
[email-masked]

---

From: "Ge' Weijers" <[email-masked]>
Date: Fri, 12 Nov 1999 12:16:38 -0700

> prove you received the message and you can decode it.

Here it shows you don't understand modern cryptography. The fact that
you can decode a message at any time does not imply that you can
decode a message at a later date. There's such a thing as 'perfect
forward secrecy'. That's the beauty of IPSEC: keys are discarded after
use. A perfect defense....

-- 
-
Ge' Weijers                                Voice: (614)326 4600
Progressive Systems, Inc.                    FAX: (614)326 4601
2000 West Henderson Rd. Suite 400, Columbus OH 43220

---

From: "Lyal Collins" <[email-masked]>
Date: Sat, 13 Nov 1999 07:44:29 +1100

What about the scenario that you wisht to prove you did send a message, but
the intended recipient denies receipt?

This could be for contractual obligation, an alibi, or to disprove claims of
negligence.
It there is undecryptable content - who knows if your claim or both
transmission and content is correct?

Regards,
Lyal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of Ge'
> Weijers
> Sent: Saturday, 13 November 1999 6:17
> To: chefren
> Cc: [email-masked]; Richard Payne
> Subject: Re: [Raven] CESA
>
>

---

From: Seth David Schoen <[email-masked]>
Date: Fri, 12 Nov 1999 22:25:09 -0800

> transmission and content is correct?

There are good protocols for proving that you sent a particular message.
Bruce Schneier has described some of them in _Applied Cryptography_.
Remember that cryptography is not just used for confidentiality.

Presumably, effective use of these protocols requires holding onto some of
the keys.  Therefore, you may need to choose between methods of communication
where you can't prove that you said a particular thing (but nobody else can
either, in practice) and methods of communication where you can prove that
you said that (but someone else might then be able to force you to do so).

There may be some middle ground, depending on what kind of proof is
necessary and when.  Most of these questions depend on the nature of the
communications and of the relationship between the communicating parties.

Why does it feel like this list is turning into cypherpunks?

-- 
Seth David Schoen <[email-masked]>  | And do not say, I will study when I
     http://www.loyalty.org/~schoen/    | have leisure; for perhaps you will
     http://www.loyalty.org/   (CAF)    | not have leisure.  -- Pirke Avot 2:5

---

From: "chefren" <[email-masked]>
Date: Mon, 15 Nov 1999 18:16:50 +0100

On 12 Nov 99, at 22:25, Seth David Schoen wrote:

..

..

Because the people with a wider view than just technology 
stopped posting messages?

Personally I don't fully agree with that, Lyal did post a 
good basic idea for continuing this list.

There are a lot of words that give the cypherpunks here 
allergic reactions but I still think the world needs a 
standard for taps.

  Ooops, shouldn't have used the word "taps".

Eh, needs a standard that enables third parties to prove 
communication did took place.

+++chefren

= =

---

From: "chefren" <[email-masked]>
Date: Mon, 15 Nov 1999 18:46:00 +0100

> use. A perfect defense....

Or.... Does it just show that some of us don't understand 
what happens for ages in courts and other places in our 
society?

It seems prety unavoidable and basic to me that people want 
auditable IP taps to prove digital communication, even 
encrypted communication, has taken place.

Banks and other institutions have tapedrives to log all 
communication for years. The only thing I try to explain 
here is that an Internet standard is definitely needed.

And it seems IETF can stop lot's of pretty stupid 
discussions with it too!

+++chefren

=Signature follows=

Everything should be organized by a central
"tapping office". This office should provide
keys for strong encryption to both communication
provider and tapping room.

=Large signature ended. If you want to
help to setup a standard for the above
design, please contact me.=

---

From: Christian Price <[email-masked]>
Date: Mon, 15 Nov 1999 12:59:29 -0700

I don't mean to get too highly speculative, but an article in the UK's
Independent News service highlites the need for encryption to be
un-tappable - and potentially extensible to voice!

http://www.independent.co.uk/news/Digital/Features/spies151199.shtml

Happy (paranoya induced) reading!

--Christian