Subject: Re: [Raven] Nevermore ...

From: [email-masked]
Date: Tue, 2 Nov 1999 10:59:44 -0500

On Mon, 1 Nov 1999  "chefren" <[email-masked]> wrote:

>On 29 Oct 99, at 18:01, [email-masked] wrote:
>
>>    We are contemplating a practical quagmire and no less than the
tapping
>>    of every IP protocol not just VoIP.  It undermines the good work of
the
>>    IETF.
>I don't see why.

Exactly!   You seem to consistently miss the point.    You've monopolized
and sidetracked the forum from a "should we" discussion to a "how can we"
discussion.  The participants on this list have repeatedly pointed out
flaws and gaps in your logic and a failure to understand the original
questions.   They have also pointed out that you may very well have a
personal financial stake in the outcome.

Basically, you and I have a big difference of opinion and underlying
philosophy.  I am not going to bother with picking apart the logical
inconsistencies in the rest of your post or enumerating our differences.
I'd like to leave it at that and let the IETF judge the results based on
the quality of arguments made in the posts.

I have stated my opinions.  I've said nothing about my opinion of lawful
intercept.  Just that the IETF should stay out.  The issue is as much
practical as philosophical.   I don't think the IETF should pursue this.
Period.

I will continue to monitor the list.  If I see anything that convinces me
that I should change my position, then I am big enough to come forward and
state that.    Otherwise, I am likely to remain silent.   I dislike wasting
bandwidth.

David Gamey

Any opinions expressed above are mine and not those of IBM or IBM Security
and Privacy Services.

_______________________________________________
raven mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/raven

---

From: "chefren" <[email-masked]>
Date: Tue, 2 Nov 1999 19:01:37 +0100

On 2 Nov 99, at 10:59, [email-masked] wrote:

> Exactly!   You seem to consistently miss the point.

Please be more specific. An standard that describes more or 
less an auditable tcpdump doesnt have ANYTHING to do with 
other standards. It doesn't undermine anything. You just 
react like someone who is allergic for something he cannot 
see feel or touch, allergic for a thought. Unfortunately my 
english isn't good enough to translate the Dutch term for 
it.

> You've monopolized and sidetracked the forum from a
> "should we" discussion to a "how can we" discussion. 

I think the crypto-believers monopolize this discussion 
with something thats completely irrelevant. The problem is 
that almost all governments in this world require taps. 
It's not difficult to make a tap, tcpdump and other 
utilities exist. However it is difficult to do a good 
auditable tap that respects privacy of the accused.

And the argument that strong encryption makes tapping 
irrelevant is far beyond the truth from a forensic point of 
view. The equivalent of fingerprints are certainly 
available and in that industry everything helps.

> The participants on this list have repeatedly pointed
> out flaws and gaps in your logic and a failure to
> understand the original questions. 

I'm sorry but you have to respect the basics of the list 
here. Everyone who wants is invited to participate, 
everyone me write whatever he wants. I think by chance I've 
got pretty involved in this some years ago because a local 
police department in The Netherlands became crazy of the 
amateuristic way of wiretapping with analog tape recorders. 
Amateuristic because of the lack of auditing. Thoughts we 
developped about 10 years ago have slowly spread over 
country and I think they are really worth to spread over 
the world (basically: taps should technically be auditable 
and preserve as much privacy of all parties as possible).

I tend to kind of hate crypto discussions with believers, 
as others stated they cannot quantify how strong the 
encryption is but they =talk= as if strong encryption is 
100% "safe". Reality in crimefighting: Nothing proves to be 
100% safe in all cases. Law enforcement may for example get 
the key from one of the parties. Law enforcement may just 
be happy with only the digital fingerprints of the 
datastream.

> They have also pointed out that you may very well have a

=That's just ad hominem and of no importance at all.= Lots 
of people here seem to write for statue. The company I work 
for is very small and even the slightest change in 
standards will undoubtly give a revenue change at IBM (your 
company) thats far bigger than ours. The standards and 
architecture I proposed have almost no value. Everything 
should be completely open source, low tech and verifiable 
so everyone can manufacture the proposed tap-box. There is 
probably some value in the recorder but that will be low 
too. Again, no importance for this list. Nobody is required 
to present a list of what he or his firm would gain with 
which direction of the discussion. Absurd idea! There even 
is no requirement for your identity. Anonymous people have 
already written here, a false name "revealed" further 
information about my background (I think it's was a breach 
of privacy that shouldn't be tolerated by the list at all).

> philosophy.

I don't know, I only know for sure you haven't read the 
information supplied by the minority.

> I am not going to bother with picking apart the logical

You haven't even started at your own proposition: If 
communication cannot be tapped governments will defacto 
allow organized crime.

..

> I've said nothing about my opinion of lawful intercept. 
> Just that the IETF should stay out. 

So you think you don't have to argue? We are not busy with 
voting here but with gathering arguments...

..

> state that.

There seems to be enough to admit for you...

+++chefren

= =
Verdien 100 Euro bij aanbrengen van een nieuwe
klant voor een website: http://www.ii.nl/premie

---

From: Paul Ferguson <[email-masked]>
Date: Tue, 02 Nov 1999 16:13:34 -0500

At 07:01 PM 11/02/1999 +0100, chefren wrote:

>[...] However it is difficult to do a good

This is not a technical issue -- it is one which rests
with the authorities (or non-authorities, as the case may
be) who conduct the tap.

>available and in that industry everything helps.

This is false on its face.

If end-to-end encryption is used, any tap results in gibberish.
(Of course, this does not hold true if GAK or key escrow is used
and the "tappers" have access to the keys needed to decrypt the
data, but that's another topic entirely.)

"Fingerprints", as you so quaintly put it, is nothing more than
source & destination information -- the type of information that
people in the security arena have been calling information used
to conduct "traffic analysis." What the "analyzers" get is nothing
more than "X" is talking to "Y".

When people become suspect under law enforcement regimes in conducting
private conversations with anyone, then the populace is subject to
excessive police powers.

Again, this is somewhat orthogonal to the discussion at hand, but
since you brought it up....

>[...] (basically: taps should technically be auditable

Again, abuses of "tapability" are not technical in nature, they
are either (a) political injustices, or (b) conducted by people
who are not in positions to conduct legal wiretaps but yet have
access to the technology. This is the basis of the discussion here.

The IETF would be doing a grave injustice to privacy-loving
peoples everywhere if it were to purposefully design tapability
into its protocols.

>100% "safe".

You know, I tend to hate discussing religion with true
believers, but that's the way the ball bounces. Get over it.

Speaking only for myself,

- paul

---

From: "chefren" <[email-masked]>
Date: Tue, 2 Nov 1999 22:44:17 +0100

> access to the technology. This is the basis of the discussion here.

There is more, people could for example tamper with the 
evidence. If the sealed open-architure tapbox under control 
of the communication provider has time stamped and 
checksummed the data that's all about history.

> peoples everywhere if it were to purposefully design tapability

Tools don't do crimes, people do crimes. IETF would do 
serious justice if it would supply an auditable version of 
tcpdump to the world.

And AGAIN: "tapability into its protocols" is totally NOT 
the question.

Only the "majority" here talks about rejecting that and 
thus prove with it they haven't listened even a little to 
the minority.

+++chefren

---

From: "Thomas Junker" <[email-masked]>
Date: Wed, 3 Nov 1999 00:59:12 -0600

> serious justice if it would supply an auditable version of 

It can't.  Only governments can mandate auditability.  Specs cannot bring 
about auditing or accountability, since those are not inseparable from the 
information that might be wiretapped.

Regards,

Thomas Junker
[email-masked]

The Unofficial Wang VS Information Center
http://www.phoenix.net/~tjunker/wang.html

---

From: James Carlson <[email-masked]>
Date: 03 Nov 1999 08:15:19 -0500

> serious justice if it would supply an auditable version of 

Hardly.

> And AGAIN: "tapability into its protocols" is totally NOT 

Dead wrong.  Since you've managed to stray so far from the IESG's
request in setting up this list, here is another copy of that request.
Please read it.  Note that it says nothing at all about "auditing."
It mentions *ONLY* tapping.

] The use of the Internet for services that replace or supplement
] traditional telephony is, predictably, causing discussions in many
] countries about the point at which special rules about telephony
] services begin to apply to Internet service providers.  In many
] countries, these rules could impose new legal obligations on ISPs,
] particularly requirements to comply with requests from law enforcement
] agencies or regulators to intercept, or gather and report other
] information about, communications. For example many traditional
] telephony devices, especially central-office switches, sold in those
] countries are required to have built-in wiretapping capabilities to
] allow telephone carriers to fulfill these obligations.
] 
] A number of IETF working groups are currently working on protocols to
] support telephony over IP networks.  The wiretap question has come up
] in one of these working groups, but the IESG has concluded that the
] general questions should be discussed, and conclusions reached, by the
] entire IETF, not just one WG.  The key questions are:
] 
]   "should the IETF develop new protocols or modify existing protocols 
]   to support mechanisms whose primary purpose is to support wiretapping 
]   or other law enforcement activities" 
] 
]   and 
] 
]   "what should the IETF's position be on informational documents that 
]   explain how to perform message or data-stream interception without 
]   protocol modifications".   
] 
] We would like to encourage discussion of these questions on the new
] [email-masked] mailing list. Subscription requests should be mailed to
] [email-masked] OR subscribe via the web at
] http://www.ietf.org/mailman/listinfo/raven

To paraphrase Monty Python's Flying Circus, if you've come here for a
discussion of the desirability or feasibility of auditable taps,
that's two doors down on the left.  This room is for arguments for or
against modifying existing protocols to support wiretapping.

-- 
James Carlson, System Architect                     <[email-masked]>
IronBridge Networks / 55 Hayden Avenue   71.246W   Vox:  +1 781 372 8132
Lexington MA  02421-7996 / USA           42.423N   Fax:  +1 781 372 8090
"PPP Design and Debugging" --- http://people.ne.mediaone.net/carlson/ppp

---

From: "Brett Wooldridge" <[email-masked]>
Date: Wed, 3 Nov 1999 11:22:31 -0600

Seems my last post got "moderated" out.  Though I'm not sure why
as it was fairly on-topic.  I'll try using different words this time.

----- Original Message -----
From: James Carlson <[email-masked]>
Newsgroups: lists.ietf.raven
To: <[email-masked]>
Sent: Wednesday, November 03, 1999 7:15 AM
Subject: Re: [Raven] Nevermore ...
> The key questions are:

100% correct.

My contention is, not only should IETF *NOT* develop protocols with
methods that support wiretapping, IETF should develop protocols that are
wiretap resistant.  Such as requiring NAT/PAT-style source-IP rewriting in
the
packet headers at each hop to DENY auditability.  And
decryption/re-encryption
between network nodes and out-of-order (vs. FIFO) forwarding of packets to
dissuade traffic analysis.

These are mechanisms essential for security.  They don't currently exist
on the Internet.  The DOD has already abandoned the Internet, their baby,
for
SIPRnet because they want to enjoy a level security that they do not wish
the
public to enjoy.  There is NO REASON that the powers-that-be could not have
made the Internet secure enough for even the most sensitive DOD traffic --
were it not for the fact that in doing so they would make OUR traffic
equally
opaque.

The same story as encryption: governments tried for as long as possible to
keep strong crypto out of the hands of the public, while enjoying it's
fruits
themselves.  Our actions are subject to scrutiny, theirs are above reproach.
Governments don't do bad things.

On the topic of wiretaps, there are only an average of 750 requests per
annum in America for wiretaps.  Most of these are narcotics related.  The
red herring of counter-terrorism is hogwash.  In no major terrorism case has
wiretap even been a factor, either in prevention or prosecution -- not even
in
the World Trade Center bombing in which the suspects were already under
surveillance.

All laws are subject to interpretation.  I see nothing in CALEA that
requires
IETF to provide wiretap facility.  Period.  I suggest that IETF take this
"window of opportunity", before legislation IS crafted that specifically
applies to IETF, to create truly secure transports.

In short, let the genie out of the bottle, quickly, before the bottle is
welded
shut.  I give us six-months.

Brett Wooldridge

---

From: "chefren" <[email-masked]>
Date: Wed, 3 Nov 1999 19:00:40 +0100

On 3 Nov 99, at 11:22, Brett Wooldridge wrote:

> welded shut.  I give us six-months.

So you more or less know your own democratically chosen 
government will be against it and you try to get "things 
fixed" before they can stop you.

I'm quite sure I'm not a facist and I'm quite sure you are 
a terrorist...

+++chefren

= =

---

From: Peter Greenwood <[email-masked]>
Date: Wed, 03 Nov 1999 23:45:04 +0000

[email-masked] said:
> So you more or less know your own democratically chosen  government
> will be against it and you try to get "things  fixed" before they can
> stop you.

At least where I live, this issue seems to be beyond the reach of democracy.
Before the last election here, the Labour opposition were against the then 
Government's plans for regulation of encryption.  After winning the election, 
the Labour government came out with more-or-less identical proposals.

-- 
	Peter Greenwood		[email-masked]