Subject: Re: [Raven] IETF and wiretapping and LAPD (oh my!)

From: John Gilmore <[email-masked]>
Date: Wed, 10 Nov 1999 18:11:47 -0800

> Facts:

Opinions, it appears to me.

> = Democracies basically can't allow places where
>   organized crime can hide.

Organized crime seems to be hiding quite well.  The gov't claims it
exists, and it almost certainly does, but do you know where it is?

> = Democracies have laws that demand taps.

Incorrect.  Some democracies have laws that require people to attempt
to tap.  There is no requirement that it be easy, that it work, or
that there be infrastructure designed for it.

> = Democracies tap.

That one's a fact.  Whether or not it's legal, governments tap.
Democratic, totalitarian, you name it.  The great thing about tapping
is that it's hard to catch people at it.  So they frequently get away
with it for decades (as under Hoover, or the Stasi) before a public
stink arises and the citizens demand a change.  We are demanding a
change.  We won't engineer the Internet the way the government managed
to get cellphones engineered (so any child or cop can monitor their
neighbors' private conversations).

> The only thing IETF can do for the citizens in this world 
> is make an auditable standard for it. One that prevents 
> misuse and tampering with the data.

Anything that doesn't publish those "audit" records immediately can be
bypassed (by making sure the records never make it to where the public
can see them).  Anything that does publish those audit records 
immediately, defeats the secrecy of the taps, which is one of their
primary advantages for the tappers.  Let's see what the FBI would
have to say about Internet wiretap infrastructure that would immediately
publish the existence of the tap as soon as it is placed.  Even that
requirement would be very hard to build robustly -- suppose the tap-box
was modified to violate the protocol, do a few taps and DIDN'T report them?

	John

_______________________________________________
raven mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/raven

---

From: "chefren" <[email-masked]>
Date: Thu, 11 Nov 1999 05:03:06 +0100

> Opinions, it appears to me.

That's a conclusion I would be happy to read them after 
your arguments.

> exists, and it almost certainly does, but do you know where it is?

  I think it's absurd to deny the existing of organized
  crime. I'm not in for playing with words. You can easy
  say "there are convicted criminal organizations" that
  thus not exist anymore and there are suspected criminal
  organizations that are only suspected so there is no
  proof. 

Do you think it's in principle acceptable for a 
democratically chosen government to allow places where 
criminals can effectively hide for law enforcement?

> to tap.

OK. =Some= democracies and even democracies that can be 
recognized as respected democracies.

> There is no requirement that it be easy, that it work,
> or that there be infrastructure designed for it. 

Who says so or asks for that? I think the basic requirement 
is a fact for at least some democracies. The only question 
that's left is the quality aspect.

And that quality aspect initiated the proposition for an  
audited tapping standard for IP according to the model 
that's used in The Netherlands for GSM and ISDN tapping.

> stink arises and the citizens demand a change.

I agree. So a high quality tap should prevent misuse of the 
technology as much as we can think of.

> We are demanding a change.  We won't engineer the
> Internet the way the government managed to get cellphones
> engineered (so any child or cop can monitor their

If I remember well the last cellphone structure that 
allowed that was destructed some time ago here in The 
Netherlands. I don't believe government has "managed" the 
easy monitoring of early cellphones. I know the EU 
orchestrated GSM that was designed with some reasonable 
encryption. Of course there are people that know better 
forms of encryption and I think it's likely there will be 
stronger encryption in future systems but the current 
system seems well balanced with the importance of the 
current use of GSM to me.

> can see them).

Might be, so that could be a requirement for a higher 
quality tapping standard. I see no problem, all tapboxes 
can for example continuously send MD5 hashes to a public 
newsgroup.

> Anything that does publish those audit records
> immediately, defeats the secrecy of the taps, 

MD5 hashes wont reveal more than necessary. And if they are 
not good enough we will find a stronger hashing system. I 
think MD5 is a good start.

> which is one of their primary advantages for the tappers.

Please explain. The tapdata should be usable in court and I 
think we cannot accept what Janet Reno stated about law 
enforcement that shouldn't have to reveal where the digital 
evidence comes from. That violates basic human rights.

> Let's see what the FBI would have to say about Internet
> wiretap infrastructure that would immediately publish the
> existence of the tap as soon as it is placed.

I think they wouldn't have a problem with the MD5 hashes.

> Even that requirement would be very hard to build
> robustly -- suppose the tap-box was modified to violate
> the protocol, do a few taps and DIDN'T report them? 

All technology can probably always be misused. IETF can 
propose a standard that very difficult to misuse. If IETF 
designs the standard well it can easily be upgraded to even 
better prevent misuse of it.

> 	John

+++chefren

=Large signature follows=

I think we need a simple architecture for a point
to point tap interface that has strong provisions
against misuse.

On one side the communication provider who only
starts tapping a specific customer or IP number
with proper warrants.

On the other side the approved tapping room.
Everything should be organized by the central
"tapping office". This office should provide
keys for strong encryption to both communication
provider and tapping room.

Law and technology should both provide as
much checks and balances as we can come up
with. Law can provide good procedures,
technology can provide technical means to
check them or force them.    

=Large signature ended, please comment me
off-line to make it better=

---

From: Declan McCullagh <[email-masked]>
Date: Thu, 11 Nov 1999 00:19:02 -0500

The IETF voted overwhelmingly this evening to reject wiretappability.

A rough count said fewer than 25 people supported it out of a room of over
500. The rest said no. (Dozens abstained.)

I suppose this mailing list can be shut down now, or folks can subscribe to
cypherpunks or something.

I will have an article at wired.com soon.

-Declan

---

From: John Young <[email-masked]>
Date: Thu, 11 Nov 1999 07:21:00 -0500

>cypherpunks or something.

Congrats to IETF for setting up this forum, and thanks to those who
made it work with excellent commentary and debate.

Chefren especially for providing much to argue against that surely
reveals what proponents of tapping are thinking as they work undercover
to get sneakily, self-justifyingly, what they cannot get approval for in
public.

What a healthy change would be wrought in making democratic societies
truly that if all the telecom standards bodies would conduct their
deliberations
as openly (disputedly and democratically) as has IETF in this case.

However, so long as national security and its obessive requirements for
secrecy, with the mad vainglory and sweetheart contracts that produces, 
continues to contaminate public policy, democracy in practice will remain a 
dream propounded by the spin doctors racketeer influenced criminal
organization -- officially sanctioned criminality in the "national interest."

---

From: Bill Sommerfeld <[email-masked]>
Date: Thu, 11 Nov 1999 10:02:18 -0500

> 500. The rest said no. (Dozens abstained.)

It's worth noting that from a process standpoint that IETF operates by
"rough consensus", not "majority vote".  The show of hands should be
interpreted as an "opinion poll", not a "vote"; it was stated that the
IESG and IAB will cogitate on this and on the mailing list discussions
and come out with a statement at some point in the future.  This is
what they did a number of years ago when they came up with the
"Danvers Doctrine" on cryptography (see RFC1984); it was stated in the
plenary that they would be following the same process this time
around.

					- Bill

---

From: Christian Price <[email-masked]>
Date: Thu, 11 Nov 1999 11:43:25 -0700

> criminals can effectively hide for law enforcement?

Do you think it is in principle acceptable for a
democratically chosen government to allow or
even mandate communications standards which violate
the citizenry's right to privacy?
 
> > or that there be infrastructure designed for it.

Excellent point - that is why various counter surveillance
products are legal for www.spyhq.com to sell.

> technology as much as we can think of.

Unfortunately there are always brilliant crackers who will
be able to break the protection against misues.

The only way MS Windows NT 3.51 is C2 certified is if it
is unplugged from a network.  NT 4.0 has not passed C2 
certification yet (nor do I think it is likely to w/o 
significant modification.  Even the Linux OS which is 
writtern by former hackers and crackers is not immune to
vulnerabilities.  As with any protection scheme, it is 
only a matter of time before it is broken, and then it
can be misused.

> current use of GSM to me.

Bruce Schneier's book Applied Cryptography covers the issue
of digital cell phone encryption handily - he even tells
you how to break it in 3 or 4 simple steps.  stuff I could 
do on a 386!

> evidence comes from. That violates basic human rights.

I agree that it violates basic rights.  The point is that
for a tap to be effective, the person being tapped must not
be aware of it.
 
> better prevent misuse of it.

I dislike the idea of creating a system which causes us to 
fight our government's misues of taps the same way we currently
have to fight crackers and hackers seeking to do electronic harm.
This fundamentally damages the relationship between government
and citizen.

--Christian

---

From: "chefren" <[email-masked]>
Date: Thu, 11 Nov 1999 22:08:20 +0100

[Chefren used as answering machine?]

> the citizenry's right to privacy?

Fact is that not all citizens respect all laws made by 
democratically chosen governments all times. That's not a 
problem until a certain point. Procecutors have te function 
to select what breaches of law go to far and should be 
further investigated by law enforcement en brought before a 
judge.

IF those law breaking citizens cannot be studied good 
enough because they use communication equipment that hides 
their possible crimes it shouldn't be a serious problem for 
law enforcement to, for example, tap the communication.

> Excellent point

To me it's just a point. And a point that's beside the 
truth in my country. All provided communication should be 
tapable by law here since almost a year. And I'm not 
talking about Iraq but about The Netherlands, I thought a 
quite happy and respected democracy.

> - that is why various counter surveillance

Ah, do you mean that for example illegal decoder cards for 
cable television decoders may freely be sold in your 
country? So called "video enhancers" are forbidden quite 
some time here.

> be able to break the protection against misues.

What do you try to tell me here? Murder is forbidden for 
centuries and it's still done. Shouldn't we stop forbidding 
it or so?

And just as with encryption, the proposed standard for 
audited tap can be as secure as we want to make it. In the 
Netherlands ISDN is specified by law as channel between 
communication provider and tapping room. Prety hard to 
break.
 
> is unplugged from a network.

If I'm right thats a basic requirement for C2 so what's 
wrong with that?

> NT 4.0 has not passed C2 
> significant modification.

I don't know. The basic kernel is not so bad. The bad thing 
of NT is the layer around it and the stupid userinterface 
that doesn't show anything that has to do with security 
unless you click at least 3-5 times.

> Even the Linux OS which is 

So the tapping standard shoul be so simple that the world 
community can keep enough oversight to conclude everything 
is OK.

(The biggest advantage of Rijndael one of the new Advanced 
Encryption Standard nominees is that backdoors are very 
unlikely, the problem with DES. I'm very pleased with that 
idea and it should be used in the new tapping standard.)

..

> for a tap to be effective, the person being tapped must not

That's no problem. If you publish hashes of the tapdata 
together with key's of sender and receiver it's impossible 
to be aware of it. You can only tell if you have all parts 
of the tap. And all parts of it will be in court before the 
judge.

> This fundamentally damages the relationship between government

I think misuse can be avoided, and prety permanently too.

And if the relationship between citizen and community 
wasn't structurally attacked by criminals there wouldn't be 
a problem at all.

+++chefren

=Signature follows=

Everything should be organized by a central
"tapping office". This office should provide
keys for strong encryption to both communication
provider and tapping room.

=Large signature ended. If you want to
help to setup a standard for the above
design, please contact me.=

---

From: "Ge' Weijers" <[email-masked]>
Date: Fri, 12 Nov 1999 11:22:57 -0700

> quite happy and respected democracy.

The public attitude towards government in countries like the US is
fundamentally different from the attitude you find the the
Netherlands. The public does _not_ trust the government much, and
history has shown they've been right about that so far, because the
government habitually breaks its own rules. I think reasonable persons
can make the assessment that they have more to fear from government
doing things outside the public view than from criminals having just
another tool: access to strong cryptography.

A solution that may be acceptable to the people in NL may be totally
unacceptable in the US and elsewhere. It is not strange therefor that
Rep. Barr wrote a letter asking the IETF not to codify wiretaps into
protocols. I think he came to the conclusion I mentioned above, and he
does not at this time want to give law enforcement personnel any more
powers than they already have.

> idea and it should be used in the new tapping standard.)

All the talk about back doors in DES has been rumor-mongering, we've
yet to see any indication of a back door or exploitable weakness
except for the key size. None of the remaining candidates for AES have
any likely back doors. They either use magic numbers derived from
mathematical constants, or they have their S-boxes generated by a
simple deterministic program. The biggest problems with DES are the
key size and the block size (birthday bound). AES is supposed to solve
that.

> wasn't structurally attacked by criminals there wouldn't be 

And if the trust between citizens and government was not constantly
abused by government we would not have this discussion. But even the
Romans know that your couldn't trust the government. 

Ge'

-- 
-
Ge' Weijers                                Voice: (614)326 4600
Progressive Systems, Inc.                    FAX: (614)326 4601
2000 West Henderson Rd. Suite 400, Columbus OH 43220