Subject: RE: [Raven] Re: Thoughts of IESG and IAB members on Raven

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 6 Dec 1999 17:33:40 -0500

Ed

You seem to be missing the point here. 

We wanted to get such an effort started, but the IESG wants
to know if it should ALLOW such an effort to get started.
When faced with the issue we brought up, the response was not
"Call a BOF meeting for wiretap architecture design".  It was
the Raven list and the questions.  The questions are general,
they ask if any group, regardless of how many people agree to
work on something, should be permitted to do so.

We don't normally have plenaries with a show of hands to
decide if a BOF can be started.  We could have 10000 IETFers say,
"I won't work on wiretap", but if 100 show up to work on it, 
you want us to say "no, you can't do that"?

This question is very much "prior restraint".  It's asking
a philosophical/ethical question, not a legal one, and not
a technical one.  It is not following the normal IETF procedure.

If we decide to use the normal route, I will call for a BOF
at the next meeting.  If we get sufficient interest, we
would develop a charter, and then develop some requirements.
I would expect the requirements to be reasonably specific,
and agreed to by the people in the WG.  I have a lot of 
confidence that I would have plenty of company at the BOF.
If we had such a WG, it's operation would be open, just
like any other WG.

The IESG has not asked for that step; it wants to develop a 
policy that will either allow or PROHIBIT such a BOF/WG. 
It wants to decide, BEFORE WE CALL A BOF MEETING whether I
can discuss such a WG.  It wants to decide, before there are
any requirements, what we cannot do.

Now, I'm actually okay with having an ethical/philosophical
discussion.  I'm not upset that the IESG created the Raven
list, and is asking the questions.  But, please, don't make 
it a legal discussion, and don't wave normal IETF procedure 
around :)

Brian

> -----Original Message-----
> From: Ed Stone [mailto:[email-masked]]
> Sent: Monday, December 06, 1999 4:48 PM
> To: [email-masked]
> Subject: RE: [Raven] Re: Thoughts of IESG and IAB members on Raven 
> 
> 
> At 04:02 PM 12/6/1999 , you wrote:
> >I don't agree with this line of thinking
> >
> >The question at hand is can we do <anything>.
> 
> Then why wasn't that asked, instead of what WAS asked, which was:
> Should IETF develop new protocols or modify existing ones to 
> support internet
> wiretap, and what should be the IETF's position on 
> informational docs that 
> say how to do internet wiretap without protocol mods.
> 
> 
> ><What> we do depends on specifics.  Specifics have not yet
> >been raised.
> >
> >We most certainly can decide if anything can be done without
> >having to be specific about what exactly anyone does.
> 
> The issue is not about "what exactly anyone does" rather it is about 
> <should> IETF develop new protocols or modify existing ones 
> to support 
> internet wiretap...
> 
> Are you asking if the IETF can create or modify standards?
> 
> >What we do should be within the purview of a specific work group,
> >and not the IETF at large.
> 
> You can seek a charter for a WG by following procedure outlined at 
> http://www.ietf.org/rfc/rfc2418.txt.
> One of the elements that Area Directors are to evaluate before 
> commissioning a WG is "Is the proposed work plan an open IETF 
> effort or is 
> it an attempt to "bless" non-IETF technology where the effect 
> of input from 
> IETF participants may be limited?"  ;-)
> 
> The process entails:
> "The formation of a working group requires a charter which is 
> primarily 
> negotiated between a prospective working group Chair and the 
> relevant Area 
> Director(s), although final approval is made by the IESG with 
> advice from 
> the Internet Architecture Board (IAB).  A charter is a 
> contract between a 
> working group and the IETF to perform a set of tasks."
> 
> Of course, it seems that the views expressed here to the specific 
> questions, as well as press accounts of the count at the 
> meeting, indicate 
> that IETF generally sees such a WG as a bad idea. And if the "Best 
> Practices" statement for forming WGs gets in the way, then I 
> suppose that 
> process can be tossed along with the show of hands at the 
> meeting and the 
> talley of the raven list...
> 
> But why not get that sought after consensus here rather than 
> bailing for a 
> different venue?
> 
> >It is dangerous for one group of people to tell another group
> >what they cannot do.
> >   If I wish to start a work group on
> >wiretap, and I get enough people to do the work, that should be
> >enough.  The WG needs a charter, and that has to be somewhat
> >specific.  The WG needs to develop its requirements, and they
> >should be quite specific.
> 
> Yes, and since those requirements will have to be specific, 
> why not just go 
> ahead now, prior to the new WG, and submit the specifics here 
> in the light 
> of day for all to see?
> 
> 
> >What we are discussing here is whether I am allowed to start
> >that work group.  I take it that your position is no,
> >I should not even be able to call a BOF meeting.
> >
> >Brian
> >
> > > -----Original Message-----
> > > From: Jim Gillogly [mailto:[email-masked]]
> > > Sent: Monday, December 06, 1999 3:15 PM
> > > To: [email-masked]
> > > Subject: RE: [Raven] Re: Thoughts of IESG and IAB members on Raven
> > >
> > >
> > > Brian Rosen wrote:
> > > > All I have at the moment is a vaguely stated requirement.
> > > >
> > > > The only question before the group is whether we do anything
> > > > in support of legal intercept.
> > > >
> > > > Those two things match.  First we find out if we can do 
> anything.
> > > > Then we get to the what exactly part.
> > >
> > > Not quite.  The questions before the group is whether we <should>
> > > develop new protocols or modify existing ones to support internet
> > > wiretap, and what should be the IETF's position on informational
> > > docs that say how to do internet wiretap without protocol mods.
> > >
> > > So rather than "first we find out if we can do anything" the
> > > order is "first we find out whether we <should> do anything."
> > > This discussion's charter has nothing to do with whether we
> > > <can> do anything.
> > >
> > > If we <should> support internet wiretap in any way, it would be
> > > because of a real requirement of some kind.  A "vaguely stated
> > > requirement" based on an unsupported extension of a related law
> > > in one country that happens to support a lot of IETF engineers
> > > does not yet rise to the level of a real requirement.
> > >
> > > If somebody knows a legal or other compelling reason that we
> > > should be supporting internet wiretaps, speak up... but be sure
> > > to keep it as international as IETF.
> > > --
> > >       Jim Gillogly
> > >       Mersday, 16 Foreyule S.R. 1999, 20:00
> > >       12.19.6.13.14, 9 Ix 2 Mac, Fourth Lord of Night
> > >
> > > _______________________________________________
> > > raven mailing list
> > > [email-masked]
> > > http://www.ietf.org/mailman/listinfo/raven
> > >
> >
> >_______________________________________________
> >raven mailing list
> >[email-masked]
> >http://www.ietf.org/mailman/listinfo/raven
> 
> --
> --------------------------
> Ed Stone
> [email-masked]
> --------------------------
> 
> _______________________________________________
> raven mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/raven
> 

_______________________________________________
raven mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/raven

---

From: [email-masked] (Mikus Grinbergs)
Date: Mon, 06 Dec 1999 17:22:54 -0600

> a technical one.  It is not following the normal IETF procedure.

Yes, what is being discussed is "prior restraint" on you
appropriating the name 'IETF' for your group.

You can set up whatever group you want.  But you need approval of
IETF officials (and since wiretap is a controversial topic, I
suggest that you *do* need the consensus of those plenary IETFers
as well) before calling it an  __IETF__  BOF or WG.

I do not see that kind of a consensus here in favor of setting up
a wiretap group under the aegis of the IETF.

mikus