Subject: [Raven] Raven, What's Needed...

From: "chefren" <[email-masked]>
Date: Wed, 22 Dec 1999 02:37:03 +0100

OK friends, let's try to KISS:

= =

What law enforcement basically needs is a way to tap only 
communication for which they have a warrant.

IETF thinks that's an unavoidable need, one that has to be 
met in standards, and is interested in how this need can be 
fulfilled in a way that preserves as much citizen rights as 
possible.

= =

BASIC IDEAS:

As much personal IPv6 numbers as the citizen wants.

 Every citizen can get as many IPv6 numbers as she/he
 wants for a small fee each (everything that costs zero
 will be spoiled). The numbers are given out by a special
 IPv6-agency under strict control of very different
 organizations. For example Local Justice department,
 Local police department and IETF. (Digital form of the
 power splitting ideas of Montesqieu.) Without proper
 warrants the IPv6-agency will never relieve which numbers
 are given out to whom. The three or more parties of which
 the agency consists each have only a part of the data and
 need each other to fulfil a request to give law
 enforcement the IPv6 numbers of a specified citizen. 

 This system, which enables the citizens to have "as much
 identities as they want", is a means to give citizens as
 much privacy as possible, to look at porn sites she/he
 can use IPv6 numbers A,B and C, for work number D, for
 friends numbers E,F,G and H, for family number K et
 cetera. 

 Laws should be in place to prevent =any= IPv6 number
 logging/registration without both knowledge of the number
 owner and his/her agreement to store it. 

 The IPv6 numbers will be the car license plates the
 citizen needs to use while communicating via the
 Internet. 

New protocol for Routers

 Routers, under control of communication providers, should
 be equipped with a new IETF tapping protocol. Basically
 this protocol makes it possible to program IPv6 numbers
 and destination addresses. All data to and from the IPv6
 numbers that pass the router will be copied to the
 according destination addresses.  

 The destination address should be a sealed open-source
 tapbox that's fully under control of the communication
 provider. The box timestamps the data, makes checksums /
 hashes of the data and will crypt the data before it's
 sent to the tapping room of the law enforcement unit that
 handed the warrant for the tap.   

+++chefren

_______________________________________________
raven mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/raven

---

From: Ed Stone <[email-masked]>
Date: Tue, 21 Dec 1999 22:15:48 -0500

>communication for which they have a warrant.

That is one version of what some say some LEAs in some countries *want*.

>fulfilled in a way that preserves as much citizen rights as

Not so, at all. Quite the contrary, in terms of the published talley of 
viewpoints here, and at the meeting. Simply put, IETF doesn't "think that's 
an unavoidable need" at all, and if it had thought so, this process would 
not have been commissioned in the first place.

--
--------------------------
Ed Stone
[email-masked]
--------------------------

---

From: Ben Laurie <[email-masked]>
Date: Wed, 22 Dec 1999 10:15:27 +0000

> fulfilled in a way that preserves as much citizen rights as

That's a total misrepresentation of the facts.

Cheers,

Ben.

--
SECURE HOSTING AT THE BUNKER! http://www.thebunker.net/hosting.htm

http://www.apache-ssl.org/ben.html

"My grandfather once told me that there are two kinds of people: those
who work and those who take the credit. He told me to try to be in the
first group; there was less competition there."
     - Indira Gandhi

---

From: Matthew Saroff <[email-masked]>
Date: Wed, 22 Dec 1999 08:28:53 -0600

On Dec 22,  2:37am, chefren wrote:
> met in standards, ......
	This basic premise is incorrect.

-- 
Matthew Saroff
Do not reply directly to this message.  Reply to
[email-masked]

---

From: "Richard Payne" <[email-masked]>
Date: Wed, 22 Dec 1999 10:04:50 -0500

> communication for which they have a warrant.

which is false. In many countries, the equation "Law Enforcement" = "Good"
does not hold, and a warrant may not be required or mean much. Remember,
we're not just talking about the Netherlands.

> fulfilled in a way that preserves as much citizen rights as

The vast majority of people who've expressed an opinion on this list, rather
than thinking it's an unavoidable need, have been against any IETF
involvement in wiretapping, period. You could look it up.

>  owner and his/her agreement to store it.

This is incredibly invasive and utterly bizarre. No two people ever use one
computer? No public access in libraries? No intranets? No free ISP's? No
dynamic assignment of IP numbers? In any case, there has been no discussion
of this on the list and no consensus in favor of it.

>  citizen needs to use while communicating via the

Some of us have been waiting, with resignation, for someone to claim that
the Information Highway (wince) need license plates. The wait is over, and
the power of misleading analogy shown yet again.

>  according destination addresses.

I strongly doubt that any such hypothetical IETF protocol will come to be.

Richard Payne