Subject: [Raw] Alissa Cooper's Block on charter-ietf-raw-00-02: (with BLOCK)

From: Alissa Cooper via Datatracker <[email-masked]>
Date: Tue, 04 Feb 2020 13:39:56 -0800

Alissa Cooper has entered the following ballot position for
charter-ietf-raw-00-02: Block

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-raw/

----------------------------------------------------------------------
BLOCK:
----------------------------------------------------------------------

I still feel that the charter is unclear on the relationship between
"Aeronautical Data Applications" and the work of this WG. The charter says this
is "one" critical application, but then uses the term "these newly identified
industry applications" and "these newer industry applications." Do those
snippets of text refer to multiple different aeronautical applications? Or do
they refer to applications in other domains? Since the aeronautical
applications are called out multiple times, are they expected to take
precedence over other applications when the use cases and requirements are
defined?

Also, this is a little pedantic but since there has been a lot of confusion
about this, I think it needs to be clarified: the charter says "RAW’s focus
will be on identifying use cases and requirements for these new applications."
Wouldn't we expect applications to flow from use cases, not the other way
around? That is, if the WG intends to invent use cases for applications that
already exist, that seems backwards.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 5 Feb 2020 08:26:44 +0000

Hello Alissa

The text may be giving the wrong impression that RAW focusses on one technology or one application. 
I started that effort 1 1/2 years ago and that was never my intent.

The problem we are looking at is that wireless has close to zero adoption in a number of environments where machines talk to machines. This kind of communication does not have the flexibility that is tolerable when humans are in the loop, because we cope with it. 

Use cases involve anything automation and to some extent safety - related. You find that in automated vehicles, nuclear plants, production lines, and even thermostats. It's all around us. The reason why wireless is left out is the lack of perceived reliability and availability. This is what our problem statement says, and what we explained at the BoF.

If you look at it, the perception comes for a reason. Even licensed band communication suffer from hinderance, e.g., multipath fading (echo), physical objects in the Fresnel zone, mobility, you name it. Certainly unlicensed (ISM band) can be worse with uncontrolled co channel interferers. But regardless, a single radio technology between a single pair of devices will not be trusted to provide reliability (Packet delivery ratio) and availability (never 4 losses in a row).

The RAW story is that IP can help. IP can assess the end-to-end R&A, e.g., through feedback and OAM, as opposed to over one hop. IP can leverage multiple technologies in parallel, over a complex graph if needed, to leverage all sorts of diversity that exist with radio (see PAREO in the problem statement). With that, we can provide the end-to-end qualities that the automation people are after.

RAW is a bridge between the extremes that are MANET and DetNet. It will inherit from both and extend them. There's also a touch of PCE in the story:
* It will cover a reasonably well-known set of devices in a reasonably mobile environment (think predictable), which is much less extreme than MANET, but still, it will leverage experience and protocols such as DLEP and IP models.
* It will reuse DetNet's multipath and OAM capabilities, and extend them, since radios are both more demanding in loss recovery and richer in capabilities to do so. It will be less extreme than DetNet, at least to start with, on reliability requirements such as bounded latency. And mostly, it will look at the forwarding behavior when the use of redundancy (no free lunch) has to be decided at the forwarding scale (for a bunch of packets till the radio conditions change) as opposed to the routing scale (of a central controller, far-far away, a global but slow overseer). 
* The goal we share with the chairs for RAW (first generation) is to work on that local engine that makes the forwarding decision for that bunch of packets across possibly multiple next hops, that may be part of complex paths that may include wireless segments. You can see it as exporting a piece of a PCE next to the packet forwarding engine so we called it a PSE.

This hybridity between 3 existing WG makes it difficult to position a STD defining WG. I think that's the reason why you do not see STD track milestones. We who want to solve the problem need you at the IESG to provide us with a place we can meet and progress.

All the best

Pascal 

> -----Original Message-----
> From: Raw <[email-masked]> On Behalf Of Alissa Cooper via Datatracker
> Sent: mardi 4 février 2020 22:40
> To: The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked]
> Subject: [Raw] Alissa Cooper's Block on charter-ietf-raw-00-02: (with BLOCK)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> 
> I still feel that the charter is unclear on the relationship between "Aeronautical
> Data Applications" and the work of this WG. The charter says this is "one"
> critical application, but then uses the term "these newly identified industry
> applications" and "these newer industry applications." Do those snippets of
> text refer to multiple different aeronautical applications? Or do they refer to
> applications in other domains? Since the aeronautical applications are called
> out multiple times, are they expected to take precedence over other
> applications when the use cases and requirements are defined?
> 
> Also, this is a little pedantic but since there has been a lot of confusion about
> this, I think it needs to be clarified: the charter says "RAW’s focus will be on
> identifying use cases and requirements for these new applications."
> --
> Raw mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/raw

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Wed, 5 Feb 2020 16:49:29 +0000

Hi Alissa,

Please refer to Pascal’s reply for background.

I didn’t intend to scope this to only aeronautical applications. I was only trying to point to it as one of the critical. As the use cases are under discussion, I didn’t want at this time to give “the answer”. The use case document has more information.

As you and Alvaro are looking for more detail, would this sentence added to the end of the second paragraph help?

“Other example wireless applications include Industrial, Pro Audio and Video, Gaming, and Edge Robotics.”

The intention of why this is not scoped specifically to aeronautical is because the hope is to find a common solution for multiple applications similar to the detnet, teas, and ccamp approach.

On your second part questioning which is first - applications or use cases- I’m not sure the confusion. Some of these applications already are existing with proprietary solutions. Others as Pascal noted are waiting for technology improvements. Can you provide suggested rewording to help us understand?

Thanks for your interest!
Deborah 

> On Feb 4, 2020, at 4:40 PM, Alissa Cooper via Datatracker <[email-masked]> wrote:
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_charter-2Dietf-2Draw_&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=502tSGOqoismvYiL8leAR3QQnD4BL_k8zLb-AfTcfEo&s=ugPn41aRiN67TWEyT9eFhIzEILnyFFm_cKV5BmDYGBU&e= 
> 
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_raw&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=502tSGOqoismvYiL8leAR3QQnD4BL_k8zLb-AfTcfEo&s=5MVQbSJo0RLpCObZkYE9G-SwrJB44e4uVsdyMi-ZdWc&e=

---

From: "Venkatesan, Ganesh" <[email-masked]>
Date: Wed, 5 Feb 2020 16:59:59 +0000

Hello All:
>> Some of these applications already are existing with proprietary solutions.

Is this something that we want to encourage? I would think that standardized solutions are far better from the perspective of interoperability and enablement of new markets.

Cheers --
ganesh
“It is amazing what you can accomplish if you don’t care who gets the credit.” – Harry Truman

-----Original Message-----
From: Raw <[email-masked]> On Behalf Of BRUNGARD, DEBORAH A
Sent: Wednesday, February 5, 2020 8:49 AM
To: Alissa Cooper <[email-masked]>
Cc: [email-masked]; [email-masked]; The IESG <[email-masked]>
Subject: Re: [Raw] Alissa Cooper's Block on charter-ietf-raw-00-02: (with BLOCK)

Hi Alissa,

> email addresses included in the To and CC lines. (Feel free to cut 
> this introductory paragraph, however.)
> 
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.
> org_doc_charter-2Dietf-2Draw_&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhG
> pW9lwi9dM7jYlxXD8w&m=502tSGOqoismvYiL8leAR3QQnD4BL_k8zLb-AfTcfEo&s=ugP
> n41aRiN67TWEyT9eFhIzEILnyFFm_cKV5BmDYGBU&e=
> 
> 
> 
> "Aeronautical Data Applications" and the work of this WG. The charter 
> says this is "one" critical application, but then uses the term "these 
> newly identified industry applications" and "these newer industry 
> applications." Do those snippets of text refer to multiple different 
> aeronautical applications? Or do they refer to applications in other 
> domains? Since the aeronautical applications are called out multiple 
> times, are they expected to take precedence over other applications 
> when the use cases and requirements are defined?
> 
> Also, this is a little pedantic but since there has been a lot of 
> confusion about this, I think it needs to be clarified: the charter 
> says "RAW’s focus will be on identifying use cases and requirements for these new applications."
> Wouldn't we expect applications to flow from use cases, not the other 
> way around? That is, if the WG intends to invent use cases for 
> applications that already exist, that seems backwards.
> 
> 
> 
> 
> --
> Raw mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mail
> man_listinfo_raw&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYl
> xXD8w&m=502tSGOqoismvYiL8leAR3QQnD4BL_k8zLb-AfTcfEo&s=5MVQbSJo0RLpCObZ
> kYE9G-SwrJB44e4uVsdyMi-ZdWc&e=

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 5 Feb 2020 12:00:43 -0500

Hi Deborah,

> On Feb 5, 2020, at 11:49 AM, BRUNGARD, DEBORAH A <[email-masked]> wrote:
> 
> Hi Alissa,
> 

Yes. I would recommend not capitalizing any of the application names in the charter.

> On your second part questioning which is first - applications or use cases- I’m not sure the confusion. Some of these applications already are existing with proprietary solutions. Others as Pascal…

Sure:
RAW’s focus will be on specifying use cases associated with these new applications and defining requirements derived from them.
Thanks,
Alissa

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Wed, 5 Feb 2020 17:07:31 +0000

Exactly- we need to provide timely standard solutions for these applications-

Deborah

Sent from my iPhone

> On Feb 5, 2020, at 12:00 PM, Venkatesan, Ganesh <[email-masked]> wrote:
> 
> Hello All:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_raw&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=b8YaPgiIvQDkqWDZFQ7QSLq9n1W00Jgze0jOn4baBC4&s=5CQGOOyeRZT7cZI5GIjD4AlCemnW9o0-H80MQ1Zi1L8&e=

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Wed, 5 Feb 2020 17:16:55 +0000

Thanks Alissa for the fast response-

Sounds good- I’ll substitute your sentence in the 3rd paragraph, first sentence, 2nd part phrase.

Sent from my iPhone

> On Feb 5, 2020, at 12:00 PM, Alissa Cooper <[email-masked]> wrote:
> 
> Hi Deborah,
>