Subject: RE: [rddp] Alignment and TCP modification

From: "Culley, Paul" <[email-masked]>
Date: Fri, 10 Jan 2003 11:05:25 -0600

Of course all issues surrounding performance are really for the market to decide.

That said, I can see very interesting scenarios where large numbers of slow clients using unmodified stacks is NOT a design point.  Implementations that perform poorly in this case are perfectly acceptable and, if cheaper, preferred.  Most of these scenarios involve a machine room or small campus environment, which also makes deployment of RDDP reasonable in the near term.

I suspect that by the time we can get lots of small clients attached, they will probably have to deal with the WAN.  This adds other considerations like security (can you say IPSEC) which may make more expensive NICs both necessary and acceptable.

Paul Culley
HP Sr. Fellow
281-514-5543

-----Original Message-----
From: Williams, Jim [mailto:[email-masked]]
Sent: Friday, January 10, 2003 10:44 AM
To: [email-masked]'; [email-masked]
Subject: RE: [rddp] Alignment and TCP modification

> So, I believe the primary issue before the WG is whether to accept:
> 	- The RDDP protocols must allow implementations over
> 		unmodified TCP/IP stacks.
>           as a requirement.  

I would say yes to this.  A few more thoughts follow.

What is the required performance of an RDMA receiver when
receiving data from a transmitter using an unmodified TCP/IP stack?

    1.  Only functional correctness matters, performance is not an issue.

    2.  Performance must be as good as conventional (non-RDMA) TCP.

    3.  Performance must be significantly better than conventional
        (non-RDMA) TCP otherwise RDMA should not be used in this case.

A second question is:

       - Is the case of a large number of slow clients using
         unmodified TCP/IP stacks talking to a fast server
         using an RDMA accelerated NIC an important design point?

If the answer to the second question is YES, then I believe
that the answer to the first question is #3.

If the answer to the second question is NO, then I believe
the answer to the first question is #1, since in practice
no one will use RDMA over an unmodified TCP/IP stack.
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Fri, 10 Jan 2003 11:36:38 -0600

On 1/10/03, Culley, Paul wrote:

>That said, I can see very interesting scenarios where
>large numbers of slow clients using unmodified stacks is
>NOT a design point.  Implementations that perform poorly
>in this case are perfectly acceptable and, if cheaper,
>preferred.  Most of these scenarios involve a machine room
>or small campus environment, which also makes deployment
>of RDDP reasonable in the near term.
>
>I suspect that by the time we can get lots of small
>clients attached, they will probably have to deal with the
>WAN.  This adds other considerations like security (can
>you say IPSEC) which may make more expensive NICs both
>necessary and acceptable.
>
Security may be handled by a VPN router, or it might not be
an issue for the specific ULP.

Some examples of the latter: RDMA to support delivery of
streaming media and/or web content, RDMA to support a remote
sealed-storage SAN server (where the content is both
encrypted and decrypted at the client end).

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp