Subject: RE: [rddp] Alignment and TCP modification

From: "Williams, Jim" <[email-masked]>
Date: Mon, 13 Jan 2003 17:29:01 -0500

> -----Original Message-----
> From: Mukund, Shridhar [mailto:[email-masked]]
> Sent: Monday, January 13, 2003 5:15 PM
> To: Williams, Jim; [email-masked]
> Subject: RE: [rddp] Alignment and TCP modification
> 
> > However for software there is significant overhead for the
> > CRC, and some reasons why it might be unnecessary.
> > 
> >   1.  IPSec authentication is in use.
> > 
> >   2.  Connection is on a private network with good quality
> >       switches/routers and good link CRCs.  So TCP checksum
> >       is enough.
> > 
> >   3.  ULP does its own end to end integrity check.
> 
> and,
> 
> 4. Several applications can tolerate TCP chksm escape.
>    ( I am assuming that you are talking only about payload
>    CRC and not header CRC )

I was suggesting both header and payload CRCs be optional,
however should be separate option, as you point out some
may need header CRC but not payload CRC. 
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Mon, 13 Jan 2003 16:46:04 -0600

On 1/13/03, Williams, Jim wrote:

>> 
>> > However for software there is significant overhead for
>> > the CRC, and some reasons why it might be unnecessary.
>> > 
>> > 2.  Connection is on a private network with good
>> > quality switches/routers and good link CRCs.  So TCP
>> > checksum is enough.
>> > 
>> 4. Several applications can tolerate TCP chksm escape. (
>> I am assuming that you are talking only about payload
>> CRC and not header CRC )
>

Deciding to rely upon ULP validation of the payload is
valid. But if the DDP Header is received in error, the
payload may have been placed anywhere that is write-enabled
for the receiving ULP.

Allowing omission of a CRC covering the DDP Header strikes
me as very dangerous, and possibly a security hole.

If there is a consensus to support splitting CRC coverage
between header and payload, I could see making payload
coverage optional. But the extra complexity is just one more
argument for sticking with a single CRC.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp