Subject: RE: [rddp] Alignment Commentary

From: "Williams, Jim" <[email-masked]>
Date: Wed, 15 Jan 2003 10:13:18 -0500

Caitlin Bestler wrote:
> 4) Are MPA markers sufficiently complex for
>    a pure software stack to implement that it is
>    worth negotiation of a "no-marker" mode?
>    
>    IMHO, Markers are truly ugly but ultimately
>    not that hard to implement. It is not worth
>    the complexity of supporting multiple modes
>    and negotiating their use.

In my mind, the strongest argument for making
markers optional (assuming, hypothetically, that
they are supported at all) is that five years
from now when people realize that they were a
bad idea and nobody is using them, they can simply
be opted out.

If you make them manditory, then if they are
subsequently discovered to be a mistake,
it is a much more difficult mistake to correct. 
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Wed, 15 Jan 2003 10:06:21 -0600

>it is a much more difficult mistake to correct. 

It is also possible that high-performance/low buffer
deployments will migrate to SCTP, leaving TCP for long-haul
connections to clients behind antiquated firewalls without
full SCTP support. In that sense markers would cease to the
extent that TCP would no longer be used.

Actually, the strongest argument for optional markers would
be pushing for marker compatability between iSCSI and MPA.
Allowing two *different* marker schemes, both of which are
optional, strikes me as a major QA headache.

Caitlin Bestler
http://asomi.com/CaitlinBestler/
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp