Subject: [rddp] DDP Message Length Question

From: "Somesh Gupta" <[email-masked]>
Date: Thu, 16 Jan 2003 11:00:34 -0800

The DDP draft, section 7.4, requires that the DDP must provide
the ULP message length to the ULP when an untagged message is
delivered. It states that the ULP Message length may be calculated
by adding the MO and the payload length in the last DDP segment
for a message.

However at the same time,, section 7.2 says that DDP SHOULD
transmit DDP segments within a DDP message in increasing MO order.

Does seem that the two sections are in conflict with one
another. Anyone care to provide a clarification.

Thanks,
Somesh
_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: "Somesh Gupta" <[email-masked]>
Date: Thu, 16 Jan 2003 11:12:39 -0800

Thanks for the clarification.

> -----Original Message-----
> From: Caitlin Bestler [mailto:[email-masked]]
> Sent: Thursday, January 16, 2003 11:10 AM
> To: Somesh Gupta
> Subject: Re: [rddp] DDP Message Length Question
> 
> 
> On 1/16/03, Somesh Gupta wrote:
> 
> >The DDP draft, section 7.4, requires that the DDP must
> >provide the ULP message length to the ULP when an untagged
> >message is delivered. It states that the ULP Message
> >length may be calculated by adding the MO and the payload
> >length in the last DDP segment for a message.
> >
> >However at the same time,, section 7.2 says that DDP
> >SHOULD transmit DDP segments within a DDP message in
> >increasing MO order.
> >
> Section 6.1:
>     The DDP Segment with the L bit set to 1 MUST be posted 
>     to the LLP after all other DDP Segments of the 
>     associated DDP Message have been posted to the LLP. For 
>     an Untagged DDP Message, the DDP Segment with the L bit 
>     set to 1 MUST carry the highest MO.
>     
>     
> An implementation may, for reasons worthy of overriding a
> "SHOULD", reshuffle the order of all segments in an untagged
> message *except* for the last one, which MUST be last.
> 
> The reason that it MUST be last, is that it allows the
> receiver to calculate the message size from the last segment
> alone. There is no required message state that must be
> accumulated to reassemble the untagged message.
> 
> Caitlin Bestler
> http://asomi.com/CaitlinBestler/