Subject: [rddp] Tagged vs Untagged wrt providing message length

From: "Barry Reinhold" <[email-masked]>
Date: Mon, 19 Jan 2004 11:46:31 -0500

Hemal (or whomever wishes to post),
	Clause 7.4 states that:

"At the Data Sink, DDP MUST provide the ULP Message Length to the ULP 
   when an Untagged DDP Message is Delivered."

Is it thus not required that the length be provided for Tagged DDP
messages? 

I guess I am unclear as to why length is needed for the untagged but not
for the tagged.

Barry Reinhold
Lamprey Networks
[email-masked]
(603) 868-8411

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Mon, 19 Jan 2004 13:17:21 -0600

> I guess I am unclear as to why length is needed for the untagged but 

Normally DDP provides no notification of tagged placements
to the ULP -- except that delivery of an untagged message
cannot take place until all *prior* tagged messages have
been fully placed.

Further, even though the standard does not state that the
DDP layer MUST NOT tell the ULP about individual tagged
placements, the ULP MUST NOT use the buffers until the
trailing untagged message is delivered. So there wouldn't
be any point in supplying that information.

The benefits of suppressing ULP interactions for tagged
messages is covered in the applicability statement.

http://www.ietf.org/internet-drafts/draft-ietf-rddp-applicability-01.txt

-- 
Caitlin Bestler - [email-masked] - http://asomi.com/
http://asomi.com/CaitlinBestlerPublicPgpKey.html