Subject: [rddp] DDP segment sequences for Untagged DDP message

From: "Barry Reinhold" <[email-masked]>
Date: Fri, 16 Jan 2004 14:08:49 -0500

So, is there agreement, for the sequences that follow, that the
specified "result" given below is the correct (and desired?) behavior as
defined by the 01 draft.

Untagged DDP Segment Sequences:

1. QN = 0, MSN = 1, MO = 100 L = 1 Payload = 100 bytes
2. QN = 0, MSN = 1, MO = 0   L = 0 Payload = 100 bytes
Result: DDP Message (bytes 0-200) is delivered to ULP

1. QN = 0, MSN = 1, MO = 100, L = 0, Payload = 100 bytes
2. QN = 0, MSN = 1, MO = 0,   L = 1, Payload = 100 bytes
Result: ULP sent Error type=Untagged Buffer Error, Error Code=Invalid MO

1. QN = 0, MSN = 1, MO = 0, L = 0, Payload = 100 bytes
2. QN = 0, MSN = 1, MO = 0, L = 1, Payload = 100 bytes
Result: DDP Message (bytes 0-100) is delivered to ULP

1. QN = 0, MSN = 1, MO = 000, L = 0, Payload = 100 bytes
2. QN = 0, MSN = 1, MO = 200, L = 1, Payload = 100 bytes
Result: DDP Message (bytes 0-300) is delivered to ULP

1. QN = 0, MSN = 1, MO = 300, L = 1, Payload = 100 bytes
Result: DDP Message (bytes 0-400) is delivered to ULP
(This is based on wording in 6.3, MO field. Note that the second
sentence simply says that the MO "that references the first octet MUST
be set to zero", not that a segment having a zero MO is required)

1. QN = 0, MSN = 1, MO = 100, L = 0, Payload = 100 bytes
2. QN = 0, MSN = 1, MO = 000, L = 1, Payload = 0 bytes
Result: ULP sent Error type=Untagged Buffer Error, Error Code = Invalid
MO
(There is ambiguity between 6.1 L bit field description ( Segment w/ L
bit set must have highest MO), and 9.1 (implies that for non-zero length
segments the header fields are not validated.)

1. QN = 0, MSN = 1, MO = 000, L = 0, Payload = 100 bytes
2. QN = 0, MSN = 1, MO = 100, L = 1, Payload = 0 bytes
Result: DDP Message (bytes 0 - 100) is delivered to ULP

1. QN = 0, MSN = 1, MO = 100, L = 1, Payload = 0 bytes
Result: DDP Message (bytes 0 - 100) id delivered to ULP. 

Barry Reinhold
Lamprey Networks
[email-masked]
(603) 868-8411

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Caitlin Bestler <[email-masked]>
Date: Fri, 16 Jan 2004 18:42:29 -0600

> Result: DDP Message (bytes 0-200) is delivered to ULP

Did you mean to set the 'L' bit on message 1?

If so, that is a sender violation, which as explained in Paul's
response may or may not be caught by the receiver.

If Msg 1 is completed *before* Msg 2 is placed, Msg 2 will
be rejected as having an invalid MSN (it would be taken as
being 2**32-1 ahead of the current location).

In either case a 200 byte receive will be reported to the ULP.
The question is whether the Stream is almost immediately
thereafter torn down.

-- 
Caitlin Bestler - [email-masked] - http://asomi.com/
http://asomi.com/CaitlinBestlerPublicPgpKey.html