Subject: RE: [rddp] Tagged vs Untagged wrt providing message length

From: [email-masked]
Date: Fri, 23 Jan 2004 14:39:36 -0700

Barry,

Length would not mean anything for tagged messages. It means something for untagged messages because they are required to always start at zero so that the MO plus length of the segment with the L bit set are the length of the message. 

For tagged messages it is the responsibility of the ULP to transfer any necessary information on what data was transfered in the tagged messages. For example, in iSER when the target iSER layer sends the Status message (an untagged message) after doing the tagged messages to move the data associated with the command the status message contents indicate what data was transfered. Another example is that in RDMAP the untagged message RDMA read response indicates that the tagged transfers required for the RDMA read have been completed.

Regards,
Pat

-----Original Message-----
From: Barry Reinhold [mailto:[email-masked]]
Sent: Monday, January 19, 2004 8:47 AM
To: Hemal Shah
Cc: RDDP
Subject: [rddp] Tagged vs Untagged wrt providing message length

Hemal (or whomever wishes to post),
	Clause 7.4 states that:

"At the Data Sink, DDP MUST provide the ULP Message Length to the ULP 
   when an Untagged DDP Message is Delivered."

Is it thus not required that the length be provided for Tagged DDP
messages? 

I guess I am unclear as to why length is needed for the untagged but not
for the tagged.

Barry Reinhold
Lamprey Networks
[email-masked]
(603) 868-8411

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: [email-masked]
Date: Fri, 23 Jan 2004 15:20:50 -0700

Caitlin,

DDP doesn't provide notification of any placements - tagged or untagged but it does provide notification of completion of a tagged message. A tagged message has a header including a RsvdULP field that MUST be passed to the ULP on completion  and delivery of the message. For instance, the RDMA Read Response is a tagged message. RDMAP needs to receive the notice of that completion to know that the data for the RDMA Read Request has been placed. (In an earlier email, I erred when I said the response was an untagged message.)

It is RDMAP that doesn't bother its ULP with delivery of some events such as RDMA writes.

Length isn't provided for tagged messages because the ULP is responsible for exchanging that information if needed and because DDP doesn't know the length. It would have to scoreboard to get the starting and ending offsets for a Tagged message and it isn't required to do that.

Regards,
Pat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Caitlin Bestler
Sent: Monday, January 19, 2004 11:17 AM
To: RDDP
Cc: Barry Reinhold
Subject: Re: [rddp] Tagged vs Untagged wrt providing message length

> I guess I am unclear as to why length is needed for the untagged but 

Normally DDP provides no notification of tagged placements
to the ULP -- except that delivery of an untagged message
cannot take place until all *prior* tagged messages have
been fully placed.

Further, even though the standard does not state that the
DDP layer MUST NOT tell the ULP about individual tagged
placements, the ULP MUST NOT use the buffers until the
trailing untagged message is delivered. So there wouldn't
be any point in supplying that information.

The benefits of suppressing ULP interactions for tagged
messages is covered in the applicability statement.

http://www.ietf.org/internet-drafts/draft-ietf-rddp-applicability-01.txt

-- 
Caitlin Bestler - [email-masked] - http://asomi.com/
http://asomi.com/CaitlinBestlerPublicPgpKey.html