Subject: RE: [rddp] RE: AD review of draft-ietf-rddp-sctp-04

From: "Caitlin Bestler" <[email-masked]>
Date: Mon, 26 Jun 2006 09:00:02 -0700

Lars Eggert wrote:
> On Jun 23, 2006, at 21:43, Caitlin Bestler wrote:
>> Lars Eggert wrote:
>>> Section 6.1., paragraph 2:
>>>> The Payload Data Chunks for a given session, when sequenced by
>>>> their DDP-SSN, MUST follow one of the patterns defined in this
>>>> section. 
>>> 
>>>    The sequence patterns in the remainder of this section don't
>>>    include any DDP-SSNs? How can compliance thus be established?
>> 
>> All SCTP Data Chunks generated by the DDP/SCTP Adaptation have a
>> DDP-SSN. Therefore all messages specified in this draft have
>> DDP-SSNs. 
> 
> Right, but I was trying to raise a different question. Let me
> try again:
> 
> "The payload data chunks [...], when sequenced by their
> DDP-SSN, MUST follow one of the patterns defined in this section."
> 
> I read this sentence as: "This section will show sequences of
> packets together with their DDP-SSNs. Valid sessions MUST
> follow one of these DDP-SSN sequences.
> 
> Did I get the meaning correctly?
> 
> If yes, my comment was that the section doesn't actually talk about
> DDP-SSNs at all. 
> 
>> The rules for formulating the DDP-SSN are already clear. The fact
>> that the messsages are sequenced clearly mandates what the DDP-SSNs
>> would be.
> 
> Ah. So they are assumed to be implicitly clear. I think this
> is problematic, because in the beginning of this section, the
> drafts says that valid exchanges MUST follow on of the
> DDP-SSN sequences, but then doesn't explicitly define them.
> Explicitly defining the valid packet exchanges together with
> the DDP-SSNs in these sections allows implementors to easily
> verify whether they are in compliance.
> 
>> Since implementations are not likely to generate the DDP-SSNs at the
>> layer discussed in these sequence sections, I do not see the value of
>> repeating this information here.
> 
> Hm. Maybe I simply got hung up on the phrasing here ("when sequenced
> by their DDP-SSN")? 
> 
> Lars

perhaps "as sequenced" might be better.

There is no implication of "if sequenced by the DDP-SSN", since *all*
packets have a DDP-SSN. Rather it is to be clear that the normative
sequence for interpreting them is that of the DDP-SSN, as opposed to
receive order or transmit order.

For example a Terminate with DDP-SSN 117 *could* be received, or even
transmitted, before a Data Chunk with DDP-SSN 116. That does not mean
that the session is terminated when 117 is received.

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Lars Eggert <[email-masked]>
Date: Mon, 26 Jun 2006 18:13:27 +0200

> receive order or transmit order.

Can replace that "sequenced by" part in the ID with the last sentence  
above, starting with "The normative sequence..." That cleared it up  
for me!

I think that was the last of my comments, meaning we can start IETF  
last call next. Given the overlap with the IETF meeting, I'd like to  
do a 3-week IETF last call, to give people enough time to review the  
document. OK with you?

Lars
-- 
Lars Eggert                                     NEC Network Laboratories

---

From: Randall Stewart <[email-masked]>
Date: Mon, 26 Jun 2006 12:32:55 -0400

Lars Eggert wrote:
> above, starting with "The normative sequence..." That cleared it up  for 
> me!
> 
> last call next. Given the overlap with the IETF meeting, I'd like to  do 
> a 3-week IETF last call, to give people enough time to review the  
> document. OK with you?
> 
> Lars

Lars:

So let me get this straight... since I finally have a few cycles.. you
want:
<t>
The Payload Data Chunks for a given session, when sequenced
by their DDP-SSN, MUST follow one of the patterns defined
in this section.
</t>

To be replaced with something like:

<t>
The normative sequence for interpreting the
Payload Data Chunks for a given session
is that of the DDP-SSN, as opposed to
receive order or transmit order.
</t>

Will that do?

R

-- 
Randall Stewart
NSSTG - Cisco Systems Inc.
803-345-0369 <or> 815-342-5222 (cell)