Subject: [rddp] RDMA over TCP/IP - IWARP but for Windows

From: Nicholas Ferguson <[email-masked]>
Date: Mon, 07 May 2007 22:25:22 -0400

Hi,

I'm looking for an RDMA over TCP/IP  that can be plugged into a Windows
based OS... it could be iwarp.  Is there NIC ( PCI Express) with a 
windows api?  And what else
would need to be ported from linux to windows.  Project is to handle in 
memory databases for
high frequency data.... financial data...

Windows application
     |
    ....
      |
RDMA OVER - TCP/IP
      |
Ethernet NIC
      |
 =========  High Availability Network =======

_______________________________________________
rddp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rddp

---

From: Michael Krause <[email-masked]>
Date: Tue, 08 May 2007 07:22:39 -0700

See the OpenFabric Alliance open source effort for both Linux and Windows 
support of the RDMA stacks.  OFED 1.2 supports iWARP.

Mike

At 07:25 PM 5/7/2007, Nicholas Ferguson wrote:
>based OS... it could be iwarp.  Is there NIC ( PCI Express) with a windows 
>api?  And what else

---

From: Nicholas Ferguson <[email-masked]>
Date: Tue, 08 May 2007 14:39:41 -0400

Thank you for the answers.

I downloaded several snapshots of OFED-1.2: vlad, swise, monis... Where 
do I find instructions to build their corresponding windows binaries.

Is there a win make file. or a project file? Or an svn for win?

Thx

Nick

Michael Krause wrote:
>
> See the OpenFabric Alliance open source effort for both Linux and 
> Windows support of the RDMA stacks. OFED 1.2 supports iWARP.
>
> Mike
>
[email-masked] wrote:
> If you do a google search for "netdma" you will find the MS stack that
> takes advantage of RDMA.
> Otherwise, if you are looking for a more opensource variety:
> https://wiki.openfabrics.org/tiki-index.php?page=openIB+Windows
>   
>
>> would need to be ported from linux to windows. Project is to handle 
>> in memory databases for

---

From: "Livingston, James" <[email-masked]>
Date: Tue, 8 May 2007 13:07:58 -0700

You might wish to contact Broadcom, Chelsio and NetEffect for their
RNICs, and their RDMA software stacks for Windows; they're normally
distributed in binary form, with an installation process.

Cheers,
jwl

James Livingston
Engineering and Testing Group
NEC Corporation of America
Redmond Technology Center
7525 166th Avenue Northeast, Suite D210
Redmond, WA 98052-7811
mailto: [email-masked]
Phone: 425-897-2033; FAX 425-895-8683

> -----Original Message-----
> From: Nicholas Ferguson [mailto:[email-masked]] 
> Sent: Tuesday, May 08, 2007 11:40 AM
> To: [email-masked]
> Subject: Re: [rddp] RDMA over TCP/IP - IWARP but for Windows
>