Subject: Re: [Rdma-cc-interest] Side meeting plans at IETF-106 - network fast feedback

From: "Roni Even (A)" <[email-masked]>
Date: Tue, 12 Nov 2019 12:08:58 +0000

Hi Lars,
Thanks and hope you can make the side meeting as for 

> 2.2 Network Fast Feedback 
> 
> Discuss follow-on feedback on MailScanner has detected a possible fraud attempt from "tools.ietf.org" claiming to be https://tools.ietf..org/html/draft-even-iccrg-dc-fast-congestion-00 which is expected to be introduced in ICCRG on Monday.  The draft discusses the state-of-the-art congestion controllers in use and from research, and poses a number of questions for discussion. What is to be researched and what could/should be standardized going forward?

This is the beginnings of a survey. It misses a ton of related work esp. from academia though. HOMA, pFabric, HULL, D3, PDQ, pHost, NDP, etc., etc.

When you say RDMA, you mean RoCE? Separate RoCE into a slice and move on. It's pointless to try and optimize for coexistence with a protocol that can change willy-nilly.

RE: The motivation was not a survey but to show the different alternatives for providing congestion information and propose direction for reporting congestion and handling it for Data Centers.  I sure did not cover all related work.
The alternatives  from the network perspective:

  1.  Based on estimation of network status: Traditional TCP, Timely.

   2.  Network provides limited information: DCQCN using only ECN, SCE
       and L4S

   3.  Network provides some information: HPCC.

   4.  Network provides proactive control: RCP (Rate Control Protocol) 

Proposing 3 and 4 for future direction. We did some initial tests and will present them in the side meeting (not enough time in ICCRG)

If there will be an interest also in a more comprehensive survey  I will be happy to get help from people who would like to see such a survey.

Roni

-- 
Rdma-cc-interest mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rdma-cc-interest

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Nov 2019 14:52:46 +0200

Hi,

> RE: The motivation was not a survey but to show the different alternatives for providing congestion information and propose direction for reporting congestion and handling it for Data Centers.  I s…

ah. That doesn't come across at all. It's not clear that the alternatives (both in terms of categories and in terms of proposals) in the draft and in the list below are only *some* of the alternatives - the draft sounds like it thinks it is all of them. It would be good to make this much clearer, and also talk about *why* only these were chosen and not some of the many others.

Lars

---

From: "Roni Even (A)" <[email-masked]>
Date: Tue, 12 Nov 2019 13:35:49 +0000

Hi Lars,
Thanks for the comments
I will clarify in the next revision that the focus is on the different congestion reporting alternatives and that the reference documents are examples of the alternatives.
Roni

-----Original Message-----
From: Rdma-cc-interest [mailto:[email-masked]] On Behalf Of Lars Eggert
Sent: Tuesday, November 12, 2019 2:53 PM
To: Roni Even (A)
Cc: [email-masked]; Paul Congdon
Subject: Re: [Rdma-cc-interest] Side meeting plans at IETF-106 - network fast feedback

Hi,

Lars