Subject: Fwd: [re-ECN] Re-ECN meeting in Chicago

From: Bob Briscoe <[email-masked]>
Date: Wed, 25 Jul 2007 17:22:51 +0100

Folks,

Just a reminder and link to slides for remote participants:

Ad hoc unofficial BoF on re-ECN at the Chicago IETF and on audio. 1-3pm
today 25 Jul 07 (Chicago time), Room: Red Lacquar.

Agenda as posted originally below, but in overview:

1-2pm moving on the work of the group.

2-3pm repeat 'Architectural Intent of re-ECN' from IETF-68, incl long
Q&A

Slides:

<http://www.cs.ucl.ac.uk/staff/B.Briscoe/projects/refb/#Presentations>

(notes/audio will also be posted there when produced).

Acknowledgement: Thanks to the IETF for the use of a room and mailing
list hosting. And thanks to Aaron Falk for agreeing to chair
again.

Bob

Date: Tue, 17 Jul 2007 13:38:13
+0100

From: <[email-masked]>

To: <[email-masked]>

Cc: [email-masked], [email-masked]

Subject: [re-ECN] Re-ECN meeting in Chicago

All,

There will be another re-ECN
unofficial "Bar BoF" happening at IETF69 in Chicago next
Wednesday July 25th. It will be at 1300-1500 in the Red Lacquar room.
This is a follow on to the meeting held in Prague in March (slides and
notes for which can be found at
<http://www.cs.ucl.ac.uk/staff/B.Briscoe/projects/refb/#Presentations>)

The aim of the meeting will be to
discuss the next steps that need to be taken to move re-ECN forward. The
draft agenda is as follows. If anyone would like to add any items please
contact me on or off list.

---1pm---

5
mins          Administrivia

25 mins         presentation and
discussion on encoding in IP v4 and v6 (rationale behind choices,
alternatives, etc) [Bob B + mostly open mic]

10 mins         How to deploy
experimentally (open mic)

10 mins         Deployment
Scenarios [Bob Briscoe]

10 mins         Next Steps:

- format of the encoding (in v4, in v6)

- mechanics of the protocol in TCP/IP

- implementation of the dropper and the policer

- extension for use by TCP proxies or other congestion control
proxies

- extension for use by other transports

- etc

---2pm---

25 mins Architectural Intent of re-ECN

35 mins Q&A

---3pm--- End

For
those that missed it, we could use the second hour of the session to do a
repeat of the presentation given in Prague in March. This was intended to
present the architectural intent behind re-ECN as well as explaining how
the base protocol works.

All Internet drafts and other
documentation relevant to re-ECN can be found at:
<http://www.cs.ucl.ac.uk/staff/B.Briscoe/projects/refb/>
including draft-briscoe-tsvwg-re-ecn-tcp which describes the protocol and
the rationale behind it.

Please could you address any replies
to this message to the unofficial IETF mailing list
[email-masked].

Toby
Moncaster

____________________________________________________________________________

Toby Moncaster, <[email-masked]> Networks Research Centre, BT Research

B54/70 Adastral Park, Martlesham Heath, Ipswich, IP53RE, UK.  +44 1473 648734

_______________________________________________

re-ECN mailing list

[email-masked]

https://www1.ietf.org/mailman/listinfo/re-ecn

____________________________________________________________________________

Notice: This contribution is the personal view of the author and does not necessarily reflect the technical nor commercial direction of BT plc.

____________________________________________________________________________

Bob Briscoe,                           Networks Research Centre, BT Research

B54/77 Adastral Park,Martlesham Heath,Ipswich,IP5 3RE,UK.    +44 1473 645196

_______________________________________________
re-ECN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/re-ecn

---

From: <[email-masked]>
Date: Wed, 25 Jul 2007 17:31:34 +0100

For remote participants the audio stream is on channel 4:
http://videolab.uoregon.edu/events/ietf/ietf694.m3u
 
We have been unable to set up a jabber stream...
 
Toby

________________________________

From: Bob Briscoe [mailto:[email-masked]] 
Sent: 25 July 2007 11:23
To: re-ECN unIETF list
Cc: PCN IETF list; Aaron Falk; tsvwg IETF list
Subject: Fwd: [re-ECN] Re-ECN meeting in Chicago

Folks,

Slides:

Acknowledgement: Thanks to the IETF for the use of a room and mailing
list hosting. And thanks to Aaron Falk for agreeing to chair again.

Bob

	Date: Tue, 17 Jul 2007 13:38:13 +0100
	From: <[email-masked]>
	To: <[email-masked]>
	Cc: [email-masked], [email-masked]
	Subject: [re-ECN] Re-ECN meeting in Chicago

	All, 
	
	There will be another re-ECN unofficial "Bar BoF" happening at
IETF69 in Chicago next Wednesday July 25th. It will be at 1300-1500 in
the Red Lacquar room. This is a follow on to the meeting held in Prague
in March (slides and notes for which can be found at
<http://www.cs.ucl.ac.uk/staff/B.Briscoe/projects/refb/#Presentations
<http://www.cs.ucl.ac.uk/staff/B.Briscoe/projects/refb/#Presentations>
>)
	
	The aim of the meeting will be to discuss the next steps that
need to be taken to move re-ECN forward. The draft agenda is as follows.
If anyone would like to add any items please contact me on or off list. 

---1pm---

	5 mins          Administrivia 
	25 mins         presentation and discussion on encoding in IP v4
and v6 (rationale behind choices, alternatives, etc) [Bob B + mostly
open mic]
	10 mins         How to deploy experimentally (open mic) 
	10 mins         Deployment Scenarios [Bob Briscoe]
	10 mins         Next Steps: 
	                   - format of the encoding (in v4, in v6) 
	                   - mechanics of the protocol in TCP/IP 
	                   - implementation of the dropper and the
policer 
	                   - extension for use by TCP proxies or other
congestion control proxies   
	                   - extension for use by other transports 
	                   - etc 

---2pm---

---3pm--- End

	For those that missed it, we could use the second hour of the
session to do a repeat of the presentation given in Prague in March.
This was intended to present the architectural intent behind re-ECN as
well as explaining how the base protocol works.
	
	All Internet drafts and other documentation relevant to re-ECN
can be found at: <http://www.cs.ucl.ac.uk/staff/B.Briscoe/projects/refb/
<http://www.cs.ucl.ac.uk/staff/B.Briscoe/projects/refb/> > including
draft-briscoe-tsvwg-re-ecn-tcp which describes the protocol and the
rationale behind it.
	
	Please could you address any replies to this message to the
unofficial IETF mailing list [email-masked]. 
	
	Toby Moncaster 
	
________________________________________________________________________
____ 
	Toby Moncaster, <[email-masked]> Networks Research
Centre, BT Research 
	B54/70 Adastral Park, Martlesham Heath, Ipswich, IP53RE, UK.
+44 1473 648734 
	_______________________________________________
	re-ECN mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/re-ecn

________________________________________________________________________
____
Notice: This contribution is the personal view of the author and does
not necessarily reflect the technical nor commercial direction of BT
plc.
________________________________________________________________________
____
Bob Briscoe,                           Networks Research Centre, BT
Research
B54/77 Adastral Park,Martlesham Heath,Ipswich,IP5 3RE,UK.    +44 1473
645196