Subject: [re-ECN] FW: New Version Notification for draft-moncaster-congestion-exposure-problem-00

From: <[email-masked]>
Date: Wed, 30 Sep 2009 16:34:42 +0100

Hi All,

Because I am going to be away until 6th October I felt it was best just to post the latest version of the problem statement as a proper draft. There is still a lot of work to do on this.

http://www.ietf.org/id/draft-moncaster-congestion-exposure-problem-00.txt 

If you want to be included as an author (or want to be removed as an author) please let me know. 

I also want eventually to arrive at a better title and draft name for this but that can wait till we see what happens after the BoF.

Toby

____________________________________________________________________ 
Toby Moncaster, Senior Researcher, Network Infrastructure Practise
B54/70 Adastral Park, Ipswich, IP53RE, UK.  +44 7918 901170 

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: 30 September 2009 16:29
To: Moncaster,T,Toby,DER3 R
Cc: [email-masked]; [email-masked]; Krug,AL,Louise,DER3 R; [email-masked]
Subject: New Version Notification for draft-moncaster-congestion-exposure-problem-00 

A new version of I-D, draft-moncaster-congestion-exposure-problem-00.txt has been successfuly submitted by T Moncaster and posted to the IETF repository.

Filename:	 draft-moncaster-congestion-exposure-problem
Revision:	 00
Title:		 The Nede for Congestion Exposure in the Internet
Creation_date:	 2009-09-30
WG ID:		 Independent Submission
Number_of_pages: 17

Abstract:
Over the past decades, TCP's congestion control algorithm has allowed
the Internet to grow enormously whilst saving it from congestion
collapse.  However, TCP is applied on a voluntary base with bandwidth
shared among flows instead of users.  This causes problems,
especially at peak times when the network becomes saturated, and this
leads some ISPs to police traffic to alleviate congestion.  However,
since congestion on the downstream path of a flow is not visible,
these approaches are blind to the true impact of the traffic being
policed and are not effective enough.

We propose congestion exposure as a possible solution.  This means
that a flow reveals an estimate of the congestion it causes on its
remaining downstream path.  Congestion exposure gives many benfits
including meaningful policing at network ingresses, congestion-based
accounting between ISPs, fairer bandwidth sharing among users,
increased trust in the congestion-responsiveness of end-systems, and
possibly congestion-dependent load balancing and routing.  In short
congestion exposure leads to a more efficient and fairer Internet.
This document motivates the need for congestion exposure and
illustrates its usefulness in different use cases.  Therefore,
actions should be taken to implement a simple form of congestion
exposure in the Internet.

The IETF Secretariat.

---

From: <[email-masked]>
Date: Wed, 30 Sep 2009 13:07:52 -0400

On Wed, 30 Sep 2009 16:34:42 +0100, <[email-masked]> wrote:

> Hi All,
> 
> Because I am going to be away until 6th October I felt it was best just
to
> post the latest version of the problem statement as a proper draft. There
> is still a lot of work to do on this.
> 

> author) please let me know.

There was no need to put me on the author list (yet).  Since you have, I
will endeavor to review the draft and send comments to the list.  Please
use my [email-masked] address in the authors' addresses
section.
 
> I also want eventually to arrive at a better title and draft name for
this
> but that can wait till we see what happens after the BoF.

I don't think the title nedes any changes.

Regards,

// Steve