Subject: [re-ECN] Fwd: Pls bash: Congestion Exposure (re-ECN) BoF in Hiroshima?

From: Bob Briscoe <[email-masked]>
Date: Fri, 04 Sep 2009 16:36:43 +0100

Folks,

Does anyone want to help co-author the BoF proposal (by Monday night)?
Or specifically commit to review it?

Bob

>Date: Wed, 02 Sep 2009 17:32:25 +0100
>To: [email-masked]
>From: Bob Briscoe <[email-masked]>
>Subject: Pls bash: Congestion Exposure (re-ECN) BoF in Hiroshima?
>
>Hi Folks,
>
>I'd like to try to arrange a Congestion Exposure (re-ECN) BoF in Nov 
>at the Hiroshima IETF. Pls bash the following proposals.
>
>A/ Basic idea: Expose Congestion at network layer, so operators can 
>encourage endpoint behaviours that minimise congestion while 
>maximising performance (e.g. LEDBAT).
>
>B/ Which Area?
>I suggest we should notify Int Area & Transport Area, but I imagine 
>Transport Area would own this.
>
>C/ Community (see separate mail)
>
>D/ Ultimate documents to deliver (draft charter milestones):...?
>1. (INF) Motivating cases for congestion exposure
>2. (EXP) protocol spec (re-ECN is one proposal)
>    - choosing an encoding in IP, plus alternative encodings in an appendix
>3. <if the encoding uses bit 48 in IPv4>
>    (STD) Reassign value 1 of bit 48 from 'reserved' to 'experimental use'
>    Also describe conditions on experiments, e.g.:
>    - confined in space and in time
>    - multiple simultaneous experiments with same value would need v 
> strong case
>4. (INF) Report(s) on experimental uses of protocols
>
>E/ Supporting text to work on
>- BoF Description     (by 07 Sep 09 BoF deadline - Monday!!)
>- Proposed BoF Agenda (by 28 Oct 09 WG agendas deadline)
>- Problem statement   (by 19 Oct 09 I-D deadline)
>- Protocol proposal(s) (by 19 Oct 09 I-D deadline)
>- have I missed anything?
>
>F/ Other requirements
>- What's the "elevator pitch"?
>- Demo? Of what? The protocol, or a use of the protocol? What use?
>- BoF Chairs x2 (Rich Woundy has volunteered)
>
>_____
>Minutes of Stockholm Bar BoF where we discussed this, and links to 
>supporting docs so far:
><http://trac.tools.ietf.org/area/tsv/trac/wiki/re-ECN>
>
>
>
>Bob
>
>________________________________________________________________
>Bob Briscoe,               Networks Research Centre, BT Research

________________________________________________________________
Bob Briscoe,               Networks Research Centre, BT Research

---

From: <[email-masked]>
Date: Fri, 4 Sep 2009 17:39:50 +0100

I'm happy to review it...

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Bob Briscoe
> Sent: 04 September 2009 16:37
> To: re-ECN unIETF list
> Subject: [re-ECN] Fwd: Pls bash: Congestion Exposure (re-ECN) BoF
> inHiroshima?
> 
> Folks,
> 
> _______________________________________________
> re-ECN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/re-ecn

---

From: marcelo bagnulo braun <[email-masked]>
Date: Fri, 04 Sep 2009 19:45:56 +0200

I can review it.
regards, marcelo

---

From: "Agarwal, Anil" <[email-masked]>
Date: Fri, 4 Sep 2009 15:53:14 -0400

Bob,

I can review it.

Anil

Anil Agarwal
ViaSat Inc.
20511 Seneca Meadows Parkway
Germantown, MD 20876
(W) 240-686-4404

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Bob Briscoe
Sent: Friday, September 04, 2009 11:37 AM
To: re-ECN unIETF list
Subject: [re-ECN] Fwd: Pls bash: Congestion Exposure (re-ECN) BoF
inHiroshima?

Folks,

Bob

---

From: Bob Briscoe <[email-masked]>
Date: Sat, 05 Sep 2009 13:31:14 +0100

Rich,

I've tried to include those that said they were willing to review - 
apologies to those I've missed. Hopefully they will get this via the list...

At 16:45 04/09/2009, Woundy, Richard wrote:
>I definitely will commit to review.
>
>What sections can I help to co-author?

Thanks. Most BoF proposals are just an email without sections or 
anything. So I suggest we do two things:
- bash the overall shape of it
   - including deciding on what needs to be taken out
- contribute draft paras where individuals have something particular 
they believe they can say well.
- then I'll edit it into shape
- then review, further bashing, etc

I'm off to a wedding for the rest of the day. I'll get back to this 
first-thing (UK time) Sunday.

Here's a suggested proposal outline:
I'm aiming for something as brief as possible (e.g. 1-2pp).

1. Intro
   1 para top level motivation: Accountability for Congestion
   1 para ambitious, so we have to bite off smallest self-contained chunk
   1 para which particular bites to take (using an expt approach like LISP):
     a) (INF) recording motivation(s)
     b) (EXP) base congestion exposure protocol
     c) (STD) process pre-requisites to do (b)
     d) (INF) reports on experiments
   1 para where other stuff is getting done, e.g. ICCRG

2. A little more on each proposed working-group activity
2.1 Motivation
     Accountability for Congestion
     Good fences make good neighbours
     - IETF not been good at doing this (NATs, firewalls)
     - this is a chance to do it well
     Vision
     - ECN gives all traffic tiny jitter & loss
     - congestion accountability handles other QoS dimension; b/w allocation
     - that's QoS sorted :)
2.2 Protocol work
        prob re-ECN, but open to suggestions
        IPv4, IPv6 & TCP as example transport (for now)
2.3 IETF Process
     Depends on protocol encoding chosen
     Current view:
       need bit 48 in IPv4 hdr & IPv6 extension hdr + clash with ECN nonce
     Planned assignment of required field(s) as experimental
     Guidelines on how to confine experimental values (in space & time)
2.4 Reports on Experiments
     This w-g NOT designed to standardise uses of the protocol
     - e.g. policers, new congestion controls, simpler QoS,
       inter-domain metering, traffic engineering, DDoS miitigation
     But w-g will act as a focus for expts & trials in using its protocol
     Will produce reports on role of congestion exposure in trials, issues,
     recommendations, re-thinks, etc.
     Informs any future move from experimental to stds track
2.5 (Optional) Focused work on deployment?
     This is more than the minimum work that the w-g needs to bite off
     But it's the most important gating factor
     Therefore, it could form a focused piece of work in its own right
     Survey of middleboxes that will break ECN, re-ECN etc.
     Permanent partial deployment (user & net choice to expose congestion)
     Incremental deployment outline & incentives

3. Proposed BoF Agenda
    Motivations (which main motivation?)
    Demo (what demo?)
    Misconceptions
     - congestion (with ECN) != impairment
     - uncongested path != good (a symptom of broken transport protocols)
     - exposing congestion != operator privacy concerns
    Brief protocol outline
    Relationship to other w-gs
    Community - who's doing what; who's planning what
    Questions to put to a vote

Bob

>One caveat: Monday Sept 7 is Labor Day in the US. I may get a guilt trip
>from my family for doing IETF work on Monday, but I'll probably do some
>work anyway. But I'll also have fewer Comcast-work distractions this
>weekend as well.
>
>-- Rich
>