Subject: [re-ECN] Pls respond: Do we have a Congestion Exposure community?

From: Bob Briscoe <[email-masked]>
Date: Wed, 02 Sep 2009 17:33:36 +0100

Folks,

I'd like to try to arrange a Congestion Exposure (re-ECN) BoF in Nov 
at the Hiroshima IETF. If so, we have to notify the area directors v 
soon - by 24:00 UTC Mon 7 Sep 09. #1 gating function for Area 
Directors: activity on an ietf list.

Therefore, pls respond preferably *on this list* if you're interested 
in being involved, no matter how insignificantly, e.g.

- you want congestion visibility for other stuff you're doing
   (but don't intend to work on it itself)
- reviewing docs,
- alternative way to achieve congestion exposure
- participate in mailing list discussion,
- co-authoring docs
- design ways to do incremental deployment
- using code for other stuff you're doing
- thinking up new uses for the protocol
- breaking it
- analysing benefits/costs
- implement protocol
- implement a demo
- running or participating in trials
- standing on the sidelines booing or clapping
- whatever

Perceived problem:
Most people want to work on something finite like a new cool 
non-TCP-friendly congestion control. Less people want to go into an 
pseudo-infinite loop fixing IP to allow other cool stuff to happen. 
If you want something like re-ECN to be there, but don't have the 
bandwidth to work on it, that's cool too - please say this - it's 
still palpable support. And you will be likely to have review 
comments related to how you want to use it.

Cheers

Bob

________________________________________________________________
Bob Briscoe,               Networks Research Centre, BT Research

---

From: Michael Welzl <[email-masked]>
Date: Wed, 02 Sep 2009 19:09:15 +0200

Hi,

> people want to go into an pseudo-infinite loop fixing IP to allow 
> other cool stuff to happen. If you want something like re-ECN to be 
> there, but don't have the bandwidth to work on it, that's cool too - 
> please say this - it's still palpable support. And you will be likely 
> to have review comments related to how you 

For now, I fall in this category (and with "for now", I only mean the
bandwidth thing, not the opinion of course  :-)   )

Cheers,
Michael

---

From: Soo-Hyun Choi <[email-masked]>
Date: Wed, 2 Sep 2009 18:24:54 +0100

Hi Bob,

On Wed, Sep 2, 2009 at 17:33, Bob Briscoe<[email-masked]> wrote:
> Folks,
>
> I'd like to try to arrange a Congestion Exposure (re-ECN) BoF in Nov at the
> Hiroshima IETF. If so, we have to notify the area directors v soon - by
> 24:00 UTC Mon 7 Sep 09. #1 gating function for Area Directors: activity on
> an ietf list.
>
> Therefore, pls respond preferably *on this list* if you're interested in
> being involved, no matter how insignificantly, e.g.
>

I would like to express my interest working on the above mentioned
items (especially, implementing protocols, co-authoring docs, promote
my own CC protocol, etc), and I would like to support the re-ECN BoF
on the next IETF meeting.

Cheers,

--
Soo-Hyun Choi
UCL Computer Science
(http://www.cs.ucl.ac.uk/staff/S.Choi)

> pseudo-infinite loop fixing IP to allow other cool stuff to happen. If you
> want something like re-ECN to be there, but don't have the bandwidth to work
> on it, that's cool too - please say this - it's still palpable support. And
> you will be likely to have review comments related to how you want to use
> it.
>
> Cheers
>
>
> Bob
>
>
> _______________________________________________
> re-ECN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/re-ecn
>

---

From: "Agarwal, Anil" <[email-masked]>
Date: Wed, 2 Sep 2009 14:14:32 -0400

Bob et al,

Yes, I am certainly interested in this topic and want to see it progress
further. I had sent comments on earlier drafts of this doc and will help
contribute to future work.

Anil

Anil Agarwal
ViaSat Inc.
20511 Seneca Meadows Parkway
Germantown, MD 20876
(W) 240-686-4404

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Bob Briscoe
Sent: Wednesday, September 02, 2009 12:34 PM
To: [email-masked]
Subject: [re-ECN] Pls respond: Do we have a Congestion Exposure
community?

Folks,

Perceived problem:

Cheers

Bob

---

From: "Woundy, Richard" <[email-masked]>
Date: Wed, 2 Sep 2009 14:41:35 -0400

Bob,

I am definitely interested in being involved in the re-ECN efforts,
including co-authoring/reviewing documents, participating in the mailing
list discussions, figuring out applications for the protocol (and the
concept of 'congestion transparency', figuring out costs / benefits for
service providers and other stakeholders, and figuring out service
provider deployment considerations.

Plus you get "standing on the sidelines booing or clapping" as a free
bonus. :)

-- Rich

-----Original Message-----

Folks,

Perceived problem:

Cheers

Bob

---

From: Michael Menth <[email-masked]>
Date: Wed, 02 Sep 2009 21:37:53 +0200

Hi Bob,

yes, I am definitely interested in re-ECN. I'd like to know how much 
it's gonna buy us for which use and under which conditions it works. I'd 
like to quantify its benefits by simulations and analyses and point out 
pitfalls. Furthermore, I would like to get involved in IETF work.

Regards,

    Michael

Bob Briscoe schrieb:
> pseudo-infinite loop fixing IP to allow other cool stuff to happen. If 
> you want something like re-ECN to be there, but don't have the 
> still palpable support. And you will be likely to have review comments 
> related to how you want to use it.
>
> Cheers
>
>
> Bob
>
>

-- 
Dr. Michael Menth, Assistant Professor
University of Wuerzburg, Institute of Computer Science
Am Hubland, D-97074 Wuerzburg, Germany, room B206
phone: (+49)-931/31-86644 (new), fax: (+49)-931/888-6632
mailto:[email-masked]
http://www3.informatik.uni-wuerzburg.de/research/ngn

---

From: "Costas Courcoubetis" <[email-masked]>
Date: Thu, 3 Sep 2009 11:01:31 +0300

Bob,
I am very much interested. Especially in staying on the sidelines booing or
clapping. Also looking at incentive issues, interconnection implications,
etc.

Costas

Prof. Costas Courcoubetis
Dept. of Computer Science
Athens University of Economics and Business
Patission 76, Athens 10434
Greece
+302108203653 (Office)
+302108203686 (Fax)
+306944357951 (Mobile)
[email-masked]
www.aueb.gr/users/courcou/

> Sent: Wednesday, September 02, 2009 7:34 PM
> To: [email-masked]
> Subject: [?? Probable Spam] [re-ECN] Pls respond: Do we have a Congestion
> Exposure community?
> 
> Folks,
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 3 Sep 2009 10:29:36 +0200

Hi Bob,

I am are definitely interested in being involved. As you know I am already 
working on investigating re-ECN and also on ideas how to use the re-ECN 
information or other Congestion Exposure mechanisms.

Regards,
Mirja 

-- 
-------------------------------------------------------------------
Dipl.-Ing. Mirja Kühlewind
Institute of Communication Networks and Computer Engineering (IKR)
University of Stuttgart, Germany
Pfaffenwaldring 47, D-70569 Stuttgart

web: www.ikr.uni-stuttgart.de
email: [email-masked]
tel: +49(0)711/685-67973
-------------------------------------------------------------------

---

From: Bob Briscoe <[email-masked]>
Date: Fri, 04 Sep 2009 16:32:29 +0100

Mirja, Michael, Rich, Anil, Soo-Hyun, Costas,

Thanks for letting us know what you're planning.

I'm hoping to get a draft BoF proposal out later 
today. It will be based on the "Pls bash" mail I 
sent out on Wed 2 Sep. So any comments on that, 
let me know now. We have to submit it Monday 
night (and I'm flying Monday pm/evening).

I've had a note from Jari Arkko (one of the 
Internet Area Directors) agreeing that this 
crosses Int Area & Transport Area, but he says 
he's happy for the Transport Area to take a lead.

Bob

---

From: Howard Green <[email-masked]>
Date: Fri, 4 Sep 2009 12:42:14 -0400

I am certainly interested in this work going forward.
/Howard

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bob Briscoe
Sent: Wednesday, September 02, 2009 9:34 AM
To: [email-masked]
Subject: [re-ECN] Pls respond: Do we have a Congestion Exposure community?

Folks,

I'd like to try to arrange a Congestion Exposure (re-ECN) BoF in Nov at the Hiroshima IETF. If so, we have to notify the area directors v soon - by 24:00 UTC Mon 7 Sep 09. #1 gating function for Area
Directors: activity on an ietf list.

Therefore, pls respond preferably *on this list* if you're interested in being involved, no matter how insignificantly, e.g.

Perceived problem:
Most people want to work on something finite like a new cool non-TCP-friendly congestion control. Less people want to go into an pseudo-infinite loop fixing IP to allow other cool stuff to happen. 
If you want something like re-ECN to be there, but don't have the bandwidth to work on it, that's cool too - please say this - it's still palpable support. And you will be likely to have review comments related to how you want to use it.

Cheers

Bob

---

From: marcelo bagnulo braun <[email-masked]>
Date: Fri, 04 Sep 2009 19:45:21 +0200

Hi,

i am certainly believe we need work in this area and i would be 
interested in participating in the discussion and the work.

Regards, marcelo

---

From: Tom Taylor <[email-masked]>
Date: Fri, 04 Sep 2009 13:26:21 -0400

Please count me in. At the least, I can review and co-author documents. I may be 
able to set up some simulations or even try my hand at implementation.

Bob Briscoe wrote:
> Folks,
> 
> I'd like to try to arrange a Congestion Exposure (re-ECN) BoF in Nov at 
> the Hiroshima IETF. If so, we have to notify the area directors v soon - 
> by 24:00 UTC Mon 7 Sep 09. #1 gating function for Area Directors: 
> activity on an ietf list.
> 
> you want something like re-ECN to be there, but don't have the bandwidth 
> to work on it, that's cool too - please say this - it's still palpable 
> support. And you will be likely to have review comments related to how 
> you want to use it.
> 
> Cheers
> 
> 
> Bob
> 
>

---

From: Richard Bennett <[email-masked]>
Date: Fri, 04 Sep 2009 12:48:32 -0700

I'm interested in cost/benefits, policy implications in network 
regulation, running simulations, devising algorithms, writing papers, 
reviewing papers, mailing list and f2f discussions, and writing code.

The over-arching concern is connecting the costs of Internet transport 
with the prices people pay. The current model separates these two things 
by a Grand Canyon of historical accident.

RB

-- 
Richard Bennett
Research Fellow
Information Technology and Innovation Foundation
Washington, DC

---

From: Janardhan Iyengar <[email-masked]>
Date: Fri, 04 Sep 2009 17:19:44 -0400

All,

I am very much in favor of having a Congestion Exposure BoF.  There are several things that need to be figured out to go towards standardization, including what the IETF deliverables should be, but I don't think those are intractable issues.

Although the extent of my participation is likely to be exactly out-of-phase with the semester schedule, I will participate on the mailing-list and at meetings, and if it works out, help out with docs as well.

(I am not yet sure if I will make it to the Hiroshima IETF, but if I do, I will certainly be at the BoF.)
- jana

-- 
Janardhan Iyengar
Assistant Professor, Computer Science
Franklin & Marshall College
http://www.fandm.edu/jiyengar

---

From: "Mayutan A." <[email-masked]>
Date: Sat, 5 Sep 2009 07:46:16 +0200

Hi,

I have been following the re-ECN development for a long time and would be
very interested in playing an active role.  I am willing to help in various
activities such as implementation, simulation, promoting a re-ECN flavour,
co-authoring documents etc.

Cheers,
Mayutan

-- 
Mayutan Arumaithurai
0049-551-2712647 (Home number)
0049-176-20322049 (mobile number)

---

From: "PAPADIMITRIOU Dimitri" <[email-masked]>
Date: Sat, 5 Sep 2009 14:33:54 +0200

I am convinced more work is needed in this area. A BoF should help determining objectives, refine space of investigation (towards specification), and specifically look at interaction/impact on inter-domain / inter-connection and traffic regulation.

As involvement, I should (at least) actively participate to the mailing list discussions, and review/comment on documents.

Thanks,
-dimitri.
-----Original Message-----
From: [email-masked] on behalf of Bob Briscoe
Sent: Wed 02/09/2009 18:33
To: [email-masked]
Subject: [re-ECN] Pls respond: Do we have a Congestion Exposure community?
 
Folks,

Perceived problem:

Cheers

Bob

---

From: João Taveira Araújo <[email-masked]>
Date: Sat, 05 Sep 2009 18:00:52 +0100

Hi Bob,

As you know, I'm very much interested in re-ECN, particularly in using 
some of its properties in other areas like TE/routing. I have cycles to 
spare so feel free to count on me for reviewing/coding/booing and clapping.

Cheers,
Joao.

---

From: marcelo bagnulo braun <[email-masked]>
Date: Sat, 05 Sep 2009 20:38:12 +0200

Hi Joao,

could you expand on the relation between re-ecn and TE/routing?

Regards, marcelo

João Taveira Araújo escribió:
> some of its properties in other areas like TE/routing. I have cycles 
> to spare so feel free to count on me for reviewing/coding/booing and 
> clapping.
>
> Cheers,
> Joao.
>
> Bob Briscoe wrote:
>> Folks,
>>

---

From: "Ford, Alan" <[email-masked]>
Date: Sun, 6 Sep 2009 15:41:09 +0100

Bob, all,

Whilst I don't have a huge number of cycles to spare (hence catching up
with these mails a bit late!) I'd certainly be interested in a BoF (I
missed the previous discussions in Stockholm) and am interested in both
practical issues of implementation and any potential wider application
of the algorithms.

Regards,
Alan

> From: [email-masked] [mailto:[email-masked]] On
Behalf Of
> Bob Briscoe
> Sent: 02 September 2009 17:34
> To: [email-masked]
community?

---

From: Bob Briscoe <[email-masked]>
Date: Sun, 06 Sep 2009 16:09:23 +0100

João,

Thanks for this.

As someone who has already implemented re-ECN (at 
least sufficiently for your ns2 analysis), your 
contribution will be particularly valuable.

Bob

At 18:00 05/09/2009, João Taveira Araújo wrote:
>Hi Bob,
>
>As you know, I'm very much interested in re-ECN, 
>particularly in using some of its properties in 
>other areas like TE/routing. I have cycles to 
>>I'd like to try to arrange a Congestion 
>>Exposure (re-ECN) BoF in Nov at the Hiroshima 
>>IETF. If so, we have to notify the area 
>>directors v soon - by 24:00 UTC Mon 7 Sep 09. 
>>#1 gating function for Area Directors: activity on an ietf list.
>>
>>Therefore, pls respond preferably *on this 
>>list* if you're interested in being involved, 
>>no matter how insignificantly, e.g.
>>
>>Most people want to work on something finite 
>>like a new cool non-TCP-friendly congestion 
>>control. Less people want to go into an 
>>pseudo-infinite loop fixing IP to allow other 
>>cool stuff to happen. If you want something 
>>like re-ECN to be there, but don't have the 
>>bandwidth to work on it, that's cool too - 
>>please say this - it's still palpable support. 
>>And you will be likely to have review comments

---

From: João Taveira Araújo <[email-masked]>
Date: Sun, 06 Sep 2009 16:32:48 +0100

Hi Marcelo,

Re-ECN reveals rest-of-path congestion, so any (interested) network node 
can estimate how much congestion a given stream of packets is expected 
to experience. In the TE case this information might be useful to 
balance traffic more efficiently than simply resorting to load factor 
and other local information.

I also believe it might be an interesting catalyst for new routing 
models as it realigns incentives at the transit level. Hesitant 
providers might warm up to the idea of providing multiple routes if 
there was something in it for them too. As it stands current multipath 
work (afaict) is bypassing the network entirely and providing a pure e2e 
solution. Not that this is wrong, but it is one of many approaches. 
Whether we're gravitating towards it because it's the only deployable 
option or on technical merits alone is not entirely clear to me.

Cheers,
Joao.

marcelo bagnulo braun wrote:
>> As you know, I'm very much interested in re-ECN, particularly in 
>> using some of its properties in other areas like TE/routing. I have 
>> cycles to spare so feel free to count on me for 
>> reviewing/coding/booing and clapping.
>>
>> Cheers,
>> Joao.
>>
>> Bob Briscoe wrote:
>>> Folks,
>>>
>>> Therefore, pls respond preferably *on this list* if you're 
>>> interested in being involved, no matter how insignificantly, e.g.
>>>

---

From: marcelo bagnulo braun <[email-masked]>
Date: Sun, 06 Sep 2009 18:13:36 +0200

Hi Joao,

João Taveira Araújo escribió:
> Hi Marcelo,
>
> Re-ECN reveals rest-of-path congestion, so any (interested) network 
> node can estimate how much congestion a given stream of packets is 
> expected to experience. In the TE case this information might be 
> useful to balance traffic more efficiently than simply resorting to 
> load factor and other local information.
>
I see what you mean and i agree that that is a very interesting application.

> work (afaict) is bypassing the network entirely and providing a pure 
> e2e solution. Not that this is wrong, but it is one of many 
> approaches. Whether we're gravitating towards it because it's the only 
> deployable option or on technical merits alone is not entirely clear 
> to me.
I think there are several reasons why we are doing it e2e.
A major one, is that the stability issues for the e2 model have been 
worked out while the ones for the router based still need work, afaik.
BEsides, the actual model for load balancing changes significantly when 
doing it at the endpoints and when doing it in the routers

But, i certainly beleive this has a lot of potential and that is a very 
interesting applications of congestion information exposure.

Regards, marcelo

>>>> I'd like to try to arrange a Congestion Exposure (re-ECN) BoF in 
>>>> Nov at the Hiroshima IETF. If so, we have to notify the area 
>>>> directors v soon - by 24:00 UTC Mon 7 Sep 09. #1 gating function 
>>>> for Area Directors: activity on an ietf list.
>>>>

---

From: Bob Briscoe <[email-masked]>
Date: Sun, 06 Sep 2009 17:18:15 +0100

Joao, Marcelo,

We had an interesting retreat at Dagstuhl in 
Germany, which focused a great deal on this 
question of whether TE is best done e2e or in the 
network. While I agree that both are likely to 
happen whatever anyone decides is best, there was 
near-unanimity that e2e had more technical merit, not just more deployable.

But to a certain extent this assumes networks can 
and have put incentives in place for endpoints to 
do what networks would want them to do.

Of course the near-consensus at Dagstuhl may have 
been more a reflection of who had invited the participants!

I believe a distinction also needs to be made 
between moving traffic around offered routes and 
finding which new routes to offer that would improve load balancing.

The report on the retreat published in CCR and a link to further info is here:
<http://www.bobbriscoe.net/pubs.html#dagstuhl-fi>

HTH

Bob

At 16:32 06/09/2009, João Taveira Araújo wrote:
>Hi Marcelo,
>
>Re-ECN reveals rest-of-path congestion, so any 
>(interested) network node can estimate how much 
>congestion a given stream of packets is expected 
>to experience. In the TE case this information 
>might be useful to balance traffic more 
>efficiently than simply resorting to load factor and other local information.
>
>I also believe it might be an interesting 
>catalyst for new routing models as it realigns 
>incentives at the transit level. Hesitant 
>providers might warm up to the idea of providing 
>multiple routes if there was something in it for 
>them too. As it stands current multipath work 
>(afaict) is bypassing the network entirely and 
>providing a pure e2e solution. Not that this is 
>wrong, but it is one of many approaches. Whether 
>we're gravitating towards it because it's the 
>only deployable option or on technical merits 
>alone is not entirely clear to me.
>
>Cheers,
>Joao.
>
>>>As you know, I'm very much interested in 
>>>re-ECN, particularly in using some of its 
>>>properties in other areas like TE/routing. I 
>>>have cycles to spare so feel free to count on 
>>>me for reviewing/coding/booing and clapping.
>>>
>>>Cheers,
>>>Joao.
>>>
>>>Bob Briscoe wrote:
>>>>Folks,
>>>>
>>>>please say this - it's still palpable 
>>>>support. And you will be likely to have 
>>>>review comments related to how you want to use it.
>>>>
>>>>Cheers
>>>>
>>>>
>>>>Bob
>>>>
>>>>

---

From: João Taveira Araújo <[email-masked]>
Date: Sun, 06 Sep 2009 17:29:44 +0100

Bob Briscoe wrote:
> Joao, Marcelo,
>
> We had an interesting retreat at Dagstuhl in Germany, which focused a 
> great deal on this question of whether TE is best done e2e or in the 
> network. While I agree that both are likely to happen whatever anyone 
> decides is best, there was near-unanimity that e2e had more technical 
> merit, not just more deployable.

Agreed, but networks can make an endhost's life a lot easier, i.e. by 
offering disjoint / pre-computed paths over which hosts then balance 
their own traffic to possibly achieve something approaching Wardrop 
equilibrium. Then networks can just signal preference implicitly through 
packet marking to induce endhost behaviour.

To reply to Marcelo's earlier mail: yes, the e2e model is the right 
approach but re-ECN is disruptive enough that many of the choices made 
should be reassessed as some underlying assumptions may no longer hold. 
This is specially true for CC, but also extends into business models and 
security.

Cheers,
Joao.

>
> But to a certain extent this assumes networks can and have put 
> incentives in place for endpoints to do what networks would want them 
> to do.
>
> Of course the near-consensus at Dagstuhl may have been more a 
> reflection of who had invited the participants!
>
> I believe a distinction also needs to be made between moving traffic 
> around offered routes and finding which new routes to offer that would 
> improve load balancing.
>
>> there was something in it for them too. As it stands current 
>> multipath work (afaict) is bypassing the network entirely and 
>> providing a pure e2e solution. Not that this is wrong, but it is one 
>> of many approaches. Whether we're gravitating towards it because it's 
>> the only deployable option or on technical merits alone is not 
>> entirely clear to me.
>>
>> Cheers,
>> Joao.
>>
>>>>> non-TCP-friendly congestion control. Less people want to go into 
>>>>> an pseudo-infinite loop fixing IP to allow other cool stuff to 
>>>>> happen. If you want something like re-ECN to be there, but don't 
>>>>> have the bandwidth to work on it, that's cool too - please say 
>>>>> this - it's still palpable support. And you will be likely to have

---

From: Bob Briscoe <[email-masked]>
Date: Mon, 07 Sep 2009 00:24:51 +0100

Steve,

Here's what was in the minutes of the Bar Bof
<http://trac.tools.ietf.org/area/tsv/trac/wiki/0907re-ECNBarBoFMinutes>

/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\
* known implementations
   - 1+ * Linux
   - 0+ * vendor
   - 2 * ns2
/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\

1 Linux is Alan Smith's (BT)
1 ns2 is Toby Moncaster's (BT)

Both are intended to be usable by others, but 
still not ready to be official patches to the Linux kernel or the ns2 codebase.
The '+' items are people who don't want to reveal 
their plans until they are closer to knowing they 
will deliver. I guess you understand there's a 
step up between a bit of code to test your own 
ideas in a focused simulation, and fully featured 
code you would be happy to distribute to others.

Bob

At 16:13 06/09/2009, you wrote:
>Speaking of implementations/demos/simulations, is there a summary
>anywhere of what is currently available in terms of code?
>
>Thanks,
>Steve
>
>
>2009/9/6 Bob Briscoe <[email-masked]>:
> > João,
> >
> > Thanks for this.
> >
> > As someone who has already implemented re-ECN (at least sufficiently for
> > your ns2 analysis), your contribution will be particularly valuable.
> >
> >
> > Bob
> >
> >>> the Hiroshima IETF. If so, we have to 
> notify the area directors v soon - by

---

From: <[email-masked]>
Date: Tue, 8 Sep 2009 09:39:23 +0100

Hi Bob,

Definitely interested in this community and actively working on
protocols and systems to make it work.

Regards,

Alan

-----Original Message-----

Folks,

<snip>

---

From: "Zaheduzzaman Sarker" <[email-masked]>
Date: Tue, 8 Sep 2009 14:29:52 +0200

Hi,

I am also interested in this work especially in transport layer aspects. My involvement will include reviewing docs, thinking up new use and perhaps running some simulations. 

Thanks!!

BR

Zahed

*******************************************
A.N.M. Zaheduzzaman Sarker   
Research Engineer 
EAB/TVK - Multimedia Technologies
Ericsson Research 
Ericsson AB
Box 920 S-971 28 Luleå, Sweden
Tel: +46 (0)1 07173743
ECN: 850-73743
Mobile: +46 (0)761 153743
*******************************************

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bob Briscoe
Sent: Wednesday, September 02, 2009 6:34 PM
To: [email-masked]
Subject: [re-ECN] Pls respond: Do we have a Congestion Exposure community?

Folks,

Perceived problem:

Cheers

Bob