Subject: Re: [re-ECN] Pls respond: Do we have a Congestion Exposure community?

From: "Piers O'Hanlon" <[email-masked]>
Date: Tue, 8 Sep 2009 12:51:26 +0100

I know I'm a little late but I'd like to register my interest in this
BoF. I'm involved in some drafts using ECN for RTP which would be
relevant to such work.

Cheers,

Piers O'Hanlon

> Date: Wed, 02 Sep 2009 17:33:36 +0100
> To: [email-masked]
> From: Bob Briscoe <[email-masked]>
> Subject: Pls respond: Do we have a Congestion Exposure community?
>
> Folks,
>
> I'd like to try to arrange a Congestion Exposure (re-ECN) BoF in Nov at the Hiroshima IETF. If so, we have to notify the area directors v soon - by 24:00 UTC Mon 7 Sep 09. #1 gating function for Area Directors: activity on an ietf list.
>
> Therefore, pls respond preferably *on this list* if you're interested in being involved, no matter how insignificantly, e.g.
>
> - you want congestion visibility for other stuff you're doing
>  (but don't intend to work on it itself)
> - reviewing docs,
> - alternative way to achieve congestion exposure
> - participate in mailing list discussion,
> - co-authoring docs
> - design ways to do incremental deployment
> - using code for other stuff you're doing
> - thinking up new uses for the protocol
> - breaking it
> - analysing benefits/costs
> - implement protocol
> - implement a demo
> - running or participating in trials
> - standing on the sidelines booing or clapping
> - whatever
>
> Perceived problem:
> Most people want to work on something finite like a new cool non-TCP-friendly congestion control. Less people want to go into an pseudo-infinite loop fixing IP to allow other cool stuff to happen. If you want something like re-ECN to be there, but don't have the bandwidth to work on it, that's cool too - please say this - it's still palpable support. And you will be likely to have review comments related to how you want to use it.
>
> Cheers
>
>
> Bob
>
> ________________________________________________________________
> Bob Briscoe,               Networks Research Centre, BT Research

________________________________________________________________
Bob Briscoe,               Networks Research Centre, BT Research

---

From: Dragana Damjanovic <[email-masked]>
Date: Tue, 8 Sep 2009 14:48:03 +0200

It is a bit late, but I would just  like  to say that I  am also interested in
this BoF and further  activities.

Cheers,
Dragana

> > I'd like to try to arrange a Congestion Exposure (re-ECN) BoF in Nov at the
> Hiroshima IETF. If so, we have to notify the area directors v soon - by 24:00
> UTC Mon 7 Sep 09. #1 gating function for Area Directors: activity on an ietf
> list.
> >
> > Therefore, pls respond preferably *on this list* if you're interested in
> being involved, no matter how insignificantly, e.g.
> >
> > Most people want to work on something finite like a new cool
> non-TCP-friendly congestion control. Less people want to go into an
> pseudo-infinite loop fixing IP to allow other cool stuff to happen. If you
> want something like re-ECN to be there, but don't have the bandwidth to work
> on it, that's cool too - please say this - it's still palpable support. And
> you will be likely to have review comments related to how you want to use it.
> >
> > Cheers
> >
> >
> > Bob
> >
> _______________________________________________
> re-ECN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/re-ecn
>

---

From: Bob Briscoe <[email-masked]>
Date: Wed, 09 Sep 2009 22:00:28 +0100

Dragana,

Never too late. Thank you for your note of support.

Bob

---

From: Bob Briscoe <[email-masked]>
Date: Wed, 09 Sep 2009 22:06:16 +0100

Piers,

>BoF. I'm involved in some drafts using ECN for RTP which would be

If we get moving, you might end up adding re-ECN to RTP at the same 
time as you add ECN :)

Bob

> > I'd like to try to arrange a Congestion Exposure (re-ECN) BoF in 
> Nov at the Hiroshima IETF. If so, we have to notify the area 
> directors v soon - by 24:00 UTC Mon 7 Sep 09. #1 gating function 
> for Area Directors: activity on an ietf list.
> >
> > Therefore, pls respond preferably *on this list* if you're 
> interested in being involved, no matter how insignificantly, e.g.
> >
> pseudo-infinite loop fixing IP to allow other cool stuff to happen. 
> If you want something like re-ECN to be there, but don't have the 
> bandwidth to work on it, that's cool too - please say this - it's 
> still palpable support. And you will be likely to have review 
> comments related to how you want to use it.
> >
> > Cheers
> >
> >
> > Bob
> >

---

From: "Piers O'Hanlon" <[email-masked]>
Date: Thu, 17 Sep 2009 13:03:35 +0100

Hi Bob,

We just had a chat about our ECN/RTP draft and wondered what
implications re-ECN (or PCN) would have apart from us avoiding the use
of the Nonce?

Cheers,

Piers

2009/9/9 Bob Briscoe <[email-masked]>:
> If we get moving, you might end up adding re-ECN to RTP at the same time as
> you add ECN :)
>
>
> Bob
>
>
>> Cheers,
>>
>> Piers O'Hanlon
>>
>>
>> > I'd like to try to arrange a Congestion Exposure (re-ECN) BoF in Nov at
>> > the Hiroshima IETF. If so, we have to notify the area directors v soon - by
>> > 24:00 UTC Mon 7 Sep 09. #1 gating function for Area Directors: activity on
>> > an ietf list.
>> >

---

From: Bob Briscoe <[email-masked]>
Date: Fri, 18 Sep 2009 09:56:20 +0100

Piers,

>implications re-ECN (or PCN) would have apart from us avoiding the use

For unicast:
It should involve a change to the sender not the protocol, as long as 
the RTCP feedback tells the sender how much CE it has seen.

For multicast:
re-ECN isn't really required so much, as there's already receiver control.

Anyway, IMHO, ECN is not usefully defined for multicast at the mo 
(effectively each packet duplication appears to duplicate the amount 
of congestion). See
S.5 of this tech report (an I-D I did with Jon Crowcroft, but with 
the pictures as a PDF):
<http://www.bobbriscoe.net/pubs.html#ecnip_tr>

That's why I suggested that ECN in RTP should be done in two bites: 
simple unicast case and all the horrible complicated cases 
(multicast, middleboxes etc).

Bob

> >> > you will be likely to have review comments related to how you 
> want to use
> >> > it.
> >> >
> >> > Cheers
> >> >
> >> >
> >> > Bob
> >> >