Subject: Re: [re-ECN] Pls respond: Do we have a Congestion Exposure community?

From: Steven Blake <[email-masked]>
Date: Fri, 04 Sep 2009 13:54:16 -0400

On Wed, 02 Sep 2009 17:33:36 +0100 Bob Briscoe wrote:

> Folks,
>
> I'd like to try to arrange a Congestion Exposure (re-ECN) BoF in Nov 
> at the Hiroshima IETF. If so, we have to notify the area directors v 
> soon - by 24:00 UTC Mon 7 Sep 09. #1 gating function for Area 
> Directors: activity on an ietf list.
> Therefore, pls respond preferably *on this list* if you're interested 
> in being involved, no matter how insignificantly, e.g.
> - you want congestion visibility for other stuff you're doing
>    (but don't intend to work on it itself)
> - reviewing docs,
> - alternative way to achieve congestion exposure
> - participate in mailing list discussion,
> - co-authoring docs
> - design ways to do incremental deployment
> - using code for other stuff you're doing
> - thinking up new uses for the protocol
> - breaking it
> - analysing benefits/costs
> - implement protocol
> - implement a demo
> - running or participating in trials
> - standing on the sidelines booing or clapping
> - whatever
>
> Perceived problem:
> Most people want to work on something finite like a new cool 
> non-TCP-friendly congestion control. Less people want to go into an 
> pseudo-infinite loop fixing IP to allow other cool stuff to happen. If
> you want something like re-ECN to be there, but don't have the 
> bandwidth to work on it, that's cool too - please say this - it's 
> still palpable support. And you will be likely to have review 
> comments related to how you want to use it.

I am interested in making congestion exposure happen, and am willing to
work on documents, write code, participate in demos, etc.

Regards,

// Steve

---

From: Scott Brim <[email-masked]>
Date: Fri, 4 Sep 2009 16:37:58 -0400

I'll stand on the sidelines and clap.

---

From: Matt Mathis <[email-masked]>
Date: Fri, 4 Sep 2009 17:13:09 -0400

I have time, energy and even a meager draft to help this process go
forward.  Yes I plan to be in Hiroshima and would like to participate
in a BOF.

Given that this week is high time for vacation and holiday travel,
one week might not be sufficient polling time.

Thanks,
--MM--
-------------------------------------------
Matt Mathis      http://staff.psc.edu/mathis
Work:412.268.3319   Home/Cell:412.654.7529
-------------------------------------------
Evil is defined by mortals who think they know
"The Truth" and use force to apply it to others.

---

From: Bob Briscoe <[email-masked]>
Date: Sat, 05 Sep 2009 12:07:57 +0100

Matt,

>one week might not be sufficient polling time.

Yes, the timing was not as planned. But a fortnight ago I had a disk 
head crash on my laptop. Once I got another machine built and all my 
data scraped off back-ups and the old disk, we were only a few days 
from the deadline.

Also, once I got back, I had to deal with the rest of the stack that 
had overtaken events - including my employer continuing to try to 
manage the recession by making researchers into contract software 
developers for its product lines... Whoops, is this a public list?

But I think we're seeing enough interest on the list anyway - for now 
- even tho the US is asleep the rest of the world is still ticking.

Bob

________________________________________________________________
Bob Briscoe,               Networks Research Centre, BT Research