Subject: Re: [re-ECN] preliminary draft of problem statement- authors wanted

From: "Ingemar Johansson S" <[email-masked]>
Date: Tue, 29 Sep 2009 07:24:01 +0200

Hi

I am a bit lost. Is there any "latest version" of the problem statement
draft available (besides the one posted on the list september 18) ?. 

/Ingemar

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: den 28 september 2009 17:21
> To: [email-masked]
> Subject: re-ECN Digest, Vol 7, Issue 151
> 
> If you have received this digest without all the individual 
> message attachments you will need to update your digest 
> options in your list subscription.  To do so, go to 
> 
> https://www.ietf.org/mailman/listinfo/re-ecn
> 
> Click the 'Unsubscribe or edit options' button, log in, and 
> set "Get MIME or Plain Text Digests?" to MIME.  You can set 
> this option globally for all the list digests you receive at 
> this point.
> 
> 
> 
> Send re-ECN mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	https://www.ietf.org/mailman/listinfo/re-ecn
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it is more 
> specific than "Re: Contents of re-ECN digest..."
> 
> 
> Today's Topics:
> 
>    1. Re:  preliminary draft of problem statement- authors wanted
>       (Mirja Kuehlewind)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Mon, 28 Sep 2009 17:22:30 +0200
> From: Mirja Kuehlewind <[email-masked]>
> Subject: Re: [re-ECN] preliminary draft of problem statement- authors
> 	wanted
> To: [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="iso-8859-1"
> 
> Hi Toby,
> 
> two comments for my side so far:
> 
> Regarding the requirements, I'm not sure if their are 
> understandable for somebody who don't know the re-ECN ideas. 
> Although another ordering might help. And at this point of 
> the document upstream and downstream congestion needs to be 
> explained first.
> 
> In 5.2 I don't see why you are referring to re-ECN in the 
> first paragraph while remaining very general in the rest of 
> the section. I would prefer to move the reference to re-ECN 
> to the end of the section. Where else a direct mention of ECN 
> as a mechanism giving feedback would make the idea of 
> re-feedback more clear to me.
> Btw. why has ECN been kicked out completely?
> 
> Mirja
> 
> 
> On Friday 25 September 2009 14:13:03 [email-masked] wrote:
> > Here is what I have done so far. I haven't yet incorporated one of 
> > Michael's abstracts and I still haven't added in the proper list of 
> > authors. I have heavily edited several sections but have to admit I 
> > haven't tried to read through to see if it makes any sense.
> >
> > I am going to leave this now for a couple of days, probably 
> until Tuesday.
> > Anyone wanting to edit it in the meantime please feel free!
> >
> > Toby
> >
> > ____________________________________________________________________
> > Toby Moncaster, Senior Researcher, Network Infrastructure Practise 
> > B54/70 Adastral Park, Ipswich, IP53RE, UK.? +44 7918 901170
> >
> > > -----Original Message-----
> > > From: Michael Menth [mailto:[email-masked]]
> > > Sent: 25 September 2009 00:01
> > > To: Moncaster,T,Toby,DER3 R
> > > Cc: [email-masked]
> > > Subject: Re: [re-ECN] preliminary draft of problem statement- 
> > > authors wanted
> > >
> > > Hi Toby,
> > >
> > > here is some text for the abstract.
> > >
> > > >    We need to add an abstract summarising the problem 
> and pointing
> > > >
> > > >    towards congestion exposure as an answer...
> > >
> > > I like it short:
> > >
> > > The idea of congestion exposure means that a flow reveals an 
> > > estimate of the congestion it causes on its remaining downstream 
> > > path. It makes policing or other actions depending on downstream 
> > > congestion in the Internet more effective and leads thereby to a 
> > > more efficient and fairer Internet. This document 
> motivates the need 
> > > for congestion exposure and illustrates its usefulness in 
> different 
> > > use cases. Therefore, actions should be taken to 
> implement a simple 
> > > form of congestion exposure in the Internet.
> > >
> > > However, an enumeration for what congestion exposure may 
> be useful 
> > > can help to catch the reader's interest:
> > >
> > > The idea of congestion exposure means that a flow reveals an 
> > > estimate of the congestion it causes on its remaining downstream 
> > > path. Congestion exposure may be useful for various 
> purposes, e.g.,  
> > > meaningful policing at network ingresses, congestion-based 
> > > accounting between ISPs, fairer bandwidth sharing among users, 
> > > increased trust in the congestion-responsiveness of 
> end-systems, and 
> > > possibly congestion-dependent load balancing and routing. 
> Therefore, 
> > > congestion exposure leads to a more efficient and fairer 
> Internet. 
> > > This document motivates the need for congestion exposure and 
> > > illustrates its usefulness in different use cases. Therefore, 
> > > actions should be taken to implement a simple form of congestion 
> > > exposure in the Internet.
> > >
> > > The abstract may also contain a summary of the problem (I 
> don't find 
> > > it's necessary in the abstract) and be placed before the 
> text above:
> > >
> > > The Internet relies on TCP's congestion control algorithm 
> and saved 
> > > it from a major congestion collapse since its adoption. 
> However, TCP 
> > > is applied on a voluntary base and the bandwidth is fairly shared 
> > > among flows instead of users. This is problematic so that 
> ISPs take 
> > > simple or advanced policing actions on some sorts of traffic. 
> > > However, since congestion on the downstream path of a flow is not 
> > > visible, these approaches possibly hit users 
> unnecessarily and are 
> > > not effective enough.
> > >
> > >
> > > Regards,
> > >
> > >     Michael
> > >
> > > [email-masked] schrieb:
> > > > Hi Michael,
> > > >
> > > > Thanks for the useful feedback. Clearly this document 
> is still in 
> > > > its very early stages. I will try and produce a new 
> version by end 
> > > > of the week  which will hopefully address some of your comments.
> > > >
> > > > Meanwhile I am still keen to get volunteers willing to 
> contribute
> > >
> > > chunks
> > >
> > > > of text for any of the sections.
> > > >
> > > > Toby
> > > >
> > > >> -----Original Message-----
> > > >> From: Michael Menth [mailto:[email-masked]]
> > > >> Sent: 23 September 2009 22:41
> > > >> To: Moncaster,T,Toby,DER3 R
> > > >> Cc: [email-masked]
> > > >> Subject: Re: [re-ECN] preliminary draft of problem statement-
> > >
> > > authors
> > >
> > > >> wanted
> > > >>
> > > >> Hi Toby,
> > > >>
> > > >> I read the whole document and still it is unclear in 
> many parts. 
> > > >> I marked them in the attached doc-file. I hope this helps to 
> > > >> improve
> > >
> > > its
> > >
> > > >> clarity.
> > > >>
> > > >> Regards,
> > > >>
> > > >>     Michael
> > > >>
> > > >> [email-masked] schrieb:
> > > >>> Hi All,
> > > >>>
> > > >>> As promised here is a new draft of the problem 
> statement with a 
> > > >>> bit
> > > >>
> > > >> more meat on the bones. There is still an awful lot of 
> work to be
> > >
> > > done
> > >
> > > >> on this and not too much time to do it. Our absolute 
> deadline to 
> > > >> get something in is October 19th - only just over 3 
> weeks away...
> > > >>
> > > >>> As before I would welcome any contributions of text or general
> > > >>
> > > >> comments. When I have a bit more time I will do proper xml2rfc
> > >
> > > author
> > >
> > > >> entries for everyone that has contributed... For political 
> > > >> reasons I want it to be clear that this is a document that has 
> > > >> been worked on from people across the whole range of 
> the IETF community.
> > > >>
> > > >>> Toby
> > >
> > > 
> ____________________________________________________________________
> > >
> > > >>> Toby Moncaster, Senior Researcher, Network Infrastructure 
> > > >>> Practise B54/70 Adastral Park, Ipswich, IP53RE, UK.  +44 7918 
> > > >>> 901170
> > > >
> > > > 
> ------------------------------------------------------------------
> > > > ---
> > > >
> > > >> -
> > > >>
> > > >>> --
> > > >>>
> > > >>> _______________________________________________
> > > >>> re-ECN mailing list
> > > >>> [email-masked]
> > > >>> https://www.ietf.org/mailman/listinfo/re-ecn
> > > >>
> > > >> --
> > > >> Dr. Michael Menth, Assistant Professor University of 
> Wuerzburg, 
> > > >> Institute of Computer Science Am Hubland,
> > >
> > > D-
> > >
> > > >> 97074 Wuerzburg, Germany, room B206
> > > >> phone: (+49)-931/31-86644 (new), fax: (+49)-931/888-6632 
> > > >> mailto:[email-masked]
> > > >> http://www3.informatik.uni-wuerzburg.de/research/ngn
> > >
> > > --
> > > Dr. Michael Menth, Assistant Professor University of Wuerzburg, 
> > > Institute of Computer Science Am Hubland, D-97074 Wuerzburg, 
> > > Germany, room B206
> > > phone: (+49)-931/31-86644 (new), fax: (+49)-931/888-6632 
> > > mailto:[email-masked]
> > > http://www3.informatik.uni-wuerzburg.de/research/ngn
> 
> 
> 
> --
> -------------------------------------------------------------------
> Dipl.-Ing. Mirja K?hlewind
> Institute of Communication Networks and Computer Engineering 
> (IKR) University of Stuttgart, Germany Pfaffenwaldring 47, 
> D-70569 Stuttgart
> 
> web: www.ikr.uni-stuttgart.de
> email: [email-masked]
> tel: +49(0)711/685-67973
> -------------------------------------------------------------------
> -------------- next part --------------
> An embedded and charset-unspecified text was scrubbed...
> Name: draft-moncaster-congestion-exposure-problem-00d.txt
> Url: 
> <http://www.ietf.org/mail-archive/web/re-ecn/attachments/20090
928/3cf1785d/attachment.txt>
> 
> ------------------------------
> 
> _______________________________________________
> re-ECN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/re-ecn
> 
> 
> End of re-ECN Digest, Vol 7, Issue 151
> **************************************
>

---

From: <[email-masked]>
Date: Tue, 29 Sep 2009 09:32:47 +0100

Hi Ingemar.

I posted a version 00d in an email last Friday...

Assuming I get the time tomorrow I will do another revision and post it
(but will then be on holiday for a few days).

Toby

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Ingemar Johansson S
> Sent: 29 September 2009 06:24
> To: [email-masked]
---------------------------------------------------------------------
authors
> > > > >> From: Michael Menth
[mailto:[email-masked]]