Subject: Re: [re-ECN] Conex charter - now in External Review

From: Leslie Daigle <[email-masked]>
Date: Wed, 05 May 2010 04:23:36 -0400

Hi,

I'm reminded that not all the current IESG may have been around when we 
shared pointers to expression of interest from the GIIC meeting last 
Fall --  see http://www.giic.org/meetings/9-30-09.asp  for the list of 
presenters, and http://www.giic.org/pdf/LondonWorkshopReportFinal.pdf 
for the report, which includes:

"There were positive and often deeply considered comments about the 
proposal from all those who
attended, included assessment of it in their talks: Dr David Clark (MIT 
and former IETF Chief
Protocol Architect), Rich Woundy (Comcast office of the CTO), Prof 
Christopher Yoo (Penn Law),
Leslie Daigle (CITO of ISOC), Kevin Mason (Telecom NZ), Don Bowman (CTO 
Sandvine), Eric
Klinker (CTO BitTorrent) and Falk von Bornstaedt (Head of Peering 
Strategy, DT). KK Ramakrishnan
(AT&T Research) who has been involved in this area since the early 
Internet added a much-needed
dose of realism about the chances of deployment. No one had anything 
negative to say about the
proposal, though some potential obstacles to adoption were raised. Bob 
Briscoe (BT) presented the
proposal and Robert Pepper gave a background talk on Cisco's predictions 
for future Internet traffic. "

Leslie.

David Harrington wrote:
> Hi,
> 
> speaking as the person likely to be the Responsible AD for such a WG
> ...
> 
> Don't put it all on Stewart. 
> Stewart raised some points that a number of others have also raised.
> Stewart somehow got the job of putting his concerns in writing.
> 
> Let me try to increase transparency while we await the issues in
> writing.
> (These are my impressions, and I'm also a new IESG member, so please
> cut me some slack ... ;-)
> 
> Are we being fair in asking such questions for CONEX but not all other
> BOFs?
> I think it fair to say that not all BOFs are asked the same detailed
> questions, such as which ISPs have indicated any plans to deploy the
> technology.
> But it is also fair to say that all BOFs are expected to answer many
> of the some basic questions, such as
> is there significant community interest?
> is there an adequate community interest that is willing to commit to
> do the work?
> does the significant community interest seem strong enough that it
> will last beyond approving a charter? (lots of commitment seems to
> evaporate once a charter is approved)
> is the problem a real problem?
> is the problem well enough understood to actually engineer a solution?
> is standardization required to solve the problem?
> is there significant community interest in the same direction, or do
> people have lots of different ideas about how to solve the problem, so
> consensus might be difficult to reach?
> is it clear how the technology would be used, and how useful it would
> be?
> is the IETF the right place to do the work, or would another
> organization be more appropriate?
> Given the limited resources available (for editing, chairing,
> reviewing, directing, etc.) is this the most important work for the
> IETF (and the responsible area) to focus on at this time?
> and so on ...
> 
> I think the biggest questions regarding CONEX so far are:
> "Is this at the point where standardization is required, or is this
> research?"
> "Is a standard required because there are multiple vendors getting
> demand from multiple operators for this type of solution to the stated
> problem?"
> 
> It is not yet clear that multiple vendors are seeing demand for such a
> solution, that multiple 
> vendors have already implemented a proprietary solution to the problem
> in their equipment,
> that vendors are at least somewhat likely to implement such a standard
> in their equipment, and 
> that multiple operators would deploy such a standard if it were
> available. 
> This raises the questions of whether a standard is required, and
> whether IETF is the appropriate place for such work.
> 
> I am not authorized to speak for the IESG, but here are my
> impressions:
> We (the IESG) are paying attention. 
> We have asked Stewart to write up his concerns so the mailing list can
> respond.
> We are soliciting feedback from vendors and operators in the community
> so we can assess demand.
> We have sent the proposal for External review.
> and we continue to discuss it within the IESG.
> 
> Some are convinced it should be approved; others are not convinced.
> At this point, it is not obvious that it will be chartered.
> At this point, it is not obvious that it will not be chartered.
> It is under discussion. We have not yet reached rough consensus within
> the IESG, and we do not believe the IETF has yet reached rough
> consensus on this proposed WG.
> 
> Hopefully that gives you some insight into the current status of the
> request.
> We are working to reach a resolution.
> 
> dbh
> 
> p.s. if this starts a firestorm telling me how to do my job, or
> telling the IESG how to do theirs, then I probably won't bother making
> the extra effort for transparency in the future. Fair warning. dbh.
> 
>> -----Original Message-----
>> From: [email-masked] 
>> [mailto:[email-masked]] On Behalf Of Woundy, Richard
>> Sent: Wednesday, April 28, 2010 10:25 PM
>> To: ken carlberg; John Leslie
>> Cc: [email-masked]
>> Subject: Re: [re-ECN] Conex charter - now in External Review
>>
>>> let's cut him some slack, please.
>> Fair enough... I will cut Stewart some slack as well.
>>
>> -----Original Message-----
>> From: ken carlberg [mailto:[email-masked]] 
>> Sent: Wednesday, April 28, 2010 6:14 PM
>> To: John Leslie
>> Cc: Woundy, Richard; Stewart Bryant; [email-masked]
>> Subject: Re: [re-ECN] Conex charter - now in External Review
>>
>>
>> On Apr 28, 2010, at 11:21 AM, John Leslie wrote:
>>
>>>   In the past, Lars has asked other IESG members to put 
>> their concerns
>>> in writing. It is reasonable to assume Stewart is responding to
> such
>>> a request. Please recall, Stewart is a new IESG member, and 
>> may not be
>>> familiar with all the history we would like him to be -- i.e.
> let's
>>> cut him some slack, please.
>> I quite agree about cutting the fellow a lot of slack.  And I'll
>> respectfully extend my apologies if my earlier response was
> considered
>> too abrupt....its always hard to convey proper tone over email.
>>
>> I deeply appreciate Stewart speaking up on the matter on the 
>> list.  And
>> whether the proper response to the business oriented questions are
> "it
>> doesn't matter" or "its out of scope" is possibly splitting hairs.
> I
>> just feel strongly that a measure of consistency approach 
>> taken by all.
>>
>> as for the MPLS question, I thought that Bob Briscoe had responded
> to
>> that question at the Anaheim meeting.  And if so, perhaps he could
>> reiterate it on the list.
>>
>> cheers,
>>
>> -ken
>>
>> _______________________________________________
>> re-ECN mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/re-ecn
>>
> 
> _______________________________________________
> re-ECN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/re-ecn

-- 

-------------------------------------------------------------------
"Reality:
      Yours to discover."
                                 -- ThinkingCat
Leslie Daigle
[email-masked]
-------------------------------------------------------------------

---

From: Kevin Mason <[email-masked]>
Date: Thu, 6 May 2010 14:17:57 +1200

First of all I will put my hand up to say there is real interest from this ISP in this work, and I have been talking to our vendors. I cannot comment on whether the local vendor reps are relaying those conversations to their reps participating at the IETF. However in saying that, the interest within my organisation is by no means widespread or altogether favourable, many do not yet comprehend the potential, and any potential benefits lie beyond the immediate business problem horizon so are not yet factored into current forward thinking. However I think it is accurate to say that improving asset utilisation, without unnecessarily trading off the service experience of any or all Internet users, is an ever growing business imperative, as well as being an increasing public policy issue. 

The challenge with this proposed work is that the benefits cannot be demonstrated and then realised until a material part of any end to end path implements the capability. No services comprise components from a single vendor end to end. User applications, home or enterprise devices, network access devices, routers etc will all need to play some part in any system before any benefits can be shown to be achieved in any real network trial deployments. The resulting new capability can then begin to be observed and understood by key parties, particularly non technical decision makers. Fully realising the benefits may require a change in current market propositions and/or trading arrangements so this becomes more than an unseen technical change. 

Marking packets and feeding that path information back to the point where useful action can practically occur will not achieve anything if applications or control points do not receive it, understand it and respond, similarly building applications or controls to respond will not achieve anything unless relevant and timely feedback is implemented in the path in a consistent way.

So is some consensus convergence of view (i.e. "standardisation" ) necessary from a credible industry body (e.g. the IETF) before any meaningful trial deployments can occur?, in my view emphatically yes, as components from multiple vendors, each employed in their respective parts of the end to end outcome, all need to be confident enough they can create capability in a coordinated predictable way for the overall benefits to begin to be observable and subsequently leveraged.

Should the IETF do this work. In my view this is very much the sort of guidance we look to the IETF to lead. Once an initial consensus expert view is established, we are then in a far better position to further the conversation with vendors. Other standardisation forums may hopefully also pick up the foundation work and incorporate it into more specific use case guidance as the capability becomes better understood by the wider industry.

Can this be resourced, all I can say here is that there is some willingness from this quarter, but as IETF work is northern hemisphere based and I am southern hemisphere based, distance remains a cost barrier to active contribution. This is probably not much help!

Regards
Kevin Mason
Principal Solution Architect, Telecom NZ Ltd 
[email-masked] 
Level 1 - Unit 1, Telecom Centre, 49-55 Tory Street
P O Box 293, Wellington, New Zealand 6140
www.telecom.co.nz 
 
________________________________

This communication, including any attachments, is confidential. If you are not the intended recipient, you should not read it - please contact me immediately, destroy it, and do not copy or use any part of this communication or disclose anything about it. Thank you. Please note that this communication does not designate an information system for the purposes of the Electronic Transactions Act 2002. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Leslie Daigle
Sent: Wednesday, 5 May 2010 8:24 p.m.
To: David Harrington
Cc: 'Woundy, Richard'; [email-masked]
Subject: Re: [re-ECN] Conex charter - now in External Review

Hi,

Leslie.

--