Subject: [regext] RDAP questions

From: Brian Mountford <[email-masked]>
Date: Wed, 3 Aug 2016 12:32:58 -0400

I have a couple questions about RDAP RFC 7483.
RFC 7483 4.7. Port 43 WHOIS Server

For registries such as ourselves, is this supposed to be the registrar’s
server, or ours? I would have thought the registrar’s since WHOIS AWIP is
that way. But the registrar’s WHOIS is a URL, whereas this is explicitly
not so.
RFC 7483 5.1. The Entity Object Class

The RFC indicates that among the items of information we should return for
an entity is its role (admin, tech, billing, registrar, etc.). But contacts
don’t necessarily have a single role. The same contact could have more than
one role in more than one domain. In our database, the role tag is
associated with the mapping of the domain to the contact, not with the
contact itself. So it’s not clear how we can provide this information for
contacts found using a direct search. For contacts displayed as part of a
domain search, or for registrars, it’s not a problem.

Thanks.

Brian Mountford
Google Registry

---

From: Andy Newton <[email-masked]>
Date: Wed, 3 Aug 2016 18:09:07 +0000

On Aug 3, 2016, at 12:32 PM, Brian Mountford <[email-masked]<mailto:[email-masked]>> wrote:

I have a couple questions about RDAP RFC 7483.
RFC 7483 4.7. Port 43 WHOIS Server
For registries such as ourselves, is this supposed to be the registrar’s server, or ours? I would have thought the registrar’s since WHOIS AWIP is that way. But the registrar’s WHOIS is a URL, whereas this is explicitly not so.

Somebody else will have to answer as to which whois server this is suppose to reference (I think registrar). But there is no whois URI scheme, which is why that is explicitly not a URI.
RFC 7483 5.1. The Entity Object Class
The RFC indicates that among the items of information we should return for an entity is its role (admin, tech, billing, registrar, etc.). But contacts don’t necessarily have a single role. The same contact could have more than one role in more than one domain. In our database, the role tag is associated with the mapping of the domain to the contact, not with the contact itself. So it’s not clear how we can provide this information for contacts found using a direct search. For contacts displayed as part of a domain search, or for registrars, it’s not a problem.

You have it exactly correct. If somebody were to lookup a contact directly, there is no context in which to have a role and therefore the “roles” array should not be present.

-andy

---

From: Gustavo Lozano <[email-masked]>
Date: Tue, 9 Aug 2016 18:31:01 +0000

Brian, Andy,

Comments inline.

Regards,
Gustavo

From:  regext <[email-masked]> on behalf of Andy Newton
<[email-masked]>
Date:  Wednesday, August 3, 2016 at 11:09
To:  Brian Mountford <[email-masked]>
Cc:  "[email-masked]" <[email-masked]>
Subject:  Re: [regext] RDAP questions

> 
> 
>> On Aug 3, 2016, at 12:32 PM, Brian Mountford <[email-masked]> wrote:
>> 
>> For registries such as ourselves, is this supposed to be the registrar¹s
>> server, or ours? I would have thought the registrar¹s since WHOIS AWIP is
>> that way. But the registrar¹s WHOIS is a URL, whereas this is explicitly not
>> so.
> 
> 
> Somebody else will have to answer as to which whois server this is suppose to
> reference (I think registrar). But there is no whois URI scheme, which is why
> that is explicitly not a URI.

In the case of the RDAP profile (gTLD space), the ³port43² element is not
expected to be used, because Whois/43 tcp will be deprecated in the future.
The objective of the RDAP profile is to keep everything in RDAP, and in the
case of ³thin² registrations, the RDAP URI of the RDAP service of the
Registrar is provided to the end-user as described in 2.3 of the RDAP
profile 
(https://www.icann.org/resources/pages/rdap-operational-profile-2016-07-26-e
n).

>> The RFC indicates that among the items of information we should return for an
>> entity is its role (admin, tech, billing, registrar, etc.). But contacts
>> don¹t necessarily have a single role. The same contact could have more than
>> one role in more than one domain. In our database, the role tag is associated
>> with the mapping of the domain to the contact, not with the contact itself.
>> So it¹s not clear how we can provide this information for contacts found
>> using a direct search. For contacts displayed as part of a domain search, or
>> for registrars, it¹s not a problem.
> 
> You have it exactly correct. If somebody were to lookup a contact directly,
> there is no context in which to have a role and therefore the ³roles² array
> should not be present.
> 
> -andy
>

---

From: Brian Mountford <[email-masked]>
Date: Wed, 10 Aug 2016 17:14:15 -0400

OK, I will remove port43 from my RDAP output. It might make sense to
include an item in the operational profile indicating that use of the
port43 member is discouraged. That certainly was not clear to me. Thanks.

Brian

On Tue, Aug 9, 2016 at 2:31 PM, Gustavo Lozano <[email-masked]>
wrote:

> Brian, Andy,
>
> Comments inline.
>
> Regards,
> Gustavo
>
> From: regext <[email-masked]> on behalf of Andy Newton <
> [email-masked]>
> Somebody else will have to answer as to which whois server this is suppose
> to reference (I think registrar). But there is no whois URI scheme, which
> is why that is explicitly not a URI.
>
>
> In the case of the RDAP profile (gTLD space), the “port43” element is not
> case of “thin” registrations, the RDAP URI of the RDAP service of the
> profile (https://www.icann.org/resources/pages/rdap-
> operational-profile-2016-07-26-en).
>
>
> You have it exactly correct. If somebody were to lookup a contact
> directly, there is no context in which to have a role and therefore the
> “roles” array should not be present.
>
> -andy
>
>