Subject: Re: [regext] draft-ietf-eppext-keyrelay

From: "James Galvin" <[email-masked]>
Date: Mon, 08 Aug 2016 10:55:31 -0400

Rik,

Speaking as working group co-chair (note that the other co-chair is 
conflicted as he is a co-author), the working group has agreed to submit 
this document for publication but the working group has not considered 
the issue of the IPR.

To say this differently, the working group has agreed with the content 
of the document but it has not fully considered the IPR that may or may 
not apply to the resulting standard.

Typically, the IETF does not approve standards with an IPR claim unless 
two things are true.  First, the working group must have significant 
consensus that it has considered the IPR and believes that the document 
represents the best solution regardless.  Second, there is an 
expectation that there will be some indication of the licensing that may 
or may not be required based on the IPR.

While it is true that no licensing statement is required, the working 
group must consider this fact as part of its discussion and then decide 
what its consensus will be based on that.

Since the working group has not yet considered the question of whether 
or not it wants to advance this document without an IPR licensing 
statement, let me ask two questions at this time.

1. To the document authors - do you want to ask the working group if it 
would be willing to advance this document without a licensing statement 
from Verisign?

2. To the working group - is there anyone who objects to moving this 
document forward without an IPR licensing statement?

While normally rough consensus is sufficient to resolve a question, in 
this case I want to state in advance that I will require significant 
consensus, which means limited objection, in order to declare that the 
working group believes that this document should move forward.  I 
believe that the IETF in general will expect this of this working group.

I would appreciate if working group members would respond to the second 
question on the list.

Thanks!

Jim
(speaking as co-Chair of REGEXT)

On 28 Jul 2016, at 8:29, Rik Ribbers wrote:

> All,
>
> Thx Ulrich for bringing this to the mailing list. I have sent a 
> lengthy email to WG-chairs and ADs on this issue but this mail sums it 
> up quite easily. This is my understanding:
>
> I have re-read BCP-79 on the train home from IETF and I have to agree 
> with Scott that the IPR-disclosure on the keyrelay draft is conform 
> BCP-79, as licence details are not mandatory.
>
> On 28 Jul 2016, at 13:46, Ulrich Wisser 
> <[email-masked]<mailto:[email-masked]>> wrote:
>
>  I believe if we indicate that the WG is
> content with the information provided by Verisign, the IESG will 
> forward the document
>
>
> As far as I see it the IPR-disclosure is conform BCP-79 and should not 
> be blocking publication. The WG has not discussed the IPR-disclosure 
> at all in public, so implementers will have to consider this IPR 
> disclosure themselves before implementing this (My company had legal 
> advice in this specific case).  Of coarse I agree that an updated 
> IPR-disclosure with licensing details makes it easier for implementers 
> to make an informed decision but it is not necessary. So I am content 
> with the information provided by Verisign.
>
> I would love to hear from others, especially the WG-chairs an ADs what 
> they think on this matter.
>
> Gr,
> Rik
>
>
>
>
>
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext

---

From: Roger D Carney <[email-masked]>
Date: Mon, 8 Aug 2016 16:11:00 +0000

Good Afternoon,

Interesting question Jim.

It seems like it would be a benefit to most of the stakeholders to have a licensing statement included prior to moving forward. Why would we not include the statement? I was unable to attend the last meeting, though I did review the minutes and it looks like there was some discussion on this, so maybe this has already been answered.

Thanks

Roger

-----Original Message-----
From: regext [mailto:[email-masked]] On Behalf Of James Galvin
Sent: Monday, August 08, 2016 9:56 AM
To: Rik Ribbers <[email-masked]>
Cc: Alexey Melnikov <[email-masked]>; Ulrich Wisser <[email-masked]>; Registration Protocols Extensions <[email-masked]>
Subject: Re: [regext] draft-ietf-eppext-keyrelay

Rik,

Speaking as working group co-chair (note that the other co-chair is conflicted as he is a co-author), the working group has agreed to submit this document for publication but the working group has not considered the issue of the IPR.

To say this differently, the working group has agreed with the content of the document but it has not fully considered the IPR that may or may not apply to the resulting standard.

Typically, the IETF does not approve standards with an IPR claim unless two things are true.  First, the working group must have significant consensus that it has considered the IPR and believes that the document represents the best solution regardless.  Second, there is an expectation that there will be some indication of the licensing that may or may not be required based on the IPR.

While it is true that no licensing statement is required, the working group must consider this fact as part of its discussion and then decide what its consensus will be based on that.

Since the working group has not yet considered the question of whether or not it wants to advance this document without an IPR licensing statement, let me ask two questions at this time.

1. To the document authors - do you want to ask the working group if it would be willing to advance this document without a licensing statement from Verisign?

2. To the working group - is there anyone who objects to moving this document forward without an IPR licensing statement?

While normally rough consensus is sufficient to resolve a question, in this case I want to state in advance that I will require significant consensus, which means limited objection, in order to declare that the working group believes that this document should move forward.  I believe that the IETF in general will expect this of this working group.

I would appreciate if working group members would respond to the second question on the list.

Thanks!

Jim

> <[email-masked]<mailto:[email-masked]<mailto:[email-masked]%3cmailto:[email-masked]>>> wrote:

>  I believe if we indicate that the WG is content with the information

> provided by Verisign, the IESG will forward the document

> [email-masked]<mailto:[email-masked]>

regext mailing list

[email-masked]<mailto:[email-masked]>

---

From: Rik Ribbers <[email-masked]>
Date: Wed, 10 Aug 2016 14:25:13 +0000

Roger,

On 08 Aug 2016, at 18:11, Roger D Carney <[email-masked]<mailto:[email-masked]>> wrote:

Why would we not include the statement?

We, the working group are depending on the legal department of Verisign to provide these license details as Verisign is the discloser. I have tried to get some feedback from them (and so has Scott) when to expect this update however there is no expected date. In theory we could be waiting forever, but in the end it will show up somewhere in time when the patent claim is either approver or rejected and this could take up to a few years (i’m not a patent expert though). If you look at the current status of the patent claim it is in an appeal state after a rejection, so anything can happen during the appeal phase.

The only reason not to include it is to move forward as we are currently stuck for over 230 days.

Hope this clarifies things.

Gr,
Rik

---

From: Marc Groeneweg <[email-masked]>
Date: Thu, 11 Aug 2016 11:55:35 +0000

All,

<SNAP/>
>1. To the document authors - do you want to ask the working group if it would be willing to advance this document without a licensing statement from Verisign?

We (the authors) agree that the best option is to forward the document with the updated IPR disclosure by Verisign. However, given the fact that we are waiting for this update for over 235 days now we think that the time has come for the workgroup to discuss alternative options to move forward.

>2. To the working group - is there anyone who objects to moving this document forward without an IPR licensing statement?

We don’t object. Like stated before we had legal advice on this specific IPR disclosure.

>While normally rough consensus is sufficient to resolve a question, in this case I want to state in advance that I will require significant consensus, which means limited objection, 
>in order to declare that the working group believes that this document should move forward.  I believe that the IETF in general will expect this of this working group.

@Jim could you please quantify what significant consensus means? Especially how many ”No objections” would be needed. The reason for asking is that there is a fast silent majority in this working group.

>I would appreciate if working group members would respond to the second question on the list.

We second that and ask people to state their opinion on the mailinglist on this specific issue.
 
Best regards,
Rik Ribbers and Marc Groeneweg

---

From: Rik Ribbers <[email-masked]>
Date: Mon, 29 Aug 2016 12:33:50 +0000

All,

This is just a friendly reminder to look into the question Jim Galvin has asked the working group here:  https://mailarchive.ietf.org/arch/msg/regext/L_TmhBqzzKGDREigZ4NeW7ANzyg

One way or another we need to discuss the IPR disclosure and what to do with it. If there is anybody who needs more information feel free to contact me on- or off mailinglist.

Gr,
Rik

---

From: Miek Gieben <[email-masked]>
Date: Tue, 30 Aug 2016 08:15:35 +0000

[ Quoting <[email-masked]> in "Re: [regext] draft-ietf-eppext-keyr..." ]
>One way or another we need to discuss the IPR disclosure and what to do with it. If there is anybody who needs more information feel free to contact me on- or off mailinglist.

I'm in favor of making epp-keyrelay a standard. But by having an IPR disclosure
and no indication of licensing, this means what? Verisign can sue anybody using
this? Or ask money? That's not really in the spirit of RFCs IMHO...

Also the date on the IPR, lists 2009. Looking at the patent itself the oldest
date there is 2011?
(I have an itchy feeling that by going through previous IETF meetings, we should
be able to find some prior art, taking 2011 as end date)

/Miek

--
Miek Gieben

---

From: Rik Ribbers <[email-masked]>
Date: Tue, 30 Aug 2016 08:48:17 +0000

Miek,

> On 30 Aug 2016, at 10:15, Miek Gieben <[email-masked]> wrote:
> 

Although it is tempting to discuss the patent claim it is irrelevant for the discusion here. The consequence of forwarding without IPR-disclosure is that any implementer will have to interpret the IPR disclosure and the patent claim themselves. And the consequence of the patent or parts of it being granted? I honestly don’t know what Versign will do. They had almost 260 days now to update the IPR statement to clarify that and it has not happened. Scott has indicated multiple times that they are working on it. So if Scott (or anybody else within Verisign) would indicate to the WG when it will update the IPR disclosure that might help to move forward.

Gr,
Rik

---

From: Miek Gieben <[email-masked]>
Date: Tue, 30 Aug 2016 09:05:34 +0000

>Although it is tempting to discuss the patent claim it is irrelevant for the discusion here. The consequence of forwarding without IPR-disclosure is that any implementer will have to interpret the I…

Ack, let's sideline this dicussion.

What about my other points?

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 31 Aug 2016 10:52:02 +0000

> From: regext [mailto:[email-masked]] On Behalf Of Rik Ribbers
> Sent: Tuesday, August 30, 2016 4:48 AM
> To: Miek Gieben
> Cc: Registration Protocols Extensions
> Although it is tempting to discuss the patent claim it is irrelevant
> for the discusion here. The consequence of forwarding without IPR-
> disclosure is that any implementer will have to interpret the IPR
> disclosure and the patent claim themselves. And the consequence of the
> patent or parts of it being granted? I honestly don’t know what Versign
> will do. They had almost 260 days now to update the IPR statement to
> clarify that and it has not happened. Scott has indicated multiple
> times that they are working on it. So if Scott (or anybody else within
> Verisign) would indicate to the WG when it will update the IPR
> disclosure that might help to move forward.

I continue to be told "soon".

Scott