Subject: [regext] I-D Action: draft-ietf-regext-verificationcode-01.txt

From: [email-masked]
Date: Mon, 17 Apr 2017 05:18:20 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Registration Protocols Extensions of the IETF.

        Title           : Verification Code Extension for the Extensible Provisioning Protocol (EPP)
        Author          : James Gould
	Filename        : draft-ietf-regext-verificationcode-01.txt
	Pages           : 35
	Date            : 2017-04-17

Abstract:
   This document describes an Extensible Provisioning Protocol (EPP)
   extension for including a verification code for marking the data for
   a transform command as being verified by a 3rd party, which is
   referred to as the Verification Service Provider (VSP).  The
   verification code is digitally signed by the VSP using XML Signature
   and is "base64" encoded.  The XML Signature includes the VSP signer
   certificate, so the server can verify that the verification code
   originated from the VSP.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-regext-verificationcode/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-regext-verificationcode-01
https://datatracker.ietf.org/doc/html/draft-ietf-regext-verificationcode-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-regext-verificationcode-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Niels ten Oever <[email-masked]>
Date: Tue, 18 Apr 2017 14:30:56 +0200

Hi all,

I just found out that this draft standards is already being approved by
ICANN since February, which somehow seems a bit the wrong way around:

https://www.icann.org/en/system/files/correspondence/papac-to-kane-27feb17-en.pdf

I brought up on this list and in the past two sessions that this
document would really benefit from Privacy Considerations (RFC6973).

Not only because it is a good thing to do, but also because if we want
these practices to exist for some time they will need to abide by
privacy regulations (such as the upcoming GODR [0]).

All the best,

Niels

[0] https://en.wikipedia.org/wiki/General_Data_Protection_Regulation

On 04/17/2017 02:18 PM, [email-masked] wrote:
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext
> 

-- 
Niels ten Oever
Head of Digital

Article 19
www.article19.org

PGP fingerprint    8D9F C567 BEE4 A431 56C4
                     678B 08B5 A0F2 636D 68E9

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 18 Apr 2017 12:41:25 +0000

> -----Original Message-----
> From: regext [mailto:[email-masked]] On Behalf Of Niels ten Oever
> Sent: Tuesday, April 18, 2017 8:31 AM
> To: [email-masked]
> Subject: [EXTERNAL] Re: [regext] I-D Action: draft-ietf-regext-
> verificationcode-01.txt
>
> Hi all,
>
> I brought up on this list and in the past two sessions that this document
> would really benefit from Privacy Considerations (RFC6973).
>
> these practices to exist for some time they will need to abide by privacy
> regulations (such as the upcoming GODR [0]).

Niels, if I remember correctly James Gould asked you at the Chicago meeting if you could help with proposed text to be added to the document, and I think you agreed. Have you had a chance to work with him to come up with that text?

Scott

---

From: Niels ten Oever <[email-masked]>
Date: Tue, 18 Apr 2017 15:01:15 +0200

On 04/18/2017 02:41 PM, Hollenbeck, Scott wrote:
>> -----Original Message----- From: regext
>> [mailto:[email-masked]] On Behalf Of Niels ten Oever Sent:
>> Tuesday, April 18, 2017 8:31 AM To: [email-masked] Subject:
>> [EXTERNAL] Re: [regext] I-D Action: draft-ietf-regext- 
>> verificationcode-01.txt
>> 
>> Hi all,
>> 
>> I just found out that this draft standards is already being
>> approved by ICANN since February, which somehow seems a bit the
>> wrong way around:
>> 
>> https://www.icann.org/en/system/files/correspondence/papac-to-kane-
>>
>> 
27feb17-en.pdf
>> Not only because it is a good thing to do, but also because if we
>> want these practices to exist for some time they will need to abide
>> by privacy regulations (such as the upcoming GODR [0]).
> 
> Niels, if I remember correctly James Gould asked you at the Chicago
> meeting if you could help with proposed text to be added to the
> document, and I think you agreed. Have you had a chance to work with
> him to come up with that text?
> 
> Scott

I did not work on this with James, but I remain happy to help.

Best,

Niels

-- 
Niels ten Oever
Head of Digital

Article 19
www.article19.org