Subject: Re: [regext] EPP extension to take in generic key value pairs

From: "Gould, James" <[email-masked]>
Date: Wed, 19 Apr 2017 18:38:01 +0000

Hi,

We created a key / value pair extension called the “Common Object Attribute (COA) Extension for the Extensible Provisioning Protocol (EPP)” that was registered in the EPP Extensions Registry (https://www.iana.org/assignments/epp-extensions/epp-extensions.xhtml ).  Use of COA has been considered on numerous occasions, but the problem always morphed into something too complex for a simple key / value pair, resulting in creation of a specific extension.  There is no typing, there is no containment mechanism, and most importantly there is no definition for the supported set of keys and when the keys are used.  You could create a key registry to ensure that keys have a consistent meaning.

Take a look at one of the simplest extensions, being the Allocation Token Extension (https://tools.ietf.org/html/draft-ietf-regext-allocation-token), where initially you could use a pre-defined key (e.g., “ALLOCATION-TOKEN”), with the value being the allocation token.  Then when you start thinking using an Allocation Token, you want to extend the check command to check the availability of a domain name using the allocation token.  And then when you think about it some more, you want to then get the Allocation Token used via the info command and response.  You could attempt to solve the check command / response, create command, and info command / response behavior with use of a general key / value pair extension with one or more pre-defined keys, but then you have a need to define when you use the keys and what the expected behavior is.  Even though the Allocation Token Extension is yet another EPP extension, it meets a specific purpose explicitly and is defined in one place.

In the end, I view the use of a general key / value pair extension as being too rudimentary for use in communication between the EPP clients and servers.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://verisigninc.com/>

From: regext <[email-masked]> on behalf of Tongfeng Zhang <[email-masked]>
Date: Wednesday, April 19, 2017 at 1:22 PM
To: "[email-masked]" <[email-masked]>
Subject: [EXTERNAL] [regext] EPP extension to take in generic key value pairs

Dear colleagues,

While adding some unrelated features to our registry platform, I thought of adding an EPP extension of accept generic key/value pairs for an entity (domain, contact, or host) instead of creating 1 specific extension per feature.

I was wondering if anyone’s implemented similar extensions in your registry. Appreciated if you could share your experience (pros and cons). Also, would like to know your onion on a making such extension a standard.

Thanks,
Tongfeng Zhang  (CIRA)

---

From: Tongfeng Zhang <[email-masked]>
Date: Tue, 25 Apr 2017 15:40:26 +0000

Thank you James for your response.

For us, I could see it being useful in a few cases when we need to take in some extra data for an entity and those data are only for info and/or internal usage.

For example, we take in a value for language for each contact created in our system. The value will determine in what language we send messages to the contact.

Thanks,
Tongfeng

From: Gould, James [mailto:[email-masked]]
Sent: Wednesday, April 19, 2017 2:38 PM
To: Tongfeng Zhang; [email-masked]
Subject: Re: [regext] EPP extension to take in generic key value pairs

Hi,

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

From: regext <[email-masked]<mailto:[email-masked]>> on behalf of Tongfeng Zhang <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, April 19, 2017 at 1:22 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [EXTERNAL] [regext] EPP extension to take in generic key value pairs

Dear colleagues,

Thanks,
Tongfeng Zhang  (CIRA)