Subject: [regext] Reseller Object vs Generic Organization Object

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 3 Apr 2017 14:21:46 +0000

I've been giving some thought to the possibility of writing up a proposal for a generic organization object that can be compared to the proposal we have for a reseller object since the topic came up at last week's meeting. After looking things over I concluded that a generic organization object would look an awful lot like what's already written for the reseller object, so I'd like to suggest an alternative that doesn't require a lot of text cloning.

Step 1: If the object described in draft-ietf-regext-reseller were changed from "reseller" to "genOrg" (or something similar), we would have an object that could be used to describe a generic organization. We might need to add or modify a field or two or more, but I think what's there is close.

Step 2: If the extension described in draft-ietf-regext-reseller-ext were modified to note different types of extended organization relationships, we could have support for resellers, DNS service providers, hosting providers, and/or whatever other organization relationships people see a need for. An extended <info> response, for example, could look like this:

S:<extension>
S:  <genOrgExt:infData xmlns:genOrgExt="urn:ietf:params:xml:ns:genOrgExt-1.0">
S:    <genOrgExt:id type="reseller">myreseller</genOrgExt:id> 
S:    <genOrgExt:id type="dnsProvider">myDNSProvider</genOrgExt:id>
S:  </genOrgExt:infData>
S:</extension>

We could add an IANA registry for organization identifier types.

Is something like this worth considering? It looks pretty simple to me.

Scott

---

From: Patrick Mevzek <[email-masked]>
Date: Tue, 4 Apr 2017 01:21:07 +0200

Hollenbeck, Scott <[email-masked]> 2017-04-03 16:23
> I've been giving some thought to the possibility of writing up a proposal for a generic organization object that can be compared to the proposal we have for a reseller object since the topic came up at last week's meeting. 

[…]
> Is something like this worth considering? It looks pretty simple to me.
 
I do agree with your idea, Scott.

For me, philosophically it sounds strange to define a reseller object,
alongside domains, hosts and contacts, where there is no registrar
object. It would look like a missing piece in the puzzle.

So having a generic organisation would be useful to code for many
cases, and do not emphasize resellers as being a more important
objects than others.

And +1 for the IANA registry on types/roles.

-- 
Patrick Mevzek

---

From: Marc Groeneweg <[email-masked]>
Date: Tue, 4 Apr 2017 07:26:29 +0000

All,

>> I've been giving some thought to the possibility of writing up a proposal for a generic organization 
>>object that can be compared to the proposal we have for a reseller object since the topic came up 
>>at last week's meeting. 
>    
>  […]
I also agree to this idea Scott.
    
>    object. It would look like a missing piece in the puzzle.
It’s indeed strange now you mention this. I presume its historically so,
because registries have, in some way, implemented a registrar object
into their system, without giving an EPP interface to handle changes
to this object (other than extend on your own, or through a webinterface,
nobody cares about…). And think about the abuse contact (ICANN).
    
>    And +1 for the IANA registry on types/roles.

+1 for the IANA registry too.

Best regards,
Marc

---

From: Andrew Newton <[email-masked]>
Date: Tue, 4 Apr 2017 08:25:41 -0500

> +1 for the IANA registry too.

+1 as well. This seems very similar to RDAP entities and the roles
registered in the IANA registry (which, btw, already has "reseller").
That leaves me wondering if we should think about an optional mapping.

-andy