Subject: Re: [regext] I-D Action: draft-ietf-regext-epp-fees-04.txt

From: "Gould, James" <[email-masked]>
Date: Tue, 6 Jun 2017 18:27:09 +0000

Roger,

Thanks for posting the updated draft, it’s getting very close.  Below is my feedback to the latest version (04):

1.       Section 3.1 “Client Commands”

a.       The list of commands needs to be updated to include the “custom” command with the “customName” attribute.  The Change Poll Extension (https://tools.ietf.org/html/draft-ietf-regext-change-poll-01#page-4 ) includes an example of the use of the “custom” command / operation along with an optional “customName” / “op” attribute to define the concrete name of the custom command.  I don’t believe there is the need to support a sub-command, where the use of a sub-command may be useful in differentiating one of the transfer operations (“request”, “approve”, “cancel”, “reject”); although the only billable transfer operations is “request”.

2.       Section 4 “Server Handling of Fee Information”

a.       Nit – “<create>>” should be “<create>”

b.       Nit – “<fee<” should be “<fee>”.

c.       Revise “If the currency or total fee provided by the client do not agree with the server’s own calculation of the fee for that command, then the server MUST reject…” to match the language included in section 5.2.1 “EPP <create> Command” where “The server MUST fail the <create> command if the <fee:fee> provided by the client is less than the server fee”.

3.       Section 5.1.1

a.       Revise the description of the <check> extension to define a new Fee Check Command, as defined in option #2 in the regext list (https://mailarchive.ietf.org/arch/msg/regext/2nZMuj9miTaEefyxeIgDnLKe9Rs/?qid=816ff935b150313c729350d5711051b1) message.  The last message on the thread message (https://mailarchive.ietf.org/arch/msg/regext/PV2lvVEZQEJKjhRhjT_2aPRVREA/?qid=ba41c1ce0656e3c9722d41f837d01b94) between Thomas Corte and I seemed to indicate that option #2 would meet the needs; although Thomas could weigh in on whether he agrees.  To meet option #2, the first sentence of section 5.1.1 would read:

                                                               i.      “This extension defines a new command called the Fee Check Command that defines additional elements for the EPP <check> command to provide fee information along with the availability information of the EPP <check> command.”

1.       Separating the fee check command as a sibling and not a child of the availability check, removes extending a fee check command automatically by availability check extensions, which allows us to include the needed fee check features without running the risk of creating a “do everything” check command down the line.

b.       Add a short description for the <fee:period> command child element with a link to section 3.3 “Validity Periods”

c.       I recommend describing the <fee:fee>, <fee:credit>, <fee:class>, and <fee:reason> response elements either directly with the element or via a reference to somewhere else within the draft.

d.       You need to support the “lang” attribute for the <fee:reason> to be consistent with the other EPP RFCs.  Maybe it would be best to describe the <fee:reason> as a subsection of section 3 “Extension Elements” with a description of support for the “lang” attribute, and then reference that section when including the <fee:reason> in other places of the draft.

4.       Section 5.2.2 “EPP <delete> Command”, section 5.2.3 “EPP <renew> Command”, section 5.2.4 “EPP <transfer> Command”, and section 5.2.5 “EPP <update> Command”

a.       I would add a short description with appropriate references to other sections with a full description for each of the command and response child elements.

The only change that would require an XSD change is adding support for the “lang” attribute in the <fee:reason> element.

—

JG

James Gould

Distinguished Engineer

[email-masked]

703-948-3271

12061 Bluemont Way

Reston, VA 20190

VerisignInc.com <http://verisigninc.com/>

On 6/5/17, 3:04 PM, "regext on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    A New Internet-Draft is available from the on-line Internet-Drafts directories.

    This draft is a work item of the Registration Protocols Extensions of the IETF.

            Title           : Registry Fee Extension for the Extensible Provisioning Protocol (EPP)

            Authors         : Roger Carney

                              Gavin Brown

                              Jothan Frakes

                Filename        : draft-ietf-regext-epp-fees-04.txt

                Pages           : 34

                Date            : 2017-06-05

    Abstract:

       This document describes an Extensible Provisioning Protocol (EPP)

       extension mapping for registry fees.

    The IETF datatracker status page for this draft is:

    https://datatracker.ietf.org/doc/draft-ietf-regext-epp-fees/

    There are also htmlized versions available at:

    https://tools.ietf.org/html/draft-ietf-regext-epp-fees-04

    https://datatracker.ietf.org/doc/html/draft-ietf-regext-epp-fees-04

    A diff from the previous version is available at:

    https://www.ietf.org/rfcdiff?url2=draft-ietf-regext-epp-fees-04

    Please note that it may take a couple of minutes from the time of submission

    until the htmlized version and diff are available at tools.ietf.org.

    Internet-Drafts are also available by anonymous FTP at:

    ftp://ftp.ietf.org/internet-drafts/

    _______________________________________________

    regext mailing list

    [email-masked]

    https://www.ietf.org/mailman/listinfo/regext

---

From: Roger D Carney <[email-masked]>
Date: Tue, 6 Jun 2017 20:57:46 +0000

Good Afternoon,

Thanks for the review James, very much appreciated. I will look to incorporate these as much as I can into the next revision (maybe the last revision J).

Thanks
Roger

From: regext [mailto:[email-masked]] On Behalf Of Gould, James
Sent: Tuesday, June 06, 2017 1:27 PM
To: [email-masked]
Subject: Re: [regext] I-D Action: draft-ietf-regext-epp-fees-04.txt

Roger,

3.       Section 5.1.1

—

JG

James Gould

Distinguished Engineer

[email-masked]<mailto:[email-masked]>

703-948-3271

12061 Bluemont Way

Reston, VA 20190

On 6/5/17, 3:04 PM, "regext on behalf of [email-masked]<mailto:[email-masked]>" <[email-masked] on behalf of [email-masked]<mailto:[email-masked][email-masked]>> wrote:

            Authors         : Roger Carney

                              Gavin Brown

                              Jothan Frakes

                Pages           : 34

                Date            : 2017-06-05

    Abstract:

    regext mailing list

    [email-masked]<mailto:[email-masked]>

---

From: Thomas Corte <[email-masked]>
Date: Wed, 7 Jun 2017 10:03:43 +0200

Hello,

On 06/06/2017 20:27, Gould, James wrote:

> ...
> a.       Revise the description of the <check> extension to define a new
> Fee Check Command, as defined in option #2 in the regext list
> (https://mailarchive.ietf.org/arch/msg/regext/2nZMuj9miTaEefyxeIgDnLKe9Rs/?qid=816ff935b150313c729350d5711051b1)
> message.  The last message on the thread message
> (https://mailarchive.ietf.org/arch/msg/regext/PV2lvVEZQEJKjhRhjT_2aPRVREA/?qid=ba41c1ce0656e3c9722d41f837d01b94)
> between Thomas Corte and I seemed to indicate that option #2 would meet
> the needs; although Thomas could weigh in on whether he agrees.

Yes, this was the option we agreed upon.

Best regards,

Thomas

-- 
____________________________________________________________________
     |       |
     | knipp |            Knipp  Medien und Kommunikation GmbH
      -------                    Technologiepark
                                 Martin-Schmeißer-Weg 9
                                 44227 Dortmund
                                 Deutschland

     Dipl.-Informatiker          Tel:    +49 231 9703-0
     Thomas Corte                Fax:    +49 231 9703-200
     Stellvertretender Leiter    SIP:    [email-masked]
     Software-Entwicklung        E-Mail: [email-masked]

                                 Registereintrag:
                                 Amtsgericht Dortmund, HRB 13728

                                 Geschäftsführer:
                                 Dietmar Knipp, Elmar Knipp