Subject: [regext] I-D Action: draft-ietf-regext-org-ext-07.txt

From: [email-masked]
Date: Thu, 14 Jun 2018 17:47:25 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Registration Protocols Extensions WG of the IETF.

        Title           : Organization Extension for the Extensible Provisioning Protocol (EPP)
        Authors         : Linlin Zhou
                          Ning Kong
                          Junkai Wei
                          Xiaodong Lee
                          James Gould
	Filename        : draft-ietf-regext-org-ext-07.txt
	Pages           : 24
	Date            : 2018-06-14

Abstract:
   This document describes an extension to EPP object mappings, which is
   designed to support assigning an organization to any existing object
   (domain, host, contact) as well as any future objects.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-regext-org-ext/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-regext-org-ext-07
https://datatracker.ietf.org/doc/html/draft-ietf-regext-org-ext-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-regext-org-ext-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Pieter Vandepitte <[email-masked]>
Date: Fri, 15 Jun 2018 12:31:42 +0000

Hi Linlin,

Thanks for updating the draft. Small issue: in 4.3 you did not specify the status of an org object after returning the action pending responses. I would add something similar like RFC 5731:

   The status of the organization object after returning this response MUST
   include "pendingCreate".  The server operator reviews the request
   offline, and informs the client of the outcome of the review either
   by queuing a service message for retrieval via the <poll> command or
   by using an out-of-band mechanism to inform the client of the
   request.

Kind regards

-- 
Pieter Vandepitte
Product Expert
+32 16 28 49 70
www.dnsbelgium.be <http://www.dnsbelgium.be>

On 15/06/18 02:48, "regext on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    
    Abstract:

    

    
    _______________________________________________
    regext mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/regext

---

From: "Linlin Zhou" <[email-masked]>
Date: Thu, 21 Jun 2018 10:40:13 +0800

Hi Pieter,
Thanks for your comments. I'll update it accordingly.

[email-masked]
 
From: Pieter Vandepitte
Date: 2018-06-15 20:31
To: [email-masked]
Subject: Re: [regext] I-D Action: draft-ietf-regext-org-ext-07.txt
Hi Linlin,

Kind regards

    
    
    Abstract: