Subject: Re: [regext] Proposed Revision to our Charter

From: "Gould, James" <[email-masked]>
Date: Wed, 13 Jun 2018 16:03:23 +0000

Broadening the charter beyond EPP and RDAP would enable the WG to take on the file format drafts that relate to the domain industry and should involve the same REGEXT participants, which include:

  1.  Data Escrow
     *   Registry Data Escrow Specifications - draft-arias-noguchi-registry-data-escrow
     *   Domain Name Registration Data (DNRD) Objects Mapping - draft-arias-noguchi-dnrd-objects-mapping
  2.  Bulk Data
     *   Data Set File Format - draft-gould-regext-dataset

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com<http://verisigninc.com/>

From: regext <[email-masked]> on behalf of Roger Carney <[email-masked]>
Date: Wednesday, June 13, 2018 at 11:53 AM
To: Registration Protocols Extensions <[email-masked]>
Subject: [EXTERNAL] Re: [regext] Proposed Revision to our Charter

Good Morning,

I was definitely not thinking of two working groups.

The focus of the WG is EPP and RDAP extensions. The additional suggested wording just adds on the ability to take on relevant (as determined by WG and AD) work (e.g. Third Party DNS Operator…). My suggestion was not to exclude, but to provide more focused wording. Maybe that wording is better, change the entire sentence to state: “The working group may also take on relevant (as determined by WG and AD) work, beyond the EPP and RDAP protocols.”

Andy, I think your original question that you posted earlier in the week is what needs to be answered first, paraphrasing “what is the motivation for this change”. Several others I think have basically asked the same question.

I don’t think I was the one asking for the charter change but here are my thoughts on why I see a change being beneficial.

To me this started with the proposed Third Party DNS Operator document. At one point the Charter was updated to add in this specific item (our current Charter). Then over the past year some discussions were had on standardizing the files that registries and registrars share (Unavailable Names, Non-Standard/Premium Domain Fees, Invoicing) which lead into the discussion of standardizing the storage of these files and other items (reporting comes to mind). Today different registries have different web portals and ftp sites to get this information from and different registrars request the information in different formats. Many registries and registrars have agreed that they would like to see a much better experience here. These topics do not fit into the EPP/RDAP focus of our current charter but the people with the most interest and expertise in these ideas are in this WG.

Thanks

Roger

-----Original Message-----
From: Andrew Newton [mailto:[email-masked]]
Sent: Wednesday, June 13, 2018 9:45 AM
To: Roger D Carney <[email-masked]>
Cc: Registration Protocols Extensions <[email-masked]>
Subject: Re: [regext] Proposed Revision to our Charter

On Wed, Jun 13, 2018 at 10:35 AM, Roger D Carney <[email-masked]<mailto:[email-masked]>> wrote:

> Good Morning,

> I agree with those saying this new wording seems a bit broad, what if

> "...related to the operation of Internet identifier registries..." was

> changed to "...related to the operation of Internet domain name

> registration systems..."?

What about RIRs? Or would you suggest we split REGEXT into two working groups?

-andy

---

From: "James Galvin" <[email-masked]>
Date: Fri, 15 Jun 2018 10:14:08 -0400

Thanks James for the proposed list of documents to add some context 
around why the charter revision is being proposed.

The chairs are understanding that the major concern is the revision is 
too broad.  The final sentence, shown here for your convenience, seems 
to be the issue:

The working group may also, in consultation with its responsible area
director, take on work related to the operation of Internet identifier
registries, beyond the EPP and RDAP protocols.

The chairs and the Area Director agree with all the concerns stated.  
This is why the phrase “in consultation with its responsible area 
director” was included in the sentence above.

We are interested in other suggestions for how to modify this sentence 
to better scope our work.

The intent is to only pursue work related to the operation of Internet 
identifier registries that use the EPP and RDAP protocols.  If there is 
a better way to express this, please to help us by proposing it.

If you think that saying EPP and RDAP is itself too broad, how would you 
propose we express the work we want to do?

James’ list below is just the current list of possible work items.  
They are representative of the kind of scope we are looking to achieve.

Any help you can offer would be most appreciated.

Thanks,

Jim

On 13 Jun 2018, at 12:03, Gould, James wrote:

> Broadening the charter beyond EPP and RDAP would enable the WG to take 
> on the file format drafts that relate to the domain industry and 
> should involve the same REGEXT participants, which include:
>
>
>   1.  Data Escrow
> The focus of the WG is EPP and RDAP extensions. The additional 
> suggested wording just adds on the ability to take on relevant (as 
> determined by WG and AD) work (e.g. Third Party DNS Operator…). My 
> suggestion was not to exclude, but to provide more focused wording. 
> Maybe that wording is better, change the entire sentence to state: 
> “The working group may also take on relevant (as determined by WG 
> and AD) work, beyond the EPP and RDAP protocols.”
>
>
>
> Andy, I think your original question that you posted earlier in the 
> week is what needs to be answered first, paraphrasing “what is the 
> motivation for this change”. Several others I think have basically 
> asked the same question.
>
>
>
> I don’t think I was the one asking for the charter change but here 
> are my thoughts on why I see a change being beneficial.
>
>
>
> To me this started with the proposed Third Party DNS Operator 
> document. At one point the Charter was updated to add in this specific 
> item (our current Charter). Then over the past year some discussions 
> were had on standardizing the files that registries and registrars 
> share (Unavailable Names, Non-Standard/Premium Domain Fees, Invoicing) 
> which lead into the discussion of standardizing the storage of these 
> files and other items (reporting comes to mind). Today different 
> registries have different web portals and ftp sites to get this 
> information from and different registrars request the information in 
> different formats. Many registries and registrars have agreed that 
> they would like to see a much better experience here. These topics do 
> not fit into the EPP/RDAP focus of our current charter but the people 
> with the most interest and expertise in these ideas are in this WG.
>
>
>
>
>
> Thanks
>
> Roger
>
>
>
>
>
> On Wed, Jun 13, 2018 at 10:35 AM, Roger D Carney 
> <[email-masked]<mailto:[email-masked]>> wrote:
>
>> Good Morning,
>
>>
>
>>
>
>>
>

> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext

---

From: "James Galvin" <[email-masked]>
Date: Fri, 22 Jun 2018 09:29:39 -0400

There has not been any discussion regarding additional changes to our 
charter.  As a result the chairs are going to interpret silence as 
suggesting that folks are okay with the proposed revision.

In a separate thread we will start a 1 week working group last call on 
the revised charter.  We need to allow a few weeks for our Area Director 
to review the proposed charter with the IESG and hopefully get it 
approved so we can move on with new work at the next IETF meeting in 
Montreal.

Thanks,

Antoin and Jim

On 15 Jun 2018, at 10:14, James Galvin wrote:

> identifier registries that use the EPP and RDAP protocols.  If there 
> is a better way to express this, please to help us by proposing it.
>
> If you think that saying EPP and RDAP is itself too broad, how would 
> you propose we express the work we want to do?
>
>> Broadening the charter beyond EPP and RDAP would enable the WG to 
>> take on the file format drafts that relate to the domain industry and 
>> document. At one point the Charter was updated to add in this 
>> specific item (our current Charter). Then over the past year some 
>> discussions were had on standardizing the files that registries and 
>> registrars share (Unavailable Names, Non-Standard/Premium Domain 
>> Fees, Invoicing) which lead into the discussion of standardizing the 
>> storage of these files and other items (reporting comes to mind). 
>> Today different registries have different web portals and ftp sites 
>> to get this information from and different registrars request the 
>> information in different formats. Many registries and registrars have 
>> agreed that they would like to see a much better experience here. 
>> These topics do not fit into the EPP/RDAP focus of our current 
>> charter but the people with the most interest and expertise in these 
>> ideas are in this WG.
>>
>>
>>
>>
>>
>> Thanks
>>
>> Roger
>>
>>
>>
>>
>>