Subject: [regext] WGLC: draft-ietf-regext-bundling-registration-03

From: "James Galvin" <[email-masked]>
Date: Fri, 08 Jun 2018 09:32:33 -0400

The document editors have indicated that the following document is ready 
for submission to the IESG to be considered for publication as an 
Informational Document:

Extensible Provisioning Protocol (EPP) Domain Name Mapping Extension for 
Strict Bundling Registration
https://datatracker.ietf.org/doc/draft-ietf-regext-bundling-registration/

Please indicate your support or no objection for the publication of this 
document.

If any working group member objects to the publication of this document 
please respond on the list by close of business everywhere, Friday, 22 
June 2018.  If there are no objections the document will be submitted to 
the IESG.

Please note, this document has potential IPR associated with it.  Please 
see the following link for details:

https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-regext-bundling-registration

As we have done in the past, when IPR is present it is essential for the 
working group members to indicate that they do not object to the 
publication of this document.  We do need to record that the IPR has 
been considered by the working group.

During the last call the chairs are looking for a document shepherd for 
this document.  If you are interested in being the document shepherd 
please let the chairs know.  The document editors cannot be the document 
shepherd.

If you’ve never been a document shepherd before don’t worry.  It’s 
a great way to understand the IETF process and your chairs would be 
delighted to help you through it.

Thanks,

Antoin and Jim
WG Co-Chairs

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 15 Jun 2018 13:17:05 +0000

> -----Original Message-----
> From: regext <[email-masked]> On Behalf Of James Galvin
> Sent: Friday, June 08, 2018 9:33 AM
> To: Registration Protocols Extensions <[email-masked]>
> Subject: [EXTERNAL] [regext] WGLC: draft-ietf-regext-bundling-
> registration-03
>
> Strict Bundling Registration https://datatracker.ietf.org/doc/draft-ietf-
> regext-bundling-registration/
>

I support publication as long there are still operators willing to implement and use this extension. I have not attempted to validate the schema or examples (more on that below), but I do have a few comments on the document itself. In no particular order:

Several of the transform command descriptions say that they do not add any elements to the structures described in RFC 5731, but they do on to say "When the command has been processed successfully, the EPP <resData> element MUST contain child elements as described in the EPP domain mapping [RFC5731].  This EPP <extension> element SHOULD contain the <b-dn:upData> which contains <b-dn:bundle> element". It would be good to include examples of these modified response elements.

Security Considerations: the document says (in so many words) that there's nothing here beyond the basic EPP considerations. I don't think I agree with that. For example, isn't there a risk of unintended consequences if transferring, modifying, or deleting one name affects an entire bundle of names? It might be a good idea to say something in this section to note that the client SHOULD know that a transform command can affect multiple domain names and not just the one passed as a command argument.

Schema and examples: have these been confirmed to work?

Scott

---

From: "James Galvin" <[email-masked]>
Date: Fri, 15 Jun 2018 09:32:46 -0400

Reminder, there is one more week remaining in the working group last 
call for this document.

As indicated below, please do respond and indicate your support or no 
objection to publication.  This is important for this document because 
it has potential IPR associated with it.  Silence cannot be used as an 
indicate of support for publication.

Antoin and Jim

On 8 Jun 2018, at 9:32, James Galvin wrote:

> The document editors have indicated that the following document is 
> ready for submission to the IESG to be considered for publication as 
> an Informational Document:
>
> Extensible Provisioning Protocol (EPP) Domain Name Mapping Extension 
> for Strict Bundling Registration
> Please indicate your support or no objection for the publication of 
> this document.
>
> If any working group member objects to the publication of this 
> document please respond on the list by close of business everywhere, 
> Friday, 22 June 2018.  If there are no objections the document will be 
> submitted to the IESG.
>
> Please note, this document has potential IPR associated with it.  
> Please see the following link for details:
>
> As we have done in the past, when IPR is present it is essential for 
> the working group members to indicate that they do not object to the 
> During the last call the chairs are looking for a document shepherd 
> for this document.  If you are interested in being the document 
> shepherd please let the chairs know.  The document editors cannot be 
> the document shepherd.
>
> If you’ve never been a document shepherd before don’t worry.  
> It’s a great way to understand the IETF process and your chairs 
> would be delighted to help you through it.
>
> Thanks,
>
> Antoin and Jim
> WG Co-Chairs