Subject: [regext] Proposed Revision to our Charter

From: "James Galvin" <[email-masked]>
Date: Fri, 08 Jun 2018 09:51:48 -0400

As we have discussed in at least the last two IETF meetings, we would 
like to propose broadening the responsibility of this working group to 
cover the standards related generally to Internet Identifier systems.

Attached you will find a proposed revision to our charter that would 
allow this.

Please review and provide any comments or concerns to the mailing list.

There is a PDF that shows the changes to the charter and a text file of 
the proposed new charter with the changes already incorporated.

Thanks,

Antoin and Jim

---

From: Patrick Mevzek <[email-masked]>
Date: Sat, 09 Jun 2018 07:57:20 +0200

> cover the standards related generally to Internet Identifier systems.

I am sorry not to have been able to participate in the last two meetings, but I also find no discussion on the mailing-list about this, so can you provide more context?

Specifically because regarding the minutes of IETF 101 and 100 I see nothing about this in 101 and in 100 only:
"Discussion about broadening the charter to adopt other
"registration-related" documents, once the document "plate" is clean.
Before london, several documents should be off our WG, and we can
adopt more documents."

from one individual.

I feel missing quite a lot of pieces of the puzzle.

New work may be interesting, but one has to question first if this is really related to what we are already doing (what is the overlap?) and then if the group has enough resources to tackle more work when:
- we are late in our milestones, and not by little (almost one year for the fee extension, more than 6 months for the organization one, etc.0
- it is difficult to find shepherds for write-ups (I can testify :-))
- there are not so many individuals commenting/reviewing each draft on the list, so consensus is already quite hard to achieve.

> Please review and provide any comments or concerns to the mailing list.

My concern is that there is only a short sentence added to the current charter that does not give a lot of details about what we are speaking about here, especially since EPP and RDAP are detailed before in many sentences.

So, in short, I am uneasy to say anything because I lack both context and substance about what we are talking about.
Some examples of relevant work could also be useful.

-- 
  Patrick Mevzek

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 11 Jun 2018 11:14:24 +0000

> -----Original Message-----
> From: regext <[email-masked]> On Behalf Of Patrick Mevzek
> Sent: Saturday, June 09, 2018 1:57 AM
> To: [email-masked]
> Subject: [EXTERNAL] Re: [regext] Proposed Revision to our Charter
>
> I am sorry not to have been able to participate in the last two meetings,
> but I also find no discussion on the mailing-list about this, so can you
> provide more context?
>
> Specifically because regarding the minutes of IETF 101 and 100 I see
> nothing about this in 101 and in 100 only:
> "Discussion about broadening the charter to adopt other "registration-
> related" documents, once the document "plate" is clean.
> Before london, several documents should be off our WG, and we can adopt
> more documents."
>
> from one individual.
>
> New work may be interesting, but one has to question first if this is
> really related to what we are already doing (what is the overlap?) and
> then if the group has enough resources to tackle more work when:
> - we are late in our milestones, and not by little (almost one year for
> the fee extension, more than 6 months for the organization one, etc.0
> - there are not so many individuals commenting/reviewing each draft on the
> list, so consensus is already quite hard to achieve.
>
> My concern is that there is only a short sentence added to the current
> charter that does not give a lot of details about what we are speaking
> about here, especially since EPP and RDAP are detailed before in many
> sentences.
>
> So, in short, I am uneasy to say anything because I lack both context and
> substance about what we are talking about.

I tend to agree. This WG hasn't exactly been a paragon of broad engagement, so I'm a little concerned about expanding our scope into unidentified identifier registries without a better understanding of what that means.

Scott

---

From: Andrew Newton <[email-masked]>
Date: Mon, 11 Jun 2018 14:13:14 -0400

> I tend to agree. This WG hasn't exactly been a paragon of broad engagement, so I'm a little concerned about expanding our scope into unidentified identifier registries without a better understandin…

+1

Also, anything related to "Internet Identifier registries" is very
broad. Will we be taking on ENUM or URN work? The IANA runs several
internet identifier registries. Is their work now part?

I'm curious, what is the motivation to do this?

-andy

---

From: Roger D Carney <[email-masked]>
Date: Wed, 13 Jun 2018 14:35:35 +0000

Good Morning,

I agree with those saying this new wording seems a bit broad, what if "...related to the operation of Internet identifier registries..." was changed to "...related to the operation of Internet domain name registration systems..."?

Thanks

Roger

-----Original Message-----
From: regext [mailto:[email-masked]] On Behalf Of James Galvin
Sent: Friday, June 08, 2018 8:52 AM
To: Registration Protocols Extensions <[email-masked]>
Subject: [regext] Proposed Revision to our Charter

As we have discussed in at least the last two IETF meetings, we would like to propose broadening the responsibility of this working group to cover the standards related generally to Internet Identifier systems.

Attached you will find a proposed revision to our charter that would allow this.

There is a PDF that shows the changes to the charter and a text file of the proposed new charter with the changes already incorporated.

Thanks,

Antoin and Jim

---

From: Andrew Newton <[email-masked]>
Date: Wed, 13 Jun 2018 10:44:57 -0400

On Wed, Jun 13, 2018 at 10:35 AM, Roger D Carney <[email-masked]> wrote:
> Good Morning,
>
>
>
> I agree with those saying this new wording seems a bit broad, what if
> "...related to the operation of Internet identifier registries..." was
> changed to "...related to the operation of Internet domain name registration
> systems..."?

What about RIRs? Or would you suggest we split REGEXT into two working groups?

-andy

---

From: Roger D Carney <[email-masked]>
Date: Wed, 13 Jun 2018 15:52:58 +0000

Good Morning,

I was definitely not thinking of two working groups.

The focus of the WG is EPP and RDAP extensions. The additional suggested wording just adds on the ability to take on relevant (as determined by WG and AD) work (e.g. Third Party DNS Operator…). My suggestion was not to exclude, but to provide more focused wording. Maybe that wording is better, change the entire sentence to state: “The working group may also take on relevant (as determined by WG and AD) work, beyond the EPP and RDAP protocols.”

Andy, I think your original question that you posted earlier in the week is what needs to be answered first, paraphrasing “what is the motivation for this change”. Several others I think have basically asked the same question.

I don’t think I was the one asking for the charter change but here are my thoughts on why I see a change being beneficial.

To me this started with the proposed Third Party DNS Operator document. At one point the Charter was updated to add in this specific item (our current Charter). Then over the past year some discussions were had on standardizing the files that registries and registrars share (Unavailable Names, Non-Standard/Premium Domain Fees, Invoicing) which lead into the discussion of standardizing the storage of these files and other items (reporting comes to mind). Today different registries have different web portals and ftp sites to get this information from and different registrars request the information in different formats. Many registries and registrars have agreed that they would like to see a much better experience here. These topics do not fit into the EPP/RDAP focus of our current charter but the people with the most interest and expertise in these ideas are in this WG.

Thanks

Roger

-----Original Message-----
From: Andrew Newton [mailto:[email-masked]]
Sent: Wednesday, June 13, 2018 9:45 AM
To: Roger D Carney <[email-masked]>
Cc: Registration Protocols Extensions <[email-masked]>
Subject: Re: [regext] Proposed Revision to our Charter

> changed to "...related to the operation of Internet domain name

> registration systems..."?

-andy

---

From: Andrew Newton <[email-masked]>
Date: Wed, 13 Jun 2018 17:39:45 -0400

Thanks for the clarification, Roger.

The file formats seem like appropriate work to me. That said, the
wording of the proposed charter seemed to indicate to me there was a
broader motivation. If there is such, it be best if it were stated.

-andy

On Wed, Jun 13, 2018 at 11:52 AM, Roger D Carney <[email-masked]> wrote:
> The focus of the WG is EPP and RDAP extensions. The additional suggested
> wording just adds on the ability to take on relevant (as determined by WG
> and AD) work (e.g. Third Party DNS Operator…). My suggestion was not to
> exclude, but to provide more focused wording. Maybe that wording is better,
> change the entire sentence to state: “The working group may also take on
> relevant (as determined by WG and AD) work, beyond the EPP and RDAP
> protocols.”
>
>
>
> Andy, I think your original question that you posted earlier in the week is
> what needs to be answered first, paraphrasing “what is the motivation for
> this change”. Several others I think have basically asked the same question.
>
>
>
> I don’t think I was the one asking for the charter change but here are my
> thoughts on why I see a change being beneficial.
>
>
>
> To me this started with the proposed Third Party DNS Operator document. At
> one point the Charter was updated to add in this specific item (our current
> Charter). Then over the past year some discussions were had on standardizing
> the files that registries and registrars share (Unavailable Names,
> Non-Standard/Premium Domain Fees, Invoicing) which lead into the discussion
> of standardizing the storage of these files and other items (reporting comes
> to mind). Today different registries have different web portals and ftp
> sites to get this information from and different registrars request the
> information in different formats. Many registries and registrars have agreed
> that they would like to see a much better experience here. These topics do
> not fit into the EPP/RDAP focus of our current charter but the people with
> the most interest and expertise in these ideas are in this WG.
>
>
>
>
>
> Thanks
>
> Roger
>
>
>
>
>
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext
>

---

From: Antoin Verschuren <[email-masked]>
Date: Fri, 15 Jun 2018 14:05:55 +0200

Ok, perhaps some clarification.

The broadening of the charter is not to broaden the scope of EPP or RDAP.
Both EPP and RDAP have always been protocols to serve any "internet infrastructure identifier registry”, be it TLD’s RIR’s, ENUM registries, 2nd/3th/4th/.. level domain registries, so currently basically domains or IP’s or anything that does something DNS, but we have never limited the protocols to be used by any other registry that could arise and saw it fit to use it for their provisioning.
We have chosen this term to avoid this working group to only think of policy limited gTLD’s as the only usage for EPP and RDAP, which is not true. ccTLD’s, sTLD’s, RIR’s and ENUM registries also use EPP and/or RDAP.

The only change to the charter is that we previously had only one permitted extra work item of the dns-operators draft beyond EPP and RDAP protocol work, because we had a long milestone list that our AD wanted us to do first before we took on new work items. Now that our milestone list shortens, we have more time to take on this additional work, but as the charter proposal says, it should be limited to work related to the provisioning of "internet infrastructure identifier registries” that use EPP or RDAP, and the extra limitation is our AD needs to approve the topic as being in scope.

I hope this helps, and if you have a better suggestion for scoping or wording, we’ll be happy to hear.
We have put this proposed charter out here for formal discusion on the mailinglist and we will also have an item on our agenda in Montreal to discuss.

- --
Antoin Verschuren

Tweevoren 6, 5672 SB Nuenen, NL
M: +31 6 37682392