Subject: Re: [regext] WGLC redux: REGEXT working group charter

From: Alexander Mayrhofer <[email-masked]>
Date: Mon, 3 Sep 2018 17:31:29 +0200

Hello everyone,

tl;dr - i do agree with all what Patrick said - more inline

On Fri, Aug 31, 2018 at 10:46 PM Patrick Mevzek <[email-masked]> wrote:
> And I still think it is too broad, especially "Data formats for files"
> (which files? what data? why the format needs a specification and a working group?).
> "Registry mapping" and "Registry transition" will probably seem obscure to anyone
> outside of the working group. I am myself not even sure what it covers or not.

I do agree to these points. For a charter, i think the functional area
would be required, and if there wasn't a draft names "registry
mapping", i wouldn't know what it meant (quite blunt: would this
covering the creation of a geographic map of all EPP/RDAP accessible
registries? ;)

Some (hopefully more productive) thoughts:

"Data format for files" -> Data format, yes, but only in the scope of
EPP/RDAP registries and between the involved parties. Limited to
frequent cases of such data exchange.

"Registry mapping" -> Representation of configuration options for
EPP/RDAP registries.

"Registry transition" -> not sure what we should standardize here... a
process? Data beyond escrow?

I understand the intention behind all these, but it seems to me those
reflect milestones rather than an abstract charter strategy.

best,
Alex

---

From: Antoin Verschuren <[email-masked]>
Date: Fri, 7 Sep 2018 16:20:02 +0200

Alex,Patrick,

Thank you for your comments. You made some good suggestions.
I agree the scope of the bulletpoints are not that clear and not scoped narrow enough for people not in this working group and not knowing which documents we discussed.
How about changing the last paragraph with bulletpoints to this:

---
The working group may also take on work to develop specifications that
describe the following types of information exchanged between entities
involved in Internet identifier registration that are using the RDAP or
EPP protocols:

*Uniform representation formats for publishing local policy or
 configuration options regarding EPP and RDAP use.
*Data formats for files exchanged between registration entities that
 need insertion in or extraction from EPP or RDAP.
*Technical guidance for registration processes that are supported by
 EPP or RDAP.
—

To explain out thinking:
The “registry mapping” and similar documents will fall under bulletpoint 1
The draft-gould-regext-dataset and similar documents will fall under bulletpoint 2
The “dnsoperator-to-rrr-protocol” and similar documents will fall under bulletpoint 3

If you agree to this text, than we will change that in the version we resend to the IESG for reconsideration.

- --
Antoin Verschuren

Tweevoren 6, 5672 SB Nuenen, NL
M: +31 6 37682392

> Op 3 sep. 2018, om 17:31 heeft Alexander Mayrhofer <[email-masked]> het volgende geschreven:
> 
> Hello everyone,
> 
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext

---

From: Jody Kolker <[email-masked]>
Date: Fri, 14 Sep 2018 15:14:35 +0000

Since EPP and RDAP is included in this paragraph:

<<
EPP protocols:

Can this paragraph be updated to:
<<
*Uniform representation formats for publishing local policy or
 configuration options between registration entities.
*Data formats for files exchanged between registration entities.
*Technical guidance for registration processes between registration entities.

The reason for changing the 2nd bullet “*Data formats for files exchanged between registration entities that
 need insertion in or extraction from EPP or RDAP.”  Is that the data reports are not downloaded via EPP or RDAP.

Thanks,
Jody Kolker

From: regext <[email-masked]> On Behalf Of Antoin Verschuren
Sent: Friday, September 7, 2018 9:20 AM
To: Registration Protocols Extensions <[email-masked]>
Subject: Re: [regext] WGLC redux: REGEXT working group charter

Alex,Patrick,

---

To explain out thinking:

- --
Antoin Verschuren

Op 3 sep. 2018, om 17:31 heeft Alexander Mayrhofer <[email-masked]<mailto:[email-masked]>> het volgende geschreven:

Hello everyone,

On Fri, Aug 31, 2018 at 10:46 PM Patrick Mevzek <[email-masked]<mailto:[email-masked]>> wrote:

best,
Alex

_______________________________________________
regext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/regext

---

From: Antoin Verschuren <[email-masked]>
Date: Fri, 14 Sep 2018 19:56:14 +0200

>  need insertion in or extraction from EPP or RDAP.”  Is that the data reports are not downloaded via EPP or RDAP.

But the data is extracted from the database that is filled by EPP right? So it’s “EPP data”.
True, you’ll need some imagination, and I also don’t know how to phrase that better right now, but I think that we want to prevent that  f.e. invoice formats, advertising text, contracts or any other god knows what non protocol paper work between registries/registrars/registrants will be in scope as long as the entity uses some system that runs EPP or RDAP. Do you agree that that may be in scope by the text that you propose and that that would be undesirable?

- --
Antoin Verschuren