Subject: Re: [regext] WGLC redux: REGEXT working group charter

From: "Gould, James" <[email-masked]>
Date: Fri, 14 Sep 2018 15:57:18 +0000

Related to bullet #2, I’m hoping that it addresses file formats such as:

  1.  Data Escrow File Format (draft-arias-noguchi-registry-data-escrow and draft-arias-noguchi-dnrd-objects-mapping)
     *   This format is associated with data escrow deposits from registration entities (registry, registrar, privacy and proxy services) to data escrow providers.  Can a data escrow provider be considered a registration entity?
  2.  Data Set File Format (draft-gould-regext-dataset)
     *   This format is primarily meant to be between registrar and registry; although a 3rd party can generate a signed data set.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com<http://verisigninc.com/>

From: regext <[email-masked]> on behalf of Jody Kolker <[email-masked]>
Date: Friday, September 14, 2018 at 11:15 AM
To: Antoin Verschuren <[email-masked]>, Registration Protocols Extensions <[email-masked]>
Subject: [EXTERNAL] Re: [regext] WGLC redux: REGEXT working group charter

Since EPP and RDAP is included in this paragraph:

<<
The working group may also take on work to develop specifications that
describe the following types of information exchanged between entities
involved in Internet identifier registration that are using the RDAP or
EPP protocols:

Can this paragraph be updated to:
<<
*Uniform representation formats for publishing local policy or
 configuration options between registration entities.
*Data formats for files exchanged between registration entities.
*Technical guidance for registration processes between registration entities.

The reason for changing the 2nd bullet “*Data formats for files exchanged between registration entities that
 need insertion in or extraction from EPP or RDAP.”  Is that the data reports are not downloaded via EPP or RDAP.

Thanks,
Jody Kolker

From: regext <[email-masked]> On Behalf Of Antoin Verschuren
Sent: Friday, September 7, 2018 9:20 AM
To: Registration Protocols Extensions <[email-masked]>
Subject: Re: [regext] WGLC redux: REGEXT working group charter

Alex,Patrick,

Thank you for your comments. You made some good suggestions.
I agree the scope of the bulletpoints are not that clear and not scoped narrow enough for people not in this working group and not knowing which documents we discussed.
How about changing the last paragraph with bulletpoints to this:

---
The working group may also take on work to develop specifications that
describe the following types of information exchanged between entities
involved in Internet identifier registration that are using the RDAP or
EPP protocols:

*Uniform representation formats for publishing local policy or
 configuration options regarding EPP and RDAP use.
*Data formats for files exchanged between registration entities that
 need insertion in or extraction from EPP or RDAP.
*Technical guidance for registration processes that are supported by
 EPP or RDAP.
—

To explain out thinking:
The “registry mapping” and similar documents will fall under bulletpoint 1
The draft-gould-regext-dataset and similar documents will fall under bulletpoint 2
The “dnsoperator-to-rrr-protocol” and similar documents will fall under bulletpoint 3

If you agree to this text, than we will change that in the version we resend to the IESG for reconsideration.

- --
Antoin Verschuren

Tweevoren 6, 5672 SB Nuenen, NL
M: +31 6 37682392

Op 3 sep. 2018, om 17:31 heeft Alexander Mayrhofer <[email-masked]<mailto:[email-masked]>> het volgende geschreven:

Hello everyone,

tl;dr - i do agree with all what Patrick said - more inline

On Fri, Aug 31, 2018 at 10:46 PM Patrick Mevzek <[email-masked]<mailto:[email-masked]>> wrote:

And I still think it is too broad, especially "Data formats for files"
(which files? what data? why the format needs a specification and a working group?).
"Registry mapping" and "Registry transition" will probably seem obscure to anyone
outside of the working group. I am myself not even sure what it covers or not.

I do agree to these points. For a charter, i think the functional area
would be required, and if there wasn't a draft names "registry
mapping", i wouldn't know what it meant (quite blunt: would this
covering the creation of a geographic map of all EPP/RDAP accessible
registries? ;)

Some (hopefully more productive) thoughts:

"Data format for files" -> Data format, yes, but only in the scope of
EPP/RDAP registries and between the involved parties. Limited to
frequent cases of such data exchange.

"Registry mapping" -> Representation of configuration options for
EPP/RDAP registries.

"Registry transition" -> not sure what we should standardize here... a
process? Data beyond escrow?

I understand the intention behind all these, but it seems to me those
reflect milestones rather than an abstract charter strategy.

best,
Alex

_______________________________________________
regext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/regext

---

From: Gustavo Lozano <[email-masked]>
Date: Sat, 15 Sep 2018 01:32:24 +0000

I think it does, but it would be great if the chairs could confirm.

Regards,

Gustavo

From: regext <[email-masked]> On Behalf Of Gould, James
Sent: Friday, September 14, 2018 08:57
To: [email-masked]; [email-masked]; [email-masked]
Subject: [Ext] Re: [regext] WGLC redux: REGEXT working group charter

a.       This format is associated with data escrow deposits from registration entities (registry, registrar, privacy and proxy services) to data escrow providers.  Can a data escrow provider be considered a registration entity?   

a.       This format is primarily meant to be between registrar and registry; although a 3rd party can generate a signed data set.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

 <http://verisigninc.com/> Verisign.com 

From: regext <[email-masked] <mailto:[email-masked]> > on behalf of Jody Kolker <[email-masked] <mailto:[email-masked]> >
Date: Friday, September 14, 2018 at 11:15 AM
To: Antoin Verschuren <[email-masked] <mailto:[email-masked]> >, Registration Protocols Extensions <[email-masked] <mailto:[email-masked]> >
Subject: [EXTERNAL] Re: [regext] WGLC redux: REGEXT working group charter

<< 

EPP protocols:

<< 

Thanks,

Jody Kolker

From: regext <[email-masked] <mailto:[email-masked]> > On Behalf Of Antoin Verschuren
Sent: Friday, September 7, 2018 9:20 AM
To: Registration Protocols Extensions <[email-masked] <mailto:[email-masked]> >
Subject: Re: [regext] WGLC redux: REGEXT working group charter

Alex,Patrick,

---

EPP protocols:

 EPP or RDAP.

—

To explain out thinking:

- -- 
Antoin Verschuren

 

Op 3 sep. 2018, om 17:31 heeft Alexander Mayrhofer <[email-masked] <mailto:[email-masked]> > het volgende geschreven:

Hello everyone,

On Fri, Aug 31, 2018 at 10:46 PM Patrick Mevzek <[email-masked] <mailto:[email-masked]> > wrote:

best,
Alex

_______________________________________________
regext mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/regext

---

From: Antoin Verschuren <[email-masked]>
Date: Fri, 21 Sep 2018 11:53:22 +0200

I personally think it does too. At least I wrote the text to include those documents in scope.
But since I’m not a native english speaker it would help to know if others read that text the same way too.
And confirm it’s not too broad in scope too.

- -- 
Antoin Verschuren

> Op 15 sep. 2018, om 03:32 heeft Gustavo Lozano <[email-masked]> het volgende geschreven:
> 
> From: regext <[email-masked] <mailto:[email-masked]>> On Behalf Of Gould, James
> To: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> Data Escrow File Format (draft-arias-noguchi-registry-data-escrow and draft-arias-noguchi-dnrd-objects-mapping) 
> Data Set File Format (draft-gould-regext-dataset) 
> [email-masked] <x-msg://1/[email-masked]>
> 
> 703-948-3271
> 12061 Bluemont Way
> Reston, VA 20190
> 
> Verisign.com <http://verisigninc.com/>
>  
> From: regext <[email-masked] <mailto:[email-masked]>> on behalf of Jody Kolker <[email-masked] <mailto:[email-masked]>>
> To: Antoin Verschuren <[email-masked] <mailto:[email-masked]>>, Registration Protocols Extensions <[email-masked] <mailto:[email-masked]>>
> From: regext <[email-masked] <mailto:[email-masked]>> On Behalf Of Antoin Verschuren
> To: Registration Protocols Extensions <[email-masked] <mailto:[email-masked]>>
> Op 3 sep. 2018, om 17:31 heeft Alexander Mayrhofer <[email-masked] <mailto:[email-masked]>> het volgende geschreven:
>  
> Hello everyone,
> 
> On Fri, Aug 31, 2018 at 10:46 PM Patrick Mevzek <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>
>  
> https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>