Subject: [regext] draft-ietf-regext-verificationcode Feedback by Gurshabad Grover at REGEXT Meeting

From: "Gould, James" <[email-masked]>
Date: Wed, 7 Nov 2018 06:00:09 +0000

There were 3 draft-ietf-regext-verificationcode items brought up by Gurshabad Grover that I captured from the REGEXT Meeting:

  1.  Clarifying that it’s up to server policy to define the server action taken when the verification code grace period expires
     *   I re-reviewed draft-ietf-regext-verificationcode, and it does not include any language related to the action taken by the server when the verification code grace period expires.  I believe this can be addressed by adding the following sentence in the Verification Profile section (section 2.2) of the draft:

                                                              i.      “…the grace period by which the verification code types MUST be set.  It is up to server policy what action to take if the verification code type is not set by the grace period.”

  1.  Ensure that the VSP does not modify the data verified after the verification code is generated
     *   I’m still not clear what the issue is here, since the role of the VSP is to perform the verification and to generate the verification code when the verification has been successfully completed.  The draft-ietf-regext-verificationcode does not define the interface used by the VSP and does not define the policies of how the verification is performed.
     *   Gurshabad, can you share your issue on the list to help clarify how the draft would address it?
  2.  Include a HRPC section in draft-ietf-regext-verificationcode
     *   This is being discussed actively on the list, but at present I believe that we can address the feedback without adding a new section to the document.  If the IESG changes the default structure of the document to add a new section, then it can certainly be added.

Let me know if I missed anything and share your feedback on the list for the items above.

Thanks,

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com<http://verisigninc.com/>

---

From: "James Galvin" <[email-masked]>
Date: Fri, 16 Nov 2018 10:18:36 -0500

One comment inline below.

On 7 Nov 2018, at 1:00, Gould, James wrote:

> There were 3 draft-ietf-regext-verificationcode items brought up by 
> Gurshabad Grover that I captured from the REGEXT Meeting:
>
>
>   1.  Clarifying that it’s up to server policy to define the server 
> action taken when the verification code grace period expires
>      *   I re-reviewed draft-ietf-regext-verificationcode, and it does 
> not include any language related to the action taken by the server 
> when the verification code grace period expires.  I believe this can 
> be addressed by adding the following sentence in the Verification 
> Profile section (section 2.2) of the draft:
>
>                                                               i.      
> “…the grace period by which the verification code types MUST be 
> set.  It is up to server policy what action to take if the 
> verification code type is not set by the grace period.”
>
>      *   I’m still not clear what the issue is here, since the role 
> of the VSP is to perform the verification and to generate the 
> verification code when the verification has been successfully 
> completed.  The draft-ietf-regext-verificationcode does not define the 
> interface used by the VSP and does not define the policies of how the 
> verification is performed.
>      *   This is being discussed actively on the list, but at present 
> I believe that we can address the feedback without adding a new 
> section to the document.  If the IESG changes the default structure of 
> the document to add a new section, then it can certainly be added.

The co-Chairs would like to remind the working group that if anyone 
believes there should be an HRPC section then the action is for that 
person to propose the text that would go in an HRPC section.  The 
working group will then consider that addition as it would the addition 
of any other contribution to the document.

Regardless, as JG suggests, he will address the feedback as appropriate 
throughout the document.

Thanks,

Antoin and Jim

> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext

---

From: Gurshabad Grover <[email-masked]>
Date: Sat, 17 Nov 2018 16:08:31 +0530

On 16/11/18 8:48 PM, James Galvin wrote:
> working group will then consider that addition as it would the
> addition of any other contribution to the document.
>
Thank you, Antoin and Jim. As one of the persons who believes there
should be an HRC section, I will propose some text on this list soon.

Gurshabad