Subject: [regext] draft-ietf-regext-epp-fees: add feature to inquire balance and credit limit?

From: "Thomas Corte (TANGO support)" <[email-masked]>
Date: Wed, 15 May 2019 16:47:47 +0200

Hello,

some of our registrars keep asking for a feature to simply inquire their
current account balance and credit limit via EPP.

As far as I can tell, even the latest fee extension draft
("draft-ietf-regext-epp-fees-16") only supports the retrieval of this
information in the response to a *transform* command, but not e.g. in a
check response.

This isn't ideal since the registrar should not be forced to send a
"dummy" sequence of billable commands (e.g., a domain create/delete or
transfer request/cancel sequence) only to get this information.
Also, even if the registrar would store the values from the most recent
"non-dummy" transform response, they could become obsolete quickly due to
intermittent automatic renewals, or account top-up deposits.

What's the opinion in this group regarding the addition of an inquiry
feature, e.g. by adding a flag to the <domain:check> command fee
extension, which could trigger the inclusion of the balance/limit in the
<domain:check> fee response extension?

Best regards,

Thomas Corte

-- 
TANGO REGISTRY SERVICES® is a product of:
Knipp Medien und Kommunikation GmbH
Technologiepark                             Phone: +49 231 9703-222
Martin-Schmeisser-Weg 9                       Fax: +49 231 9703-200
D-44227 Dortmund                       E-Mail: [email-masked]
Germany

---

From: "Matthias Pfeifer" <[email-masked]>
Date: Wed, 15 May 2019 17:15:31 +0200

Hello Thomas,
 
 We have technically a credits based backend with pre-payment (tldbox).
 But in fact we are doing post-payment with our Registrars by managing huge
 volumes of credits for each of them. So in our case this wouldn’t make sense
 - at least it could lead to confusion.
 
 So this should be optional.
 
 Best, Matthias

 > -----Ursprüngliche Nachricht-----
> > Von: regext <[email-masked]> Im Auftrag von Thomas Corte
> > (TANGO support)
> > Gesendet: Mittwoch, 15. Mai 2019 16:48
> > An: [email-masked]
> > Cc: [email-masked]
> > Betreff: [regext] draft-ietf-regext-epp-fees: add feature to inquire
> > balance and credit limit?
> >
> > Hello,
> >
> > some of our registrars keep asking for a feature to simply inquire
> > their current account balance and credit limit via EPP.
> >
> > information in the response to a *transform* command, but not e.g. in
> > a check response.
> >
> > This isn't ideal since the registrar should not be forced to send a "dummy"
> > sequence of billable commands (e.g., a domain create/delete or
> > Also, even if the registrar would store the values from the most
> > recent "non- dummy" transform response, they could become obsolete
> > quickly due to intermittent automatic renewals, or account top-up
> deposits.
> >
> > extension, which could trigger the inclusion of the balance/limit in
> > the <domain:check> fee response extension?
> >
> > Best regards,
> >
> > Thomas Corte
> >
> > --
> > _______________________________________________
> > regext mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/regext

---

From: "Gould, James" <[email-masked]>
Date: Wed, 15 May 2019 17:52:24 +0000

Thomas,

I view the balance and credit limit information as separate from the fee information supported by draft-ietf-regext-epp-fees.  The balance and credit limit information can optionally be returned by draft-ietf-regext-epp-fees, but I believe it's better to support a specific query mechanism.  The Balance Mapping, which is registered in the EPP Extension Registry (https://www.iana.org/assignments/epp-extensions/epp-extensions.xhtml), enables querying for the balance and credit limit information directly.  The Low Balance Mapping, which is also registered in the EPP Extension Registry, supports a poll message when the available credit falls below a pre-defined threshold.  Is there interest in these extensions?  

—
 
JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com <http://verisigninc.com/> 

On 5/15/19, 10:49 AM, "regext on behalf of Thomas Corte (TANGO support)" <[email-masked] on behalf of [email-masked]> wrote:

    Hello,

    

    Best regards,
    
    Thomas Corte

---

From: Pieter Vandepitte <[email-masked]>
Date: Wed, 15 May 2019 18:05:01 +0000

Hi Thomas,

At DNS Belgium, we have implemented a custom "registrar:info" extension for that a long time ago. Balance or credit limit is a registrar property, so in my opinion it does not belong in the response of any domain command. Instead of defining a new registrar object, you could implement the organisation extension and lobby for an update of the epp-fees extension to include balance data in info commands? Or something in that direction (I'm not aware of all details of these extensions)

Kind regards,

Pieter

On 15/05/2019, 16:49, "regext on behalf of Thomas Corte (TANGO support)" <[email-masked] on behalf of [email-masked]> wrote:

    Hello,

    

    Best regards,
    
    Thomas Corte

---

From: Mario Loffredo <[email-masked]>
Date: Thu, 16 May 2019 07:58:23 +0200

.it is interested in the Balance Mapping extension.  With regard to the Low Balance Mapping extension, .it has already implemented a poll message with the same meaning.

Mario

Inviato da iPhone

> Il giorno 15 mag 2019, alle ore 19:52, Gould, James <jgould=[email-masked]> ha scritto:
> 
> Thomas,
>

---

From: Thomas Corte <[email-masked]>
Date: Thu, 16 May 2019 10:58:54 +0200

Hello,

On 15/05/2019 19:52, Gould, James wrote:

> Thomas,
> 
> I view the balance and credit limit information as separate from the
> fee information supported by draft-ietf-regext-epp-fees.  The balance
> and credit limit information can optionally be returned by
> draft-ietf-regext-epp-fees, but I believe it's better to support a
> specific query mechanism.

To me, this means that the current state of the fee extension is
somewhat inconsistent, since it does include balance information in some
contexts but not in others. Either it is a purely fee related extension
(in which case the balance/credit limit features should be removed
altogether), or it's a general extension dealing with all billing issues
(in which case a query feature should be added).

> The Balance Mapping, which is registered
> in the EPP Extension Registry
> (https://www.iana.org/assignments/epp-extensions/epp-extensions.xhtml),
> enables querying for the balance and credit limit information
> directly.  The Low Balance Mapping, which is also registered in the
> EPP Extension Registry, supports a poll message when the available
> credit falls below a pre-defined threshold.  Is there interest in
> these extensions?

The Balance Mapping in the EPP Extension Registry looks like a viable
option, we'd consider implementing it if it became an IETF standard.

Best regards,

Thomas

---

From: "Gould, James" <[email-masked]>
Date: Thu, 16 May 2019 13:03:42 +0000

Thomas,

The primary purpose of draft-ietf-regext-epp-fees is fees and credits, and returning the balance and credit limit in the response to a transform command is an optional feature that the server can choose to support.  I don't see an issue with a server deciding to return the balance and credit limit information in the response to a billable transform command, but I don't believe it should be a requirement.  Providing a mechanism to explicitly query for the balance and credit limit information is best suited with an object mapping such as the Balance Mapping.  
  
—
 
JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

On 5/16/19, 4:59 AM, "Thomas Corte" <[email-masked]> wrote:

    Hello,

    

    
    Best regards,
    
    Thomas