Subject: Re: [regext] New-AD review of draft-ietf-regext-bundling-registration-09

From: "Jiankang Yao" <[email-masked]>
Date: Fri, 4 Oct 2019 19:55:07 +0800 (GMT+08:00)

-----原始邮件-----
发件人:"Barry Leiba" <[email-masked]>
发送时间:2019-09-26 12:17:10 (星期四)
收件人: "Jiankang Yao" <[email-masked]>
抄送: [email-masked], [email-masked]
主题: Re: [regext] New-AD review of draft-ietf-regext-bundling-registration-09

This remains quite incomplete: the last call comments have not been properly handled.

In Sections 6.1, 6.2, 7.1.2, and all the 7.2.x you made changes in response to Adam’s AD review, but you tried to use the second of his suggested fixes.  What you did do is flawed, as you have introduced a space character between the two U+ characters (which is why he advised against that fix, because doing it without the extra space makes it hard to read, but adding the space makes it wrong).  Please fix that.  I suggest using Adam’s XML-escaping example to fix it.

Yao: Yes, we will use Adam's suggestion to fix it. thanks.

The Gen-ART review asked for BCP 14 key words in Section 5, and you said you would add them.  You did not.  That’s fine if you ultimately decided not to (I personally think it is not necessary), but I want to make sure you didn’t simply forget to make that change.

Yao:Yes, we ultimately think that we do not need to make the change.

The Gen-ART review asked for a brief explanation of what the conditions might be for not complying with the “SHOULD” requirements in Sections 7.2.x, and what the consequences would be.  You did not add that, and I think it’s necessary.  Please add an explanation in each of those sections.

Yao: We will add it.

The SecDir review suggested changing the contact for the IANA registrations to the IETF, rather than the authors, and I agree: it should be “the IETF”, probably with the regext mailing list as the contact information.  You did not make any change.  Please do.

You also did not address my comment about needing an explanation for why this is Informational and not Proposed Standard.  It’s fine for it to be Informational, but the shepherd writeup needs to explain why (please update it), and the Introduction probably should also, assuming that reason has to do with the deployment, applicability, or maturity of what’s documented here.

Yao:  In the section "IANA Considerations" , we will add the following sentence

" This document describes a non-standard EPP

extension, so that the registrant contact will use author's address under the REGEXT WG's guidance."

Thanks for your kind detail review.Best RegardsJiankang Yao

I won’t pass this up to the IESG until all these points are addressed.  So back into Revised I-D needed this goes, and please handle this without undue delay.

Thanks,

Barry

On Sat, Sep 21, 2019 at 7:15 AM Jiankang Yao <[email-masked]> wrote:

Dear Barry,

     The new version has been submitted. It addresses the comments received during IETF LC.
     https://datatracker.ietf.org/doc/html/draft-ietf-regext-bundling-registration-10

  Thanks.

Jiankang Yao

> -----原始邮件-----
> 发件人: "Jiankang Yao" <[email-masked]>
> 发送时间: 2019-09-13 16:39:04 (星期五)
> 收件人: "Barry Leiba" <[email-masked]>
> 抄送: [email-masked], [email-masked]
> 主题: Re: [regext] New-AD review of draft-ietf-regext-bundling-registration-09
>
>
> Thanks Barry.
> We have finished an initial new version. We will refine it and submit it within 2 weeks.
>
> Best Regards.
>
> Jiankang Yao
>
> > -----原始邮件-----
> > 发件人: "Barry Leiba" <[email-masked]>
> > 发送时间: 2019-09-13 09:21:02 (星期五)
> > 收件人: "Jiankang Yao" <[email-masked]>
> > 抄送: [email-masked], [email-masked]
> > 主题: Re: [regext] New-AD review of draft-ietf-regext-bundling-registration-09
> >
> > >       Thanks a lot. We will update a new version based on your guidance.
> >
> > It's been almost 12 weeks.  Is a new version forthcoming?  When can we
> > expect it?
> >
> > Barry
> >
> > > > 在 2019年6月22日，02:28，Barry Leiba <[email-masked]>; 写道：
> > > >
> > > > Hey, regext folks,
> > > >
> > > > This document had an AD review from Adam, a Gen-ART review from Joel,
> > > > and a SecDir review from Russ, and went through IETF last call.  All
> > > > three reviews were responded to on the regext mailing list (by
> > > > Jiankang and by Antoine), but there has been no revision of the draft
> > > > to address the issues raised.  That has to happen.
> > > >
> > > > While we're there, there's the issue of the Informational status and
> > > > the registrant contact for the namespace:
> > > >
> > > > It's my understanding that this isn't specifying a standard, but,
> > > > rather, is documenting an existing non-standard extension that is not
> > > > expected to be a standard nor widely implemented.  Is that correct?
> > > >
> > > > If so, the document should make that clear in the Abstract (briefly)
> > > > and in the Introduction (somewhat less briefly).
> > > >
> > > > Also, the shepherd writeup doesn't help me understand why this is
> > > > Informational, and it should: (from the writeup text, emphasis mine)
> > > > "Explain briefly what the intent of the document is (the document's
> > > > abstract is usually good for this), and WHY THE WORKING GROUP HAS
> > > > CHOSEN THE REQUESTED PUBLICATION TYPE".  You say the working group
> > > > decided, but you don't say why.
> > > >
> > > > So:
> > > > Please revise the draft to address the last call reviews, and also
> > > > please add something to the Introduction (and possibly the Abstract)
> > > > to explain the status of the document, making clear what the standards
> > > > or non-standards status is and what applicability we expect for it.
> > > >
> > > > I'm putting this into a "Revised I-D Needed" substate, awaiting such revision.
> > > >
> > > > Thanks,
> > > > Barry
> >
> > _______________________________________________
> > regext mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/regext
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext

---

From: Barry Leiba <[email-masked]>
Date: Fri, 4 Oct 2019 10:00:27 -0400

Thanks, Jiankang.

On one point only:

>> The SecDir review suggested changing the contact for the IANA
>> registrations to the IETF, rather than the authors, and I agree: it
>> should be “the IETF”, probably with the regext mailing list as the
>> contact information.  You did not make any change.  Please do.
>>
>> You also did not address my comment about needing an explanation for
>> why this is Informational and not Proposed Standard.  It’s fine for it
>> to be Informational, but the shepherd writeup needs to explain why
>> (please update it), and the Introduction probably should also,
>> assuming that reason has to do with the deployment, applicability, or
>> maturity of what’s documented here.
>

I don't think that's where you should put it, and at this point I
don't think you need to make any change to the IANA Considerations.
As I said in my note in response to you and Antoin:

> The explanation that
> this is a proprietary extension and where it comes from needs to be in
> the Introduction (early in the Introduction).  I would also mention it
> in the abstract (change "This document describes an extension" to
> something like, "This document describes a non-standard proprietary
> extension").

In addition to the change I suggest above to the Abstract, I would
like to see a change to this paragraph in the Introduction:

   In order to meet the above requirements of strict bundled name
   registration, this document describes an extension of the EPP domain
   name mapping [RFC5731] for the provisioning and management of bundled
   names.

To start with, I'd like it to say "describes a non-standard
proprietary extension".  But then I'd like to see another sentence
after what's above, which says a little more about where the
proprietary extension comes from, and a work about its deployment (is
it limited to certain environments, certain companies, certain
registries/registrars, certain countries?).

This should be easy: we're only talking about a few sentences.

Barry