Subject: [regext] Side meeting about "Domain Suggestion APIs" - any interest?

From: Alexander Mayrhofer <[email-masked]>
Date: Mon, 28 Oct 2019 08:45:03 +0100

Hello everyone,

we've recently done some work on a tool that suggests domain names to
registrants if their desired name is already taken. The primary focus
is now using it on our website, but a subsequent step would be
providing an API for registrars so that they can integrate it into
their websites as well. I'm looking at something REST/JSON based for
now.

Since this is a pretty generic function, i was wondering whether
there's any interest in holding a side meeting at IETF 106 about the
standardization side of that topic? Or shall we do a slot in regext
itself? it's not perfectly in-charter, but it's obviously closely
related.

feedback appreciated!

best,
Alex

---

From: Mario Loffredo <[email-masked]>
Date: Mon, 28 Oct 2019 09:22:46 +0100

Hi Alex,

I'm interested. At .it, we have already implemented a domain suggestion 
capability in RDAP. At the moment, the implementation is only a proof of 
concept but we are working to provide it as a stable service to .it 
registrars.

The white paper describing .it approach is available here 
<https://www.iit.cnr.it/sites/default/files/IIT-06-2018.pdf>

My preferred days for the side meeting at IETF 106 are Tuesday (late in 
the afternoon), Wednesday and Thursday.

Cheers,

mario

Il 28/10/2019 08:45, Alexander Mayrhofer ha scritto:
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext

-- 
Dr. Mario Loffredo
Servizi Internet e Sviluppo Tecnologico
CNR - Istituto di Informatica e Telematica
via G. Moruzzi 1, I-56124 PISA, Italy
E-Mail: [email-masked]
Phone: +39.0503153497
Mobile: +39.3462122240
Web: http://www.iit.cnr.it/mario.loffredo

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 28 Oct 2019 11:18:35 +0000

I'm interested. This is also something that could be a good topic for next May's Registration Operations Workshop, especially if someone has a candidate API (or APIs) to discuss.

Scott

> -----Original Message-----
> From: regext <[email-masked]> On Behalf Of Alexander Mayrhofer
> Sent: Monday, October 28, 2019 3:45 AM
> To: Registration Protocols Extensions <[email-masked]>
> Subject: [EXTERNAL] [regext] Side meeting about "Domain Suggestion APIs" -
> any interest?
>
> Hello everyone,
>
> registrants if their desired name is already taken. The primary focus is now
> using it on our website, but a subsequent step would be providing an API for
> registrars so that they can integrate it into their websites as well. I'm looking
> at something REST/JSON based for now.
>
> Since this is a pretty generic function, i was wondering whether there's any
> interest in holding a side meeting at IETF 106 about the standardization side
> of that topic? Or shall we do a slot in regext itself? it's not perfectly in-
> charter, but it's obviously closely related.
>
> feedback appreciated!
>
> best,
> Alex
>

---

From: Tim Wicinski <[email-masked]>
Date: Mon, 28 Oct 2019 11:07:56 -0400

Put me on the list Alexander.

Tim

On Mon, Oct 28, 2019 at 7:18 AM Hollenbeck, Scott <shollenbeck=
[email-masked]> wrote:

> I'm interested. This is also something that could be a good topic for next
> May's Registration Operations Workshop, especially if someone has a
> candidate API (or APIs) to discuss.
>
> Scott
>

---

From: Jody Kolker <[email-masked]>
Date: Mon, 28 Oct 2019 15:56:55 +0000

Please add me to the list also.

Thanks,
Jody Kolker
319-294-3933 (office)
319-329-9805 (mobile)
This email message and any attachments hereto is intended for use only by the addressee(s) named herein and may contain confidential information. If you have received this email in error, please immediately notify the sender and permanently delete the original and any copy of this message and its attachments.

From: regext <[email-masked]> On Behalf Of Tim Wicinski
Sent: Monday, October 28, 2019 10:08 AM
To: Hollenbeck, Scott <shollenbeck=[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [regext] Side meeting about "Domain Suggestion APIs" - any interest?

Notice: This email is from an external sender.

Tim

On Mon, Oct 28, 2019 at 7:18 AM Hollenbeck, Scott <shollenbeck=[email-masked]<mailto:[email-masked]>> wrote:
I'm interested. This is also something that could be a good topic for next May's Registration Operations Workshop, especially if someone has a candidate API (or APIs) to discuss.

Scott

> From: regext <[email-masked]<mailto:[email-masked]>> On Behalf Of Alexander Mayrhofer
> To: Registration Protocols Extensions <[email-masked]<mailto:[email-masked]>>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
regext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/regext