Subject: [regext] I-D Action: draft-ietf-regext-dnrd-objects-mapping-04.txt

From: [email-masked]
Date: Mon, 16 Dec 2019 14:10:26 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Registration Protocols Extensions WG of the IETF.

        Title           : Domain Name Registration Data (DNRD) Objects Mapping
        Authors         : Gustavo Lozano
                          James Gould
                          Chethan Thippeswamy
	Filename        : draft-ietf-regext-dnrd-objects-mapping-04.txt
	Pages           : 184
	Date            : 2019-12-16

Abstract:
   This document specifies the format, contents and semantics of Domain
   Name Registration Data (DNRD) Escrow deposits for a Domain Name
   Registry.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-regext-dnrd-objects-mapping/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-regext-dnrd-objects-mapping-04
https://datatracker.ietf.org/doc/html/draft-ietf-regext-dnrd-objects-mapping-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-regext-dnrd-objects-mapping-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Gustavo Lozano <[email-masked]>
Date: Tue, 17 Dec 2019 00:44:03 +0000

Hello,

Hello,

Version 04 of draft-ietf-regext-dnrd-objects-mapping addresses the feedback provided by Scott (thank you, great feedback) during document shepherd review:

	https://mailarchive.ietf.org/arch/msg/regext/TjRlL9OygsrZ_BXjnJDs7UeHRJk

Regarding this suggestion:

The IANA Considerations section requests registration of multiple XML namespaces and XML schemas. For example, urn:ietf:params:xml:ns:rdeCsv-1.0 and urn:ietf:params:xml:schema:rdeCsv-1.0. Recent convention has been to include “epp” in the URIS for EPP-associated namespaces and schemas, e.g. urn:ietf:params:xml:ns:epp:<identifier>. That convention should be followed here, making the requested values urn:ietf:params:xml:ns:epp:rdeCsv-1.0 and urn:ietf:params:xml:schema:epp:rdeCsv-1.0.

The authors believe that this change will have a major impact on current implementations, and a case can be made that the names should be maintained as this specification has been in development and used for years.

Version 04 also addresses the feedback provided by Jim during the review of the examples in the draft:

	https://mailarchive.ietf.org/arch/msg/regext/Y2G2yHJppT1DSb8_TYp4uMo0T-s

No material updates on this version and it maintains backward compatibility.

Regards,
Gustavo

On 12/16/19, 14:10, "regext on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    
    Abstract:

    The IETF datatracker status page for this draft is:
    https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dregext-2Ddnrd-2Dobjects-2Dmapping_&d=DwICAg&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=PJSRBLyB4XEyPjZ7HnhjuUhCCohufILMzA4_azq3bbc&s=dRHXIrIokDu9b513pD7KkSDIA904T3B1dYm8FDEKgIY&e= 
    
    There are also htmlized versions available at:
    https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dregext-2Ddnrd-2Dobjects-2Dmapping-2D04&d=DwICAg&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=PJSRBLyB4XEyPjZ7HnhjuUhCCohufILMzA4_azq3bbc&s=fzNZEyXpiNUZ8pX1UBA4gEY68MvVnvJAHsURnLagY50&e= 
    https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Dregext-2Ddnrd-2Dobjects-2Dmapping-2D04&d=DwICAg&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=PJSRBLyB4XEyPjZ7HnhjuUhCCohufILMzA4_azq3bbc&s=m8dtoUmMsUb1vOniyTGlqL68p_JZFPp6_hImFW28trY&e= 
    
    A diff from the previous version is available at:
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Dregext-2Ddnrd-2Dobjects-2Dmapping-2D04&d=DwICAg&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=PJSRBLyB4XEyPjZ7HnhjuUhCCohufILMzA4_azq3bbc&s=GFLT5MAGmBDLTSc2srA_Q_sekbteWqK0uAGe38Vc_lo&e= 

    Internet-Drafts are also available by anonymous FTP at:
    https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=DwICAg&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=PJSRBLyB4XEyPjZ7HnhjuUhCCohufILMzA4_azq3bbc&s=tclc4n9_FE_Aq0A_FDmwgiDNKWW5AyZyxjeE44HH1jc&e= 
    
    _______________________________________________
    regext mailing list
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_regext&d=DwICAg&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=PJSRBLyB4XEyPjZ7HnhjuUhCCohufILMzA4_azq3bbc&s=171zABwuAahsoTrvqEHZmdL2HJP18Gd6Pm_kKgbTq90&e=

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 17 Dec 2019 15:52:01 +0000

Thanks for the update, Gustavo. I think there are a few more minor edits to discuss. From Jim Gould's testing of the examples:

" 6. Section 5.5.2.1.1 “idnLanguage CSV File Definition
a. Example needs to be updated to use <rdeCsv:csv name="idnLanguage" sep=","> and not include the <rdeCsv:sep>,</rdeCsv:sep> element "

" 7. Section 5.2.2.1.3 “hostAddresses” CSV File Definition
a. Change reference of hostAddressesObj-YYYYMMDD.csv to hostAddresses-YYYYMMDD.csv"

These are both still in the new document. Should they be?

One minor idnit:

"Outdated reference: A later version (-03) exists of draft-ietf-regext-data-escrow-02"

That's all I found in my follow-up.

Scott

> -----Original Message-----
> From: regext <[email-masked]> On Behalf Of Gustavo Lozano
> Sent: Monday, December 16, 2019 7:44 PM
> To: [email-masked]
> Subject: [EXTERNAL] Re: [regext] [Ext] I-D Action: draft-ietf-regext-dnrd-
> objects-mapping-04.txt
> 
> Hello,
> 
> Hello,
> 
> Version 04 of draft-ietf-regext-dnrd-objects-mapping addresses the
> feedback provided by Scott (thank you, great feedback) during document
> shepherd review:
> 
> The IANA Considerations section requests registration of multiple XML
> namespaces and XML schemas. For example, urn:ietf:params:xml:ns:rdeCsv-
> 1.0 and urn:ietf:params:xml:schema:rdeCsv-1.0. Recent convention has been
> to include “epp” in the URIS for EPP-associated namespaces and schemas,
> e.g. urn:ietf:params:xml:ns:epp:<identifier>. That convention should be
> followed here, making the requested values
> urn:ietf:params:xml:ns:epp:rdeCsv-1.0 and
> urn:ietf:params:xml:schema:epp:rdeCsv-1.0.
> 
> The authors believe that this change will have a major impact on current
> implementations, and a case can be made that the names should be
> maintained as this specification has been in development and used for years.
> 
> 
> On 12/16/19, 14:10, "regext on behalf of [email-masked]" <regext-
> [email-masked] on behalf of [email-masked]> wrote:
> 
> 
>     https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dietf-2Dregext-2Ddnrd-2Dobjects-
> 2Dmapping_&d=DwICAg&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5c
> M&r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-
> 0BvgAgfmwfE0&m=PJSRBLyB4XEyPjZ7HnhjuUhCCohufILMzA4_azq3bbc&s=d
> RHXIrIokDu9b513pD7KkSDIA904T3B1dYm8FDEKgIY&e=
> 
>     https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dietf-2Dregext-2Ddnrd-2Dobjects-
> 2Dmapping-
> 2D04&d=DwICAg&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=V
> bweciUcwYQpIOZDSxl0ezGd1hGDtd-
> 0BvgAgfmwfE0&m=PJSRBLyB4XEyPjZ7HnhjuUhCCohufILMzA4_azq3bbc&s=f
> zNZEyXpiNUZ8pX1UBA4gEY68MvVnvJAHsURnLagY50&e=
>     https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Dregext-2Ddnrd-
> 2Dobjects-2Dmapping-
> 2D04&d=DwICAg&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=V
> bweciUcwYQpIOZDSxl0ezGd1hGDtd-
> 0BvgAgfmwfE0&m=PJSRBLyB4XEyPjZ7HnhjuUhCCohufILMzA4_azq3bbc&s=
> m8dtoUmMsUb1vOniyTGlqL68p_JZFPp6_hImFW28trY&e=
> 
>     https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Dregext-2Ddnrd-
> 2Dobjects-2Dmapping-
> 2D04&d=DwICAg&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=V
> bweciUcwYQpIOZDSxl0ezGd1hGDtd-
> 0BvgAgfmwfE0&m=PJSRBLyB4XEyPjZ7HnhjuUhCCohufILMzA4_azq3bbc&s=
> GFLT5MAGmBDLTSc2srA_Q_sekbteWqK0uAGe38Vc_lo&e=
> 
> 
>     https://urldefense.proofpoint.com/v2/url?u=ftp-
> 3A__ftp.ietf.org_internet-
> 2Ddrafts_&d=DwICAg&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM
> &r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-
> 0BvgAgfmwfE0&m=PJSRBLyB4XEyPjZ7HnhjuUhCCohufILMzA4_azq3bbc&s=t
> clc4n9_FE_Aq0A_FDmwgiDNKWW5AyZyxjeE44HH1jc&e=
> 
>     https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_regext&d=DwICAg&c=FmY1u3PJp6wrc
> rwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-
> 0BvgAgfmwfE0&m=PJSRBLyB4XEyPjZ7HnhjuUhCCohufILMzA4_azq3bbc&s=1
> 71zABwuAahsoTrvqEHZmdL2HJP18Gd6Pm_kKgbTq90&e=
> 
> 
> https://www.ietf.org/mailman/listinfo/regext

---

From: "Gould, James" <[email-masked]>
Date: Fri, 20 Dec 2019 20:49:40 +0000

Scott,

I believe the two identified changes you identified need to be correctly applied to the draft, and you are correct that the reference to draft-ietf-regext-data-escrow-02 needs to be updated to draft-ietf-regext-data-escrow-03.  Gustavo and I will work to fix these issues.

Thanks,  

-- 
 
JG

James Gould
Distinguished Engineer
[email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com <http://verisigninc.com/>

On 12/17/19, 10:52 AM, "regext on behalf of Hollenbeck, Scott" <[email-masked] on behalf of shollenbeck=[email-masked]> wrote:

    

    
    One minor idnit:

    
    Scott