Subject: [regext] 7482bis: Search Path Segment Specification Clarification

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 23 Jan 2020 14:21:26 +0000

Section 3.2 contains this text:

"The HTTP query string is formed using a concatenation of the question mark character ('?', US-ASCII value 0x003F), the JSON object value associated with the object being searched for, the equal sign character ('=', US-ASCII value 0x003D), and the search pattern."

Proposed change:

"The HTTP query string is formed using a concatenation of the question mark character ('?', US-ASCII value 0x003F), [a noun representing the JSON object property] associated with the object being searched for, the equal sign character ('=', US-ASCII value 0x003D), and the search pattern."

What do people think about this proposal?

Scott

---

From: Mario Loffredo <[email-masked]>
Date: Thu, 23 Jan 2020 17:42:18 +0100

Inviato da iPhone

> Il giorno 23 gen 2020, alle ore 15:21, Hollenbeck, Scott <shollenbeck=[email-masked]> ha scritto:
> 

This sentence seems to exclude any future use of additional parameters in the query string.

Having said that, partial-response and sorting-and-paging would be uncompliant with 7482bis.

Similarly, I would consider such possibility for lookup queries.

Mario

> Scott
> 
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext