Subject: [regext] CALL FOR ADOPTION: draft-gould-regext-secure-authinfo-transfer

From: Antoin Verschuren <[email-masked]>
Date: Fri, 24 Jan 2020 15:51:00 +0100

This is a formal adoption request for Extensible Provisioning Protocol (EPP) Secure Authorization Information for Transfer: 
https://datatracker.ietf.org/doc/draft-gould-regext-secure-authinfo-transfer/

Please review this draft to see if you think it is suitable for adoption by REGEXT, and comment to the list, clearly stating your view.

Please also indicate if you are willing to contribute text, review text, or be a document shepherd.

This call for adoption ends Friday, 7 February 2020.

If there are no objections, and we receive enough consensus for adoption, the chairs will consider this document adopted.

Thanks,

Your REGEXT co-chairs Jim and Antoin

- -- 
Antoin Verschuren

Tweevoren 6, 5672 SB Nuenen, NL
M: +31 6 37682392

---

From: Roger D Carney <[email-masked]>
Date: Fri, 24 Jan 2020 16:18:30 +0000

+1 to add to milestones.

-----Original Message-----
From: regext <[email-masked]> On Behalf Of Antoin Verschuren
Sent: Friday, January 24, 2020 8:51 AM
To: regext <[email-masked]>
Subject: [regext] CALL FOR ADOPTION: draft-gould-regext-secure-authinfo-transfer

Notice: This email is from an external sender.

Thanks,

- --
Antoin Verschuren

_______________________________________________
regext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/regext

---

From: Mario Loffredo <[email-masked]>
Date: Sat, 25 Jan 2020 11:29:42 +0100

I support adoption.

Mario

-- 
Dr. Mario Loffredo
Servizi Internet e Sviluppo Tecnologico
CNR - Istituto di Informatica e Telematica
via G. Moruzzi 1, I-56124 PISA, Italy
E-Mail: [email-masked]
Phone: +39.0503153497
Mobile: +39.3462122240
Web: http://www.iit.cnr.it/mario.loffredo

---

From: "Gould, James" <[email-masked]>
Date: Tue, 28 Jan 2020 16:00:42 +0000

Patrick,

I respond to your comments below.

-- 
 
JG

James Gould
Distinguished Engineer
[email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com <http://verisigninc.com/>

On 1/28/20, 2:29 AM, "regext on behalf of Patrick Mevzek" <[email-masked] on behalf of [email-masked]> wrote:

    On Fri, Jan 24, 2020, at 09:51, Antoin Verschuren wrote:
    > This is a formal adoption request for Extensible Provisioning Protocol 
    > (EPP) Secure Authorization Information for Transfer: 
    > Please review this draft to see if you think it is suitable for 
    > adoption by REGEXT, and comment to the list, clearly stating your view.
    
    While the subject of transfers between registrars might need work,
    I am not convinced this working group is the appropriate place for that,
    as in particular this document seems to mostly impose directives on registries
    and how they should handle and store domain passwords which is for me 
    off topic for EPP as a protocol, and transfer issues cover points that are
    not completely technical but also business related, including the
    specific security model in which we want to work.
    (one might note that multiple procedure specify a transfer "undo" procedure,
    while this does not exist technically anywhere in EPP land...)

JG - You have brought this up before, but the adoption of a BCP draft by the WG is certainly applicable.  A transfer "undo" procedure is something new and can be handled separately.  
    
    As discussed in other threads, I am more leaning towards a ground up discussion
    on passwords attached to domains, and if other models can exist here.
    So I think work should instead go in that direction, which is then
    really completely EPP related, while discussions on passwords size, complexity,
    entropy, storage, TTLs, and so on as found in this draft are for me clearly
    out of scope of both the working group and EPP related specifications.

    The authInfo node was defined from the ground up to be extensible,
    and we should leverage that to put into place better mechanisms than
    current plain text passwords.

JG - An alternative approach is not mutually exclusive and I look forward to any proposals that you may have.
    
    I also fear discussions may forget there are already today other models than
    the "common" gTLD one that the draft tries to change,
    and I would like to make sure they are taken
    into account when drafting a solution.
    Among others, some registries use a "push" transfer model (so no
    passwords needed at all any more) and other registries basically do not
    let registrars set/handle passwords anymore, the first step of a transfer
    is the loosing registrar to ask the registry to generate a password that
    is in fact directly sent to the registrant, who in turn will input it
    at the gaining registrar (with some time window limits).

JG - Any input from interested parties is welcome.  The main question is whether other models can be fit into a common practice or whether they stand on their own.   
    
    Also while things should be left separate to be really able to produce
    new ideas, transfer issues can not be tackled without at least looking
    a little around RDDS and specifically RDAP, and around laws such
    as the GDPR from EU land, because this has the direct consequence
    for example that some registries do not continue to collect contacts, 
    or none besides the registrant.

JG - One goal of enhancing the security of the authorization information for transfers is to reduce or remove the dependency on the use of RDDS.  
    
    PS: as an exercise I reviewed how a batch of registries currently reply
    to domain:info queries in the following case:
    - registrar is not sponsoring registrar, and not providing authInfo
    - registrar is not sponsoring registrar, and providing invalid authInfo
    - registrar is not sponsoring registrar, and providing correct authInfo
    - domain does not exist and registrar is providing authInfo
    - domain does not exist and registrar is not providing authInfo
    
    Results vary a lot, even when just looking at the EPP return code.
    Also the content of <infData> can change, and differ - even outside of the password
    - between sponsoring and non sponsoring registrars.
    There is clearly no standardization here and this directly impacts
    how transfers can be done by registrars
    (on issues for example of being able to test the password without
    really starting the transfer, or to know the current nameservers
    attached to the domain, or its expiration, etc.)

JG - draft-gould-regext-secure-authinfo-transfer focuses on the behavior of the info command and response as it relates to verifying the authorization information value and disclosing whether the authorization information is set in the info response to the sponsoring or non-sponsoring registrar.  Defining a BCP would help to make things more consistent.  draft-gould-regext-secure-authinfo-transfer does not cover what elements are returned in a full or partial info response.  My thought is that if the valid authorization information is provided by a non-sponsoring registrar that the full info response should be returned.  Something like that could be added to draft-gould-regext-secure-authinfo-transfer if it would help with the transfer.  Your thoughts on this would be helpful.    
    
    -- 
      Patrick Mevzek
      [email-masked]

---

From: "Patrick Mevzek" <[email-masked]>
Date: Tue, 28 Jan 2020 11:30:06 -0500

On Tue, Jan 28, 2020, at 11:00, Gould, James wrote:
> JG - You have brought this up before, but the adoption of a BCP draft 
> by the WG is certainly applicable. 

I remain unconvinced, and would advocate that this draft, if going forward,
is *at best* EXPERIMENTAL, and certainly not BCP.

Again, there are multiple models of transfers out there. No one can say,
and specifically not at the protocol level, that one is flat out better
than another. The fact that the current situation has to be amended regarding
passwords (the whole purpose of the draft) clearly shows the current
"most common" case is far from being perfect.
Hence, whatever is written here can not be a BCP.
And everything related to password storage, complexity, entropy, etc. should
not be in a specification coming out of the REGEXT working group. Coming out of IETF,
maybe. But just not from this group.

I am just advocating to take all of that into account, instead of taking
one case and declaring this is the only way to do it (while it is obviously
not true on the field), because this is exactly why EPP is so fragmented today.

> JG - An alternative approach is not mutually exclusive and I look 
> forward to any proposals that you may have.

I think I gave multiple ideas (which can of all boil down to: let us step back and think about passwords in general instead of fixing current situation with workarounds; this is the same problem I have with login-security extension), but I won't work on those alone if no one 
is interested. Yet, they exist, as I am sure others not even written yet.

But, even if they do not exist, this does not give an immediate green light
to what is proposed here. However in order not to rehash things I will stop here
for now, and maybe participate in further discussions when/if the draft is adopted
by WG which seems plausible.

In its current form however I would clearly voice my concerns against BCP status.

> JG - Any input from interested parties is welcome.  The main question 
> is whether other models can be fit into a common practice or whether 
> they stand on their own.   

At this stage, this is not what interests me, and if concerned parties
do not want to participate here they may have their reasons (starting with not feeling
to be taken into account, I guess, I do not know I do not speak for anyone).
My concern is just to show that there are multiple ways to operate, that must
have a reason and that should make us think at the protocol level how to handle
all that instead of "patching" the current password situation.
     
> JG - One goal of enhancing the security of the authorization 
> information for transfers is to reduce or remove the dependency on the 
> use of RDDS.  

This may need to be expressed in the draft then.
 
> JG - draft-gould-regext-secure-authinfo-transfer focuses on the 
> behavior of the info command and response as it relates to verifying 
> the authorization information value and disclosing whether the 
> authorization information is set in the info response to the sponsoring 
> or non-sponsoring registrar.  Defining a BCP would help to make things 
> more consistent.  draft-gould-regext-secure-authinfo-transfer does not 
> cover what elements are returned in a full or partial info response.  

This may be a little contradictory with the goal of reducing dependency of 
RDDS. If the business side of things mandates to send emails to contacts,
and if nothing nowhere is said about replies to domain:info from
non sponsoring registrar, then you are back at basically the current situation.

> My thought is that if the valid authorization information is provided 
> by a non-sponsoring registrar that the full info response should be 
> returned. 

Maybe. I am just saying (observing) that it is not the case today.

Here is a non-scientific sample of responses to domain:info from non sponsoring
registrar with correct authInfo:

- all data but no authInfo, nor any date
- all data but no authInfo
- error code 2201
- all data but no contact IDs
- all data but authInfo value replaced with a placeholder
- error code 2306
- all data, but no expiration date
- and of course, "sometimes" :-) all data including the authInfo

(the problem for a registrar trying to validate a password is the following: on what
criteria(s) to separate "successful domain:info because good authInfo" from "successful
domain:info because all of them are successful by default, sponsoring registrar or not,
valid authInfo or not" <- yes this case exists, and not just once, and again with
some filtering on what is returned)

You can say they are all violating the specification.
My problem is: even if that is true, it does not change anything on the field,
in real life.
Nothing will change in current responses, and no document, even BCP, will make
registries change behavior, if there are no good reasons/generic framework/clear push
from registrars that are very silent in this WG/etc.

Maybe at some point, as controversial it might be, it would make sense to start working
on "epp-2.0" or at least "domain-2.0".

HTH,

-- 
  Patrick Mevzek
  [email-masked]

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 28 Jan 2020 18:41:27 +0000

> Sent: Friday, January 24, 2020 9:51 AM
> Subject: [EXTERNAL] [regext] CALL FOR ADOPTION: draft-gould-regext-
> secure-authinfo-transfer
>
> This is a formal adoption request for Extensible Provisioning Protocol (EPP)
> Secure Authorization Information for Transfer:
> Please review this draft to see if you think it is suitable for adoption by
> REGEXT, and comment to the list, clearly stating your view.
>

I support adoption of this draft. I'm willing to review it and contribute text as needed.

Scott