Subject: [regext] New Version Notification for draft-gould-regext-secure-authinfo-transfer-03

From: "Gould, James" <[email-masked]>
Date: Tue, 14 Jan 2020 16:33:38 +0000

The draft-gould-regext-secure-authinfo-transfer-03 was posted that includes the following:

1.       Updates based on the feedback from the interim REGEXT meeting held at ICANN-66

2.       Updates based on the review by Michael Bauland

3.       Updates based on the authorization information messages by Martin Casanova on the REGEXT mailing list

    URL:            https://www.ietf.org/internet-drafts/draft-gould-regext-secure-authinfo-transfer-03.txt

    Status:         https://datatracker.ietf.org/doc/draft-gould-regext-secure-authinfo-transfer/

   Htmlized:       https://tools.ietf.org/html/draft-gould-regext-secure-authinfo-transfer-03

    Htmlized:       https://datatracker.ietf.org/doc/html/draft-gould-regext-secure-authinfo-transfer

    Diff:           https://www.ietf.org/rfcdiff?url2=draft-gould-regext-secure-authinfo-transfer-03

Review and feedback is appreciated.

Thanks,

--

JG

James Gould

Distinguished Engineer

[email-masked]

703-948-3271

12061 Bluemont Way

Reston, VA 20190

Verisign.com <http://verisigninc.com/>

---

From: Mario Loffredo <[email-masked]>
Date: Tue, 21 Jan 2020 14:51:34 +0100

Hi James,

I don't know if it also goes for other registrires but at .it the losing 
registrar might be temporarily (e.g. due to a suspension) or permanently 
(e.g. because the registrar goes out of business) inactive. 
Consequently, it might be supposedly unable to generate the Secure 
AuthInfo.  In this case, the registry could generate the Secure Authinfo 
on request of the registrant.

Should the secure transfer model consider such scenario too?

Mario

Il 14/01/2020 17:33, Gould, James ha scritto:

> 1.Updates based on the feedback from the interim REGEXT meeting held 
> at ICANN-66
>
> 2.Updates based on the review by Michael Bauland
> 3.Updates based on the authorization information messages by Martin 
> Casanova on the REGEXT mailing list
>
>     URL: 
> https://www.ietf.org/internet-drafts/draft-gould-regext-secure-authinfo-transfer-03.txt
>
>     Status: 
> https://datatracker.ietf.org/doc/draft-gould-regext-secure-authinfo-transfer/
>
>    Htmlized: 
> https://tools.ietf.org/html/draft-gould-regext-secure-authinfo-transfer-03
>
>     Htmlized: 
> https://datatracker.ietf.org/doc/html/draft-gould-regext-secure-authinfo-transfer
>
>     Diff: 
> https://www.ietf.org/rfcdiff?url2=draft-gould-regext-secure-authinfo-transfer-03
>
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext

-- 
Dr. Mario Loffredo
Servizi Internet e Sviluppo Tecnologico
CNR - Istituto di Informatica e Telematica
via G. Moruzzi 1, I-56124 PISA, Italy
E-Mail: [email-masked]
Phone: +39.0503153497
Mobile: +39.3462122240
Web: http://www.iit.cnr.it/mario.loffredo

---

From: "Gould, James" <[email-masked]>
Date: Tue, 21 Jan 2020 20:56:50 +0000

Mario,

Thank you for your review and feedback.  I believe registrar statuses that may restrict registrar actions is a policy decision for the registry.  This is a much broader topic than transfers that is not a well suited scenario to consider in draft-gould-regext-secure-authinfo-transfer.

--

JG

James Gould
Distinguished Engineer
[email-masked]<applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com<http://verisigninc.com/>

From: Mario Loffredo <[email-masked]>
Date: Tuesday, January 21, 2020 at 8:54 AM
To: James Gould <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [EXTERNAL] Re: [regext] New Version Notification for draft-gould-regext-secure-authinfo-transfer-03

Hi James,

I don't know if it also goes for other registrires but at .it the losing registrar might be temporarily (e.g. due to a suspension) or permanently (e.g. because the registrar goes out of business) inactive. Consequently, it might be supposedly unable to generate the Secure AuthInfo.  In this case, the registry could generate the Secure Authinfo on request of the registrant.

Mario

Thanks,

--

JG

James Gould

Distinguished Engineer

[email-masked]<mailto:[email-masked]>

703-948-3271

12061 Bluemont Way

Reston, VA 20190

Verisign.com <http://verisigninc.com/><http://verisigninc.com/>

regext mailing list

[email-masked]<mailto:[email-masked]>

--

Dr. Mario Loffredo

E-Mail: [email-masked]<mailto:[email-masked]>

Phone: +39.0503153497

Mobile: +39.3462122240

---

From: Antoin Verschuren <[email-masked]>
Date: Fri, 24 Jan 2020 17:59:30 +0100

Mario, in this scenario, "the registry" may perform the action, but not in it’s role as registry, but as a registrar of last resort.
It is quite common and good practice for ccTLD’s to have a registrar of last resort implemented as an entity they run themselves or outsource where they don’t fall under ICANN’s umbrella of mandated policy, but you have to realise that you will supply the Authinfo code in a role as registrar of last resort and not as the registry function.
When a registrar goes out of business, the registrar of last resort takes over the customers temporarily depending on the registry’s policy, until the registrants have found a new registrar to represent them at the registry.

- -- 
Antoin Verschuren

Tweevoren 6, 5672 SB Nuenen, NL
M: +31 6 37682392

> Op 21 jan. 2020, om 14:51 heeft Mario Loffredo <[email-masked]> het volgende geschreven:
> 
> Hi James,
> 
>>     URL:            https://www.ietf.org/internet-drafts/draft-gould-regext-secure-authinfo-transfer-03.txt <https://www.ietf.org/internet-drafts/draft-gould-regext-secure-authinfo-transfer-03.txt>
>>     Status:         https://datatracker.ietf.org/doc/draft-gould-regext-secure-authinfo-transfer/ <https://datatracker.ietf.org/doc/draft-gould-regext-secure-authinfo-transfer/>
>>    Htmlized:       https://tools.ietf.org/html/draft-gould-regext-secure-authinfo-transfer-03 <https://tools.ietf.org/html/draft-gould-regext-secure-authinfo-transfer-03>
>>     Htmlized:       https://datatracker.ietf.org/doc/html/draft-gould-regext-secure-authinfo-transfer <https://datatracker.ietf.org/doc/html/draft-gould-regext-secure-authinfo-transfer>
>>     Diff:           https://www.ietf.org/rfcdiff?url2=draft-gould-regext-secure-authinfo-transfer-03 <https://www.ietf.org/rfcdiff?url2=draft-gould-regext-secure-authinfo-transfer-03>
>>  
>> [email-masked] <mailto:[email-masked]>
>>  
>> 703-948-3271
>> 12061 Bluemont Way
>> Reston, VA 20190
>>  
>> Verisign.com <http://verisigninc.com/> <http://verisigninc.com/>
>>  
>> 
>> 
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>
> -- 
> Dr. Mario Loffredo
> E-Mail: [email-masked] <mailto:[email-masked]>
> Phone: +39.0503153497
> Mobile: +39.3462122240
> Web: http://www.iit.cnr.it/mario.loffredo <http://www.iit.cnr.it/mario.loffredo>_______________________________________________
> regext mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>

---

From: Mario Loffredo <[email-masked]>
Date: Sat, 25 Jan 2020 10:30:53 +0100

Hi Antoin,

I completely agree. I didn’t catch that this special case was implied. 

Best,
Mario

Inviato da iPhone

> Il giorno 24 gen 2020, alle ore 17:59, Antoin Verschuren <[email-masked]> ha scritto:
> 
>