Subject: [regext] 7482bis: Partial String Search Clarification

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 23 Jan 2020 13:40:59 +0000

This is a 7482 clarification proposal that I received off-list.

Current text:
Partial string searching uses the asterisk ('*', US-ASCII value 0x002A) character to match zero or more trailing characters.  A character string representing multiple domain name labels MAY be concatenated to the end of the search pattern to limit the scope of the search.  For example, the search pattern "exam*" will match "example.com" and "example.net".  The search pattern "exam*.com" will match "example.com".  If an asterisk appears in a search string, any label that contains the non-asterisk characters in sequence plus zero or more characters in sequence in place of the asterisk would match. Additional pattern matching processing is beyond the scope of this specification.

Proposed new text:
Partial string searching uses the asterisk ('*', US-ASCII value 0x002A) character to match zero or more trailing characters.  A character string representing [a domain label suffix] MAY be concatenated to the end of the search pattern to limit the scope of the search.  For example, the search pattern "exam*" will match "example.com" and "example.net".  The search pattern "exam*.com" will match "example.com".  If an asterisk appears in a search string, any label that contains the non-asterisk characters in sequence plus zero or more characters in sequence in place of the asterisk would match. [Only a single asterisk is allowed for a partial string search.] Additional pattern matching processing is beyond the scope of this specification.

What do people think about this proposal?

Scott

---

From: Mario Loffredo <[email-masked]>
Date: Thu, 23 Jan 2020 15:14:28 +0100

> What do people think about this proposal?

My opinion is that allowing one or more asterisks in partial matching 
should be a matter of the server policy.

Mario

>
> Scott
>
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext

-- 
Dr. Mario Loffredo
Servizi Internet e Sviluppo Tecnologico
CNR - Istituto di Informatica e Telematica
via G. Moruzzi 1, I-56124 PISA, Italy
E-Mail: [email-masked]
Phone: +39.0503153497
Mobile: +39.3462122240
Web: http://www.iit.cnr.it/mario.loffredo

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 28 Jan 2020 14:11:06 +0000

> -----Original Message-----
> From: Mario Loffredo <[email-masked]>
> Sent: Thursday, January 23, 2020 9:14 AM
> To: Hollenbeck, Scott <[email-masked]>; [email-masked]
> Subject: [EXTERNAL] Re: [regext] 7482bis: Partial String Search Clarification
> 
> 
> > Partial string searching uses the asterisk ('*', US-ASCII value 0x002A)
> character to match zero or more trailing characters.  A character string
> representing multiple domain name labels MAY be concatenated to the end
> of the search pattern to limit the scope of the search.  For example, the
> search pattern "exam*" will match "example.com" and "example.net".  The
> search pattern "exam*.com" will match "example.com".  If an asterisk
> appears in a search string, any label that contains the non-asterisk characters
> in sequence plus zero or more characters in sequence in place of the asterisk
> would match. Additional pattern matching processing is beyond the scope of
> this specification.
> >
> > Proposed new text:
> > Partial string searching uses the asterisk ('*', US-ASCII value 0x002A)
> character to match zero or more trailing characters.  A character string
> representing [a domain label suffix] MAY be concatenated to the end of the
> search pattern to limit the scope of the search.  For example, the search
> pattern "exam*" will match "example.com" and "example.net".  The search
> pattern "exam*.com" will match "example.com".  If an asterisk appears in a
> search string, any label that contains the non-asterisk characters in sequence
> plus zero or more characters in sequence in place of the asterisk would
> match. [Only a single asterisk is allowed for a partial string search.] Additional
> pattern matching processing is beyond the scope of this specification.
> >
> My opinion is that allowing one or more asterisks in partial matching should
> be a matter of the server policy.

Mario, I'd like to push back a bit on this suggestion. The intent of the original text was to allow for only a single pattern-matching asterisk, so if we change the text to allow more than one we're changing the protocol. A protocol change means we'd need to re-spin 7482 at the Proposed Standard level, and that's something I'm trying to avoid for now.

Additionally, if we say "server policy", we'd need to figure out how to publish and discover these policies. That, too, goes beyond what's currently in 7482.

My preference for improving search would be to produce another draft/RFC that adds whatever new capabilities are desired. There was an effort to do this a while back in an Internet-Draft that described regular expression searching, but that draft never caught on with anyone. We've also seen very little implementation of partial string searching in the real world (it's not included in ICANN's gTLD profile, for example), so there may not be a lot of support for the concept. So, can we just clarify the original intent in 7482bis and leave search improvement to another effort?

Scott

---

From: Mario Loffredo <[email-masked]>
Date: Wed, 29 Jan 2020 09:36:26 +0100

> My preference for improving search would be to produce another draft/RFC that adds whatever new capabilities are desired. There was an effort to do this a while back in an Internet-Draft that descr…

OK. No problem. I made that comment because, in my opinion, what really 
matters for server processing is the position of the asterisks rather 
than their number.

mario

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 29 Jan 2020 15:51:38 +0000

> Sent: Wednesday, January 29, 2020 3:36 AM
> >> character to match zero or more trailing characters.  A character
> >> string representing multiple domain name labels MAY be concatenated
> >> to the end of the search pattern to limit the scope of the search.
> >> For example, the search pattern "exam*" will match "example.com" and
> >> "example.net".  The search pattern "exam*.com" will match
> >> "example.com".  If an asterisk appears in a search string, any label
> >> that contains the non-asterisk characters in sequence plus zero or
> >> more characters in sequence in place of the asterisk would match.
> >> Additional pattern matching processing is beyond the scope of this
> specification.
> >>> Proposed new text:
> >> character to match zero or more trailing characters.  A character
> >> string representing [a domain label suffix] MAY be concatenated to
> >> the end of the search pattern to limit the scope of the search.  For
> >> example, the search pattern "exam*" will match "example.com" and
> >> "example.net".  The search pattern "exam*.com" will match
> >> "example.com".  If an asterisk appears in a search string, any label
> >> that contains the non-asterisk characters in sequence plus zero or
> >> more characters in sequence in place of the asterisk would match.
> >> [Only a single asterisk is allowed for a partial string search.] Additional
> > Mario, I'd like to push back a bit on this suggestion. The intent of the
> original text was to allow for only a single pattern-matching asterisk, so if we
> change the text to allow more than one we're changing the protocol. A
> protocol change means we'd need to re-spin 7482 at the Proposed Standard
> level, and that's something I'm trying to avoid for now.
> >
> > Additionally, if we say "server policy", we'd need to figure out how to
> publish and discover these policies. That, too, goes beyond what's currently
> in 7482.
> >
> > My preference for improving search would be to produce another
> draft/RFC that adds whatever new capabilities are desired. There was an
> effort to do this a while back in an Internet-Draft that described regular
> expression searching, but that draft never caught on with anyone. We've
> also seen very little implementation of partial string searching in the real
> world (it's not included in ICANN's gTLD profile, for example), so there may
> not be a lot of support for the concept. So, can we just clarify the original
> intent in 7482bis and leave search improvement to another effort?
>
> matters for server processing is the position of the asterisks rather than their
> number.

I've also made this change in -01.

Scott