Subject: Re: [regext] Questions about RDAP extensions and registration at IANA, role of prefix and version

From: "Patrick Mevzek" <[email-masked]>
Date: Thu, 23 Jan 2020 01:10:32 -0500

Hi Scott,

On Thu, Nov 7, 2019, at 07:04, Hollenbeck, Scott wrote:
> Patrick, my expectation is that the value registered with IANA is the 
> exact value that should appear in an rdapConformance section. The 
> purpose of these values is to clearly identify an associated 
> specification, so one should be able to extract an identifier from an 
> RDAP response, look it up in the IANA registry, find an exact match, 
> and unambiguously identify the associated specification. We clearly 
> need to clean up this part of 7483 if/when we do 7483bis.

Thanks to have shared your views because indeed, due to the under specification,
I was thinking more about "prefix" registration than "exact match".

This would be good to address in some bis process, as the current situation
is clearly not ideal and is bound to become worse.

Note that related to that there is at least one EPP server out there
(in production for a real TLD) that gives this at greeting:

<objURI>urn:ietf:params:xml:ns:contact</objURI>
<objURI>urn:ietf:params:xml:ns:host</objURI>
<objURI>urn:ietf:params:xml:ns:domain</objURI>
<objURI>urn:ietf:params:xml:ns:svcsub</objURI>
<svcExtension>
  <extURI>urn:ietf:params:xml:ns:neulevel</extURI>
  <extURI>urn:ietf:params:xml:ns:secDNS-1.1</extURI>
  <extURI>urn:ietf:params:xml:ns:idn-1.0</extURI>
<svcExtension>

See the lack of version numbers in the schema URI provided,
but not for all of them :-).

This can be deemed a direct violation of the protocol,
but registrars still have to deal with it in some way.

-- 
  Patrick Mevzek
  [email-masked]

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 23 Jan 2020 16:09:35 +0000

> -----Original Message-----
> From: regext <[email-masked]> On Behalf Of Patrick Mevzek
> Sent: Thursday, January 23, 2020 1:11 AM
> To: [email-masked]
> Subject: [EXTERNAL] Re: [regext] Questions about RDAP extensions and
> registration at IANA, role of prefix and version
> 
> Hi Scott,
> 
> Thanks to have shared your views because indeed, due to the under
> specification, I was thinking more about "prefix" registration than "exact
> match".
> 
> This would be good to address in some bis process, as the current situation is
> clearly not ideal and is bound to become worse.

I'm starting work on 7483bis now. I should have it published within the next few weeks.

> Note that related to that there is at least one EPP server out there (in
> production for a real TLD) that gives this at greeting:
> 
> See the lack of version numbers in the schema URI provided, but not for all
> of them :-).
> 
> This can be deemed a direct violation of the protocol, but registrars still have
> to deal with it in some way.

The URNs that appear in a greeting should exactly match those that appear in a specification, are registered with IANA, should be used during login, etc. I hope that registrars can work with that server operator to make appropriate corrections.

Scott

---

From: "Patrick Mevzek" <[email-masked]>
Date: Thu, 23 Jan 2020 11:32:04 -0500

On Thu, Jan 23, 2020, at 11:09, Hollenbeck, Scott wrote:
> The URNs that appear in a greeting should exactly match those that 
> appear in a specification, are registered with IANA, should be used 
> during login, etc. I hope that registrars can work with that server 
> operator to make appropriate corrections.

I agree, but FWIW it is an old ccTLD (so not like a new server/TLD
just having appeared), and I just stumbled on that by chance recently
and was keen to share with the community, but since I guess this exists for a long
time, no one was feeling it should be corrected, so I guess it will persist
for a long time. Unfortunately.

But it happens, often (maybe?) it is simpler for registrars to work around
(with local "patches") what they think is a problem from responses they got,
than trying to make the registry act on them. It is just a matter of finding
out where your time is better spent, since "being 100% standard compliant"
is not exactly a big selling point for customers, just accepting orders
may be preferred, business-wise, than taking time to put pressure on registries
to fix things.

There is no worldwide EPP police indeed.

Unfortunately.
Or fortunately :-)

-- 
  Patrick Mevzek
  [email-masked]