Subject: Re: [regext] CALL FOR ADOPTION: draft-gould-regext-secure-authinfo-transfer

From: "James Galvin" <[email-masked]>
Date: Fri, 07 Feb 2020 09:42:03 -0500

Speaking with Chair hat on:

Your message starts by suggesting that this work does not belong in this 
working group but then moves towards discussing a solution for work that 
belongs in this working group.

As the CALL FOR ADOPTION comes to a close, the chairs are leaning 
towards interpreting your message as agreement there is work that could 
be done.  Note that adopting the document does not guarantee that it 
will be published by this working group; that will be decided as part of 
the discussion and review.

Is this okay with you?  If not, please do take some time to clarify your 
position.

Thanks,

Antoin and Jim

On 28 Jan 2020, at 2:28, Patrick Mevzek wrote:

> On Fri, Jan 24, 2020, at 09:51, Antoin Verschuren wrote:
>> This is a formal adoption request for Extensible Provisioning 
>> Protocol
>> (EPP) Secure Authorization Information for Transfer:
>> https://datatracker.ietf.org/doc/draft-gould-regext-secure-authinfo-transfer/
>>
>> Please review this draft to see if you think it is suitable for
>> adoption by REGEXT, and comment to the list, clearly stating your 
>> view.
>
> While the subject of transfers between registrars might need work,
> I am not convinced this working group is the appropriate place for 
> that,
> as in particular this document seems to mostly impose directives on 
> registries
> and how they should handle and store domain passwords which is for me
> off topic for EPP as a protocol, and transfer issues cover points that 
> are
> not completely technical but also business related, including the
> specific security model in which we want to work.
> (one might note that multiple procedure specify a transfer "undo" 
> procedure,
> while this does not exist technically anywhere in EPP land...)
>
> As discussed in other threads, I am more leaning towards a ground up 
> discussion
> on passwords attached to domains, and if other models can exist here.
> So I think work should instead go in that direction, which is then
> really completely EPP related, while discussions on passwords size, 
> complexity,
> entropy, storage, TTLs, and so on as found in this draft are for me 
> clearly
> out of scope of both the working group and EPP related specifications.
>
> The authInfo node was defined from the ground up to be extensible,
> and we should leverage that to put into place better mechanisms than
> current plain text passwords.
>
> I also fear discussions may forget there are already today other 
> models than
> the "common" gTLD one that the draft tries to change,
> and I would like to make sure they are taken
> into account when drafting a solution.
> Among others, some registries use a "push" transfer model (so no
> passwords needed at all any more) and other registries basically do 
> not
> let registrars set/handle passwords anymore, the first step of a 
> transfer
> is the loosing registrar to ask the registry to generate a password 
> that
> is in fact directly sent to the registrant, who in turn will input it
> at the gaining registrar (with some time window limits).
>
> Also while things should be left separate to be really able to produce
> new ideas, transfer issues can not be tackled without at least looking
> a little around RDDS and specifically RDAP, and around laws such
> as the GDPR from EU land, because this has the direct consequence
> for example that some registries do not continue to collect contacts,
> or none besides the registrant.
>
> PS: as an exercise I reviewed how a batch of registries currently 
> reply
> to domain:info queries in the following case:
> - registrar is not sponsoring registrar, and not providing authInfo
> - registrar is not sponsoring registrar, and providing invalid 
> authInfo
> - registrar is not sponsoring registrar, and providing correct 
> authInfo
> - domain does not exist and registrar is providing authInfo
> - domain does not exist and registrar is not providing authInfo
>
> Results vary a lot, even when just looking at the EPP return code.
> Also the content of <infData> can change, and differ - even outside of 
> the password
> - between sponsoring and non sponsoring registrars.
> There is clearly no standardization here and this directly impacts
> how transfers can be done by registrars
> (on issues for example of being able to test the password without
> really starting the transfer, or to know the current nameservers
> attached to the domain, or its expiration, etc.)
>
> -- 
>   Patrick Mevzek
>   [email-masked]
>
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext

---

From: Antoin Verschuren <[email-masked]>
Date: Fri, 14 Feb 2020 15:42:48 +0100

This call for adoption has ended with no objections.
The chairs therefor accepted this document as a Working Group Document.

For the WG: We still need a volunteer for this document to be the document shepherd. This is an excellent opportunity to get to know the IETF processes for new working group members, so please volunteer! No real technical insight about this draft is needed to volunteer, so don’t be shy. The only thing that you will need to do is to verify that all comments during WGLC and IESG review are attended to once the document reaches that state, and fill in a template about that process. This and all other things the chairs will help you with, but we need an independent document shepherd to state that the correct process was followed.

For the authors: Please resubmit the latest version of your draft with the following name:
draft-ietf-regext-secure-authinfo-transfer
We have pre-approved the publication of this draft as a WG document.

Regards,

Jim and Antoin

> Op 7 feb. 2020, om 15:42 heeft James Galvin <[email-masked]> het volgende geschreven:
> 
> Your message starts by suggesting that this work does not belong in this working group but then moves towards discussing a solution for work that belongs in this working group.
> 
> As the CALL FOR ADOPTION comes to a close, the chairs are leaning towards interpreting your message as agreement there is work that could be done.  Note that adopting the document does not guarantee that it will be published by this working group; that will be decided as part of the discussion and review.
> 
> Is this okay with you?  If not, please do take some time to clarify your position.
> 
> Thanks,
> 
> Antoin and Jim
> 
> 
> 
> 
> 
>>> This is a formal adoption request for Extensible Provisioning Protocol
>>> adoption by REGEXT, and comment to the list, clearly stating your view.
>> 
>> I am not convinced this working group is the appropriate place for that,
>> as in particular this document seems to mostly impose directives on registries
>> off topic for EPP as a protocol, and transfer issues cover points that are
>> (one might note that multiple procedure specify a transfer "undo" procedure,
>> As discussed in other threads, I am more leaning towards a ground up discussion
>> really completely EPP related, while discussions on passwords size, complexity,
>> entropy, storage, TTLs, and so on as found in this draft are for me clearly
>> I also fear discussions may forget there are already today other models than
>> passwords needed at all any more) and other registries basically do not
>> let registrars set/handle passwords anymore, the first step of a transfer
>> is the loosing registrar to ask the registry to generate a password that
>> PS: as an exercise I reviewed how a batch of registries currently reply
>> - registrar is not sponsoring registrar, and providing invalid authInfo
>> - registrar is not sponsoring registrar, and providing correct authInfo
>> Also the content of <infData> can change, and differ - even outside of the password