Subject: [regext] Limit parameter in sorting-and-paging draft

From: Mario Loffredo <[email-masked]>
Date: Mon, 3 Feb 2020 14:12:54 +0100

Hi folks,

as a consequence of Karl Heinz's review of sorting-and-paging, I'd like 
to know your opinion about the need of a new parameter, namely "limit", 
enabling clients to send their preference about the maximum number of 
objects to be returned in response to a search query.

Do you think it would be useful?

Thanks in advance,

Mario

-- 
Dr. Mario Loffredo
Systems and Technological Development Unit
Institute of Informatics and Telematics (IIT)
National Research Council (CNR)
via G. Moruzzi 1, I-56124 PISA, Italy
Phone: +39.0503153497
Mobile: +39.3462122240
Web: http://www.iit.cnr.it/mario.loffredo

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 3 Feb 2020 13:54:04 +0000

> -----Original Message-----
> From: regext <[email-masked]> On Behalf Of Mario Loffredo
> Sent: Monday, February 3, 2020 8:13 AM
> To: [email-masked]
> Cc: Karl Heinz Wolf <[email-masked]>
> Subject: [EXTERNAL] [regext] Limit parameter in sorting-and-paging draft
> 
> Hi folks,
> 
> as a consequence of Karl Heinz's review of sorting-and-paging, I'd like to
> know your opinion about the need of a new parameter, namely "limit",

Yes, I think it would be useful, but I wonder if it will be used in practice. My experience with end users is that they want everything they can get, so I have a sneaking suspicion that people will tend to use whatever value returns the most information. If you include this parameter, please consider some suggestions about appropriate defaults and what a server can/should do if it decides that it can't or doesn't want to honor the client's request.

Scott