Subject: [regext] Significant change to sorting-and-paging

From: Mario Loffredo <[email-masked]>
Date: Mon, 10 Feb 2020 16:52:19 +0100

Hi Jim and Antoin,

this mail is for asking your opinion about a significant change on sorting-and-paging draft.

According to the last version, "totalCount" is a member of the "paging_metadata" object. However, the counting capability might be
implemented by an RDAP server without implementing pagination as well.

Such field was originally put inside "paging_metadata" because, in many REST API implementations, it pertains the pagination information.
In addition, by doing so, only two response extensions would have been defined.

For the sake of clarity, the authors think that it would be better to put "totalCount" outside "paging_metadata". Basically, this would mean to define a new
rdapConformance tag (e.g. "count_level_0") and rename the field accordingly (e.g. simply "count" or "count_all").

In authors' opinion, it might also be appropiate to rename the draft to "counting-sorting-and-paging".
  
Even if the authors don't expect any relevant feedback since the draft content would remain substantially the same, some time would be needed for discussion before starting a last call.

Does it sound reasonable for you?

Many thanks in advance,

Mario.

-- 
Dr. Mario Loffredo
Systems and Technological Development Unit
Institute of Informatics and Telematics (IIT)
National Research Council (CNR)
via G. Moruzzi 1, I-56124 PISA, Italy
Phone: +39.0503153497
Mobile: +39.3462122240
Web: http://www.iit.cnr.it/mario.loffredo

---

From: "James Galvin" <[email-masked]>
Date: Fri, 14 Feb 2020 09:52:45 -0500

Comments inline below.

Important question for the working group, does anyone object to this 
document moving to working group last call?

On 10 Feb 2020, at 10:52, Mario Loffredo wrote:

> According to the last version, "totalCount" is a member of the 
> "paging_metadata" object. However, the counting capability might be
> Such field was originally put inside "paging_metadata" because, in 
> many REST API implementations, it pertains the pagination information.
> For the sake of clarity, the authors think that it would be better to 
> put "totalCount" outside "paging_metadata". Basically, this would mean 
> to define a new
> rdapConformance tag (e.g. "count_level_0") and rename the field 
> accordingly (e.g. simply "count" or "count_all").

The chairs would prefer to evaluate the consensus of the working group.

We would prefer if folks who object to the choice you have made in the 
document would please speak up on the mailing list and make a technical 
argument against it.

Similarly, folks who support the choice you have made should speak up on 
the list in response to any objection.

> to "counting-sorting-and-paging".

In general, it’s not necessary to rename a document.

Thanks,

Antoin and Jim

>  Even if the authors don't expect any relevant feedback since the 
> draft content would remain substantially the same, some time would be 
> needed for discussion before starting a last call.
>
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext