Subject: Re: [regext] I-D Action: draft-hollenbeck-regext-rfc7482bis-02.txt

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 6 Feb 2020 15:45:47 +0000

> -----Original Message-----
> From: I-D-Announce <[email-masked]> On Behalf Of
> [email-masked]
> Sent: Thursday, February 6, 2020 10:43 AM
> To: [email-masked]
> Subject: [EXTERNAL] I-D Action: draft-hollenbeck-regext-rfc7482bis-02.txt
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>
>         Title           : Registration Data Access Protocol (RDAP) Query Format
>         Authors         : Scott Hollenbeck
>                           Andrew Lee Newton
>       Filename        : draft-hollenbeck-regext-rfc7482bis-02.txt
>       Pages           : 24
>       Date            : 2020-02-06
>
> Abstract:
>    This document describes uniform patterns to construct HTTP URLs that
>    may be used to retrieve registration information from registries
>    (including both Regional Internet Registries (RIRs) and Domain Name
>    Registries (DNRs)) using "RESTful" web access patterns.  These
>    uniform patterns define the query syntax for the Registration Data
>    Access Protocol (RDAP).
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-hollenbeck-regext-rfc7482bis/

This version of the document completes the updates for all known clarifications and corrections. We may still want to add implementation status information, so if you're an RDAP client implementor and you'd like to help move this along your input would be greatly appreciated. Beyond that, all known update work has been completed and we can queue up a "what next?" discussion for IETF-107.

Scott

---

From: "Patrick Mevzek" <[email-masked]>
Date: Thu, 06 Feb 2020 11:38:30 -0500

Hello Scott,

On Thu, Feb 6, 2020, at 10:45, Hollenbeck, Scott wrote:
> This version of the document completes the updates for all known 
> clarifications and corrections. We may still want to add implementation 
> status information, so if you're an RDAP client implementor and you'd 
> like to help move this along your input would be greatly appreciated. 

I was under the impression, but I may be wrong, that "bis" documents should/can
have a section clearly outlining the differences they bring from the original
RFC they are a bis on, so that an implementer can see immediately which area
have changes. Is this not useful there or not relevant? Or will that happen
maybe later?

As for implementations, I guess I could add data about the RDAP client one from work,
(and hence many deployment experiences similar to what is outlined in
draft-blanchet-regext-rdap-deployfindings)
as I have not being able yet to release anything for my own free one under free time.
But not sure it would add value to the document. We can discuss that separately.

-- 
  Patrick Mevzek
  [email-masked]

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 6 Feb 2020 16:49:02 +0000

> From: regext <[email-masked]> On Behalf Of Patrick Mevzek
> Sent: Thursday, February 6, 2020 11:39 AM
> To: [email-masked]
> Subject: [EXTERNAL] Re: [regext] I-D Action: draft-hollenbeck-regext-
> rfc7482bis-02.txt
>
> Hello Scott,
>
> > clarifications and corrections. We may still want to add
> > implementation status information, so if you're an RDAP client
> > implementor and you'd like to help move this along your input would be
> greatly appreciated.
>
> I was under the impression, but I may be wrong, that "bis" documents
> should/can have a section clearly outlining the differences they bring from
> the original RFC they are a bis on, so that an implementer can see
> immediately which area have changes. Is this not useful there or not
> relevant? Or will that happen maybe later?

There's a log at the end of the document. All of the changes have been described on the errata page and/or in email sent to this mailing list.

https://www.rfc-editor.org/errata/eid5621

I *could* spell out each change in detail in the document itself, but as a lazy editor I wanted to take a "less work" approach first, especially until we get a sense of reactions to the changes. If folks want to see a detailed OLD vs. NEW comparison, I'll add it.

> As for implementations, I guess I could add data about the RDAP client one
> from work, (and hence many deployment experiences similar to what is
> outlined in

Anything you're willing to contribute would be welcomed.

Scott