Subject: Re: [regext] [Ext] Re: WG LAST CALL: draft-ietf-regext-tmch-func-spec

From: Gustavo Lozano <[email-masked]>
Date: Mon, 6 Apr 2020 23:11:51 +0000

Thank you Scott,

Comments inline.

Regards,
Gustavo

On 2/28/20, 07:17, "regext on behalf of Hollenbeck, Scott" <[email-masked] on behalf of shollenbeck=[email-masked]> wrote:

    > -----Original Message-----
    > From: regext <[email-masked]> On Behalf Of Antoin Verschuren
    > Sent: Friday, February 14, 2020 10:01 AM
    > To: regext <[email-masked]>
    > Subject: [EXTERNAL] [regext] WG LAST CALL: draft-ietf-regext-tmch-func-
    > spec
    > 
    > The following working group document is believed to be ready for
    > submission to the IESG for publication as an Informational document:
    > 
    > https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dregext-2Dtmch-2Dfunc-2Dspec_&d=DwIGaQ&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=gChL047ncZhA5g-WHSBuzKDgXtyQQkPxKa1UV6_b_R4&s=Pd6hP_3xoBBmLnpmZwuxkp6BkY5qS9B6saWNRBvNP_A&e= 
    > 
    > This WG last call will end at close of business, Friday, 28 February 2020.
    > 
    > Please review this document and indicate your support (a simple “+1” is
    > sufficient) or concerns with the publication of this document by replying to
    > this message on the list.
    
    +1, but I do see some minor issues in Section 10, IANA Considerations:
    
    1. "One URI assignment have been registered by the IANA", but two assignments are requested. That text should say "Two URI assignments have been registered by the IANA".

GL- Fixed in version 07, here: https://tools.ietf.org/rfcdiff?url2=draft-ietf-regext-tmch-func-spec-07.txt

    2. It's been a recent convention to include "epp" in the URNs, e.g. "urn:ietf:params:xml:ns:epp:<identifier>" vs. "urn:ietf:params:xml:ns:<identifier>". It may be worth noting somewhere why that convention isn't being followed here. Perhaps there are existing implementations that would be difficult to change?

GL- There are existing implementations that would be extremely difficult to change. The first version of this draft is from March 2013, and the draft was developed while the TMCH implementation was ongoing.

    3. The schema URN is incorrect. "URI: urn:ietf:params:xml:ns:tmNotice-1.0" should be "URI: urn:ietf:params:xml:schema:tmNotice-1.0".

GL- Fixed in version 07, here: https://tools.ietf.org/rfcdiff?url2=draft-ietf-regext-tmch-func-spec-07.txt

    Scott
    _______________________________________________
    regext mailing list
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_regext&d=DwIGaQ&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=gChL047ncZhA5g-WHSBuzKDgXtyQQkPxKa1UV6_b_R4&s=9GzrIKxLZqhDIkAOSL0bAmHsu1UZD1ywJjm1hO2JZTc&e=

---

From: Gustavo Lozano <[email-masked]>
Date: Mon, 6 Apr 2020 23:13:01 +0000

Thank you Roger,

Comments inline.

Regards,
Gustavo

From: regext <[email-masked]> on behalf of Roger D Carney <[email-masked]>
Date: Friday, February 14, 2020 at 11:06
To: regext <[email-masked]>
Subject: [Ext] Re: [regext] WG LAST CALL: draft-ietf-regext-tmch-func-spec

Good Afternoon,

As I have mentioned previously, this informational draft has quite a few policy dependencies built into it that are currently being reviewed and will be changed by ICANN. The authors have addressed several of these potential policy issues but there are some that still exist (e.g. TCNIDs generated twice daily; use and definition of <tmNotice:notBefore> and <tmNotice:notAfter>).

I do support sending this to the IESG as this draft does depict the current operating environment, but due to these dependent policy items, I do believe this will need to be revisited and corrected once these policy decisions are made/changed, I would guess, at ICANN speed, in the next 2-3 years.

There are a few wording/grammatical issues that a good read should resolve (e.g. section 5.2.2, second paragraph, I believe “effective allocate” is meant to be “effectively allocate”, copyright dates should be updated).

Thanks

Roger

-----Original Message-----
From: regext <[email-masked]> On Behalf Of Antoin Verschuren
Sent: Friday, February 14, 2020 9:01 AM
To: regext <[email-masked]>
Subject: [regext] WG LAST CALL: draft-ietf-regext-tmch-func-spec

Notice: This email is from an external sender.

The following working group document is believed to be ready for submission to the IESG for publication as an Informational document:

https://datatracker.ietf.org/doc/draft-ietf-regext-tmch-func-spec/ [datatracker.ietf.org]<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dregext-2Dtmch-2Dfunc-2Dspec_&d=DwMGaQ&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=73ufxAmSXCd0vveExmXTvdE3z6y5K6uMRGKBxBwEv9w&s=udjLQkEClJS45xb0nauQ2dvQDaSdp-hu6TxkGa_ZADQ&e=>

Please review this document and indicate your support (a simple “+1” is sufficient) or concerns with the publication of this document by replying to this message on the list.

The document shepherd for this document is Ulrich Wisser.

Thanks!

Jim and Antoin

regext mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/regext [ietf.org]<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_regext&d=DwMGaQ&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=73ufxAmSXCd0vveExmXTvdE3z6y5K6uMRGKBxBwEv9w&s=55GGKNNukGpdcN7sq_NknUMNSZi0WSkXSsvluHdKta8&e=>