Subject: [regext] Virtual Interim Meeting Question: XXXX and YYYY in rfc7482bis

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 28 Apr 2020 15:18:46 +0000

During yesterday's meeting there was a question about the text on slide 9 of my rfc7482bis deck. It said:

"Syntax: domains?nsLdhName =<domain search pattern>
Syntax: domains?nsIp =<domain search pattern>
XXXX is a search pattern representing a domain name in "letters, digits, hyphen" (LDH) format [RFC5890] in a zone administered by the server operator of a DNR
YYYY is a search pattern representing a host name in "letters, digits, hyphen" format [RFC5890] in a zone administered by the server operator of a DNR"

He wondered where the XXXX and YYYY fit into the query syntax as shown on the slide The text on the slide didn't include all of the text from the document, so that's why these look disjoint. The XXXX and YYYY are actually part of other queries that appear in the same section. It's actually clear when you take a look at the document.

Scott

---

From: Alexander Mayrhofer <[email-masked]>
Date: Wed, 29 Apr 2020 08:35:26 +0200

Hello Scott,

> -----Ursprüngliche Nachricht-----
> Von: regext <[email-masked]> Im Auftrag von Hollenbeck, Scott
> Betreff: [regext] Virtual Interim Meeting Question: XXXX and YYYY in
> rfc7482bis

[AM] My point was that the text on the slide...

> Syntax: domains?nsIp =<domain search pattern> XXXX is a search pattern
> representing a domain name in "letters, digits, hyphen" (LDH) format
> [RFC5890] in a zone administered by the server operator of a DNR YYYY is a
> search pattern representing a host name in "letters, digits, hyphen" format
> [RFC5890] in a zone administered by the server operator of a DNR"

[AM] .. contained one query based on and LDH name, and one query based on an IP address, but both search patterns referred to LDH names. I had the impression that one of the search patterns would need to be an IP address (for the second query parameter). But I do admit that was an uneducated comment that I made without reading the document itself.

> He wondered where the XXXX and YYYY fit into the query syntax as shown on
> the slide The text on the slide didn't include all of the text from the
> document, so that's why these look disjoint. The XXXX and YYYY are actually
> part of other queries that appear in the same section. It's actually clear when
> you take a look at the document.

[AM] Thanks for clarifying. I'll go back and "read the source, luke".

Best,
Alex

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 29 Apr 2020 12:54:35 +0000

> -----Original Message-----
> From: regext <[email-masked]> On Behalf Of Alexander Mayrhofer
> Sent: Wednesday, April 29, 2020 2:35 AM
> To: Hollenbeck, Scott <shollenbeck=[email-masked]>;
> [email-masked]
> Subject: [EXTERNAL] Re: [regext] Virtual Interim Meeting Question: XXXX
> and YYYY in rfc7482bis
>
> Hello Scott,
>
> > [RFC5890] in a zone administered by the server operator of a DNR YYYY
> > is a search pattern representing a host name in "letters, digits,
> > hyphen" format [RFC5890] in a zone administered by the server operator
> of a DNR"
>
> [AM] .. contained one query based on and LDH name, and one query based
> on an IP address, but both search patterns referred to LDH names. I had the
> impression that one of the search patterns would need to be an IP address
> (for the second query parameter). But I do admit that was an uneducated
> comment that I made without reading the document itself.

It turns out that the text on the slide was incorrect. The document itself says this:

   Syntax: domains?name=<domain search pattern>

   Syntax: domains?nsLdhName=<nameserver search pattern>

   Syntax: domains?nsIp=<IP address search pattern>

So the document itself is correct. Sorry for the confusion!

Scott