Subject: Re: [regext] milestones for recently adopted documents

From: Roger D Carney <[email-masked]>
Date: Mon, 4 May 2020 13:04:21 +0000

Good Morning,

Thanks for your review and comments Patrick.

For the questions you brought up:

DDoS/SRS down - This draft is not intended to support emergency notifications.

<maint:environment> - Draft will be updated to include language describing type and name attributes.

<maint:description> - Draft will be updated to match text to schema. Simply, we limited size to restrict someone from writing a book, is there an alternative size people would suggest?

Thanks
Roger, Tobias, Jody

________________________________
From: regext <[email-masked]> on behalf of Patrick Mevzek <[email-masked]>
Sent: Monday, April 27, 2020 12:32 AM
To: [email-masked] <[email-masked]>
Subject: Re: [regext] milestones for recently adopted documents

Notice: This email is from an external sender.

On Fri, Mar 6, 2020, at 10:02, James Galvin wrote:
> The co-chairs have discussed proposed milestones for the recently
> adopted documents.  We would like to propose the following.
>
> https://datatracker.ietf.org/doc/draft-ietf-regext-epp-registry-maintenance/
>       2020 October - Jim Galvin will be document shepherd

[..]

> Document authors are encouraged to begin discussion of these documents
> on the list at this time, in preparation for asking for submission to
> the IESG for publication.

In that regard, for this document, I can offer again my list of comments and questions
already asked 2 years ago on the mailing-list without any follow-up:
https://mailarchive.ietf.org/arch/msg/regext/d79sscIkCy0RR1yv-VZb3d2_D48/

They were also some procedural interrogations, but the technical parts are below.

Before that, now with a fresh view, I'm wondering if "maintenances" are really
objects that should managed through EPP and what is the benefit.

If I take for example one of the major ccTLD disruption from this week-end,
due to DDOS, the EPP server was completely unreachable. I am also sure the registry
at that moment had other things to worry about than enqueing to all registrars
EPP polling queue a message about an emergency maintenance... which can not
be read anyway as the server is unreachable.
So right now I am not sure anymore to be convinced that:
- maintenances are objects in EPP ecosystem, like domains or hosts
(in fact they are not *registrar* objects in registry database, which is what EPP is bout)
- if doing so does really provide benefit in operations, especially for the
unscheduled maintenance cases

Back to the technical part from 2 years ago:
I did a quick glance on my past technical comments anyway, it seems the document did not change significantly since then
so most if not all points apply.
In fact in the meantime I found other 2 areas of concern that I did not bother
post about but here they are:

*)

"     <maint:environment>
       MUST be present and indicates the type of the affected system;
       values SHOULD either be 'production', 'ote', 'staging' or 'dev'"

but in schema:
     <complexType name="envType">
       <simpleContent>
         <extension base="token">
           <attribute name="type" type="maint:envEnum" use="required"/>
           <attribute name="name" type="token" use="optional"/>
         </extension>
       </simpleContent>
     </complexType>

So text and schema do not seem to align very well and at the very
least the text does not say anything about the "type" and "name" attributes.
Also, since "type" is an enum, you can not say "values SHOULD either be...", they MUST be one of the values in the enum list.
And you do not list the "custom" value among the possible ones.

*)

"     <maint:description>
       MAY be present and provides a freeform description of the
       maintenance without having to create and traverse an external
       resource. The maximum length MUST NOT exceed 1024 bit."

and in schema:
     <complexType name="descriptionType">
       <restriction base="string">
         <maxLength value="1024"/>
       </restriction>
     </complexType>

So, it should be 1024 characters in the text, not 1024 bit (sic).
Also, I see no reason for this limit, can you care to explain why description content, being freeform for human consumption, should be limited at the protocol level?

--
  Patrick Mevzek
  [email-masked]

_______________________________________________
regext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/regext

---

From: "Patrick Mevzek" <[email-masked]>
Date: Mon, 04 May 2020 10:02:59 -0500

Hello,

>  For the questions you brought up:

If possible, please also see the points I raised earlier in:
https://mailarchive.ietf.org/arch/msg/regext/d79sscIkCy0RR1yv-VZb3d2_D48/

>  DDOS/SRS down - This draft is not intended to support emergency notifications.

Ok but then the draft says:

     <maint:reason>
       MUST be present and contains the reason behind the maintenance;
       values SHOULD either be 'planned' or 'emergency'.

emergency is listed as a value...

>  <maint:description> - Draft will be updated to match text to schema. 
> Simply, we limited size to restrict someone from writing a book, is 
> there an alternative size people would suggest?

I see no reason to limit it at the protocol level.
And even if you do limit it, I do not think that "MUST NOT exceed 1024 bit." is the adequate description for a string of characters.

-- 
  Patrick Mevzek
  [email-masked]