Subject: [regext] [Technical Errata Reported] RFC7483 (6158)

From: RFC Errata System <[email-masked]>
Date: Wed, 6 May 2020 11:56:26 -0700 (PDT)

The following errata report has been submitted for RFC7483,
"JSON Responses for the Registration Data Access Protocol (RDAP)".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6158

--------------------------------------
Type: Technical
Reported by: Scott Hollenbeck <[email-masked]>

Section: 10.2.3

Original Text
-------------
Description: The object instance was transferred from one registrant to another.

Corrected Text
--------------
Description: The object instance was transferred from one registrar to another.

Notes
-----
I believe the corrected text is what was intended for this particular registry value, and is what is being implemented by operators today. Registrant-to-registrant transfers are also possible, but they're not performed using EPP and are not logged as an event action. The text in the RFC should be changed and the description of the action in the IANA registry should also be changed.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7483 (draft-ietf-weirds-json-response-14)
--------------------------------------
Title               : JSON Responses for the Registration Data Access Protocol (RDAP)
Publication Date    : March 2015
Author(s)           : A. Newton, S. Hollenbeck
Category            : PROPOSED STANDARD
Source              : Web Extensible Internet Registration Data Service
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 6 May 2020 18:58:44 +0000

FYI, folks.

Scott

-----Original Message-----
From: RFC Errata System <[email-masked]>
Sent: Wednesday, May 6, 2020 2:56 PM
To: [email-masked]; Hollenbeck, Scott <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: Hollenbeck, Scott <[email-masked]>; [email-masked]; [email-masked]
Subject: [EXTERNAL] [Technical Errata Reported] RFC7483 (6158)

The following errata report has been submitted for RFC7483, "JSON Responses for the Registration Data Access Protocol (RDAP)".

--------------------------------------
You may review the report below and at:
https://secure-web.cisco.com/1_k1UcIrAJJBcJC9sHLsu3Lv0d_MIY0c_cjS3-eWGvSkEgZM7K-O9i9kLrC_MY0gdVaZEeUEA4n_sGl2JeaG_X2P2GNzEnX5WY4JxgI1qXtWnX-J8EXa5-rPVbZvgirOgQmUWinitPU4CcXbKLg6qT2jK1cD0wY-e3d1Tn-jJz9OkgBL-TKQFiqRCFunTpRLOGUbIY4OcX70RM2VSSzvjxxPAyoFm2j1ayh08JbpZQT-OIFC8akHgomkyCToi5-y4V5CnfFqVwv2QXXVrGCCAIQ/https%3A%2F%2Fwww.rfc-editor.org%2Ferrata%2Feid6158

Section: 10.2.3

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party can log in to change the status and edit the report, if necessary.

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 7 May 2020 16:43:17 +0000

(Updating a few email addresses...)

> To: [email-masked]; Hollenbeck, Scott <[email-masked]>;
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> The following errata report has been submitted for RFC7483, "JSON
> Responses for the Registration Data Access Protocol (RDAP)".
>
> https://secure-web.cisco.com/1_k1UcIrAJJBcJC9sHLsu3Lv0d_MIY0c_cjS3-
> eWGvSkEgZM7K-
> O9i9kLrC_MY0gdVaZEeUEA4n_sGl2JeaG_X2P2GNzEnX5WY4JxgI1qXtWnX-
> J8EXa5-rPVbZvgirOgQmUWinitPU4CcXbKLg6qT2jK1cD0wY-e3d1Tn-jJz9OkgBL-
> TKQFiqRCFunTpRLOGUbIY4OcX70RM2VSSzvjxxPAyoFm2j1ayh08JbpZQT-
> OIFC8akHgomkyCToi5-
> y4V5CnfFqVwv2QXXVrGCCAIQ/https%3A%2F%2Fwww.rfc-
> editor.org%2Ferrata%2Feid6158
>
> I believe the corrected text is what was intended for this particular registry
> value, and is what is being implemented by operators today. Registrant-to-
> registrant transfers are also possible, but they're not performed using EPP
> and are not logged as an event action. The text in the RFC should be changed
> and the description of the action in the IANA registry should also be changed.
>
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please use
> "Reply All" to discuss whether it should be verified or rejected. When a
> decision is reached, the verifying party can log in to change the status and
> edit the report, if necessary.
>

I'd like to suggest that this erratum be verified and that IANA be instructed to update the description of the registry value by changing "registrant" to "registrar".

Scott