Subject: Re: [regext] [Ext] Robert Wilton's Discuss on draft-ietf-regext-data-escrow-07: (with DISCUSS and COMMENT)

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 7 May 2020 16:02:25 +0000

Hi Gustavo,

> -----Original Message-----
> From: Gustavo Lozano <[email-masked]>
> Sent: 17 April 2020 00:59
> To: Rob Wilton (rwilton) <[email-masked]>; The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked];
> [email-masked]; James Gould <[email-masked]>
> Subject: Re: [Ext] Robert Wilton's Discuss on draft-ietf-regext-data-
> escrow-07: (with DISCUSS and COMMENT)
> 
> Thank you Robert,
> 
> Comments inline, prefixed with GL -
> 
> Regards,
> Gustavo
> 
> On 4/8/20, 10:04, "Robert Wilton via Datatracker" <[email-masked]>
> wrote:
> 
>     Robert Wilton has entered the following ballot position for
>     draft-ietf-regext-data-escrow-07: Discuss
> 
>     When responding, please keep the subject line intact and reply to all
>     email addresses included in the To and CC lines. (Feel free to cut
> this
>     introductory paragraph, however.)
> 
> 
>     Please refer to https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_iesg_statement_discuss-
> 2Dcriteria.html&d=DwICaQ&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=V
> bweciUcwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=gZgTftWuC9SsZdq_QWTwb-
> T4RjxNiDq9i2krpdXgHfM&s=QHMiOWDTGvuiZh0DtVdWwx_J4DxECAFWGpr-Srux4pQ&e=
>     for more information about IESG DISCUSS and COMMENT positions.
> 
> 
>     The document, along with other ballot positions, can be found here:
>     https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dietf-2Dregext-2Ddata-
> 2Descrow_&d=DwICaQ&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciU
> cwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=gZgTftWuC9SsZdq_QWTwb-
> T4RjxNiDq9i2krpdXgHfM&s=YhAtC7C7hDwiSnfUvetOd_lI7t6Q5KkhtITQ9Vv9OXE&e=
> 
> 
> 
>     ----------------------------------------------------------------------
>     DISCUSS:
>     ----------------------------------------------------------------------
> 
>     Hi,
> 
>     I spotted some issues with the terminology and the description of the
> algorithm
>     that I would like you to please address.
> 
>     Section 2: Terminology
> 
>     The definitions provided for "Differential" vs "Incremental" are the
> opposite
>     to their standard meaning in backups.  The term definitions should be
> reversed
>     to align with the common vernacular.  I.e. differential is the diff
> against the
>     last full backup, incremental is the backup since the backup (of any
> type) was
>     performed.
> 
> GL - The definition of differential in the draft complies with the legal
> use in the gTLD space. The amount of work required to make this change,
> make it unrealistic. It's worth mentioning that data escrow is not the
> same as a backup.
> 

I don't see a huge difference between a remote backup vs data escrow.  E.g., if I use an online backup service then it seems that they are storing data securely on my behalf that I can subsequently recover if required.  It feels like the concepts are so very similar that using the same set of terms with different meanings could easily cause confusion.

The choice here is between having 
(i) a protocol that matches legal data escrow definitions but could easily be confused by people who see this as a type of remote backup
(ii) a protocol specification that matches the widely used common definitions for these terms (e.g. https://en.wikipedia.org/wiki/Incremental_backup, https://en.wikipedia.org/wiki/Differential_backup), but that is opposite to the legal definitions.

It seems to me that the legal definitions are really self-contained within their documents, and potentially could be updated over time.  However, I see no way that we can convince the world in general to reverse their understanding/usage of these terms, and hence if you are to use these terms, I still believe that they should align to their common usage rather than the legal definitions.

Of course, an alternative solution would be to define and use completely different terms for the incremental and differential deposits, e.g. full deposit, full-delta deposit, minimal-delta deposit.

Thanks,
Rob

---

From: Barry Leiba <[email-masked]>
Date: Thu, 7 May 2020 13:36:46 -0400

I'm afraid I have to agree with Gustavo that the terms used here need
to match what's used in the domain this is written for.  It's often
the case that things mean different things in different domains, and
sometimes those domains are similar enough that we wish it weren't the
case.  When it is, that's sad... but.

Unless someone in the working group wants to tell us that Gustavo is
wrong and we should go with what Rob suggests, I think the discussion
has been had.  I *would* like to hear some input from the working
group on this, though, before we make any final decisions.

Barry

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 7 May 2020 17:53:37 +0000

> From: regext <[email-masked]> On Behalf Of Barry Leiba
> Sent: Thursday, May 7, 2020 1:37 PM
> To: Rob Wilton (rwilton) <rwilton=[email-masked]>
> Cc: Gould, James <[email-masked]>; [email-masked]; The IESG
> <[email-masked]>; Gustavo Lozano <[email-masked]>;
> [email-masked]; [email-masked]
> Subject: [EXTERNAL] Re: [regext] [Ext] Robert Wilton's Discuss on draft-ietf-
> regext-data-escrow-07: (with DISCUSS and COMMENT)
>
> I'm afraid I have to agree with Gustavo that the terms used here need to
> match what's used in the domain this is written for.  It's often the case that
> things mean different things in different domains, and sometimes those
> domains are similar enough that we wish it weren't the case.  When it is,
> that's sad... but.
>
> Unless someone in the working group wants to tell us that Gustavo is wrong
> and we should go with what Rob suggests, I think the discussion has been
> had.  I *would* like to hear some input from the working group on this,
> though, before we make any final decisions.

A description of the terms tied to their use in the document really should be sufficient.

Scott

---

From: Roger D Carney <[email-masked]>
Date: Thu, 7 May 2020 18:42:53 +0000

+1 Scott.

________________________________
From: regext <[email-masked]> on behalf of Hollenbeck, Scott <shollenbeck=[email-masked]>
Sent: Thursday, May 7, 2020 12:53 PM
To: [email-masked] <[email-masked]>; rwilton=[email-masked] <rwilton=[email-masked]>
Cc: Gould, James <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [regext] [Ext] Robert Wilton's Discuss on draft-ietf-regext-data-escrow-07: (with DISCUSS and COMMENT)

Notice: This email is from an external sender.

Scott
_______________________________________________
regext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/regext

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 12 May 2020 16:15:37 +0000

Hi Barry, Gustavo, all,

Thanks for your comments.

On the one hand, the scope of this document is tied to Domain Registries (e.g. its title, and the bulk of the description), but on the other hand the abstract and introduction indicate that the data escrow definitions can be used for any data escrow, and it still seems to me that data escrow is just a special form of backup.  I.e., I can see that these two domains have the potential to overlap over time and these terms could cause confusion.

However, it does appear that I'm in the rough, and I don't wish to needlessly hold up this document.

I could probably live with a short paragraph in the introduction, highlighting that these terms are used in the somewhat similar domain of backup operations, but with different meanings, and hence readers should pay attention to the precise definitions.  E.g., perhaps something like:

This document defines terms for three types of deposit that are used in data escrow: Full, Differential and Incremental.  These same terms are also commonly used in the related domain of data backups, but with different definitions.  Hence, readers are advised to read the terminology section carefully to understand their precise meanings when used for data escrow.

Regards,
Rob

> From: Barry Leiba <[email-masked]>
> Sent: 07 May 2020 18:37
> To: Rob Wilton (rwilton) <[email-masked]>
> Cc: Gustavo Lozano <[email-masked]>; The IESG <[email-masked]>;
> [email-masked]; James Gould <[email-masked]>;
> > I don't see a huge difference between a remote backup vs data escrow.
> E.g., if I use an online backup service then it seems that they are
> storing data securely on my behalf that I can subsequently recover if
> required.  It feels like the concepts are so very similar that using the
> same set of terms with different meanings could easily cause confusion.
> >
> > (i) a protocol that matches legal data escrow definitions but could
> easily be confused by people who see this as a type of remote backup
> > (ii) a protocol specification that matches the widely used common
> definitions for these terms (e.g.
> https://en.wikipedia.org/wiki/Incremental_backup,
> https://en.wikipedia.org/wiki/Differential_backup), but that is opposite
> to the legal definitions.
> >
> > It seems to me that the legal definitions are really self-contained
> within their documents, and potentially could be updated over time.
> However, I see no way that we can convince the world in general to reverse
> their understanding/usage of these terms, and hence if you are to use
> these terms, I still believe that they should align to their common usage
> rather than the legal definitions.
> >
> > Of course, an alternative solution would be to define and use completely
> different terms for the incremental and differential deposits, e.g. full
> deposit, full-delta deposit, minimal-delta deposit.
> >
> > Thanks,
> > Rob
> >

---

From: Gustavo Lozano <[email-masked]>
Date: Tue, 12 May 2020 23:17:28 +0000

Hi Rob,

Updates in version 09. See, https://www.ietf.org/rfcdiff?url2=draft-ietf-regext-data-escrow-09

Thank you for your feedback.

Regards,
Gustavo

On 5/12/20, 09:16, "Rob Wilton (rwilton)" <[email-masked]> wrote:

    Hi Barry, Gustavo, all,

    Regards,
    Rob

    > https://urldefense.proofpoint.com/v2/url?u=https-3A__en.wikipedia.org_wiki_Incremental-5Fbackup&d=DwIGaQ&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=1L8mecOmXYHf-S9_N59ShLSZlCtF2CNXAow6FvYCD-I&s=IF3CR_PqF7CusnR8FLweNe6ktIM2W75cVORcdw8ILoI&e= ,
    > https://urldefense.proofpoint.com/v2/url?u=https-3A__en.wikipedia.org_wiki_Differential-5Fbackup&d=DwIGaQ&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciUcwYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=1L8mecOmXYHf-S9_N59ShLSZlCtF2CNXAow6FvYCD-I&s=kp2_C7D5tVWMc9vG1WRHtEjmXycwluQCWa6IriCIObc&e= ), but that is opposite

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 13 May 2020 15:09:45 +0000

Hi Gustavo,

Thanks for the update and addressing my comments.  I've cleared the discuss.

Regards,
Rob

> Sent: 13 May 2020 00:17
> To: Rob Wilton (rwilton) <[email-masked]>; Barry Leiba
> <[email-masked]>
> Cc: The IESG <[email-masked]>; [email-masked]; James Gould
> <[email-masked]>; [email-masked]; draft-ietf-regext-data-
> [email-masked]
>     On the one hand, the scope of this document is tied to Domain
> Registries (e.g. its title, and the bulk of the description), but on the
> other hand the abstract and introduction indicate that the data escrow
> definitions can be used for any data escrow, and it still seems to me that
> data escrow is just a special form of backup.  I.e., I can see that these
> two domains have the potential to overlap over time and these terms could
> cause confusion.
> 
>     I could probably live with a short paragraph in the introduction,
> highlighting that these terms are used in the somewhat similar domain of
> backup operations, but with different meanings, and hence readers should
> pay attention to the precise definitions.  E.g., perhaps something like:
> 
>     This document defines terms for three types of deposit that are used
> in data escrow: Full, Differential and Incremental.  These same terms are
> also commonly used in the related domain of data backups, but with
> different definitions.  Hence, readers are advised to read the terminology
> section carefully to understand their precise meanings when used for data
> escrow.
> 
>     Regards,
>     Rob
> 
> 
>     > > >     When responding, please keep the subject line intact and
> reply to
>     > all
>     > > >     Please refer to
>     > > >     The document, along with other ballot positions, can be
> found
>     > here:
>     > > >     ------------------------------------------------------------
> ------
>     > ----
>     > > >     DISCUSS:
>     > > >     ------------------------------------------------------------
> ------
>     > ----
>     > > >
>     > > >     Hi,
>     > > >
>     > > >     I spotted some issues with the terminology and the
> description of
>     > the
>     > > > algorithm
>     > > >     The definitions provided for "Differential" vs "Incremental"
> are
>     > the
>     > > > opposite
>     > > >     to their standard meaning in backups.  The term definitions
> should
>     > be
>     > > > reversed
>     > > >     to align with the common vernacular.  I.e. differential is
> the
>     > diff
>     > > > against the
>     > > >     last full backup, incremental is the backup since the backup
> (of
>     > any
>     > > > type) was
>     > > >     performed.
>     > > >
>     > > > GL - The definition of differential in the draft complies with
> the
>     > legal
> 3A__en.wikipedia.org_wiki_Incremental-
> 5Fbackup&d=DwIGaQ&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciUc
> wYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=1L8mecOmXYHf-
> S9_N59ShLSZlCtF2CNXAow6FvYCD-
> I&s=IF3CR_PqF7CusnR8FLweNe6ktIM2W75cVORcdw8ILoI&e= ,
> 3A__en.wikipedia.org_wiki_Differential-
> 5Fbackup&d=DwIGaQ&c=FmY1u3PJp6wrcrwll3mSVzgfkbPSS6sJms7xcl4I5cM&r=VbweciUc
> wYQpIOZDSxl0ezGd1hGDtd-0BvgAgfmwfE0&m=1L8mecOmXYHf-
> S9_N59ShLSZlCtF2CNXAow6FvYCD-
> I&s=kp2_C7D5tVWMc9vG1WRHtEjmXycwluQCWa6IriCIObc&e= ), but that is opposite