Subject: [regext] Fwd: New Version Notification for draft-ietf-regext-rdap-sorting-and-paging-18.txt

From: Mario Loffredo <[email-masked]>
Date: Fri, 2 Oct 2020 17:24:32 +0200

Hi everybody,

hope this new version includes all the edits suggested by Ben and Roman.

Ben, please note I updated the "Introduction" section again. I think now 
it is consistent with your remark.

Happy to take any feedback should I have missed something.

Best,

Mario

-------- Messaggio Inoltrato --------
Oggetto: 	New Version Notification for 
draft-ietf-regext-rdap-sorting-and-paging-18.txt
Data: 	Fri, 02 Oct 2020 07:42:29 -0700
Mittente: 	[email-masked]
A: 	Maurizio Martinelli <[email-masked]>, Scott 
Hollenbeck <[email-masked]>, Mario Loffredo 
<[email-masked]>

A new version of I-D, draft-ietf-regext-rdap-sorting-and-paging-18.txt
has been successfully submitted by Mario Loffredo and posted to the
IETF repository.

Name: draft-ietf-regext-rdap-sorting-and-paging
Revision: 18
Title: Registration Data Access Protocol (RDAP) Query Parameters for 
Result Sorting and Paging
Document date: 2020-10-02
Group: regext
Pages: 31
URL: 
https://www.ietf.org/id/draft-ietf-regext-rdap-sorting-and-paging-18.txt
Status: 
https://datatracker.ietf.org/doc/draft-ietf-regext-rdap-sorting-and-paging/
Htmlized: 
https://datatracker.ietf.org/doc/html/draft-ietf-regext-rdap-sorting-and-paging
Htmlized: 
https://tools.ietf.org/html/draft-ietf-regext-rdap-sorting-and-paging-18
Diff: 
https://www.ietf.org/rfcdiff?url2=draft-ietf-regext-rdap-sorting-and-paging-18

Abstract:
The Registration Data Access Protocol (RDAP) does not include core
functionality for clients to provide sorting and paging parameters
for control of large result sets. This omission can lead to
unpredictable server processing of queries and client processing of
responses. This unpredictability can be greatly reduced if clients
can provide servers with their preferences for managing large
responses. This document describes RDAP query extensions that allow
clients to specify their preferences for sorting and paging result
sets.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 2 Oct 2020 15:17:48 -0700

> it is consistent with your remark.

It is more than consistent -- it is very well said; thank you.

I have updated my ballot position in the datatracker.

Thanks again for the updates and explanations!

-Ben

---

From: Roman Danyliw <[email-masked]>
Date: Fri, 2 Oct 2020 22:57:22 +0000

Hi Mario!

Thanks for merging all of the updates we discussed into -18.  This addressed my DISCUSS and COMMENTS.  I’ve cleared my ballot.

Regards,
Roman

From: Mario Loffredo <[email-masked]>
Sent: Friday, October 2, 2020 11:25 AM
To: [email-masked]; Benjamin Kaduk <[email-masked]>; Roman Danyliw <[email-masked]>
Subject: Fwd: New Version Notification for draft-ietf-regext-rdap-sorting-and-paging-18.txt

Hi everybody,

Ben, please note I updated the "Introduction" section again. I think now it is consistent with your remark.

Best,

Mario

-------- Messaggio Inoltrato --------
Oggetto:

New Version Notification for draft-ietf-regext-rdap-sorting-and-paging-18.txt

Data:

Fri, 02 Oct 2020 07:42:29 -0700

Mittente:

[email-masked]<mailto:[email-masked]>

A:

Maurizio Martinelli <[email-masked]><mailto:[email-masked]>, Scott Hollenbeck <[email-masked]><mailto:[email-masked]>, Mario Loffredo <[email-masked]><mailto:[email-masked]>

Name: draft-ietf-regext-rdap-sorting-and-paging
Revision: 18
Title: Registration Data Access Protocol (RDAP) Query Parameters for Result Sorting and Paging
Document date: 2020-10-02
Group: regext
Pages: 31
URL: https://www.ietf.org/id/draft-ietf-regext-rdap-sorting-and-paging-18.txt
Status: https://datatracker.ietf.org/doc/draft-ietf-regext-rdap-sorting-and-paging/
Htmlized: https://datatracker.ietf.org/doc/html/draft-ietf-regext-rdap-sorting-and-paging
Htmlized: https://tools.ietf.org/html/draft-ietf-regext-rdap-sorting-and-paging-18
Diff: https://www.ietf.org/rfcdiff?url2=draft-ietf-regext-rdap-sorting-and-paging-18

Abstract:

The IETF Secretariat