Subject: [regext] Fwd: Re: IANA Considerations in draft-ietf-regext-rdap-reverse-search

From: Mario Loffredo <[email-masked]>
Date: Tue, 20 Oct 2020 14:42:17 +0200

Hi all,

as a consequence of last discussion about rdapConformance, I propose to 
update RFC7483bis in order to clarify that rdapConformance in the help 
response must be used to signal the conformances with all the 
specifications implemented by the RDAP server. For any other response, 
rdapConformance must provide only hints as to the specifications used in 
the construction of the response.

Additionally, I wonder whether or not the rdapConformance values should 
be returned according to the user profile. Does an RDAP user really need 
to know about services that he won't be able to request?

Best,
Mario

-------- Messaggio Inoltrato --------
Oggetto: 	Re: [regext] IANA Considerations in 
draft-ietf-regext-rdap-reverse-search
Data: 	Fri, 31 Jul 2020 19:12:36 +0200
Mittente: 	Mario Loffredo <[email-masked]>
A: 	Jasdip Singh <[email-masked]>, Patrick Mevzek <[email-masked]>, 
[email-masked] <[email-masked]>

Hi all,

if I understood well the rdapConformance content in the help response 
should be different from that included in the other responses. Right?

I misunderstood Scott's proposal as a mean by which a server could 
inform a client about the supported features any time regardless the 
response content.

In that sense, I proposed the server could distinguish the 
rdapConformance content according the user profile.

I have no objection to this solution but I think that the two cases 
above should be outlined in RFC7483bis.

Best,

Mario

Il 31/07/2020 18:50, Jasdip Singh ha scritto:
> Agree with Patrick's points about rdapConformance in the help response 
> informing about all capabilities and rdapConformance being more 
> specific for a particular query response.
>
> Jasdip
>
> On 7/31/20, 12:29 PM, "regext on behalf of Patrick Mevzek" 
> <[email-masked] on behalf of [email-masked]> wrote:
>
> On Fri, Jul 31, 2020, at 11:21, Hollenbeck, Scott wrote:
> > Note "supported extensions". This is why I'm saying that we need to
> > register all extensions with IANA
> I agree.
> > and include them in the
> > rdapConformance data structure even if they don't describe a response
> > extension.
> I agree, everything should be listed in the reply to an help query.
> I am just saying that for any other reply that is a specific one on a 
> specific resource
> then the rdapConformance should just list the "extensions" needed to 
> understand this
> specific response, and not list absolutely all extensions the server 
> knows about
> (and that are irrelevant for this specific response).
> The list of what is written in the response should certainly not be 
> just server policy,
> especially if there is no automated way to learn about this policy. 
> Otherwise if you include
> options like that (the list presented might be the list of all server 
> extensions OR only the subset needed for this specific response) AND 
> there is no way for the client to know which
> case he is in, it immediately creates interoperability problems. I 
> prefer no such options
> and the protocol clearly defining the content. Or if such options are 
> really needed
> (if help response is always all extensions, and any other response is 
> just the specific extensions needed, then nothing more is needed), 
> there should be a signal to know which
> case we are in.
> > The help response should include supported
> > extensions that are available to that client.
> Yes, the help response allows to "discover" all possible extensions 
> from a specific client.
> --
> Patrick Mevzek
> [email-masked]
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext
>
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext

-- 
Dr. Mario Loffredo
Systems and Technological Development Unit
Institute of Informatics and Telematics (IIT)
National Research Council (CNR)
via G. Moruzzi 1, I-56124 PISA, Italy
Phone: +39.0503153497
Mobile: +39.3462122240
Web: http://www.iit.cnr.it/mario.loffredo

_______________________________________________
regext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/regext

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 20 Oct 2020 13:00:51 +0000

From: regext <[email-masked]> On Behalf Of Mario Loffredo
Sent: Tuesday, October 20, 2020 8:42 AM
To: [email-masked]
Subject: [EXTERNAL] [regext] Fwd: Re: IANA Considerations in draft-ietf-regext-rdap-reverse-search

Hi all,

as a consequence of last discussion about rdapConformance, I propose to update RFC7483bis in order to clarify that rdapConformance in the help response must be used to signal the conformances with all the specifications implemented by the RDAP server. For any other response, rdapConformance must provide only hints as to the specifications used in the construction of the response.

[SAH] This makes sense.

Additionally, I wonder whether or not the rdapConformance values should be returned according to the user profile. Does an RDAP user really need to know about services that he won't be able to request?

[SAH] What user profile? There’s no such thing described in the specifications.

Scott

---

From: Mario Loffredo <[email-masked]>
Date: Tue, 20 Oct 2020 16:03:54 +0200

Hi Scott,

Il 20/10/2020 15:00, Hollenbeck, Scott ha scritto:
>
> *From:* regext <[email-masked]> *On Behalf Of *Mario Loffredo
> *Sent:* Tuesday, October 20, 2020 8:42 AM
> *To:* [email-masked]
> *Subject:* [EXTERNAL] [regext] Fwd: Re: IANA Considerations in 
> as a consequence of last discussion about rdapConformance, I propose 
> to update RFC7483bis in order to clarify that rdapConformance in the 
> help response must be used to signal the conformances with all the 
> rdapConformance must provide only hints as to the specifications used 
> in the construction of the response.
>
> */[SAH] This makes sense./*
>
> Additionally, I wonder whether or not the rdapConformance values 
> should be returned according to the user profile. Does an RDAP user 
> really need to know about services that he won't be able to request?
>
> */[SAH] What user profile? There’s no such thing described in the 
> specifications./*
>
/*I was simply referring to what is described in 
https://tools.ietf.org/html/rfc7481#section-3.3
*/

/*Mario*/

> *//*
> */Scott/*

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 20 Oct 2020 14:21:56 +0000

From: Mario Loffredo <[email-masked]>
Sent: Tuesday, October 20, 2020 10:04 AM
To: Hollenbeck, Scott <[email-masked]>; [email-masked]
Subject: [EXTERNAL] Re: [regext] Fwd: Re: IANA Considerations in draft-ietf-regext-rdap-reverse-search

Hi Scott,

   From: regext <[email-masked]><mailto:[email-masked]> On Behalf Of Mario Loffredo
   Sent: Tuesday, October 20, 2020 8:42 AM
   To: [email-masked]<mailto:[email-masked]>
   Subject: [EXTERNAL] [regext] Fwd: Re: IANA Considerations in draft-ietf-regext-rdap-reverse-search

   Hi all,

   [SAH] This makes sense.

   I was simply referring to what is described in https://tools.ietf.org/html/rfc7481#section-3.3<https://secure-web.cisco.com/112-TobxeBxtn_P2RR20FkGeKzq3gWLTHZ_c9yfiVICbZ5ClmOFC--UCdn4nGc9Uyst0HYSV9PdlW8tLsm0yUQ5_G6F5U-Z81hHHBtyWLdE67KdnNFRU-JIHcSbAnAKtqLozEKCbiaua90UcwhAtBWfeeP297Zu05lYrVqVgV9ayUZr9rV6WYMGvlYzgejmgo1oCK5zum1qfV0ckScX9MtnzUTL896TmY6BbEHpBIU7u4emClB8PgZCjpxCS92yoBhKEusgGhC2D0zyFurPMsBfOphkUPei61ETKrpCIMe7Q/https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc7481%23section-3.3>

   [SAH] OK, understood. With client identification, authentication, and authorization a server can indeed provide different services so that, too, is worth mentioning.

   Scott