Subject: Re: [regext] WG LAST CALL: draft-ietf-regext-unhandled-namespaces-03

From: "Gould, James" <[email-masked]>
Date: Mon, 9 Nov 2020 17:30:14 +0000

Jim,

There is an update planned for draft-ietf-regext-unhandled-namespaces-05 that addresses the concerns that Thomas Corte raised during the WGLC, with the following changes:

  1.  Based on feedback from Thomas Corte, added a description of the <extValue> element in RFC 5730 and it being extended to support returning unhandled namespace information.
  2.  Based on feedback from Thomas Corte, added a Implementation Considerations section to cover client and server implementation recommendations such as monitoring unhandled namespaces in the server to report to the clients out-of-band and monitoring for responses containing unhanded namespace information in the client to proactively add support for the unhandled namespaces.

draft-ietf-regext-unhandled-namespaces-05 will be posted once the draft submission window opens up.

Thanks,

--

JG

James Gould

Fellow Engineer

[email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271

12061 Bluemont Way

Reston, VA 20190

Verisign.com <http://verisigninc.com/>

On 11/9/20, 12:01 PM, "regext on behalf of James Galvin" <[email-masked] on behalf of [email-masked]> wrote:

    The WGLC for this document is now closed.

    Thanks to the working group for the additional discussion on the concern

    raised by Patrick Mevzek.  Two additional people - Thomas Corte and

    Martin Casanova - have indicated their support for the document.

    The Chairs believe this document is now ready for submission to the

    IESG.  The document shepherd, David Smith, is requested to prepare the

    shepherd writeup.  Please be sure to note the last concern raised and

    its resolution in the technical writeup.

    Thanks,

    Antoin and Jim

    On 26 Oct 2020, at 10:01, James Galvin wrote:

    > The Chairs would like to extend this WG Last Call for an additional

    > two weeks, to close on Friday, 30 October 2020.

    > Although there have been 3 indications of support, Patrick Mevzek and

    > James Gould have been having an extended discussion on the mailing

    > list about one issue.  The chairs believe it is important to get

    > additional points of view, ideally from other EPP client developers

    > but all opinions are welcome.

    > Current consensus is to seek publication.  However, we are a

    > relatively small group and we would like all comments considered by

    > multiple people.  Would others please indicate their point of view in

    > the active thread between James and Patrick?

    > Thank you,

    > Antoin and Jim

    > On 2 Oct 2020, at 16:52, James Galvin wrote:

    >> The following working group document is believed to be ready for

    >> submission to the IESG for publication as a standards track document:

    >> https://secure-web.cisco.com/1dzUO4TGHUUPomDmedIaC2XjNHykoP8AdoJi85uaef2rF8hGoMlvw0I2YAm8WFgiX-mzllTPy1a0LGQm-VEZ5CMmOPg0r5o-wWe8dEnQikqWPx1MJ2NT3RvBRXaLLtiMLUpZuWv72D8eP0LCrbgC5pbvt4jJ2-YqPhi2_zOueQTxMCs0GfX5DzM1BCZhljRy2zuZVoFsMvkYUvcCj_muzL1hwjPvALejlQqWHl30Wsu_gSYNguMHS2NDCtWpqqQk2NMjR2FC2sPTxmfbT8vUJaQ/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-regext-unhandled-namespaces%2F

    >> This WG last call will end at close of business, Friday, 16 October

    >> 2020.

    >> Please review this document and indicate your support (a simple

    >> “+1” is sufficient) or concerns with the publication of this

    >> document by replying to this message on the list.

    >> The document shepherd for this document is David Smith.

    >> Regards,

    >> Antoin and Jim

    _______________________________________________

    regext mailing list

    [email-masked]

    https://secure-web.cisco.com/1Md8cfFbq82PdmCgP_5bkiKpd1-RKysH7Jp8FwK8d3ONPrqMvzZ4_v3LIxtHfYOtp22T88dX3wYPxwF2nQG9xzvABH3P04oDLXETu6QEq0HMbX7h4LS7Eit6jnKSejLb4hpmhhW8gEtQOJrKNHt9LKstOriCunNufoXXFMdczhcEiHS3wLB3Fm80FjxVLpur-SJoXtKfy5MIINe6ZHe14V-XTDsfibS6kXlYFt9CMrfysfYxArNudz_DLq377Rftr_Ud4Y496kNDvEPEWairXBX1pU0etlgJ_6h1jDhcp5zs/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext

---

From: "James Galvin" <[email-masked]>
Date: Mon, 09 Nov 2020 13:30:13 -0500

Thanks for calling this out Jim.  Antoin and I were talking about this 
this morning and still I managed to miss it when sending the note out.

The document shepherd - David Smith - should wait for the latest version 
of the document to do his writeup.

Jim

On 9 Nov 2020, at 12:30, Gould, James wrote:

> Jim,
>
>
>
> There is an update planned for 
> draft-ietf-regext-unhandled-namespaces-05 that addresses the concerns 
> that Thomas Corte raised during the WGLC, with the following changes:
>
>
>
>   1.  Based on feedback from Thomas Corte, added a description of the 
> <extValue> element in RFC 5730 and it being extended to support 
> returning unhandled namespace information.
>   2.  Based on feedback from Thomas Corte, added a Implementation 
> Considerations section to cover client and server implementation 
> recommendations such as monitoring unhandled namespaces in the server 
> to report to the clients out-of-band and monitoring for responses 
> containing unhanded namespace information in the client to proactively 
> add support for the unhandled namespaces.
>
>
>
> [email-masked] 
> <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>
>
>
>
> 703-948-3271
>
> 12061 Bluemont Way
>
> Reston, VA 20190
>
>
>
> On 11/9/20, 12:01 PM, "regext on behalf of James Galvin" 
> <[email-masked] on behalf of [email-masked]> wrote:
>
>
>