Subject: [regext] I-D Action: draft-ietf-regext-simple-registration-reporting-02.txt

From: [email-masked]
Date: Mon, 02 Nov 2020 14:21:17 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Registration Protocols Extensions WG of the IETF.

        Title           : Simple Registration Reporting
        Authors         : Joseph Yee
                          James Galvin
	Filename        : draft-ietf-regext-simple-registration-reporting-02.txt
	Pages           : 33
	Date            : 2020-11-02

Abstract:
   Domain name registries and registrars report to each other by sharing
   bulk information through files.  This document creates two IANA
   registries to establish a standard reporting mechanism between domain
   name registries and registrars.  The first IANA registry lists
   standard data elements and their syntax for inclusion in the files.
   The second IANA registry lists standard reports based on the standard
   data elements.  Each report is a file formatted as a CSV file.  The
   advantage of this reporting mechanism is that report, each file, can
   be imported by recipients without any prior knowledge of their
   contents, although reporting is enhanced with a minimum of knowledge
   about the files.  The mechanism for the transmission and reception of
   the files is a matter of local policy.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-regext-simple-registration-reporting/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-regext-simple-registration-reporting-02.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-regext-simple-registration-reporting-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Tobias Sattler <[email-masked]>
Date: Tue, 3 Nov 2020 14:43:24 +0100

Hi Joseph,
Hi Jim,

Thanks for updating this draft.

Some thoughts and comments from my side:

General thoughts
This document is intended to be informational. Therefore, I think it is better to avoid the word “standard” in the text. Because it would seem to be a de facto standard. I think that someone might be irritated by this later.

Abstract
I would open it up and write about Registries, Registrars, and Resellers.

1. Introduction
I would define “the producer” and “the consumer” by using the example Registries and Registrars as well as Registrars and Resellers. And reference later on only to producer and consumer.

2. Data Element Specification
I am missing the character encoding. You are mentioning it in section 7. I would add a reference in section 2 to 7.

2.1.11 Registrar
If you open it up to Resellers, then I would rename it to Consumer.

2.2.5. Trade
I would add the field trade here, which is not uncommon in the ccTLD world. Just to have it right from the start.

2.4.1. Registrar_ID
If you open it up to Resellers, then I would rename it to Consumer_ID

3. Report Definition Specification
After reading it, it is not 100% clear to me, what the delimiter is and if the values should be enclosed with (single or double) quotes.

Appendix A. Acknowledgment
There is a typo in bestpractices.domains. It is bestpractice.domains without a “s".

Best,
Tobias

> On 2. Nov 2020, at 23:21, [email-masked] wrote:
> 
> 
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext