Subject: Re: [regext] I-D Action: draft-ietf-regext-epp-registry-maintenance-05.txt

From: "Gould, James" <[email-masked]>
Date: Tue, 1 Dec 2020 14:35:26 +0000

In reviewing draft-ietf-regext-epp-registry-maintenance-05, below is my feedback:

  1.  Replace “defnition” with “definition” in two places.
  2.  Section 2.3 Maintenance Elements
     *   I would modify the description of the <maint:item> element.  Specifically, change the second sentence to read like “This element is used in a maintenance item EPP <info> response and <poll> message.”.
  3.  Section 3.1.3.1 “Query one maintenance item”
     *   The name “Query one maintenance item” could be shortened to “Info Maintenance Item”.
     *   I would explicitly define the Info Maintenance Item command element (<maint:id>) without making the reference to Section 2.3, since Section 2.3 defines the Info Maintenance Item Response.
     *   The command example incorrectly references <maint:impact>blackout</maint:impact> instead of <maint:impact>full</maint:impact>.
     *   The dates in the response example should be updated to more recent dates (e.g., update 2017 to 2020)
     *   I would define the response similar to:

                                                               i.      When an <info> command has been processed successfully, the EPP <resData> element MUST contain a child <maint:infData> element that identifies the maintenance namespace.  The <maint:infData> element contains the <maint:item> element defined in Section 2.3.

  1.  Section 3.1.3.2 “Query maintenance list”
     *   The name could be updated to “Info Maintenance List”.
     *   I would explicitly define the Info Maintenance List element (<maint:list/>), which is an empty element to indicate an Info Maintenance List command.
     *   The dates in the response example should be updated to more recent dates (e.g., update 2017 to 2020)
     *   I would define the response similar to:

                                                               i.      When an <info> command has been processed successfully, the EPP <resData> element MUST contain a child <maint:infData> element that identifies the maintenance namespace.  The <maint:infData> element contains the <maint:list> element with a list of <maint:listItem> elements.  The <maint:listItem> element contains the following child elements:

1.  <maint:id>: <maint:id> defined in Section 2.3.

2.  <maint:start>: <maint:start> defined in Section 2.3.

3.  <maint:end>: <maint:end> defined in Section 2.3.

4.  <maint:crDate>: <maint:crDate> defined in Section 2.3.

5.  <maint:upDate>: OPTIONAL <maint:upDate> defined in Section 2.3.

  1.  Sect 3.1.4 “EPP <poll> Command”
     *   The dates in the poll response example should be updated to more recent dates (e.g., update 2017 to 2020)

--

JG

James Gould

Fellow Engineer

[email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271

12061 Bluemont Way

Reston, VA 20190

Verisign.com <http://verisigninc.com/>

On 12/1/20, 7:32 AM, "regext on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    A New Internet-Draft is available from the on-line Internet-Drafts directories.

    This draft is a work item of the Registration Protocols Extensions WG of the IETF.

            Title           : Registry Maintenance Notifications for the Extensible Provisioning Protocol (EPP)

            Authors         : Tobias Sattler

                              Roger Carney

                              Jody Kolker

                Filename        : draft-ietf-regext-epp-registry-maintenance-05.txt

                Pages           : 20

                Date            : 2020-12-01

    Abstract:

       This document describes an Extensible Provision Protocol (EPP)

       mapping for registry's maintenance notifications.

    The IETF datatracker status page for this draft is:

    https://secure-web.cisco.com/1li8mLoCxeVjC53-tGvYzKD4YcjkoE6Ev-IZRxp8KydPQ9dy_dgHOxizxSu23hsx4RZVoh7T-GMHV8zzq0pNGEZqcIUucZuoE6CiU1K8nM-bkcRygXmVdp3F6IUnzumkKuauScX42WmKG3nZr5M5pzix-u_BLsV61qGnHT0yCC-E7kdUw4ZjoJ_Gs8-hgv9eabShu15czchF07EvEhnXBjZGQ3xXpcztwDy3pitq834n2SIblYBWUMsF2dJUQTlJi7Q9o-v8tOLMf5xtlZWSLcA/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-regext-epp-registry-maintenance%2F

    There are also htmlized versions available at:

    https://secure-web.cisco.com/1S6_PU9v_ZkWX9nWp6WP47Od0hWHICawFbyNoykQ6CD7yvG7EpPWyV2XcTGNB60pzVywp_LjRV-wPBbVt7XptxNhGqCGxm4Zihg4MoaiCDcHXbrQPw3IzXF30wCX4DTMCQD2S9PmF2mpQ9i74fwPzhclx0RtAyhDG-mI0VwhiH9_PzB9t57cO3jvzWA3fEIgSL6H6z71YjNr5CgarKpreOKxtbWxyy2gQw1kAfy1waFnV5vIif11v_zgPjEL7IUsUNva6DcWIjZMhYqspuhwKAaSa8M5u8D3iJ5Jj7ByMf-8/https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-regext-epp-registry-maintenance-05

    https://secure-web.cisco.com/1XNpISpXfN8MQw1PEsPccAZ0_sZLESxXSKZD_sTvZwJ0QIufYJqXbGF7wdOTdR-pMMnOEH9LNrozfFZ1A4is0CHnJTuDLvhWgwwQ6ZQnpUxrk49oTY2HM7dgf9sbMhl_d2NuioFX8zj9eDSza6SYpZNMAQWA6mWsaobZSEHoaDcBsvWALD0as2Ko7xiWtIyrzb8YC5d0FfZnjNNkjDeILwCeXKqeU6UPGFZ1_1-2vHpW1yad8vgx2YnKBz42vnOcggnzk5g6kBEpntmhY1sKUkA/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-regext-epp-registry-maintenance-05

    A diff from the previous version is available at:

    https://secure-web.cisco.com/1KSWNQPojpKmLvO_WIQ_irF2tlGnvVG0NPX5XV846TrqHNQ1N4Nnh4PreFg5v0DC0wn9U0sbBn1u2ZrTcuObqRweYR6CvUQFmHQTv8zi_xPnobTWzspaoT_WO3Hmp5APY41nDiHh4IuQkqTPiXNq6tATib3PopqsT9kHFgCTslmKqRe9GH3jhJgNoPxh4lTox7f5sDssSMM_Sx3dUV40K0iag_k-wRIhnkeBZwf9P6Dw7kl1tClmighR8iEjHf2cO1gZhmKA_WTzmYvg_vwL-vvEtrutRQMo0TyWX7OTMgOk/https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-regext-epp-registry-maintenance-05

    Please note that it may take a couple of minutes from the time of submission

    until the htmlized version and diff are available at tools.ietf.org.

    Internet-Drafts are also available by anonymous FTP at:

    ftp://ftp.ietf.org/internet-drafts/

    _______________________________________________

    regext mailing list

    [email-masked]

    https://secure-web.cisco.com/1v2GmNiRW6LGBp9t0VmF4qf64EGWy5imLishTLvSm672F9aofELXoa5Vvzw1jGfadWXdD85jL-lLbbuTU_ugz0VCc3te-397rOJjLDv0NR80D6etQe8LMdvw1kjzNczvhvXphV0JlOT7ke70TQWpwNhQZbRG2bUBJ2VdVkHRsWCc-5mRwbrwOS6uEMUXD4CDYxVLSUsWuLlQ7rOH5viQJMbIasArywqdHgWETm7pcWtK-vh4Ryzg6QJFYoaSFdee8QhZ0jU7QcWc7RqVs4wPHeUGtcrcAic59uemX_otwo8s/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext

---

From: Tobias Sattler <[email-masked]>
Date: Tue, 1 Dec 2020 15:58:42 +0100

Hi Jim,

Thank you for your swift feedback.

We will go through it and make the adjustments where needed.

Best,
Tobias

> On 1. Dec 2020, at 15:35, Gould, James <jgould=[email-masked]> wrote:
> 
> Replace “defnition” with “definition” in two places.
> Section 2.3 Maintenance Elements
> I would modify the description of the <maint:item> element.  Specifically, change the second sentence to read like “This element is used in a maintenance item EPP <info> response and <poll> message.”.
> Section 3.1.3.1 “Query one maintenance item”
> The name “Query one maintenance item” could be shortened to “Info Maintenance Item”.
> I would explicitly define the Info Maintenance Item command element (<maint:id>) without making the reference to Section 2.3, since Section 2.3 defines the Info Maintenance Item Response. 
> The command example incorrectly references <maint:impact>blackout</maint:impact> instead of <maint:impact>full</maint:impact>.
> The dates in the response example should be updated to more recent dates (e.g., update 2017 to 2020)
> I would define the response similar to:
> Section 3.1.3.2 “Query maintenance list”
> The name could be updated to “Info Maintenance List”.
> I would explicitly define the Info Maintenance List element (<maint:list/>), which is an empty element to indicate an Info Maintenance List command.
> The dates in the response example should be updated to more recent dates (e.g., update 2017 to 2020)
> I would define the response similar to:
> Sect 3.1.4 “EPP <poll> Command”
> The dates in the poll response example should be updated to more recent dates (e.g., update 2017 to 2020)
>  
> -- 
>  
> JG
>  
>  
>  
> James Gould
> Fellow Engineer
> [email-masked] <mailto:[email-masked]> <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>>
>  
> 703-948-3271
> 12061 Bluemont Way
> Reston, VA 20190
>  
> Verisign.com <http://verisign.com/> <http://verisigninc.com/ <http://verisigninc.com/>>
>  
> On 12/1/20, 7:32 AM, "regext on behalf of [email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]> on behalf of [email-masked] <mailto:[email-masked]>> wrote:
>  
>     https://secure-web.cisco.com/1li8mLoCxeVjC53-tGvYzKD4YcjkoE6Ev-IZRxp8KydPQ9dy_dgHOxizxSu23hsx4RZVoh7T-GMHV8zzq0pNGEZqcIUucZuoE6CiU1K8nM-bkcRygXmVdp3F6IUnzumkKuauScX42WmKG3nZr5M5pzix-u_BLsV61qGnHT0yCC-E7kdUw4ZjoJ_Gs8-hgv9eabShu15czchF07EvEhnXBjZGQ3xXpcztwDy3pitq834n2SIblYBWUMsF2dJUQTlJi7Q9o-v8tOLMf5xtlZWSLcA/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-regext-epp-registry-maintenance%2F <https://secure-web.cisco.com/1li8mLoCxeVjC53-tGvYzKD4YcjkoE6Ev-IZRxp8KydPQ9dy_dgHOxizxSu23hsx4RZVoh7T-GMHV8zzq0pNGEZqcIUucZuoE6CiU1K8nM-bkcRygXmVdp3F6IUnzumkKuauScX42WmKG3nZr5M5pzix-u_BLsV61qGnHT0yCC-E7kdUw4ZjoJ_Gs8-hgv9eabShu15czchF07EvEhnXBjZGQ3xXpcztwDy3pitq834n2SIblYBWUMsF2dJUQTlJi7Q9o-v8tOLMf5xtlZWSLcA/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-regext-epp-registry-maintenance%2F>
>  
>     https://secure-web.cisco.com/1S6_PU9v_ZkWX9nWp6WP47Od0hWHICawFbyNoykQ6CD7yvG7EpPWyV2XcTGNB60pzVywp_LjRV-wPBbVt7XptxNhGqCGxm4Zihg4MoaiCDcHXbrQPw3IzXF30wCX4DTMCQD2S9PmF2mpQ9i74fwPzhclx0RtAyhDG-mI0VwhiH9_PzB9t57cO3jvzWA3fEIgSL6H6z71YjNr5CgarKpreOKxtbWxyy2gQw1kAfy1waFnV5vIif11v_zgPjEL7IUsUNva6DcWIjZMhYqspuhwKAaSa8M5u8D3iJ5Jj7ByMf-8/https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-regext-epp-registry-maintenance-05 <https://secure-web.cisco.com/1S6_PU9v_ZkWX9nWp6WP47Od0hWHICawFbyNoykQ6CD7yvG7EpPWyV2XcTGNB60pzVywp_LjRV-wPBbVt7XptxNhGqCGxm4Zihg4MoaiCDcHXbrQPw3IzXF30wCX4DTMCQD2S9PmF2mpQ9i74fwPzhclx0RtAyhDG-mI0VwhiH9_PzB9t57cO3jvzWA3fEIgSL6H6z71YjNr5CgarKpreOKxtbWxyy2gQw1kAfy1waFnV5vIif11v_zgPjEL7IUsUNva6DcWIjZMhYqspuhwKAaSa8M5u8D3iJ5Jj7ByMf-8/https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-regext-epp-registry-maintenance-05>
>     https://secure-web.cisco.com/1XNpISpXfN8MQw1PEsPccAZ0_sZLESxXSKZD_sTvZwJ0QIufYJqXbGF7wdOTdR-pMMnOEH9LNrozfFZ1A4is0CHnJTuDLvhWgwwQ6ZQnpUxrk49oTY2HM7dgf9sbMhl_d2NuioFX8zj9eDSza6SYpZNMAQWA6mWsaobZSEHoaDcBsvWALD0as2Ko7xiWtIyrzb8YC5d0FfZnjNNkjDeILwCeXKqeU6UPGFZ1_1-2vHpW1yad8vgx2YnKBz42vnOcggnzk5g6kBEpntmhY1sKUkA/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-regext-epp-registry-maintenance-05 <https://secure-web.cisco.com/1XNpISpXfN8MQw1PEsPccAZ0_sZLESxXSKZD_sTvZwJ0QIufYJqXbGF7wdOTdR-pMMnOEH9LNrozfFZ1A4is0CHnJTuDLvhWgwwQ6ZQnpUxrk49oTY2HM7dgf9sbMhl_d2NuioFX8zj9eDSza6SYpZNMAQWA6mWsaobZSEHoaDcBsvWALD0as2Ko7xiWtIyrzb8YC5d0FfZnjNNkjDeILwCeXKqeU6UPGFZ1_1-2vHpW1yad8vgx2YnKBz42vnOcggnzk5g6kBEpntmhY1sKUkA/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-regext-epp-registry-maintenance-05>
>  
>     https://secure-web.cisco.com/1KSWNQPojpKmLvO_WIQ_irF2tlGnvVG0NPX5XV846TrqHNQ1N4Nnh4PreFg5v0DC0wn9U0sbBn1u2ZrTcuObqRweYR6CvUQFmHQTv8zi_xPnobTWzspaoT_WO3Hmp5APY41nDiHh4IuQkqTPiXNq6tATib3PopqsT9kHFgCTslmKqRe9GH3jhJgNoPxh4lTox7f5sDssSMM_Sx3dUV40K0iag_k-wRIhnkeBZwf9P6Dw7kl1tClmighR8iEjHf2cO1gZhmKA_WTzmYvg_vwL-vvEtrutRQMo0TyWX7OTMgOk/https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-regext-epp-registry-maintenance-05 <https://secure-web.cisco.com/1KSWNQPojpKmLvO_WIQ_irF2tlGnvVG0NPX5XV846TrqHNQ1N4Nnh4PreFg5v0DC0wn9U0sbBn1u2ZrTcuObqRweYR6CvUQFmHQTv8zi_xPnobTWzspaoT_WO3Hmp5APY41nDiHh4IuQkqTPiXNq6tATib3PopqsT9kHFgCTslmKqRe9GH3jhJgNoPxh4lTox7f5sDssSMM_Sx3dUV40K0iag_k-wRIhnkeBZwf9P6Dw7kl1tClmighR8iEjHf2cO1gZhmKA_WTzmYvg_vwL-vvEtrutRQMo0TyWX7OTMgOk/https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-regext-epp-registry-maintenance-05>
>  
>  
>     until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
>  
>     ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
>  
>  
>     [email-masked] <mailto:[email-masked]>
>     https://secure-web.cisco.com/1v2GmNiRW6LGBp9t0VmF4qf64EGWy5imLishTLvSm672F9aofELXoa5Vvzw1jGfadWXdD85jL-lLbbuTU_ugz0VCc3te-397rOJjLDv0NR80D6etQe8LMdvw1kjzNczvhvXphV0JlOT7ke70TQWpwNhQZbRG2bUBJ2VdVkHRsWCc-5mRwbrwOS6uEMUXD4CDYxVLSUsWuLlQ7rOH5viQJMbIasArywqdHgWETm7pcWtK-vh4Ryzg6QJFYoaSFdee8QhZ0jU7QcWc7RqVs4wPHeUGtcrcAic59uemX_otwo8s/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext <https://secure-web.cisco.com/1v2GmNiRW6LGBp9t0VmF4qf64EGWy5imLishTLvSm672F9aofELXoa5Vvzw1jGfadWXdD85jL-lLbbuTU_ugz0VCc3te-397rOJjLDv0NR80D6etQe8LMdvw1kjzNczvhvXphV0JlOT7ke70TQWpwNhQZbRG2bUBJ2VdVkHRsWCc-5mRwbrwOS6uEMUXD4CDYxVLSUsWuLlQ7rOH5viQJMbIasArywqdHgWETm7pcWtK-vh4Ryzg6QJFYoaSFdee8QhZ0jU7QcWc7RqVs4wPHeUGtcrcAic59uemX_otwo8s/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext>
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>

---

From: Tobias Sattler <[email-masked]>
Date: Tue, 8 Dec 2020 09:08:40 +0100

Hi Jim,

We addressed your feedback and submitted the new version.

Thanks,
Tobias

> On 1. Dec 2020, at 15:58, Tobias Sattler <[email-masked]> wrote:
> 
> Hi Jim,
> 
>> On 1. Dec 2020, at 15:35, Gould, James <jgould=[email-masked] <mailto:jgould=[email-masked]>> wrote:
>>

---

From: Tobias Sattler <[email-masked]>
Date: Tue, 8 Dec 2020 21:38:43 +0100

Just to let you know, we will prepare a new version (07) because we forgot to change <maint:host> as discussed, and do a review before submitting it.

Tobias

> On 8. Dec 2020, at 09:08, Tobias Sattler <[email-masked]> wrote:
> 
> Hi Jim,
> 
>> On 1. Dec 2020, at 15:58, Tobias Sattler <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Jim,
>> 
> https://www.ietf.org/mailman/listinfo/regext