Subject: [regext] CALL FOR ADOPTION: draft-loffredo-regext-rdap-jcard-deprecation-03

From: "James Galvin" <[email-masked]>
Date: Mon, 18 Jan 2021 09:29:23 -0500

This is a formal adoption request for “Using JSContact in Registration 
Data Access Protocol (RDAP) JSON Responses”:

https://datatracker.ietf.org/doc/draft-loffredo-regext-rdap-jcard-deprecation/

Please review this draft to see if you think it is suitable for adoption 
by REGEXT, and comment to the list, clearly stating your view.

Please indicate if you are willing to contribute text, review text, or 
be a document shepherd.

Please also indicate any preference you have for a proposed milestone 
date.

This call for adoption ends Monday, 1 February 2021.

If there are no objections, and we receive enough consensus for 
adoption, the chairs will consider this document adopted.

Thanks,

Your REGEXT co-chairs Antoin and Jim

---

From: Jasdip Singh <[email-masked]>
Date: Mon, 18 Jan 2021 16:30:25 +0000

Hi.

I support the adoption of this draft.

Thanks,
Jasdip

On 1/18/21, 9:28 AM, "regext on behalf of James Galvin" <[email-masked] on behalf of [email-masked]> wrote:

    

    

    Thanks,

    _______________________________________________
    regext mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/regext

---

From: Mario Loffredo <[email-masked]>
Date: Tue, 19 Jan 2021 09:21:49 +0100

Hi all,

I support adoption and am willing to go on working on it.

Mario

Il 18/01/2021 15:29, James Galvin ha scritto:
> Please review this draft to see if you think it is suitable for 
> adoption by REGEXT, and comment to the list, clearly stating your view.
>

-- 
Dr. Mario Loffredo
Technological Unit “Digital Innovation”
Institute of Informatics and Telematics (IIT)
National Research Council (CNR)
via G. Moruzzi 1, I-56124 PISA, Italy
Phone: +39.0503153497
Web: http://www.iit.cnr.it/mario.loffredo

---

From: Maurizio Martinelli <[email-masked]>
Date: Wed, 20 Jan 2021 13:14:28 +0100

Hi all,

I support its adoption.

Maurizio

> Il giorno 18 gen 2021, alle ore 15:29, James Galvin <[email-masked]> ha scritto:
> 
> This is a formal adoption request for “Using JSContact in Registration Data Access Protocol (RDAP) JSON Responses”:
> 
> Please review this draft to see if you think it is suitable for adoption by REGEXT, and comment to the list, clearly stating your view.
> 
> Please indicate if you are willing to contribute text, review text, or be a document shepherd.
> 
> Please also indicate any preference you have for a proposed milestone date.
> 
> If there are no objections, and we receive enough consensus for adoption, the chairs will consider this document adopted.
> 
> Thanks,
> 

----
Dr. Maurizio Martinelli
Responsabile Unità Tecnologica Innovazione Digitale
CNR - Istituto di Informatica e Telematica
via G. Moruzzi 1, 56124 PISA, Italy
E-Mail: [email-masked]
Phone: +39 050 3152087
Web: http://www.iit.cnr.it/maurizio.martinelli

---

From: Jody Kolker <[email-masked]>
Date: Wed, 20 Jan 2021 16:43:56 +0000

Hi everyone,

I support its adoption as well.

Thanks,
Jody Kolker.

-----Original Message-----
From: regext <[email-masked]> On Behalf Of Maurizio Martinelli
Sent: Wednesday, January 20, 2021 6:14 AM
To: James Galvin <[email-masked]>
Cc: REGEXT WG <[email-masked]>
Subject: Re: [regext] CALL FOR ADOPTION: draft-loffredo-regext-rdap-jcard-deprecation-03

Notice: This email is from an external sender.

Hi all,

I support its adoption.

Maurizio

> Your REGEXT co-chairs Antoin and Jim

----
Dr. Maurizio Martinelli
Responsabile Unità Tecnologica Innovazione Digitale CNR - Istituto di Informatica e Telematica via G. Moruzzi 1, 56124 PISA, Italy
E-Mail: [email-masked]
Phone: +39 050 3152087
Web: http://www.iit.cnr.it/maurizio.martinelli

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 29 Jan 2021 13:17:21 +0000

> From: regext <[email-masked]> On Behalf Of James Galvin
> Sent: Monday, January 18, 2021 9:29 AM
> To: REGEXT WG <[email-masked]>
> Subject: [EXTERNAL] [regext] CALL FOR ADOPTION: draft-loffredo-regext-
> rdap-jcard-deprecation-03
> 
> Caution: This email originated from outside the organization. Do not click links
> or open attachments unless you recognize the sender and know the content
> is safe.
> 

While I understand the motivation for this draft, I'm a little worried that it's trying to solve a problem that is no longer a problem for anyone who has completed a jCard implementation. At this point, RDAP implementations with jCard are quite widespread among registries, registrars, and RIRs.  

Yes, we've heard that jCard can be cumbersome or tedious to implement, but once that work is done, an implementer has something that works.  Due to the nature of the problem domain, it is stable and doesn't require maintenance. 

While an implementation involving jSContact would certainly be more elegant from a technical perspective, I see limited value in developing a specification that would imply re-doing what has already been implemented to produce something that does basically the same thing. There must be some material benefit for implementers (of both servers and then clients) to offset the development and deployment cost of re-implementing the contact representation. Section 2 of the draft describes differences from jCard - are they enough to justify this investment?

Scott

---

From: Jasdip Singh <[email-masked]>
Date: Fri, 29 Jan 2021 14:11:42 +0000

Interesting point, Scott. Adopting JSContact (and deprecating jCard eventually) seems a tradeoff between ease-of-implementation for future servers/clients and diminishing returns for the current servers/clients. Should the latter (diminishing returns) prevent the former (easy-of-implementation)? It may help to gauge what other protocols have done in the past when presented with such a trade-off.

Jasdip  

    

    
    Scott

---

From: Mario Loffredo <[email-masked]>
Date: Fri, 29 Jan 2021 20:26:46 +0100

Hi,

the document has a twofold goal:

- introducing an  alternative to jcard as an extension

- defining a deprecation process through which the extension can replace 
jcard progressively

The document doesn't state that replacing jcard with jscontact is an 
absolute must but it provides the means to make it possible.

Whether and when the transition procedure will be fully completed will 
depend on the general consensus among RDAP implementers that jscontact 
is a much more efficient representation of contact information than 
jcard and, consequently, is worthy to be implemented.

Usually, when we propose an EPP or RDAP extension, we are not sure that 
it will be widely adopted. We simply admit that an inefficiency or a 
lack of functionality exists and we agree on a solution that can 
represent a valid guidance for all the implementers. Ultimately, only 
the implementers evaluate our proposals as worthy to be adopted.

Therefore, in my opinion, the main questions are: do we agree that jcard 
is inefficient? do we agree that the solution proposed for fixing such 
inefficiency can become a guidance for all the RDAP implementers?

Finally, I would like to say that I have released an open-source Java 
library supporting the burden of those who are willing to implement the 
proposal. At least in this case and for java developers, the 
implementation effort wouldn't be so strong :-)

Best,

Mario