Subject: [regext] I-D Action: draft-ietf-regext-rdap-openid-06.txt

From: [email-masked]
Date: Tue, 05 Jan 2021 06:00:12 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Registration Protocols Extensions WG of the IETF.

        Title           : Federated Authentication for the Registration Data Access Protocol (RDAP) using OpenID Connect
        Author          : Scott Hollenbeck
	Filename        : draft-ietf-regext-rdap-openid-06.txt
	Pages           : 25
	Date            : 2021-01-05

Abstract:
   The Registration Data Access Protocol (RDAP) provides "RESTful" web
   services to retrieve registration metadata from domain name and
   regional internet registries.  RDAP allows a server to make access
   control decisions based on client identity, and as such it includes
   support for client identification features provided by the Hypertext
   Transfer Protocol (HTTP).  Identification methods that require
   clients to obtain and manage credentials from every RDAP server
   operator present management challenges for both clients and servers,
   whereas a federated authentication system would make it easier to
   operate and use RDAP without the need to maintain server-specific
   client credentials.  This document describes a federated
   authentication system for RDAP based on OpenID Connect.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-regext-rdap-openid/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-regext-rdap-openid-06
https://datatracker.ietf.org/doc/html/draft-ietf-regext-rdap-openid-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-regext-rdap-openid-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 5 Jan 2021 14:06:32 +0000

> -----Original Message-----
> From: regext <[email-masked]> On Behalf Of internet-
> [email-masked]
> Sent: Tuesday, January 5, 2021 9:00 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [EXTERNAL] [regext] I-D Action: draft-ietf-regext-rdap-openid-06.txt
>
> Caution: This email originated from outside the organization. Do not click links
> or open attachments unless you recognize the sender and know the content
> is safe.
>

I just submitted this version of draft-ietf-regext-rdap-openid since the previous version was about to expire.

It may be time to wrap this document up. The capability is needed for some of the other RDAP extensions, and even though the ICANN community isn't talking about using something like this right now the document describes a model that's flexible enough to adapt to changes in the attributes needed to make authorization and access control decisions. AT this point I think the document is ready for WG last call as a Proposed Standard. We need a document shepherd - is anyone interested? Does anyone think that there's anything more to discuss, or any unresolved issues?

Scott