Subject: [regext] Robert Wilton's No Objection on draft-ietf-regext-rfc7482bis-02: (with COMMENT)

From: Robert Wilton via Datatracker <[email-masked]>
Date: Mon, 15 Feb 2021 03:37:43 -0800

Robert Wilton has entered the following ballot position for
draft-ietf-regext-rfc7482bis-02: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-regext-rfc7482bis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Hi,

Thanks for this document.  Only one minor comment:

It wasn't clear to me whether the Appendix "Changes from RFC 7482" was going to
be kept - there is no RFC editor note to suggest that it be removed.

Generally, I think that have a short section explaining how a RFC has changed
from a previously published version is helpful.  But if this is kept, then I
would try and condense this text down to the list of important changes from RFC
7482.  E.g., added "implementation status" wouldn't apply if that is going to
be stripped before the RFC is published.

Regards,
Rob

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 18 Feb 2021 15:12:09 +0000

> -----Original Message-----
> From: Robert Wilton via Datatracker <[email-masked]>
> Sent: Monday, February 15, 2021 6:38 AM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked];
> [email-masked]; Mario Loffredo <[email-masked]>;
> [email-masked]
> Subject: [EXTERNAL] Robert Wilton's No Objection on draft-ietf-regext-
> rfc7482bis-02: (with COMMENT)
>
> Caution: This email originated from outside the organization. Do not click links
> or open attachments unless you recognize the sender and know the content
> is safe.
>
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)

[SAH] [snip]

> It wasn't clear to me whether the Appendix "Changes from RFC 7482" was
> going to be kept - there is no RFC editor note to suggest that it be removed.
>
> from a previously published version is helpful.  But if this is kept, then I would
> try and condense this text down to the list of important changes from RFC

[SAH] My intention was for the appendix to be kept as-is to provide a detailed list of editorial and explanatory changes, confirming that the protocol itself has not been changed. Has the RFC Editor been removing such sections? If so, I can add a note to request that it be preserved.

Scott

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 18 Feb 2021 15:26:59 +0000

Hi Scott,

> From: iesg <[email-masked]> On Behalf Of Hollenbeck, Scott
> Sent: 18 February 2021 15:12
> To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
> [email-masked]; [email-masked]
> Subject: RE: Robert Wilton's No Objection on draft-ietf-regext-rfc7482bis-
> 02: (with COMMENT)
> 
> email
> [SAH] My intention was for the appendix to be kept as-is to provide a
> detailed list of editorial and explanatory changes, confirming that the
> protocol itself has not been changed. Has the RFC Editor been removing
> such sections? If so, I can add a note to request that it be preserved.
[RW] 

No, I don’t think that the RFC editor will remove this automatically unless explicitly asked.

But I question the value of having the full history of all doc updates, and I would prefer to see just a summary of the key differences against RFC 7482, since I think that would be most relevant to readers.  It is also possible to diff between the RFCs, or see the document history anyway, if that was ever needed.

Note, this is just a comment, not blocking, so you are not required to act on it if you don't want to.

Regards,
Rob