Subject: [regext] Roman Danyliw's No Objection on draft-ietf-regext-rfc7483bis-04: (with COMMENT)

From: Roman Danyliw via Datatracker <[email-masked]>
Date: Sun, 14 Feb 2021 11:31:34 -0800

Roman Danyliw has entered the following ballot position for
draft-ietf-regext-rfc7483bis-04: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-regext-rfc7483bis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you to Rich Salz for the SECDIR review, and the discussion around it is
appreciated.

** Section 3. handle.  Per “This value is a simple string”, is this making a
statement about the JSON data type?  I didn’t follow what this clarification
added on top of the original text in RFC7483.

** Section 3.  Editorial.
OLD
The "fn" member is required and MUST NOT be null
   according to [RFC6350], where an empty "fn" member MAY be used when
   the contact name does not exist or is redacted.

NEW
The "fn" member is required and MUST NOT be null according to [RFC6350].  An
empty "fn" member MAY be used when the contact name does not exist or is
redacted.

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 18 Feb 2021 15:08:51 +0000

> -----Original Message-----
> From: Roman Danyliw via Datatracker <[email-masked]>
> Sent: Sunday, February 14, 2021 2:32 PM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked];
> [email-masked]; Jasdip Singh <[email-masked]>; [email-masked]
> Subject: [EXTERNAL] Roman Danyliw's No Objection on draft-ietf-regext-
> rfc7483bis-04: (with COMMENT)
>
> Caution: This email originated from outside the organization. Do not click links
> or open attachments unless you recognize the sender and know the content
> is safe.
>
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)

[SAH] [snip]

[SAH] 7483 doesn't mention the data type, so yes, some people felt it necessary to mention that this a string data type. Would "simple character string" be better?

> The "fn" member is required and MUST NOT be null according to [RFC6350].
> An empty "fn" member MAY be used when the contact name does not exist
> or is redacted.

[SAH] OK.

Scott

---

From: Roman Danyliw <[email-masked]>
Date: Thu, 18 Feb 2021 15:35:23 +0000

Hi Scott!

> From: iesg <[email-masked]> On Behalf Of Hollenbeck, Scott
> Sent: Thursday, February 18, 2021 10:09 AM
> To: Roman Danyliw <[email-masked]>; [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: RE: Roman Danyliw's No Objection on draft-ietf-regext-rfc7483bis-04:
> (with COMMENT)
> 
> > Caution: This email originated from outside the organization. Do not
> > click links or open attachments unless you recognize the sender and
> > know the content is safe.
> >
> > email addresses included in the To and CC lines. (Feel free to cut
> > this introductory paragraph, however.)
> 
> [SAH] [snip]
> 
> > Thank you to Rich Salz for the SECDIR review, and the discussion
> > around it is appreciated.
> >
> > ** Section 3. handle.  Per “This value is a simple string”, is this
> > making a statement about the JSON data type?  I didn’t follow what
> > this clarification added on top of the original text in RFC7483.
> 
> [SAH] 7483 doesn't mention the data type, so yes, some people felt it necessary
> to mention that this a string data type. Would "simple character string" be
> better?

Understood.  I trust the WG to better understand where a clarification is needed.  A "simple character string" works for me.

> > An empty "fn" member MAY be used when the contact name does not exist

Thanks.

Regards,
Roman