Subject: [regext] Genart last call review of draft-ietf-regext-rfc7482bis-02

From: Dan Romascanu via Datatracker <[email-masked]>
Date: Thu, 04 Feb 2021 06:56:02 -0800

Reviewer: Dan Romascanu
Review result: Ready with Issues

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-regext-rfc7482bis-02
Reviewer: Dan Romascanu
Review Date: 2021-02-04
IETF LC End Date: 2021-02-08
IESG Telechat date: Not scheduled for a telechat

Summary:

This Document is Ready with one issue that I would suggest to clarify and
possibly apply edits before approval.

Major issues:

If my understanding is correct this document together with 7483bis will replace
RFC 7482 and RFC 7483 and advance them to Internet Standard. Sections 7 and 8
will be taken out from the final published RFC. I believe that the relationship
with RFC 7482 needs to be detailed either in the Introduction or in a dedicated
version, in order to clarify for future readers and users the status of the 2 /
4 documents. I also believe that a shortened version of the 'Changes from RFC
7482' section now an Appendix should be included in the text of the document in
its final form.

Minor issues:

Nits/editorial comments:

---

From: Barry Leiba <[email-masked]>
Date: Thu, 4 Feb 2021 09:57:47 -0500

Thanks for the review, Dan.

Your comment makes sense, yes.

Barry

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 4 Feb 2021 15:06:17 +0000

> -----Original Message-----
> From: Dan Romascanu via Datatracker <[email-masked]>
> Sent: Thursday, February 4, 2021 9:56 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: [EXTERNAL] Genart last call review of draft-ietf-regext-rfc7482bis-02
> 
> Caution: This email originated from outside the organization. Do not click links
> or open attachments unless you recognize the sender and know the content
> is safe.
> 
> Reviewer: Dan Romascanu
> I am the assigned Gen-ART reviewer for this draft. The General Area Review
> Team (Gen-ART) reviews all IETF documents being processed by the IESG for
> the IETF Chair.  Please treat these comments just like any other last call
> comments.
> 
> <https://secure-
> web.cisco.com/1it8MJTs4lDbEREI1LQUNZG_Vva3pasdIc3nRXd93eAnKO8pL8c
> lDx4Pi8a3pUnd3OVSqlbrXmmDSW-cnl-
> drNV5DHXN5gw1Npy1iJSih3_ipEMV7vNnaGP5-
> xZZa3jEPY2vvgjozipMQ3VYc8FH9KLjjtG15P42IhohN4F6FNircOBH-
> qBAVcH4V5Q8VuX4tccIue67ds7aJR4tEXZ3vl23e0ZnfU3MQ7ZPbsUa3PhYmfF-
> HIbzG5Chx6gVnpuoOzskOilbIifyT6kuRFu54mQ/https%3A%2F%2Ftrac.ietf.org
> %2Ftrac%2Fgen%2Fwiki%2FGenArtfaq>.
> 
> If my understanding is correct this document together with 7483bis will
> replace RFC 7482 and RFC 7483 and advance them to Internet Standard.
> Sections 7 and 8 will be taken out from the final published RFC. I believe that
> the relationship with RFC 7482 needs to be detailed either in the Introduction
> or in a dedicated version, in order to clarify for future readers and users the
> status of the 2 /
> 4 documents. I also believe that a shortened version of the 'Changes from
> RFC 7482' section now an Appendix should be included in the text of the
> document in its final form.

Dan, thanks for the review. Would you please give me a little more on what you think is needed to explain the relationship between the two documents? I can't think of much more to say beyond "7482 describes protocol queries" and "7483 describes protocol responses to the queries described in 7482", but would adding a few sentences to that effect in the Introduction do what you're suggesting? Of course, the RFC numbers will need to be updated.

Scott

---

From: Benjamin Kaduk <[email-masked]>
Date: Mon, 15 Feb 2021 15:55:48 -0800

Hi Scott,

> Dan, thanks for the review. Would you please give me a little more on
> what you think is needed to explain the relationship between the two
> documents? I can't think of much more to say beyond "7482 describes
> protocol queries" and "7483 describes protocol responses to the queries
> described in 7482", but would adding a few sentences to that effect in
> the Introduction do what you're suggesting? Of course, the RFC numbers
> will need to be updated.

I think the idea was (at least partially) that this, as rfc7482bis, should
describe its relationship with rfc7482-not-bis (e.g., that it obsoletes the
latter for purpose of advancing the protocol to Internet Standard), in both
Abstract and Introduction.  The fact that this document is not listed as
having an Obsoletes: relationship to rfc7482 (outside of the shepherd
writeup) makes the question of what exactly the relationship between the
two is much more interesting...

-Ben

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 16 Feb 2021 16:05:43 -0500

Dan, thanks for your review. I agree with your point and hope to see some text added to address this. I entered a No Objection ballot.

Alissa

> On Feb 4, 2021, at 9:56 AM, Dan Romascanu via Datatracker <[email-masked]> wrote:
> 
> Reviewer: Dan Romascanu
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 18 Feb 2021 15:23:25 +0000

> From: Benjamin Kaduk <[email-masked]>
> Sent: Monday, February 15, 2021 6:56 PM
> To: Hollenbeck, Scott <[email-masked]>
> Cc: [email-masked]; [email-masked]; [email-masked]; draft-ietf-
> [email-masked]; [email-masked]
> Subject: [EXTERNAL] Re: [Last-Call] Genart last call review of draft-ietf-
> regext-rfc7482bis-02
>
> > protocol queries" and "7483 describes protocol responses to the
> > queries described in 7482", but would adding a few sentences to that
> > effect in the Introduction do what you're suggesting? Of course, the
> > RFC numbers will need to be updated.
>
> I think the idea was (at least partially) that this, as rfc7482bis, should describe
> its relationship with rfc7482-not-bis (e.g., that it obsoletes the latter for
> purpose of advancing the protocol to Internet Standard), in both Abstract
> and Introduction.  The fact that this document is not listed as having an
> Obsoletes: relationship to rfc7482 (outside of the shepherd

[SAH] OK, understood. I can add text to the header, Abstract, and Introduction to note that 7482bis and 7483bis obsolete their predecessors.

Scott