Subject: Re: [regext] I-D Action: draft-ietf-regext-simple-registration-reporting-02.txt

From: Joseph Yee <[email-masked]>
Date: Mon, 22 Feb 2021 17:57:52 -0500

Hi Tobias,

Many thanks for your feedback. Please see comments inline

On Tue, Nov 3, 2020 at 8:44 AM Tobias Sattler <[email-masked]>
wrote:

> Hi Joseph,
> Hi Jim,
>
> Thanks for updating this draft.
>
> Some thoughts and comments from my side:
>
> General thoughts
> This document is intended to be informational. Therefore, I think it is
> better to avoid the word “standard” in the text. Because it would seem to
> be a de facto standard. I think that someone might be irritated by this
> later.
>
I vaguely recalled that some suggested changing this to BCP.  Can't find it
in the minutes. I keep 'informational' with words 'standard' around for
now. Will update on future revisions depends on which way the draft will go.

>
> Abstract
> I would open it up and write about Registries, Registrars, and Resellers.
>
I add the words 'producer' and 'consumer' next to the term registry
operator and the registrar respectively. Would the intro section be better
for the elaboration?

>
> 1. Introduction
> I would define “the producer” and “the consumer” by using the example
> Registries and Registrars as well as Registrars and Resellers. And
> reference later on only to producer and consumer.
>
But wouldn't registrar be a better understanded term?

>
> 2. Data Element Specification
> I am missing the character encoding. You are mentioning it in section 7. I
> would add a reference in section 2 to 7.
>
Done.

>
> 2.1.11 Registrar
> If you open it up to Resellers, then I would rename it to Consumer.
>
Would expanding the definition be better? I haven't made any changes to it,
want to discuss more on this first.

>
> 2.2.5. Trade
> I would add the field trade here, which is not uncommon in the ccTLD
> world. Just to have it right from the start.
>
Added.  Do you know if some ccTLD operators use a custom EPP command on
trade (to domain object)? Or it's domain update with a new contact object
where the registry operator charges on this specific transaction?

>
> 2.4.1. Registrar_ID
> If you open it up to Resellers, then I would rename it to Consumer_ID
>
Same as Registrar_ID.

>
> 3. Report Definition Specification
> After reading it, it is not 100% clear to me, what the delimiter is and if
> the values should be enclosed with (single or double) quotes.
>
We referenced RFC4180 regarding CSV.  The source mentioned double quotes.

>
> Appendix A. Acknowledgment
> There is a typo in bestpractices.domains. It is bestpractice.domains
> without a “s".
>
Fixed.  thanks.

The next revision will incorporate the changes mentioned above. And would
love to discuss more on items I haven't made changes to.

Best,
Joseph

>
>
> Best,
> Tobias
>
> > On 2. Nov 2020, at 23:21, [email-masked] wrote:
> >
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> > This draft is a work item of the Registration Protocols Extensions WG of
> the IETF.
> >
> >        Title           : Simple Registration Reporting
> >        Authors         : Joseph Yee
> >                          James Galvin
> >       Filename        :
> draft-ietf-regext-simple-registration-reporting-02.txt
> >       Pages           : 33
> >       Date            : 2020-11-02
> >
> > Abstract:
> >   Domain name registries and registrars report to each other by sharing
> >   bulk information through files.  This document creates two IANA
> >   registries to establish a standard reporting mechanism between domain
> >   name registries and registrars.  The first IANA registry lists
> >   standard data elements and their syntax for inclusion in the files.
> >   The second IANA registry lists standard reports based on the standard
> >   data elements.  Each report is a file formatted as a CSV file.  The
> >   advantage of this reporting mechanism is that report, each file, can
> >   be imported by recipients without any prior knowledge of their
> >   contents, although reporting is enhanced with a minimum of knowledge
> >   about the files.  The mechanism for the transmission and reception of
> >   the files is a matter of local policy.
> >
> >
> > The IETF datatracker status page for this draft is:
> >
> https://datatracker.ietf.org/doc/draft-ietf-regext-simple-registration-reporting/
> >
> > There is also an HTML version available at:
> >
> https://www.ietf.org/archive/id/draft-ietf-regext-simple-registration-reporting-02.html
> >
> > A diff from the previous version is available at:
> >
> https://www.ietf.org/rfcdiff?url2=draft-ietf-regext-simple-registration-reporting-02
> >
> >
> > Please note that it may take a couple of minutes from the time of
> submission
> > until the htmlized version and diff are available at tools.ietf.org.
> >
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/
> >
> >
> > _______________________________________________
> > regext mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/regext
>
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext
>

---

From: Tobias Sattler <[email-masked]>
Date: Tue, 23 Feb 2021 14:54:34 +0100

Hi Joseph,

Thank you for the update.

Please find my comments inline.

Best,
Tobias

> On 22. Feb 2021, at 23:57, Joseph Yee <[email-masked]> wrote:
> 
> Hi Tobias,
> 
> On Tue, Nov 3, 2020 at 8:44 AM Tobias Sattler <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Joseph,
> Hi Jim,
> 
> This document is intended to be informational. Therefore, I think it is better to avoid the word “standard” in the text. Because it would seem to be a de facto standard. I think that someone might be irritated by this later.
> I vaguely recalled that some suggested changing this to BCP.  Can't find it in the minutes. I keep 'informational' with words 'standard' around for now. Will update on future revisions depends on which way the draft will go.
>  
> 
> Abstract
> I add the words 'producer' and 'consumer' next to the term registry operator and the registrar respectively. Would the intro section be better for the elaboration? 
> 

TS: Looks good to me.

>  
> 
> 1. Introduction
> I would define “the producer” and “the consumer” by using the example Registries and Registrars as well as Registrars and Resellers. And reference later on only to producer and consumer.

TS: True, however, this document can be used for reports from Registries to Registrars as well as from Registrars to Resellers. Or maybe even the other way around. There might be multiple ways of using it. Therefore, it may make sense to broaden it and to use generic terms, such as producer and consumer.

> I am missing the character encoding. You are mentioning it in section 7. I would add a reference in section 2 to 7.
> Done.

TS: Confirmed.

> Would expanding the definition be better? I haven't made any changes to it, want to discuss more on this first.
>  
> 
> 2.2.5. Trade
> I would add the field trade here, which is not uncommon in the ccTLD world. Just to have it right from the start.
> Added.  Do you know if some ccTLD operators use a custom EPP command on trade (to domain object)? Or it's domain update with a new contact object where the registry operator charges on this specific transaction?

TS: I’ve seen multiple implementations some of them not based on EPP either. So I don't think it's wrong to have that in there.

> After reading it, it is not 100% clear to me, what the delimiter is and if the values should be enclosed with (single or double) quotes.

TS: Confirmed.

> There is a typo in bestpractices.domains. It is bestpractice.domains without a “s".
> Fixed.  thanks.
> 
> The next revision will incorporate the changes mentioned above. And would love to discuss more on items I haven't made changes to.
> 
> Best,
> Joseph
>  
> 
> 
> Best,
> Tobias
> 
> > On 2. Nov 2020, at 23:21, [email-masked] <mailto:[email-masked]> wrote:
> > 
> > 
> > A New Internet-Draft is available from the on-line Internet-Drafts directories.
> > This draft is a work item of the Registration Protocols Extensions WG of the IETF.
> > 
> >       Filename        : draft-ietf-regext-simple-registration-reporting-02.txt
> >       Pages           : 33
> >       Date            : 2020-11-02
> > 
> > Abstract:
> > https://datatracker.ietf.org/doc/draft-ietf-regext-simple-registration-reporting/ <https://datatracker.ietf.org/doc/draft-ietf-regext-simple-registration-reporting/>
> > 
> > https://www.ietf.org/archive/id/draft-ietf-regext-simple-registration-reporting-02.html <https://www.ietf.org/archive/id/draft-ietf-regext-simple-registration-reporting-02.html>
> > 
> > https://www.ietf.org/rfcdiff?url2=draft-ietf-regext-simple-registration-reporting-02 <https://www.ietf.org/rfcdiff?url2=draft-ietf-regext-simple-registration-reporting-02>
> > 
> > 
> > Please note that it may take a couple of minutes from the time of submission
> > until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> > 
> > ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
> > 
> > 
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>