Subject: [regext] EXTENDED: Re: CALL FOR ADOPTION: draft-loffredo-regext-rdap-jcard-deprecation-03

From: "James Galvin" <[email-masked]>
Date: Wed, 10 Feb 2021 14:33:36 -0500

The Chairs would like to extend this CALL FOR ADOPTION because we’d 
like to separate out an issue that has come up in the discussion of this 
adoption.  We are hoping that this clarity will address the concern that 
has been raised.

This document actually covers two distinct issues.

1. A specification for jsContact.
2. A proposal for migrating to jsContact from jCard.

There are words suggesting that jCard would be deprecated as part of 
this and the question has been raised on the list as to whether or not 
this is actually a reality.

The Chairs would like to propose that we separate out the question of 
whether or not jCard will be deprecated.  That is better considered as a 
separate question.

Since there is precedent in the IETF for documenting alternate ways of 
meeting a requirement, here is what we propose.

This CALL FOR ADOPTION is to commit to a specification of jsContact.  
The specification would be permitted to document how one could migrate 
from jCard to jsContact.  The starting point for this work is 
draft-loffredo-regext-rdap-jcard-deprecation-03.

If this document is adopted, then we will need to consider the 
relationship between the use of jsContact and jCard.  The IESG will ask 
us this question as part of considering the publication of any document 
we develop.  This will effect the potential status of the document, 
e.g., Proposed Standard vs Experimental.  More specifically, we will 
need to consider whether there is support to migrate to something new 
given the legacy deployment.  It is appropriate to have this discussion 
within the working group.

With all that in mind, here is the revised, extended CALL FOR ADOPTION:

This is a formal adoption request for “Using JSContact in Registration 
Data Access Protocol (RDAP) JSON Responses”:

https://datatracker.ietf.org/doc/draft-loffredo-regext-rdap-jcard-deprecation/

This document will serve as the starting point for documenting 
jsContact.  It may also document how to migrate from jCard to jsContact, 
depending on the consensus of the working group.

Please review this draft to see if you think it is suitable for adoption 
by REGEXT for the stated purpose, and comment to the list, clearly 
stating your view.

If adopted, the document will be renamed as follows: 
draft-ietf-regext-rdap-jscontact.

Please indicate if you are willing to contribute text, review text, or 
be a document shepherd.

Please also indicate any preference you have for a proposed milestone 
date.

This call for adoption ends Monday, 22 February 2021.

If there are no objections, and we receive enough consensus for 
adoption, the chairs will consider this document adopted.

Thanks,

Your REGEXT co-chairs Antoin and Jim

On 18 Jan 2021, at 9:29, James Galvin wrote:

> This is a formal adoption request for “Using JSContact in 
> Registration Data Access Protocol (RDAP) JSON Responses”:
>
> https://datatracker.ietf.org/doc/draft-loffredo-regext-rdap-jcard-deprecation/
>
> Please review this draft to see if you think it is suitable for 
> adoption by REGEXT, and comment to the list, clearly stating your 
> view.
>
> Please indicate if you are willing to contribute text, review text, or 
> be a document shepherd.
>
> Please also indicate any preference you have for a proposed milestone 
> date.
>
> This call for adoption ends Monday, 1 February 2021.
>
> If there are no objections, and we receive enough consensus for 
> adoption, the chairs will consider this document adopted.
>
> Thanks,
>
> Your REGEXT co-chairs Antoin and Jim

---

From: Mario Loffredo <[email-masked]>
Date: Thu, 11 Feb 2021 16:26:53 +0100

Hi,

I support adoption of this draft for the purpose stated by WG Chairs and 
am willing to go on working on it.

Mario

Il 10/02/2021 20:33, James Galvin ha scritto:
> like to separate out an issue that has come up in the discussion of 
> this adoption.  We are hoping that this clarity will address the 
> concern that has been raised.
>
> whether or not jCard will be deprecated.  That is better considered as 
> a separate question.
>
> relationship between the use of jsContact and jCard.  The IESG will 
> ask us this question as part of considering the publication of any 
> document we develop.  This will effect the potential status of the 
> document, e.g., Proposed Standard vs Experimental.  More specifically, 
> we will need to consider whether there is support to migrate to 
> something new given the legacy deployment.  It is appropriate to have 
> this discussion within the working group.
>
> jsContact.  It may also document how to migrate from jCard to 
> jsContact, depending on the consensus of the working group.
>
> adoption by REGEXT for the stated purpose, and comment to the list, 
> clearly stating your view.
>
>> adoption by REGEXT, and comment to the list, clearly stating your view.
>>
>> Please indicate if you are willing to contribute text, review text, 
>> or be a document shepherd.
>>
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext

-- 
Dr. Mario Loffredo
Technological Unit “Digital Innovation”
Institute of Informatics and Telematics (IIT)
National Research Council (CNR)
via G. Moruzzi 1, I-56124 PISA, Italy
Phone: +39.0503153497
Web: http://www.iit.cnr.it/mario.loffredo

---

From: Jasdip Singh <[email-masked]>
Date: Thu, 11 Feb 2021 15:34:39 +0000

Hi.

+1 for adoption.

Jasdip

On 2/10/21, 2:33 PM, "regext on behalf of James Galvin" <[email-masked] on behalf of [email-masked]> wrote:

    

    

    

    

    

    
    
    Thanks,

---

From: Maurizio Martinelli <[email-masked]>
Date: Thu, 11 Feb 2021 16:49:14 +0100

Hi all,

+1 for adoption.

Best,
Maurizio

> Il giorno 10 feb 2021, alle ore 20:33, James Galvin <[email-masked]> ha scritto:
> 
> The Chairs would like to extend this CALL FOR ADOPTION because we’d like to separate out an issue that has come up in the discussion of this adoption.  We are hoping that this clarity will address the concern that has been raised.
> 
> There are words suggesting that jCard would be deprecated as part of this and the question has been raised on the list as to whether or not this is actually a reality.
> 
> The Chairs would like to propose that we separate out the question of whether or not jCard will be deprecated.  That is better considered as a separate question.
> 
> Since there is precedent in the IETF for documenting alternate ways of meeting a requirement, here is what we propose.
> 
> This CALL FOR ADOPTION is to commit to a specification of jsContact.  The specification would be permitted to document how one could migrate from jCard to jsContact.  The starting point for this work is draft-loffredo-regext-rdap-jcard-deprecation-03.
> 
> If this document is adopted, then we will need to consider the relationship between the use of jsContact and jCard.  The IESG will ask us this question as part of considering the publication of any document we develop.  This will effect the potential status of the document, e.g., Proposed Standard vs Experimental.  More specifically, we will need to consider whether there is support to migrate to something new given the legacy deployment.  It is appropriate to have this discussion within the working group.
> 
> This is a formal adoption request for “Using JSContact in Registration Data Access Protocol (RDAP) JSON Responses”:
> 
> This document will serve as the starting point for documenting jsContact.  It may also document how to migrate from jCard to jsContact, depending on the consensus of the working group.
> 
> Please review this draft to see if you think it is suitable for adoption by REGEXT for the stated purpose, and comment to the list, clearly stating your view.
> 
> If adopted, the document will be renamed as follows: draft-ietf-regext-rdap-jscontact.
> 
> Please indicate if you are willing to contribute text, review text, or be a document shepherd.
> 
> Please also indicate any preference you have for a proposed milestone date.
> 
> If there are no objections, and we receive enough consensus for adoption, the chairs will consider this document adopted.
> 
> Thanks,
> 
>> This is a formal adoption request for “Using JSContact in Registration Data Access Protocol (RDAP) JSON Responses”:
>> 
>> Please review this draft to see if you think it is suitable for adoption by REGEXT, and comment to the list, clearly stating your view.
>> 
>> Please indicate if you are willing to contribute text, review text, or be a document shepherd.
>> 
>> Please also indicate any preference you have for a proposed milestone date.
>> 
>> If there are no objections, and we receive enough consensus for adoption, the chairs will consider this document adopted.
>> 
>> Thanks,
>> 

----
Dr. Maurizio Martinelli
Responsabile Unità Tecnologica Innovazione Digitale
CNR - Istituto di Informatica e Telematica
via G. Moruzzi 1, 56124 PISA, Italy
E-Mail: [email-masked]
Phone: +39 050 3152087
Web: http://www.iit.cnr.it/maurizio.martinelli

---

From: Alexander Mayrhofer <[email-masked]>
Date: Sun, 14 Feb 2021 16:51:12 +0100

I do support adoption of this document, and I am willing to perform reviews and text.

Best,
Alex

> -----Ursprüngliche Nachricht-----
> Von: regext <[email-masked]> Im Auftrag von James Galvin
> Gesendet: Montag, 18. Jänner 2021 15:29
> An: REGEXT WG <[email-masked]>
> Betreff: [regext] CALL FOR ADOPTION: draft-loffredo-regext-rdap-jcard-
> deprecation-03
> 
> Please review this draft to see if you think it is suitable for adoption by
> REGEXT, and comment to the list, clearly stating your view.
> 
> If there are no objections, and we receive enough consensus for adoption,
> the chairs will consider this document adopted.
> 
> Thanks,
>

---

From: Gavin Brown <[email-masked]>
Date: Mon, 15 Feb 2021 10:38:05 +0000

Hi,

I support adoption of this document and will continue to contribute to it.

G.

> On 10 Feb 2021, at 19:33, James Galvin <[email-masked]> wrote:
> 

--
Gavin Brown
Head of Registry Services
CentralNic Group plc (LSE:CNIC)
https://centralnicregistry.com

Cal: https://cnic.link/gbcalendar

CentralNic Group plc is a company registered in England and Wales with company number 8576358. Registered Offices: Saddlers House, Gutter Lane, London EC2V 6BR.

https://www.centralnic.com