Subject: [regext] Magnus Westerlund's No Objection on draft-ietf-regext-rfc7482bis-02: (with COMMENT)

From: Magnus Westerlund via Datatracker <[email-masked]>
Date: Thu, 18 Feb 2021 06:11:21 -0800

Magnus Westerlund has entered the following ballot position for
draft-ietf-regext-rfc7482bis-02: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-regext-rfc7482bis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Section 1:
"Servers MUST return an
   HTTP 501 (Not Implemented) [RFC7231] response to inform clients of
   unsupported query types."

I don't really like when already in the introduction one leaps into normative
statements. Doesn't this statement more belong in either Query processing or
extensibility?

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 18 Feb 2021 15:58:38 +0000

> -----Original Message-----
> From: Magnus Westerlund via Datatracker <[email-masked]>
> Sent: Thursday, February 18, 2021 9:11 AM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked];
> [email-masked]; Mario Loffredo <[email-masked]>;
> [email-masked]
> Subject: [EXTERNAL] Magnus Westerlund's No Objection on draft-ietf-
> regext-rfc7482bis-02: (with COMMENT)
>
> Caution: This email originated from outside the organization. Do not click links
> or open attachments unless you recognize the sender and know the content
> is safe.
>
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)

[SAH] [snip]

> statements. Doesn't this statement more belong in either Query processing
> or extensibility?

[SAH] Probably, but this is something inherited from 7482. I'm thus inclined to leave it there.

Scott

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 19 Feb 2021 08:19:20 +0000

Hi,

> [SAH] Probably, but this is something inherited from 7482. I'm thus inclined

Ok, I see the point too keep it as it is.

/Magnus