Subject: [regext] I-D Action: draft-ietf-regext-epp-registry-maintenance-12.txt

From: [email-masked]
Date: Sat, 27 Mar 2021 08:51:09 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Registration Protocols Extensions WG of the IETF.

        Title           : Registry Maintenance Notifications for the Extensible Provisioning Protocol (EPP)
        Authors         : Tobias Sattler
                          Roger Carney
                          Jody Kolker
	Filename        : draft-ietf-regext-epp-registry-maintenance-12.txt
	Pages           : 22
	Date            : 2021-03-27

Abstract:
   This document describes an Extensible Provision Protocol (EPP)
   mapping for registry's maintenance notifications.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-regext-epp-registry-maintenance/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-regext-epp-registry-maintenance-12
https://datatracker.ietf.org/doc/html/draft-ietf-regext-epp-registry-maintenance-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-regext-epp-registry-maintenance-12

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Michael Bauland <[email-masked]>
Date: Tue, 30 Mar 2021 11:22:39 +0200

Hi,

I have reviewed the document and support it as it is. Nevertheless, I
have the following very minor comments/questions.

1 Introduction:
> This mapping provides a
>    mechanism by which EPP servers may notify and EPP clients to query
>    upcoming maintenances.

While I'm not a native speaker, to me it sounds as if the grammar is not
correct in the second part of the sentence. Maybe the "EPP clients to"
should be replace by "EPP clients can"?

3.3.  Maintenance Elements:

The <maint:id> content must not be changed. What about the optional
"name" attribute? There's no rule about it so implementations are free
to alter this if the ID remains the same. Is that correct/intended?

<maint:host>:
> The affected maintained system contains the hostname, which
>             SHALL be an A-label according to [RFC5891].

This again sounds strange to my (non-native) ears. Shouldn't this
perhaps be something like:
"The affected maintained system's hostname, which SHALL be an A-label
according to [RFC5891]."

<maint:environment>:
There must be exactly one environment. If I want to inform about a
maintenance which affects, e.g., both OT&E and staging I have to send
two notifications (with two different server unique identifiers). I
guess that's a corner case that does not happen too often, so it should
be ok.

<maint:description>:
Would it maybe make sense to allow multiple occurrences with different
language attributes? If I want to add a German and English description.
I have seen such notifications from some registries (mainly cc) that
communicate in English and their native tongue.

Best regards,

Michael

-- 
____________________________________________________________________
     |       |
     | knipp |            Knipp  Medien und Kommunikation GmbH
      -------                    Technologiepark
                                 Martin-Schmeisser-Weg 9
                                 44227 Dortmund
                                 Germany

     Dipl.-Informatiker          Fon:    +49 231 9703-0
                                 Fax:    +49 231 9703-200
     Dr. Michael Bauland         SIP:    [email-masked]
     Software Development        E-mail: [email-masked]

                                 Register Court:
                                 Amtsgericht Dortmund, HRB 13728

                                 Chief Executive Officers:
                                 Dietmar Knipp, Elmar Knipp

---

From: Jody Kolker <[email-masked]>
Date: Wed, 31 Mar 2021 14:08:14 +0000

On behalf of Roger, Tobias and I, thank you for you review Michael.

Please see my comments in line below.

The updates have been made in github for your review:
https://github.com/seitsu/registry-epp-maintenance/blob/master/draft-ietf-regext-epp-registry-maintenance.txt>

Let us know if you have any questions or comments

Thanks,
Jody Kolker

-----Original Message-----
From: regext <[email-masked]> On Behalf Of Michael Bauland
Sent: Tuesday, March 30, 2021 4:23 AM
To: [email-masked]
Subject: Re: [regext] I-D Action: draft-ietf-regext-epp-registry-maintenance-12.txt

Hi,

I have reviewed the document and support it as it is. Nevertheless, I have the following very minor comments/questions.

>    mechanism by which EPP servers may notify and EPP clients to query

While I'm not a native speaker, to me it sounds as if the grammar is not correct in the second part of the sentence. Maybe the "EPP clients to"
should be replace by "EPP clients can"?

<< JWK
The text has been updated to "EPP clients can"

The <maint:id> content must not be changed. What about the optional "name" attribute? There's no rule about it so implementations are free to alter this if the ID remains the same. Is that correct/intended?

<< JWK
This is correct, the name attribute can be changed.  We see the ID being used as the main identifier to be stored and used to identify the maintenance.  The name could be mistyped in subsequent polls or it maybe renamed as the registry sees fit, but we would expect the ID to not change.

>             SHALL be an A-label according to [RFC5891].

This again sounds strange to my (non-native) ears. Shouldn't this perhaps be something like:
"The affected maintained system's hostname, which SHALL be an A-label according to [RFC5891]."
<<  JWK
Text has been updated.

<maint:environment>:
There must be exactly one environment. If I want to inform about a maintenance which affects, e.g., both OT&E and staging I have to send two notifications (with two different server unique identifiers). I guess that's a corner case that does not happen too often, so it should be ok.
<< JWK
Thanks for your review.  We would see multiple environments needing separate poll messages.

<maint:description>:
Would it maybe make sense to allow multiple occurrences with different language attributes? If I want to add a German and English description.
I have seen such notifications from some registries (mainly cc) that communicate in English and their native tongue.
<< JWK
The maint:description element is unbounded.  If descriptions in different languages are needed, they can be sent on the same poll message.

Best regards,

Michael

                                 Register Court:

_______________________________________________
regext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/regext