Subject: Re: [regext] 2nd WG LAST CALL: draft-ietf-regext-epp-registry-maintenance

From: Gavin Brown <[email-masked]>
Date: Wed, 7 Apr 2021 13:46:13 +0100

Hi Antoin,

I've reviewed the document and support its submission to the RFC Editor queue.

G.

> On 29 Mar 2021, at 13:49, Antoin Verschuren <[email-masked]> wrote:
> 
> The following working group document is believed to be ready for submission to the IESG for publication as a standards track document:
> 
> https://datatracker.ietf.org/doc/draft-ietf-regext-epp-registry-maintenance/
> 
> EXTRA ATTENTION: This is the second WGLC for this document. During the first WGLC, there were still some substantial comments to be addressed, and there was not enough positive feedback to declare consensus on this document. Let’s do better this time and please take the time to review this document and indicate your support (a simple “+1” is sufficient) or concerns with the publication of this document by replying to this message on the list. Since we have 3 authors, we need more reviewers to state support!
> 
> This WG last call will end at close of business, Monday, 12 April 2021.
> 
> 
> The document shepherd for this document is James Galvin.
> 
> Regards,
> 
> Antoin and Jim
> 
> 
> 
> 
> 

--
Gavin Brown
Head of Registry Services
CentralNic Group plc (LSE:CNIC)
https://centralnicregistry.com

Cal: https://cnic.link/gbcalendar

CentralNic Group plc is a company registered in England and Wales with company number 8576358. Registered Offices: Saddlers House, Gutter Lane, London EC2V 6BR.

https://www.centralnic.com

---

From: Joseph Yee <[email-masked]>
Date: Sun, 11 Apr 2021 12:25:07 -0400

Hi Antoin and everyone,

I reviewed the -12 draft and support the publication.

Two (very) minor changes suggested:

(1)
Section 3.3
<maint:detail>
The OPTIONAL URI to detailed maintenance description.

It's clear what URI is, but should still need to reference it with the
according RFCs.

(2)
Section 5.1
The formal syntax for <maint:id> should include the attribute specification
for 'name' and 'lang'.

Best,
Joseph

On Mon, Mar 29, 2021 at 9:21 AM Antoin Verschuren <[email-masked]> wrote:

> Just to be clear, since this is a 2nd WGLC, the new WGLC is for
> draft-ietf-regext-epp-registry-maintenance-12
>
>
>
> > Op 29 mrt. 2021, om 14:49 heeft Antoin Verschuren <[email-masked]> het
> volgende geschreven:
> >
> > The following working group document is believed to be ready for
> submission to the IESG for publication as a standards track document:
> >
> >
> > EXTRA ATTENTION: This is the second WGLC for this document. During the
> first WGLC, there were still some substantial comments to be addressed, and
> there was not enough positive feedback to declare consensus on this
> document. Let’s do better this time and please take the time to review this
> document and indicate your support (a simple “+1” is sufficient) or
> concerns with the publication of this document by replying to this message
> on the list. Since we have 3 authors, we need more reviewers to state
> support!
> >
> > _______________________________________________
> > regext mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/regext
>
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext
>

---

From: Tobias Sattler <[email-masked]>
Date: Mon, 12 Apr 2021 13:21:49 +0200

Thanks, Joseph.

Please see our comments inline.

Tobias

> On 11. Apr 2021, at 18:25, Joseph Yee <[email-masked]> wrote:
> 
> Hi Antoin and everyone,
> 
> It's clear what URI is, but should still need to reference it with the according RFCs.

TS: We will add the reference.

> 
> (2)
> Section 5.1
> The formal syntax for <maint:id> should include the attribute specification for 'name' and 'lang'.

TS: Can you please clarify that? We have “name” and “lang” for <maint:id>.

<complexType name="infoType">
       <sequence>
         <choice>
           <element name="list"/>
           <element name="id" type="maint:idType"/>
         </choice>
       </sequence>
     </complexType>
     <!--
     Human-readable text may describe the maintenance
     -->
     <complexType name="idType">
       <simpleContent>
         <extension base="token">
           <attribute name="name" type="token"/>
           <attribute name="lang" type="language" default="en"/>
         </extension>
       </simpleContent>
     </complexType>

> 
> Best,
> Joseph
> 
> 
> 
> On Mon, Mar 29, 2021 at 9:21 AM Antoin Verschuren <[email-masked] <mailto:[email-masked]>> wrote:
> Just to be clear, since this is a 2nd WGLC, the new WGLC is for draft-ietf-regext-epp-registry-maintenance-12
> 
> 
> 
> > Op 29 mrt. 2021, om 14:49 heeft Antoin Verschuren <[email-masked] <mailto:[email-masked]>> het volgende geschreven:
> > 
> > https://datatracker.ietf.org/doc/draft-ietf-regext-epp-registry-maintenance/ <https://datatracker.ietf.org/doc/draft-ietf-regext-epp-registry-maintenance/>
> > 
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>

---

From: Antoin Verschuren <[email-masked]>
Date: Mon, 12 Apr 2021 15:48:29 +0200

Hi all,

This is a reminder that this 2nd WGLC will end tonight!
We still don’t seem to have enough consensus, so please state your support. Also if you have responded to the first WGLC.

Regards,

Jim and Antoin

> Op 29 mrt. 2021, om 14:49 heeft Antoin Verschuren <[email-masked]> het volgende geschreven:
>

---

From: Marcel Parodi <[email-masked]>
Date: Mon, 12 Apr 2021 16:40:29 +0000

For some time now, I’ve been wondering whether it’s a good idea to choose the EPP service as a channel to provide information about maintenance windows of an unspecified set of services.
After reading last weeks discussion here on the mailing list, it seems rather unrealistic to me, that this proposed EPP extension will ever help a registrar to significantly simplify its job of juggling with the services of hundreds of registries. In my view, the semantics of several fields are not defined precise enough to be of much help. And during the last week it got even worse (by declaring <system:host> as optional).

A “system” (what I usually call a service) is specified by two free form strings (<system:id>, <system:name>) and an (meanwhile) optional <system:host>. The value of <system:name> can be updated by the registry at discretion. How can an EPP client make sense out of these strings?

In my opinion, the proposed extension can only be used to communicate the beginning and end of some maintenance windows in machine readable form. Information about the affected services can be provided only as free form text (or as a URI whose content can be changed at any time).
Or is it indended, that the missing semantics will be specified outside IETF? Will some other group need to specify an “EPP maintenance profile”?

Regards,
Marcel.

On 12.04.21, 15:49, "regext on behalf of Antoin Verschuren" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Regards,

Jim and Antoin

Op 29 mrt. 2021, om 14:49 heeft Antoin Verschuren <[email-masked]<mailto:[email-masked]>> het volgende geschreven:

Regards,

Antoin and Jim

---

From: Joseph Yee <[email-masked]>
Date: Mon, 12 Apr 2021 16:08:08 -0400

Hi Tobias,

inline

>            <attribute name="lang" type="language" default="en"/>
Yes, re-read the draft and it's there.  I missed it when I wrote my comment.

Thanks,
Joseph

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 13 Apr 2021 00:03:30 +0000

Hi Antoin,

I support the document's submission.

Thanks
Quoc

-----Original Message-----
From: regext <[email-masked]> On Behalf Of Antoin Verschuren
Sent: Tuesday, 30 March 2021 12:21 AM
To: [email-masked]
Subject: Re: [regext] 2nd WG LAST CALL: draft-ietf-regext-epp-registry-maintenance

Caution: This email is from an external sender. Please do not click links or open attachments unless you recognize the sender and know the content is safe. Forward suspicious emails to isitbad@.

> https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-regext-epp-registry-maintenance/__;!!N14HnBHF!t-eFGRG4PtyrY0iwBcYlInHNEeDNnS14tqdnjz2zZ408D8SsBzRsY7-F80vVCGqfkqNYj8Q8$
>
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/regext__;!!N14HnBHF!t-eFGRG4PtyrY0iwBcYlInHNEeDNnS14tqdnjz2zZ408D8SsBzRsY7-F80vVCGqfkneFILA5$

_______________________________________________
regext mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/regext__;!!N14HnBHF!t-eFGRG4PtyrY0iwBcYlInHNEeDNnS14tqdnjz2zZ408D8SsBzRsY7-F80vVCGqfkneFILA5$

---

From: Jody Kolker <[email-masked]>
Date: Tue, 13 Apr 2021 02:23:34 +0000

Thanks for the reply Marcel.

If registrys had a standard email format for sending out registry notices, I would tend to agree with you.  But since I have not seen any type of standard among registry maintenance emails, we are proposing at least a specification that should be able to be used by all registrys that the registrars can parse easily.  Emails can go unnoticed, mailboxes full or moved into folders by rules that have been set up incorrectly.  Sending the notification via an EPP messages gives registrars the ability to parse the elements that registrars are most concerned with in a standard format.  Could this be done with emails?  Sure, but not as easily unless a spec was defined for the email.  The maintenance system, time,  duration, environment, impact and TLDs can be read from a standard format within an EPP poll message easier and more reliably than a free form email.

As far as system names needing to be standard, I am not concerned if one registry calls their EPP system “EPP” and another calls it “SRS”.  It seems as if every registry has implemented their own version of an EPP “redemption” of a domain, their own domain lifecycle, and EPP implementation of Sunrise and Landrush protocols.  Determining the names of each registrys system will be much easier than any of those three processes.

I do not plan on parsing the free form description for any information regarding the maintenance, as I expect no other registrars will.  As I stated above, we are only concerned with what time, duration, environment, impact and TLDs, which are separate elements in the specification.  However, description was added in case registrars wanted to send a more human readable message in the their systems to operations or customer support teams.

Registrars plan to rely heavily on this EPP message so that they can automate the messaging of registry maintenance to our entire company instead of having someone manually read emails and update notifications to our specific teams.  It has become an operational burden to try to keep up with the stream of maintenance emails that arrive constantly.

Please let us know if you have any questions.

Thanks,
Jody Kolker.

From: regext <[email-masked]> On Behalf Of Marcel Parodi
Sent: Monday, April 12, 2021 11:40 AM
To: Antoin Verschuren <[email-masked]>; regext <[email-masked]>
Subject: Re: [regext] 2nd WG LAST CALL: draft-ietf-regext-epp-registry-maintenance

Regards,
Marcel.

Hi all,

Regards,

Jim and Antoin

Regards,

Antoin and Jim

_______________________________________________
regext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/regext

---

From: Michael Bauland <[email-masked]>
Date: Tue, 13 Apr 2021 08:05:31 +0200

Hi all,

On 12.04.2021 15:48, Antoin Verschuren wrote:
> We still don’t seem to have enough consensus, so please state your
> support. Also if you have responded to the first WGLC.

I'm not sure if my comment from 2020-03-30
("I have reviewed the document and support it as it is.")
has already been counted. If not I can repeat it here again:

I support this draft.

Best regards,

Michael

-- 
____________________________________________________________________
     |       |
     | knipp |            Knipp  Medien und Kommunikation GmbH
      -------                    Technologiepark
                                 Martin-Schmeisser-Weg 9
                                 44227 Dortmund
                                 Germany

     Dipl.-Informatiker          Fon:    +49 231 9703-0
                                 Fax:    +49 231 9703-200
     Dr. Michael Bauland         SIP:    [email-masked]
     Software Development        E-mail: [email-masked]

                                 Register Court:
                                 Amtsgericht Dortmund, HRB 13728

                                 Chief Executive Officers:
                                 Dietmar Knipp, Elmar Knipp

---

From: Antoin Verschuren <[email-masked]>
Date: Mon, 19 Apr 2021 15:27:11 +0200

Working group Last Call for this document ended last Monday.
We are happy to see that we finally got 7 participants in favour, and no objections to this draft.

This means that we are now ready submit this document to the IESG.
We see that the authors have already submitted a version -13 for this draft, that we assume has all the comments during the 2nd WGLC implemented.

The document shepherd for this draft is Jim Galvin.
I will ask the document shepherd to verify the -13 version to see all WGLC comments have been addressed, and do a write-up for the document before submitting it to the IESG.

Thank you all for your review and confirmation of support.

Your co-chair, Antoin.

---

From: Tobias Sattler <[email-masked]>
Date: Mon, 19 Apr 2021 16:00:28 +0200

Thanks, Antoin.

Please note that I am going to release v14 to address Jim Gould’s feedback to raise the XML namespace from 0.3 to 1.0 after successful WGLC.

Tobias

> On 19. Apr 2021, at 15:27, Antoin Verschuren <[email-masked]> wrote:
>