Subject: Re: [regext] Robert Wilton's No Objection on draft-ietf-regext-secure-authinfo-transfer-06: (with COMMENT)

From: "Gould, James" <[email-masked]>
Date: Mon, 19 Apr 2021 14:51:57 +0000

Robert,

Thank you for your review and feedback.  I provide responses to your feedback embedded below.

-- 
 
JG

James Gould
Fellow Engineer
[email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com <http://verisigninc.com/>

On 4/19/21, 7:57 AM, "Robert Wilton via Datatracker" <[email-masked]> wrote:

    Robert Wilton has entered the following ballot position for
    draft-ietf-regext-secure-authinfo-transfer-06: No Objection

    When responding, please keep the subject line intact and reply to all
    email addresses included in the To and CC lines. (Feel free to cut this
    introductory paragraph, however.)

    Please refer to https://secure-web.cisco.com/1nRJLRUiDha_wZnJfplBfW_pNR-Lw2xsv9qMMvatXWM3grB7zxr0vzxD0wFabNBjuWMawi8MSGohvoADlPx1luGJbH3vcnfYlia21So3k4RQWhOHzpjz6fGyDooK4AvwdPkg_1StQ_SQ1RdG0jK21rlCoY0tYim3vJcKfKjai0-12IC-P22F_w_JYt-GJxxgcH6bpU03vRvPp_If8O1a1-zuYTlTQDqMBRy6nyw5QqFA0znDRnkYtP4HTW3SlMD-C/https%3A%2F%2Fwww.ietf.org%2Fiesg%2Fstatement%2Fdiscuss-criteria.html
    for more information about DISCUSS and COMMENT positions.

    The document, along with other ballot positions, can be found here:
    https://secure-web.cisco.com/1rxr6X1OLj6yHWwZC-H4jTllgY_zX38cAQ0vMpclzgy1DMDjJs0nEThOO9aqx3f8nku40mR9XpzB1drPdbDe8orN31fBmSJquUXXjrwS6SJCWCyiZEHhf1jbEb1PzB0VLVzPLZn-lYpRt5fYSuB_vJWIKdd84JVnJlqF5VMEx8tG5nQPmSN0S4-NWF--scEabNqkCv2uJwvCKWEmUmANnztp_Fzlg5V_Ng5VEmO9RBN3r9xx30EB0UDiE8rOPG_1K/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-regext-secure-authinfo-transfer%2F

    ----------------------------------------------------------------------
    COMMENT:
    ----------------------------------------------------------------------

    Hi,

    Thanks for this document.

    I found it hard to understand what is actually being transferred in the
    title/abstract.  Perhaps this could be expanded a little to help readers who
    are not familiar with EPP.

JG - EPP supports an extensible set of objects that can be transferred between registrars, but the most important object defined is domain names.  How about extending the first sentence to provide a little bit more clarity as in "The Extensible Provisioning Protocol (EPP), in RFC 5730, defines the use of authorization information to authorize a transfer of an EPP object, such as a domain name, between clients that are referred to as registrars".  Providing what is being transferred and between whom may help things out.  Do you agree and do you have any recommendations to help non-EPP readers?   This could be updated in the abstract and the introduction.    

    I don't feel particularly strongly on this point, but when reviewing this
    document, I was wondering whether this document wouldn't be better published as
    informational rather than stds track, given that it seems to describe an
    operational practice of how an existing protocol (EPP) should be used.

JG - The working group had a thorough discussion around the track of the draft, which started out a BCP and moved to standards track.  The practice is relevant to the protocol, which does include signaling by the client and the server with defined behavior expectations, so standards track is the appropriate track.  

    Regards,
    Rob

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 19 Apr 2021 15:00:52 +0000

Hi James,

Please see inline ...

> -----Original Message-----
> From: Gould, James <[email-masked]>
> Sent: 19 April 2021 15:52
> To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
> Cc: [email-masked]; regext-
> [email-masked]; [email-masked]; [email-masked]
> Subject: Re: Robert Wilton's No Objection on draft-ietf-regext-secure-
> authinfo-transfer-06: (with COMMENT)
> 
> Robert,
> 
>     Please refer to https://secure-
> web.cisco.com/1nRJLRUiDha_wZnJfplBfW_pNR-
> Lw2xsv9qMMvatXWM3grB7zxr0vzxD0wFabNBjuWMawi8MSGohvoADlPx1luGJbH3vcnfYlia21
> So3k4RQWhOHzpjz6fGyDooK4AvwdPkg_1StQ_SQ1RdG0jK21rlCoY0tYim3vJcKfKjai0-
> 12IC-P22F_w_JYt-GJxxgcH6bpU03vRvPp_If8O1a1-
> zuYTlTQDqMBRy6nyw5QqFA0znDRnkYtP4HTW3SlMD-
> C/https%3A%2F%2Fwww.ietf.org%2Fiesg%2Fstatement%2Fdiscuss-criteria.html
>     https://secure-web.cisco.com/1rxr6X1OLj6yHWwZC-
> H4jTllgY_zX38cAQ0vMpclzgy1DMDjJs0nEThOO9aqx3f8nku40mR9XpzB1drPdbDe8orN31fB
> mSJquUXXjrwS6SJCWCyiZEHhf1jbEb1PzB0VLVzPLZn-
> lYpRt5fYSuB_vJWIKdd84JVnJlqF5VMEx8tG5nQPmSN0S4-NWF--
> scEabNqkCv2uJwvCKWEmUmANnztp_Fzlg5V_Ng5VEmO9RBN3r9xx30EB0UDiE8rOPG_1K/http
> s%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-regext-secure-authinfo-
> transfer%2F
> 
> 
> 
> JG - EPP supports an extensible set of objects that can be transferred
> between registrars, but the most important object defined is domain names.
> How about extending the first sentence to provide a little bit more
> clarity as in "The Extensible Provisioning Protocol (EPP), in RFC 5730,
> defines the use of authorization information to authorize a transfer of an
> EPP object, such as a domain name, between clients that are referred to as
> registrars".  Providing what is being transferred and between whom may
> help things out.  Do you agree and do you have any recommendations to help
> non-EPP readers?   This could be updated in the abstract and the
> introduction.
[RW] 

Yes, I think that would be sufficient clarification.  Hopefully it will help folks understand what topic this document is broadly addressing.

> JG - The working group had a thorough discussion around the track of the
> draft, which started out a BCP and moved to standards track.  The practice
> is relevant to the protocol, which does include signaling by the client
> and the server with defined behavior expectations, so standards track is
> the appropriate track.
[RW] 

Thanks for the explanation and extra background information.  No objection from me.

Regards,
Rob