Subject: Re: [regext] I-D Action: draft-ietf-regext-epp-registry-maintenance-12.txt

From: "Gould, James" <[email-masked]>
Date: Tue, 6 Apr 2021 16:33:00 +0000

Tobias,

It looks good with one nit of making descriptions plural as in “Zero or more OPTIONAL free-form descriptions”.

--

JG

James Gould
Fellow Engineer
[email-masked]<applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com<http://verisigninc.com/>

From: Tobias Sattler <[email-masked]>
Date: Tuesday, April 6, 2021 at 12:29 PM
To: James Gould <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [EXTERNAL] Re: [regext] I-D Action: draft-ietf-regext-epp-registry-maintenance-12.txt

Thanks Michael and Jim.

I’ve made the adjustment on GitHub for your review.
https://github.com/seitsu/registry-epp-maintenance/blob/master/draft-ietf-regext-epp-registry-maintenance.txt<https://secure-web.cisco.com/1qHhn9m_n0q1Aop-LvX59fsy8JV04r9d-NS_iCDZ5x8vZ_ZXeJt2CO7oDXK27hsU8Mr8S_41nsjRPFrjYDAiFveBRZ3ZkF5Nw_uo2v2SnNYXN7rkMl6JYfcd0O3CGnC0_kwrvWmTkqx6cPzh6l4_7icShqr4GYvhj7rqXvmaccBz2M5PDzZm--ziQiAUKihBIGtyIJkMdPi33ApZBYhIAqUSMx1C5YFQyxN622sUqjir77szIdHyTOIdQrMiPLsb6/https%3A%2F%2Fgithub.com%2Fseitsu%2Fregistry-epp-maintenance%2Fblob%2Fmaster%2Fdraft-ietf-regext-epp-registry-maintenance.txt>

Tobias

On 6. Apr 2021, at 14:21, Gould, James <jgould=[email-masked]<mailto:jgould=[email-masked]>> wrote:

If the intent is to support a list of description elements, then my recommendation is to update the schema, as previously noted with maxOccurs="unbounded", and update the description of the element with something similar to:

Zero or more OPTIONAL free-form descriptions of the maintenance...

--

JG

James Gould
Fellow Engineer
[email-masked]<mailto:[email-masked]> <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com<http://Verisign.com> <http://verisigninc.com/<http://secure-web.cisco.com/1q-u3_Fr2541unEM2O8NdJxYqFh-WP_FpSuHAnIlW4rGpTehTzsSVd_qpsRWqNaHhOnOwxg6faxqvKocTCBIu91LoZVv_J_kw1nC2UsaEML6NrC3QKXRfXGhRa2bpkKVVR6rxisAdEeCN5_wuXAs58cVUua-wGK4zjIMlgZpfeSCqA4JTmRfBdUhBQcg1jYXcsyK5sZXzT7K2BFB0_DUbc1h4YT-Vd5yi8GGR6IdM3hqyirKu_MwDUGUBUVo6E2R_/http%3A%2F%2Fverisigninc.com%2F>>

On 4/6/21, 5:50 AM, "regext on behalf of Michael Bauland" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

   Hi Jody,

   thanks for your answer.

   I agree with your comments, but there is still an issue with the
   descriptions in multiple languages. You said:

<< JWK
The maint:description element is unbounded.  If descriptions in different languages are needed, they can be sent on the same poll message.

   I think this is not the case according to the schema:

        <complexType name="maintDataType">
          <sequence>
            <element name="id" type="maint:idType"/>
            <element name="type" type="maint:typeType" minOccurs="0"/>
            <element name="pollType" type="maint:pollType" minOccurs="0"/>
            <element name="systems" type="maint:systemsType"/>
            <element name="environment" type="maint:envType"/>
            <element name="start" type="dateTime"/>
            <element name="end" type="dateTime"/>
            <element name="reason" type="maint:reasonEnum"/>
            <element name="detail" type="anyURI" minOccurs="0"/>
            <element name="description" type="maint:descriptionType"
             minOccurs="0"/>
            <element name="tlds" type="maint:tldsType" minOccurs="0"/>
            <element name="intervention" type="maint:interventionType"
             minOccurs="0"/>
            <element name="crDate" type="dateTime"/>
            <element name="upDate" type="dateTime" minOccurs="0"/>
          </sequence>
        </complexType>

   There is no maxOccurs element and the default is maxOccurs="1".
   My suggestion is to update the schema and allow unbounded occurrences to
   support multiple languages in one notification.

   Best regards,

   Michael

   --
   ____________________________________________________________________
        |       |
        | knipp |            Knipp  Medien und Kommunikation GmbH
         -------                    Technologiepark
                                    Martin-Schmeisser-Weg 9
                                    44227 Dortmund
                                    Germany

        Dipl.-Informatiker          Fon:    +49 231 9703-0
                                    Fax:    +49 231 9703-200
        Dr. Michael Bauland         SIP:    [email-masked]<mailto:[email-masked]>
        Software Development        E-mail: [email-masked]<mailto:[email-masked]>

                                    Register Court:
                                    Amtsgericht Dortmund, HRB 13728

                                    Chief Executive Officers:
                                    Dietmar Knipp, Elmar Knipp

   _______________________________________________
   regext mailing list
   [email-masked]<mailto:[email-masked]>
   https://secure-web.cisco.com/15k4MSsRmzO-vHkCwzCFTssa7wd6ube1TSVU9nPxSO0AvM5DSo-tqeF_QM-BOhHtQTCvYiN1Vu5caHJVGataZX93gVy4Td_WfFf5P69l-KZVWCTZeL63FrxS3j4izOnCXW-UkcYj9gZZxKHR8n7ECnYRg01JPweXW12kVqhxtE6z8By7KHJXHqSb4Grl_-1b_WDL_WAddOkE8Unkkb_601jo0hsbojViwdeVAB0mLY90OJBdLKj7DeW6hTQwwrxZQ/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext

_______________________________________________
regext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/regext

---

From: Tobias Sattler <[email-masked]>
Date: Tue, 6 Apr 2021 19:00:53 +0200

Thanks, Jim. I fixed it.

> On 6. Apr 2021, at 18:33, Gould, James <[email-masked]> wrote:
> 
> Tobias,
>  
> [email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>
> 
> 703-948-3271
> 12061 Bluemont Way
> Reston, VA 20190
> 
> Verisign.com <http://verisigninc.com/>
>  
> From: Tobias Sattler <[email-masked] <mailto:[email-masked]>>
> To: James Gould <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> https://github.com/seitsu/registry-epp-maintenance/blob/master/draft-ietf-regext-epp-registry-maintenance.txt <https://secure-web.cisco.com/1qHhn9m_n0q1Aop-LvX59fsy8JV04r9d-NS_iCDZ5x8vZ_ZXeJt2CO7oDXK27hsU8Mr8S_41nsjRPFrjYDAiFveBRZ3ZkF5Nw_uo2v2SnNYXN7rkMl6JYfcd0O3CGnC0_kwrvWmTkqx6cPzh6l4_7icShqr4GYvhj7rqXvmaccBz2M5PDzZm--ziQiAUKihBIGtyIJkMdPi33ApZBYhIAqUSMx1C5YFQyxN622sUqjir77szIdHyTOIdQrMiPLsb6/https%3A%2F%2Fgithub.com%2Fseitsu%2Fregistry-epp-maintenance%2Fblob%2Fmaster%2Fdraft-ietf-regext-epp-registry-maintenance.txt>
>  
> Tobias
> 
> 
>> On 6. Apr 2021, at 14:21, Gould, James <jgould=[email-masked] <mailto:jgould=[email-masked]>> wrote:
>>  
>> [email-masked] <mailto:[email-masked]> <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>>
>> 
>> 703-948-3271
>> 12061 Bluemont Way
>> Reston, VA 20190
>> 
>> Verisign.com <http://verisign.com/> <http://verisigninc.com/ <http://secure-web.cisco.com/1q-u3_Fr2541unEM2O8NdJxYqFh-WP_FpSuHAnIlW4rGpTehTzsSVd_qpsRWqNaHhOnOwxg6faxqvKocTCBIu91LoZVv_J_kw1nC2UsaEML6NrC3QKXRfXGhRa2bpkKVVR6rxisAdEeCN5_wuXAs58cVUua-wGK4zjIMlgZpfeSCqA4JTmRfBdUhBQcg1jYXcsyK5sZXzT7K2BFB0_DUbc1h4YT-Vd5yi8GGR6IdM3hqyirKu_MwDUGUBUVo6E2R_/http%3A%2F%2Fverisigninc.com%2F>>
>> 
>> On 4/6/21, 5:50 AM, "regext on behalf of Michael Bauland" <[email-masked] <mailto:[email-masked]> on behalf [email-masked] <mailto:[email-masked]>> wrote:
>> 
>> 
>>    Hi Jody,
>> 
>>    thanks for your answer.
>> 
>>         Dr. Michael Bauland         SIP:    [email-masked] <mailto:[email-masked]>
>>         Software Development        E-mail: [email-masked] <mailto:[email-masked]>
>> 
>>                                     Register Court:
>>    [email-masked] <mailto:[email-masked]>
>>    https://secure-web.cisco.com/15k4MSsRmzO-vHkCwzCFTssa7wd6ube1TSVU9nPxSO0AvM5DSo-tqeF_QM-BOhHtQTCvYiN1Vu5caHJVGataZX93gVy4Td_WfFf5P69l-KZVWCTZeL63FrxS3j4izOnCXW-UkcYj9gZZxKHR8n7ECnYRg01JPweXW12kVqhxtE6z8By7KHJXHqSb4Grl_-1b_WDL_WAddOkE8Unkkb_601jo0hsbojViwdeVAB0mLY90OJBdLKj7DeW6hTQwwrxZQ/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext <https://secure-web.cisco.com/15k4MSsRmzO-vHkCwzCFTssa7wd6ube1TSVU9nPxSO0AvM5DSo-tqeF_QM-BOhHtQTCvYiN1Vu5caHJVGataZX93gVy4Td_WfFf5P69l-KZVWCTZeL63FrxS3j4izOnCXW-UkcYj9gZZxKHR8n7ECnYRg01JPweXW12kVqhxtE6z8By7KHJXHqSb4Grl_-1b_WDL_WAddOkE8Unkkb_601jo0hsbojViwdeVAB0mLY90OJBdLKj7DeW6hTQwwrxZQ/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext>
>> 
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>