Subject: Re: [regext] Martin Duke's No Objection on draft-ietf-regext-secure-authinfo-transfer-06: (with COMMENT)

From: "Gould, James" <[email-masked]>
Date: Mon, 19 Apr 2021 15:33:34 +0000

Martin,

Thank you for the review and feedback.  

-- 
 
JG

James Gould
Fellow Engineer
[email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com <http://verisigninc.com/>

On 4/9/21, 8:17 PM, "Martin Duke via Datatracker" <[email-masked]> wrote:

    Martin Duke has entered the following ballot position for
    draft-ietf-regext-secure-authinfo-transfer-06: No Objection

    When responding, please keep the subject line intact and reply to all
    email addresses included in the To and CC lines. (Feel free to cut this
    introductory paragraph, however.)

    Please refer to https://secure-web.cisco.com/1494LouXp6bnWPFFb6b5w8o2N6PBUWORrjKHj7DaJ1fIpki6yYVATnUosU_eR__hWijPM6aZrt4vX-R70aY_Ve_217eTqq4T3H1p3S5Jmr8L0THnw_Vx6y04g1mtiIN_2y01sFHCguCYGtz1gEUVkFYy73r5m6vh-lXVKBt7OCUB2Ptb7_Cf5ajuHaeu2_LbG6VMiYAyLuS2AaWhRknr2RYBYFb_b2wh-BeAmqodQNRX1Xfl_LAXAa8LlKnXEMIKT/https%3A%2F%2Fwww.ietf.org%2Fiesg%2Fstatement%2Fdiscuss-criteria.html
    for more information about IESG DISCUSS and COMMENT positions.

    The document, along with other ballot positions, can be found here:
    https://secure-web.cisco.com/1tY59lQ76IHNrNSCIANCtv_U3SJiFbCWPeNsk4IQ4UyZpg9VaGurEaU4pEsj5bPBvSOY8M4-8dwJR04JEHaz7xQxWqYnKBw8V-IYqayrShT4hPYDmk-Rs-o9w5cW0z_QABUGhNHzN7zCR8S9j0EdScfgTBC072IFBPGEPBFMjIZr-w_yfRbb_VYwghXmTt60IFtBBPMRul1biaf2rUeCcO3Uh65Boc76I86PYBa-IikrXpA8chtAHSjMPSlYsHcFG/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-regext-secure-authinfo-transfer%2F

    ----------------------------------------------------------------------
    COMMENT:
    ----------------------------------------------------------------------

    In the third paragraph of (5.3) there is a roundabout way of saying how the
    registry responds to a valid info request by saying that it MUST NOT send no
    authorization value, or a non-empty authorization value. It would be more
    straightforward to say something like

    "the registry MUST respond to a valid info request by the non-sponsoring
    registrar with an empty authorization value".

JG - The third paragraph needs to be as explicit as possible to cover never including the authorization information value, but with the support of an optional existence indication of an authorization value only to the sponsoring registrar.  Considering the combination of non-empty elements, empty elements, and two different types of clients (registrars), I believe the paragraph needs to stay as is.

---

From: Martin Duke <[email-masked]>
Date: Tue, 20 Apr 2021 11:29:08 -0700

Fair enough. I missed that subtlety.

On Mon, Apr 19, 2021 at 8:33 AM Gould, James <[email-masked]> wrote:

> [email-masked]
> <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>
>
> 703-948-3271
> 12061 Bluemont Way
> Reston, VA 20190
>
>     Please refer to
> https://secure-web.cisco.com/1494LouXp6bnWPFFb6b5w8o2N6PBUWORrjKHj7DaJ1fIpki6yYVATnUosU_eR__hWijPM6aZrt4vX-R70aY_Ve_217eTqq4T3H1p3S5Jmr8L0THnw_Vx6y04g1mtiIN_2y01sFHCguCYGtz1gEUVkFYy73r5m6vh-lXVKBt7OCUB2Ptb7_Cf5ajuHaeu2_LbG6VMiYAyLuS2AaWhRknr2RYBYFb_b2wh-BeAmqodQNRX1Xfl_LAXAa8LlKnXEMIKT/https%3A%2F%2Fwww.ietf.org%2Fiesg%2Fstatement%2Fdiscuss-criteria.html
> JG - The third paragraph needs to be as explicit as possible to cover
> never including the authorization information value, but with the support
> of an optional existence indication of an authorization value only to the
> sponsoring registrar.  Considering the combination of non-empty elements,
> empty elements, and two different types of clients (registrars), I believe
> the paragraph needs to stay as is.
>
>
>