Subject: Re: [regext] I-D Action: draft-ietf-regext-epp-registry-maintenance-12.txt

From: "Gould, James" <[email-masked]>
Date: Tue, 6 Apr 2021 12:21:17 +0000

If the intent is to support a list of description elements, then my recommendation is to update the schema, as previously noted with maxOccurs="unbounded", and update the description of the element with something similar to:

Zero or more OPTIONAL free-form descriptions of the maintenance...

-- 
 
JG

James Gould
Fellow Engineer
[email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com <http://verisigninc.com/>

On 4/6/21, 5:50 AM, "regext on behalf of Michael Bauland" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Jody,

    thanks for your answer.

    I agree with your comments, but there is still an issue with the
    descriptions in multiple languages. You said:

    > << JWK
    > The maint:description element is unbounded.  If descriptions in different languages are needed, they can be sent on the same poll message.
    >>>

    I think this is not the case according to the schema:

         <complexType name="maintDataType">
           <sequence>
             <element name="id" type="maint:idType"/>
             <element name="type" type="maint:typeType" minOccurs="0"/>
             <element name="pollType" type="maint:pollType" minOccurs="0"/>
             <element name="systems" type="maint:systemsType"/>
             <element name="environment" type="maint:envType"/>
             <element name="start" type="dateTime"/>
             <element name="end" type="dateTime"/>
             <element name="reason" type="maint:reasonEnum"/>
             <element name="detail" type="anyURI" minOccurs="0"/>
             <element name="description" type="maint:descriptionType"
              minOccurs="0"/>
             <element name="tlds" type="maint:tldsType" minOccurs="0"/>
             <element name="intervention" type="maint:interventionType"
              minOccurs="0"/>
             <element name="crDate" type="dateTime"/>
             <element name="upDate" type="dateTime" minOccurs="0"/>
           </sequence>
         </complexType>

    There is no maxOccurs element and the default is maxOccurs="1".
    My suggestion is to update the schema and allow unbounded occurrences to
    support multiple languages in one notification.

    Best regards,

    Michael

    -- 
    ____________________________________________________________________
         |       |
         | knipp |            Knipp  Medien und Kommunikation GmbH
          -------                    Technologiepark
                                     Martin-Schmeisser-Weg 9
                                     44227 Dortmund
                                     Germany

         Dipl.-Informatiker          Fon:    +49 231 9703-0
                                     Fax:    +49 231 9703-200
         Dr. Michael Bauland         SIP:    [email-masked]
         Software Development        E-mail: [email-masked]

                                     Register Court:
                                     Amtsgericht Dortmund, HRB 13728

                                     Chief Executive Officers:
                                     Dietmar Knipp, Elmar Knipp

    _______________________________________________
    regext mailing list
    [email-masked]
    https://secure-web.cisco.com/15k4MSsRmzO-vHkCwzCFTssa7wd6ube1TSVU9nPxSO0AvM5DSo-tqeF_QM-BOhHtQTCvYiN1Vu5caHJVGataZX93gVy4Td_WfFf5P69l-KZVWCTZeL63FrxS3j4izOnCXW-UkcYj9gZZxKHR8n7ECnYRg01JPweXW12kVqhxtE6z8By7KHJXHqSb4Grl_-1b_WDL_WAddOkE8Unkkb_601jo0hsbojViwdeVAB0mLY90OJBdLKj7DeW6hTQwwrxZQ/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext

---

From: Tobias Sattler <[email-masked]>
Date: Tue, 6 Apr 2021 18:29:08 +0200

Thanks Michael and Jim.

I’ve made the adjustment on GitHub for your review.
https://github.com/seitsu/registry-epp-maintenance/blob/master/draft-ietf-regext-epp-registry-maintenance.txt <https://github.com/seitsu/registry-epp-maintenance/blob/master/draft-ietf-regext-epp-registry-maintenance.txt>

Tobias

> On 6. Apr 2021, at 14:21, Gould, James <jgould=[email-masked]> wrote:
> 
> https://www.ietf.org/mailman/listinfo/regext