Subject: Re: [regext] Last Call: <draft-ietf-regext-epp-registry-maintenance-16.txt> (Registry Maintenance Notifications for the Extensible Provisioning Protocol (EPP)) to Proposed Standard

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 16 Aug 2021 02:07:45 -0700

On Wed, Jul 28, 2021 at 7:01 AM The IESG <[email-masked]> wrote:

>
> The IESG has received a request from the Registration Protocols Extensions
> WG
> (regext) to consider the following document: - 'Registry Maintenance
> Notifications for the Extensible Provisioning
>    Protocol (EPP)'
>   <draft-ietf-regext-epp-registry-maintenance-16.txt> as Proposed Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits final
> comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2021-08-11. Exceptionally, comments
> may
> be sent to [email-masked] instead. In either case, please retain the
> beginning
> of the Subject line to allow automated sorting.
>
> Abstract
>
>
>    This document describes an Extensible Provision Protocol (EPP)
>    extension called "Registry Maintenance Notification", used by EPP
>    servers to notify EPP clients and allow EPP clients to query EPP
>    servers on maintenance events.
>
>
>
>
> The file can be obtained via
>
> https://datatracker.ietf.org/doc/draft-ietf-regext-epp-registry-maintenance/
>
>
>
> No IPR declarations have been submitted directly on this I-D.
>

This has completed Last Call.  However, IANA's expert reviewers have raised
some issues that are visible in the datatracker.  Is someone looking into
these?

-MSK

---

From: Tobias Sattler <[email-masked]>
Date: Mon, 16 Aug 2021 11:19:25 +0200

Hi Murray,

We addressed the point on the XML schema by changing the URI as suggested; and explained our reasoning behind the “maint” abbreviation.

The IANA experts want to get back to us as soon as they have new information.

If there are no other change requests, we are ready to release an update.

Would you please let us know if anything else is needed?

Thank you,
Tobias

> On 16. Aug 2021, at 11:07, Murray S. Kucherawy <[email-masked]> wrote:
> 
> On Wed, Jul 28, 2021 at 7:01 AM The IESG <[email-masked] <mailto:[email-masked]>> wrote:
> 
> The IESG has received a request from the Registration Protocols Extensions WG
> [email-masked] <mailto:[email-masked]> mailing lists by 2021-08-11. Exceptionally, comments may
> be sent to [email-masked] <mailto:[email-masked]> instead. In either case, please retain the beginning
> https://datatracker.ietf.org/doc/draft-ietf-regext-epp-registry-maintenance/ <https://datatracker.ietf.org/doc/draft-ietf-regext-epp-registry-maintenance/>
> 
> 
> 
> This has completed Last Call.  However, IANA's expert reviewers have raised some issues that are visible in the datatracker.  Is someone looking into these?
> 
> -MSK
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext

---

From: Tim Bray <[email-masked]>
Date: Tue, 17 Aug 2021 10:34:05 -0700

I'm sorry but I think this sentence

"maint" is used as an abbreviation for
"urn:ietf:params:xml:ns:epp:maintenance-1.0".

is misleading - it is used as, and only as, an example XML namespace
prefix, mapped to the URN. Which is just fine. It's not a general-purpose
abbreviation in this document. The word "abbreviation" does not appear in
the XML namespaces spec and this terminology would appear strange to an XML
practitioner.

The answer seems to be "but we use this wording in this whole family of
RFCs".  OK, my objection stands and I think this WG should abandon this
nonstandard and misleading language, but I guess my objection should be
non-blocking.

On Tue, Aug 17, 2021 at 10:23 AM Tobias Sattler <[email-masked]>
wrote:

> Hi Murray,
>
> We addressed the point on the XML schema by changing the URI as suggested;
> and explained our reasoning behind the “maint” abbreviation.
>
> This has completed Last Call.  However, IANA's expert reviewers have
> raised some issues that are visible in the datatracker.  Is someone looking
> into these?
>
> -MSK
> --
> last-call mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/last-call
>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 19 Aug 2021 15:57:53 -0700

[Cc: trimmed]

Hi Tobias,

> Would you please let us know if anything else is needed?

IANA's comment in the tracker was posted 2021-08-12 against version 16 of
this draft.  That's still the current version.  Is a new version pending,
or did IANA's comment actually apply to an earlier version?

Version 16 was also the one that was last called.

-MSK

---

From: Tobias Sattler <[email-masked]>
Date: Fri, 20 Aug 2021 08:53:36 +0200

Hi Murray,

We made the change on GitHub and provided the IANA experts the link asking if this is fine for them. They said they would check that and get back to us.

Best,
Tobias

> On 20. Aug 2021, at 00:57, Murray S. Kucherawy <[email-masked]> wrote:
> 
> [Cc: trimmed]
> 
> Hi Tobias,
> 
> On Mon, Aug 16, 2021 at 2:19 AM Tobias Sattler <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Murray,
> 
> IANA's comment in the tracker was posted 2021-08-12 against version 16 of this draft.  That's still the current version.  Is a new version pending, or did IANA's comment actually apply to an earlier version?
>

---

From: Tobias Sattler <[email-masked]>
Date: Mon, 23 Aug 2021 14:07:42 +0200

Hi Murray,

We can publish the next version (v17) while we are waiting.

We made the editorial changes, and we only wait on feedback regarding the security consideration section by SECDIR / Melinda and the abbreviation by IANA / Sabrina.

What do you think?

Best,
Tobias

> On 20. Aug 2021, at 08:53, Tobias Sattler <[email-masked]> wrote:
> 
> Hi Murray,
> 
>> On 20. Aug 2021, at 00:57, Murray S. Kucherawy <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> [Cc: trimmed]
>> 
>> Hi Tobias,
>> 
>> [email-masked] <mailto:[email-masked]>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 27 Aug 2021 00:03:59 -0700

Sounds good to me.  If we nailed it here, then v17 is ready to go onwards.

-MSK

On Mon, Aug 23, 2021 at 5:07 AM Tobias Sattler <[email-masked]>
wrote:

> We made the editorial changes, and we only wait on feedback regarding the
> security consideration section by SECDIR / Melinda and the abbreviation by
> IANA / Sabrina.
>
> What do you think?
>
> Best,
> Tobias
>
> We made the change on GitHub and provided the IANA experts the link asking
> if this is fine for them. They said they would check that and get back to
> us.
>
> Best,
> Tobias
>
>> We addressed the point on the XML schema by changing the URI as
>> suggested; and explained our reasoning behind the “maint” abbreviation.
>>

---

From: Tobias Sattler <[email-masked]>
Date: Fri, 27 Aug 2021 09:18:27 +0200

Thanks and done.

Best,
Tobias

> On 27. Aug 2021, at 09:03, Murray S. Kucherawy <[email-masked]> wrote:
> 
> On Mon, Aug 23, 2021 at 5:07 AM Tobias Sattler <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Murray,
> 
>> On 20. Aug 2021, at 08:53, Tobias Sattler <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Murray,
>> 
>>> https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>
>> 
>> https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>
>