Subject: Re: [regext] I-D Action: draft-ietf-regext-rdap-redacted-01.txt

From: "Gould, James" <[email-masked]>
Date: Wed, 1 Sep 2021 16:39:45 +0000

draft-ietf-regext-rdap-redacted-01 was posted that includes updates associated with feedback from Gustavo Lozano, Marc Blanchet, and Mario Loffredo.  This version adds the use of the JSON Values Registry for the registration of redacted name and reason values.  One item that was discussed with the document editors is support for redaction of RDAP search responses.  draft-ietf-regext-rdap-redacted-01 only supports RDAP lookup responses, but the editors feel that support for RDAP search responses can be added, but we wanted to discuss it first on the mailing list.

Please review draft-ietf-regext-rdap-redacted-01 for feedback, and weigh in on the list whether you believe the draft should be updated to support redaction in RDAP search responses.

Thanks,

-- 
 
JG

James Gould
Fellow Engineer
[email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com <http://verisigninc.com/>

On 9/1/21, 12:32 PM, "regext on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    A New Internet-Draft is available from the on-line Internet-Drafts directories.
    This draft is a work item of the Registration Protocols Extensions WG of the IETF.

            Title           : Redacted Fields in the Registration Data Access Protocol (RDAP) Response
            Authors         : James Gould
                              David Smith
                              Jody Kolker
                              Roger Carney
    	Filename        : draft-ietf-regext-rdap-redacted-01.txt
    	Pages           : 27
    	Date            : 2021-09-01

    Abstract:
       This document describes an RDAP extension for explicitly identifying
       redacted RDAP lookup response fields, using JSONPath as the default
       expression language.

    The IETF datatracker status page for this draft is:
    https://secure-web.cisco.com/16DGvEB5c--xR_JLpGRIrM-opeQNoWbJI5ct57yY8cVAKC3H27rL2O0fBsA3q9SeObeEMKhdI_gVeSHl9SgmHnXcbevhOVGjygTH1_Xy6IvR6zhY4-VOfLJvqGs6OWw-fieZaLQ0AbGeNZUS21DANRlOZbknT9qrISoabWDBTz5Z436n3ZLhgK6S0MWXe5lDZB9RWIQTAldjV1_3nhRP1svu2GItnRZ94viXIAua5kqC5FwtFzCmttXznMxhgGUwH/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-regext-rdap-redacted%2F

    There is also an HTML version available at:
    https://secure-web.cisco.com/1B7lP-aCUuzVSsJwAWnyoZYU0TOUkjP1YHViXJ5hEiaYs3n_Cz8vvSZpGJSJ73IN9HAFWFWJd1vpUQapi2cBZJy9aMyYqztsMf3gro7xjfCsDARlYy3cwEqL138V93giUYbpmm9RSOKoPpRyfeSejCCTbZKlQhSFwfQSSDgN4It-STXofB4EZ28EA0Y79D7cS_kbF9o5KXxAOpGyEEcxX6-awau_Ux1Ff4RAfbj1hPZOsB_F3mBsFMucjlpBXklpb/https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-ietf-regext-rdap-redacted-01.html

    A diff from the previous version is available at:
    https://secure-web.cisco.com/1tta330G8Bv27jWb3jM9azf5TmwgvZUADmv2LlhPKvepSDwyw3oU-hk2uNxSeh4n-a5P3Auqwa6zhKBtxuFPinVofU6MTBSid5OE6ooOKeiG5iOMsttndnHJA9G_xXW34tQrcBGDl33bINp5fbRI1XWoO-rIG5j4UzKUlod2jlQQYj-XnvL8WO01CATEVWJKMuPQ5TUqtjT-aKbQ6RV5e8MQjb9bW_0DcsxzhmHtlLHTiW8rv-boiN23NhcBIqzdb/https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-regext-rdap-redacted-01

    Internet-Drafts are also available by anonymous FTP at:
    ftp://ftp.ietf.org/internet-drafts/

    _______________________________________________
    regext mailing list
    [email-masked]
    https://secure-web.cisco.com/1D_jdBL04m1G7muZQT7pgeKPx7xNe2uenH_edt9dfpMkxVcC6tzEHzMqjq2yNq9xEXHFnDNDE23FytUugwHkfObAjwJ9t7EgaLUlZTSNLOSepsO_VibrKsfcf2Ws5zoi5aeBYrEyMugkWKSCwjlD-qSskzkcFtgs2Y2fjMFoT_QYy6oDpE5oRD8HI-UR4C1mT5hboY2EY5WZrfhpRxoHzUsF3iF5Q_h6x_ZSRZsElfJliLYcncRMJ-RFDNWXbauNT/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 1 Sep 2021 16:58:01 +0000

Not having support for redacting search results could provide a back-door workaround that allows a client to avoid redaction completely. I think it should be included.

Scott

> -----Original Message-----
> From: regext <[email-masked]> On Behalf Of Gould, James
> Sent: Wednesday, September 1, 2021 12:40 PM
> To: [email-masked]
> Subject: [EXTERNAL] Re: [regext] I-D Action: draft-ietf-regext-rdap-redacted-
> 01.txt
>
> Caution: This email originated from outside the organization. Do not click links
> or open attachments unless you recognize the sender and know the content
> is safe.
>
> draft-ietf-regext-rdap-redacted-01 was posted that includes updates
> associated with feedback from Gustavo Lozano, Marc Blanchet, and Mario
> Loffredo.  This version adds the use of the JSON Values Registry for the
> registration of redacted name and reason values.  One item that was
> discussed with the document editors is support for redaction of RDAP search
> responses.  draft-ietf-regext-rdap-redacted-01 only supports RDAP lookup
> responses, but the editors feel that support for RDAP search responses can
> be added, but we wanted to discuss it first on the mailing list.
>
> Please review draft-ietf-regext-rdap-redacted-01 for feedback, and weigh in
> on the list whether you believe the draft should be updated to support
> redaction in RDAP search responses.
>
> Thanks,
>
> --
>
> JG
>
>
>
> James Gould
> Fellow Engineer
> Verisign.com <http://secure-web.cisco.com/1ShpKZViQUxYU-
> quhusQohO_mbcAMXxVlexvSlAiG9rr4IjZXZUX0zYfbMxnbN2NAij-
> 8OK_p9xshhB7KDFIoAYjRlvU-y5khfAcOSzM6-
> OBqVDgKK3P0mqayurJOvqga8W91bDeYlTdtaEGEkoVEtJo6vJXgzzaJWAdhXsc
> 6n1aYtmGBOOOt2RVs9w9q-TD26LGbxsxp-
> PENxk9V_KhAX1FsQh9FOg3XCusgW9uLju-XYA02SkwNQAJM3QYe-
> xYlEt98xEWQwz3t1buVXAa2LA/http%3A%2F%2Fverisigninc.com%2F>
>
> On 9/1/21, 12:32 PM, "regext on behalf of [email-masked]" <regext-
> [email-masked] on behalf of [email-masked]> wrote:
>
>     https://secure-web.cisco.com/16DGvEB5c--xR_JLpGRIrM-
> opeQNoWbJI5ct57yY8cVAKC3H27rL2O0fBsA3q9SeObeEMKhdI_gVeSHl9Sgm
> HnXcbevhOVGjygTH1_Xy6IvR6zhY4-VOfLJvqGs6OWw-
> fieZaLQ0AbGeNZUS21DANRlOZbknT9qrISoabWDBTz5Z436n3ZLhgK6S0MWXe
> 5lDZB9RWIQTAldjV1_3nhRP1svu2GItnRZ94viXIAua5kqC5FwtFzCmttXznMxhg
> GUwH/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-regext-
> rdap-redacted%2F
>
>     https://secure-web.cisco.com/1B7lP-
> aCUuzVSsJwAWnyoZYU0TOUkjP1YHViXJ5hEiaYs3n_Cz8vvSZpGJSJ73IN9HAF
> WFWJd1vpUQapi2cBZJy9aMyYqztsMf3gro7xjfCsDARlYy3cwEqL138V93giUYbp
> mm9RSOKoPpRyfeSejCCTbZKlQhSFwfQSSDgN4It-
> STXofB4EZ28EA0Y79D7cS_kbF9o5KXxAOpGyEEcxX6-
> awau_Ux1Ff4RAfbj1hPZOsB_F3mBsFMucjlpBXklpb/https%3A%2F%2Fwww.i
> etf.org%2Farchive%2Fid%2Fdraft-ietf-regext-rdap-redacted-01.html
>
>     https://secure-
> web.cisco.com/1tta330G8Bv27jWb3jM9azf5TmwgvZUADmv2LlhPKvepSDwy
> w3oU-hk2uNxSeh4n-
> a5P3Auqwa6zhKBtxuFPinVofU6MTBSid5OE6ooOKeiG5iOMsttndnHJA9G_xX
> W34tQrcBGDl33bINp5fbRI1XWoO-rIG5j4UzKUlod2jlQQYj-
> XnvL8WO01CATEVWJKMuPQ5TUqtjT-
> aKbQ6RV5e8MQjb9bW_0DcsxzhmHtlLHTiW8rv-
> boiN23NhcBIqzdb/https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraf
> t-ietf-regext-rdap-redacted-01
>
>
>     https://secure-
> web.cisco.com/1D_jdBL04m1G7muZQT7pgeKPx7xNe2uenH_edt9dfpMkxVc
> C6tzEHzMqjq2yNq9xEXHFnDNDE23FytUugwHkfObAjwJ9t7EgaLUlZTSNLOSep
> sO_VibrKsfcf2Ws5zoi5aeBYrEyMugkWKSCwjlD-
> qSskzkcFtgs2Y2fjMFoT_QYy6oDpE5oRD8HI-
> UR4C1mT5hboY2EY5WZrfhpRxoHzUsF3iF5Q_h6x_ZSRZsElfJliLYcncRMJ-
> RFDNWXbauNT/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fr
> egext
>
>
> https://secure-
> web.cisco.com/1rgZCZofV492uXwDusvSWJPJZjXjNVOE6GggkNPIefp3F_5Rb2
> I5dKZEjnDj8nG-SAmgGWcowqwysQo_PGPXGSzxKDmEetTaru_aR-
> 2wzdPIP5GOmfrzx6eOV-KYP5sPYN_APjv38tMlTIM-W-
> ypClQqgFs2g7AiuoX1tMxl6YkhK1qrbB05zmx2zn5uGFKg7dPvxYi7xQ3CfUmLw
> UjfaWaPXNGS1cYuzd9cFTU2y_6GoyPJQdiV3ZHlRaO4Rjz4xyqJqF8CrCt0wGRq
> ccJfiuA/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext

---

From: Mario Loffredo <[email-masked]>
Date: Fri, 3 Sep 2021 16:04:09 +0200

+1 about supporting redaction in search resposnses.

Mario

-- 
Dr. Mario Loffredo
Technological Unit “Digital Innovation”
Institute of Informatics and Telematics (IIT)
National Research Council (CNR)
via G. Moruzzi 1, I-56124 PISA, Italy
Phone: +39.0503153497
Web: http://www.iit.cnr.it/mario.loffredo

---

From: Gustavo Lozano <[email-masked]>
Date: Fri, 3 Sep 2021 16:12:51 +0000

+1

On 9/3/21, 7:05 AM, "regext on behalf of Mario Loffredo" <[email-masked] on behalf of [email-masked]> wrote:

    Mario

    Web: https://urldefense.com/v3/__http://www.iit.cnr.it/mario.loffredo__;!!PtGJab4!peyrC9U93AwqG481OpigkPtaDqMYs9LYWpsDQEyPJTQ7Zxin6Z6fgKv6NAyEWIMQzAqEJ9iDb4A$ 

    _______________________________________________
    regext mailing list
    [email-masked]
    https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/regext__;!!PtGJab4!peyrC9U93AwqG481OpigkPtaDqMYs9LYWpsDQEyPJTQ7Zxin6Z6fgKv6NAyEWIMQzAqEc6goqtY$