Subject: [regext] Éric Vyncke's No Objection on draft-ietf-regext-epp-registry-maintenance-17: (with COMMENT)

From: Éric Vyncke via Datatracker <[email-masked]>
Date: Wed, 06 Oct 2021 08:46:20 -0700

Éric Vyncke has entered the following ballot position for
draft-ietf-regext-epp-registry-maintenance-17: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/blog/handling-iesg-ballot-positions/
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-regext-epp-registry-maintenance/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for the work put into this document.

Please find below some non-blocking COMMENT points (but replies would be
appreciated even if only for my own education).

I hope that this helps to improve the document,

Regards,

-éric

-- Section 3.3 --

In "mantid", should the reference for the encoding of the language be mentioned
?

The use of "maint:tlds" seems to indicate a limitation to top-level domains
only (even if the text mentions later "registry zone") but EPP is used not only
for TLD. Suggest to make it even clearer (as I am afraid that it is too late in
the process to change the element name).

-- Section 4.1.3.1 --
In the example, there is "<maint:type lang="en">" but lang is not specified as
an attribute of "maint:type" in section 3.3.

---

From: Jody Kolker <[email-masked]>
Date: Wed, 6 Oct 2021 16:33:40 +0000

Eric,

Thank you for review and comments.  We've added our replies in line below.  Please let us know if you have any questions.

Thanks,
Jody.

-----Original Message-----
From: Éric Vyncke via Datatracker <[email-masked]> 
Sent: Wednesday, October 6, 2021 10:46 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; James Galvin <[email-masked]>; [email-masked]
Subject: Éric Vyncke's No Objection on draft-ietf-regext-epp-registry-maintenance-17: (with COMMENT)

Caution: This email is from an external sender. Please do not click links or open attachments unless you recognize the sender and know the content is safe. Forward suspicious emails to isitbad@.

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fblog%2Fhandling-iesg-ballot-positions%2F&amp;data=04%7C01%7Cjkolker%40godaddy.com%7C8aa3255dd3954a55677d08d988e072c7%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637691319858834084%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=f2yLEq%2FNdLl1eu3fCFnpsrN%2BXdTfhFWa8tjlurOc%2FWo%3D&amp;reserved=0
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-regext-epp-registry-maintenance%2F&amp;data=04%7C01%7Cjkolker%40godaddy.com%7C8aa3255dd3954a55677d08d988e072c7%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637691319858834084%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=6YZwwbPyo0VmdSA3G%2BzqqbEy%2F8Ov93wkUiNvTw0ctBU%3D&amp;reserved=0

Please find below some non-blocking COMMENT points (but replies would be appreciated even if only for my own education).

Regards,

-éric

-- Section 3.3 --

In "mantid", should the reference for the encoding of the language be mentioned ?

<<
We believe that the encoding for the language of "maintid" should default to the encoding included in the "encoding" attribute of the main "xml" element of the response and should not be needed to be included here.

The use of "maint:tlds" seems to indicate a limitation to top-level domains only (even if the text mentions later "registry zone") but EPP is used not only for TLD. Suggest to make it even clearer (as I am afraid that it is too late in the process to change the element name).

<<
The description of <maint:tld> element includes that the element can include top-level domain or registry zone and we felt that adding the description to <maint:tlds> may add duplication that may not be needed.  However if others agree we would be happy to add in the <maint:tlds> description also.

-- Section 4.1.3.1 --
In the example, there is "<maint:type lang="en">" but lang is not specified as an attribute of "maint:type" in section 3.3.

<<
In section 3.3, the description of "<maint:type>" does already appear to have the following language -  
      "The OPTIONAL "lang" attribute MAY be present to
      identify the language if the negotiated value is something other
      than the default value of "en" (English)."

We might have missed it, but it seems it is already there.  Could you verify?

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 7 Oct 2021 11:24:15 +0000

Jody,

Thanks for your reply but in section 3.3 I only see the attribute "lang" for the element "<maint:id>" and not on "<maint:type>" per:
   <maint:id>
      The server unique identifier for the maintenance event with the
      OPTIONAL "name" attribute that includes a human-readable name of
      the event. The server unique identifier SHALL NOT be changed if
      the event is updated or deleted. When the "name" attribute is set,
      the OPTIONAL "lang" attribute MAY be present to identify the
      language if the negotiated value is something other than the
      default value of "en" (English).

   <maint:type>
      Zero or more OPTIONAL types of the maintenance event that has the
      possible set of values defined by server policy, such as
      "Routine Maintenance", "Software Update", "Software Upgrade", or
      "Extended Outage".

-éric

On 06/10/2021, 18:33, "Jody Kolker" <[email-masked]> wrote:

    Eric,

    Thanks,
    Jody.

    -----Original Message-----
    From: Éric Vyncke via Datatracker <[email-masked]> 
    Sent: Wednesday, October 6, 2021 10:46 AM
    To: The IESG <[email-masked]>
    Cc: [email-masked]; [email-masked]; [email-masked]; James Galvin <[email-masked]>; [email-masked]
    Subject: Éric Vyncke's No Objection on draft-ietf-regext-epp-registry-maintenance-17: (with COMMENT)

    Regards,

    -éric

    -- Section 3.3 --

    <<

    <<

    -- Section 4.1.3.1 --

    <<

---

From: Jody Kolker <[email-masked]>
Date: Thu, 7 Oct 2021 12:29:25 +0000

Thanks for the feed back Erik.  Apologies for missing this on v17.  We have updated the document to v18 and included the updated suggested.

https://github.com/seitsu/registry-epp-maintenance/blob/master/draft-ietf-regext-epp-registry-maintenance.txt

Thanks!

Jody Kolker.

-----Original Message-----
From: Eric Vyncke (evyncke) <[email-masked]> 
Sent: Thursday, October 7, 2021 6:24 AM
To: Jody Kolker <[email-masked]>; The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; James Galvin <[email-masked]>
Subject: Re: Éric Vyncke's No Objection on draft-ietf-regext-epp-registry-maintenance-17: (with COMMENT)

[You don't often get email from [email-masked]. Learn why this is important at http://aka.ms/LearnAboutSenderIdentification.]

Jody,

   <maint:type>

-éric

    Eric,

    Thanks,
    Jody.

    -----Original Message-----
    From: Éric Vyncke via Datatracker <[email-masked]>
    Sent: Wednesday, October 6, 2021 10:46 AM
    To: The IESG <[email-masked]>
    Cc: [email-masked]; [email-masked]; [email-masked]; James Galvin <[email-masked]>; [email-masked]
    Subject: Éric Vyncke's No Objection on draft-ietf-regext-epp-registry-maintenance-17: (with COMMENT)

    Please refer to https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fblog%2Fhandling-iesg-ballot-positions%2F&amp;data=04%7C01%7Cjkolker%40godaddy.com%7C99f471a3e3de4281efd908d989850cc3%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637692026809761671%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=G5IdUKXIAF3WoFJ2KZUIRfWdkIKABoosG7pWogliHCo%3D&amp;reserved=0
    for more information about how to handle DISCUSS and COMMENT positions.

    The document, along with other ballot positions, can be found here:
    https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-regext-epp-registry-maintenance%2F&amp;data=04%7C01%7Cjkolker%40godaddy.com%7C99f471a3e3de4281efd908d989850cc3%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637692026809761671%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=O0oQ%2FI0uEVJYzn1khPUrrNt3rcRX2PbZGitFNtzw3lA%3D&amp;reserved=0

    Regards,

    -éric

    -- Section 3.3 --

    <<

    <<

    -- Section 4.1.3.1 --

    <<