Subject: [regext] [Errata Verified] RFC7484 (5461)

From: RFC Errata System <[email-masked]>
Date: Thu, 2 Dec 2021 07:45:24 -0800 (PST)

The following errata report has been verified for RFC7484,
"Finding the Authoritative Registration Data (RDAP) Service". 

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5461

--------------------------------------
Status: Verified
Type: Editorial

Reported by: Pieter Vandepitte <[email-masked]>
Date Reported: 2018-08-14
Verified by: Murray Kucherawy (IESG)

Section: 4

Original Text
-------------
{
       "version": "1.0",
       "publication": "YYYY-MM-DDTHH:MM:SSZ",
       "description": "Some text",
       "services": [
         [
           ["net", "com"],
           [
             "https://registry.example.com/myrdap/"
           ]
         ],
         [
           ["org", "mytld"],
           [
             "http://example.org/"
           ]
         ],
         [
           ["xn--zckzah"],
           [
             "https://example.net/rdapxn--zckzah/",
             "http://example.net/rdapxn--zckzah/"
           ]
         ]
       ]
   }

Corrected Text
--------------
{
       "version": "1.0",
       "publication": "YYYY-MM-DDTHH:MM:SSZ",
       "description": "Some text",
       "services": [
         [
           ["net", "com"],
           [
             "https://registry.example.com/myrdap/"
           ]
         ],
         [
           ["org", "mytld"],
           [
             "http://example.org/"
           ]
         ],
         [
           ["xn--zckzah"],
           [
             "https://example.net/rdap/xn--zckzah/",
             "http://example.net/rdap/xn--zckzah/"
           ]
         ]
       ]
   }

Notes
-----
Include a slash between rdap and xn--zckzah. rdapxn--zckzah is not a valid a-label

--------------------------------------
RFC7484 (draft-ietf-weirds-bootstrap-11)
--------------------------------------
Title               : Finding the Authoritative Registration Data (RDAP) Service
Publication Date    : March 2015
Author(s)           : M. Blanchet
Category            : PROPOSED STANDARD
Source              : Web Extensible Internet Registration Data Service
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Bernhard Reutner-Fischer <[email-masked]>
Date: Tue, 7 Dec 2021 11:43:22 +0100

On Thu,  2 Dec 2021 07:45:24 -0800 (PST)

> Include a slash between rdap and xn--zckzah. rdapxn--zckzah is not a valid a-label

While i agree that a slash is missing between rdap and xn--zckzah i
wonder on what grounds the second sentence is based on?

AFAICS rdapxn--whatever does not have hyphens at position 3 and 4 and
does not start with "xn--" so is just a normal a-label like "a-label",
"a--xn--he--ro" or "foo---bar" according to RFC5890, no?

thanks,