Subject: Re: [regext] WG LAST CALL: draft-ietf-regext-epp-eai-04

From: "Gould, James" <[email-masked]>
Date: Thu, 9 Dec 2021 16:58:50 +0000

Scott,

Thanks for the review and feedback.  I provide responses to your feedback embedded below.

-- 
 
JG

James Gould
Fellow Engineer
[email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com <http://verisigninc.com/>

On 12/6/21, 9:18 AM, "regext on behalf of Hollenbeck, Scott" <[email-masked] on behalf of shollenbeck=[email-masked]> wrote:

    A few questions/comments:

    Section 6: We need to provide the rationale for that SHOULD (Registries SHOULD validate the domain names in the provided email addresses). What does "validate" mean? For syntax? For reachability?

JG - This is associated with validating the syntax.  The goal is to ensure that the domain name, whether an ASCII or IDN domain name is a syntactic valid domain name the may be reachable.  Would it help to modify this to read "Registries SHOULD validate the syntax of the domain names in the provided email addresses so they may be reachable."? 

    Section 7: What's significant about "eai-0.3"? The "0.3" part doesn't track to the current version of the draft; perhaps "1.0" would be better now. See also Section 5.2.

JG - Yes, the namespace will be changed to "eai-1.0" once it passes WGLC similar to what has happened in past EPP extensions with pointed namespaces.

    Section 8: It might be helpful to add more text to explain why "Registries MAY apply extra limitation to the email address syntax". Why might they want to do that? It seems a little unusual to say that they MAY do something, but in the next sentence say, "These limitations are out of scope of this document".

JG - Agreed, this does not look to add value.  Do you believe the Implementation Considerations section should be removed, since the contents really don't provide any material considerations?

    Scott

    > -----Original Message-----
    > From: regext <[email-masked]> On Behalf Of Antoin Verschuren
    > Sent: Monday, December 6, 2021 8:45 AM
    > To: regext <[email-masked]>
    > Subject: [EXTERNAL] [regext] WG LAST CALL: draft-ietf-regext-epp-eai-04
    > 
    > Caution: This email originated from outside the organization. Do not click links
    > or open attachments unless you recognize the sender and know the content
    > is safe.
    > 
    > Dear Working Group,
    > 
    > The authors of the following working group document have indicated that it
    > is believed to be ready for submission to the IESG for publication as a
    > standards track document:
    > 
    > https://secure-
    > web.cisco.com/1X5Kk__ilGc6oof5yK8LaQgMPmsel3cbXrjvP6yfCa-
    > iVfLpCfrnBYMRTIvXbM0GvDKBiON-Ov-
    > pREl74hVXhhUF3ZazbgTE1CEaM4duKFOvjrV_3I7HDiLZgWzL98iv15YwuZ-
    > pTGAxsg3IDn0uqgEt9YvSjDBdV_i2AX8lOL0cnO7AchXeNfZXqGZeY9PGQJECO
    > wf11n9JNYZ1SAk3PVDN3Ps0D4flSVggLJqsVYtZY5LM0zpnOZhqtG1JDPTN7/htt
    > ps%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-regext-epp-eai%2F
    > 
    > This WG last call will end at close of business, Monday, 20 December 2021.
    > 
    > Please review this document and indicate your support (a simple “+1” is
    > sufficient) or concerns with the publication of this document by replying to
    > this message on the list.
    > 
    > The document shepherd for this document is Jody Kolker.
    > 
    > Regards,
    > 
    > Jim and Antoin
    > 
    > 
    > 
    > 
    > 
    > _______________________________________________
    > regext mailing list
    > [email-masked]
    > https://secure-
    > web.cisco.com/1QyK_wkcmwIc2P574Pc5VmjVE57Mnfz3Vn7xRHhdJtHU-
    > IqkLUb4bfO9CKRO5rPtSy6vGMyLePNyeha5aFXPg4jY4xpuRq6VNGzbMIeeqg
    > nw_yTHAPZV7tlWCeAbhXEwUg21MetU8GFuFV_5mqGR1qrC6TFuY6K_1tBuh
    > nlPECh2n-58RY1QH4ZTK6flKyNwxX_K-
    > gmeWvGtkCC4L8Zp4S04w5J2e3AczYPujFUpZP03fjW3BMjBOkt_vM2Sk5D_s/
    > https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext
    _______________________________________________
    regext mailing list
    [email-masked]
    https://secure-web.cisco.com/1nTyyGGSkXFAxcZSDLSAVBoYqwcU3eW8hQcbrdqctKvLzp64KAiM-npIcm5_mzosajXP1ElFjDvvMG4tkF6e5p-ulUqeN8JXQlfTnarRHHP6at67L1_IEJ2DXZqwEmKrhv4fx2YjrEpx767pnGiyj_E2hm4PUFWa-qDN_kYxkNOQkHzRlOPwuJgwzCWDHL2w6GmceHkZXN7YGcQqxx46TGRsBioACHqpK6wzHEKs9DH3hlavNWlJhteH199-QC5wL/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 13 Dec 2021 13:15:02 +0000

> From: Gould, James <jgould=[email-masked]>
> Sent: Thursday, December 9, 2021 11:59 AM
> To: Hollenbeck, Scott <[email-masked]>;
> ietf=[email-masked] <[email-masked]>; [email-masked]
> Subject: [EXTERNAL] Re: Re: [regext] WG LAST CALL: draft-ietf-regext-epp-
> eai-04
>
> Verisign.com <http://secure-
> web.cisco.com/1bUEhaRz5CoSQPd4colm8eTGE5D6zPQvtrYPAzQf9pUSXnqD
> Nq7mmnlZ8At92joPzY5DkJdQiiPe1mlyvgzDAdDz_shcqHzSugkfXA2qX9z7aQp0
> 6ld-
> LnwMzxo2VGkwqFH5gLrI7qSYQlgj4Unll4AIUd6ALSZ38i2kjYqgA0AnBBjaJEVg7
> yUIN-
> P8bpFGxQgN__tWour_sxUBBx2vUcVpmrR7SUG6UsUo5U3gb_YbWCYcRn8b
> 4Rl06BQIL8B8k/http%3A%2F%2Fverisigninc.com%2F>
>
> On 12/6/21, 9:18 AM, "regext on behalf of Hollenbeck, Scott" <regext-
> [email-masked] on behalf of shollenbeck=[email-masked]>
> wrote:
>
>
>     Section 6: We need to provide the rationale for that SHOULD (Registries
> SHOULD validate the domain names in the provided email addresses). What
> does "validate" mean? For syntax? For reachability?
>
> JG - This is associated with validating the syntax.  The goal is to ensure 
> that
> the domain name, whether an ASCII or IDN domain name is a syntactic valid
> domain name the may be reachable.  Would it help to modify this to read
> "Registries SHOULD validate the syntax of the domain names in the provided
> email addresses so they may be reachable."?

[SAH] Syntax validity is no guarantee of reachability. The only way to confirm 
that an email address "works" is to send email to that address and confirm 
that it's delivered. I don't think we want to suggest that registries should 
start sending out email delivery tests, so maybe something like this instead:

" Registries SHOULD ensure that the provided email addresses are syntactically 
valid to reduce the risk of future usability errors."

>     Section 7: What's significant about "eai-0.3"? The "0.3" part doesn't 
> track to
> the current version of the draft; perhaps "1.0" would be better now. See 
> also
> Section 5.2.
>
> JG - Yes, the namespace will be changed to "eai-1.0" once it passes WGLC
> similar to what has happened in past EPP extensions with pointed
> namespaces.

[SAH] OK.

>     Section 8: It might be helpful to add more text to explain why 
> "Registries
> MAY apply extra limitation to the email address syntax". Why might they
> want to do that? It seems a little unusual to say that they MAY do 
> something,
> but in the next sentence say, "These limitations are out of scope of this
> document".
>
> JG - Agreed, this does not look to add value.  Do you believe the
> Implementation Considerations section should be removed, since the
> contents really don't provide any material considerations?

[SAH] Yes, that's probably a good idea.

Scott

---

From: Taras Heichenko <[email-masked]>
Date: Tue, 14 Dec 2021 21:13:19 +0200

The comment is in body.

> On 13 Dec 2021, at 15:15, Hollenbeck, Scott <shollenbeck=[email-masked]> wrote:
> 

The check of existing of the domain (MX or at least A/AAAA record) from the
email address may be added. I am not sure that it should be there but it also
raises the probability that the email address is valid.

> https://www.ietf.org/mailman/listinfo/regext

--
Taras Heichenko
[email-masked]

---

From: Dmitry Belyavsky <[email-masked]>
Date: Wed, 15 Dec 2021 15:14:45 +0100

Dear Taras.

On Tue, Dec 14, 2021 at 8:13 PM Taras Heichenko <[email-masked]>
wrote:

> >> Caution: This email originated from outside the organization. Do not
> click
> >> links
> >> Thanks for the review and feedback.  I provide responses to your
> feedback
> >> embedded below.
> >>
> >> --
> >>
> >> JG
> >>
> >>
> >>
> >> James Gould
> >> Fellow Engineer
> >> [email-masked] on behalf of shollenbeck=[email-masked]
> >
> >> wrote:
> >>
> >>

Personally I don't think it is feasible to reject the contact
registration/change if these records don't exist.
And anyway, it's out of scope for this document.

-- 
SY, Dmitry Belyavsky

---

From: Taras Heichenko <[email-masked]>
Date: Sat, 18 Dec 2021 15:53:15 +0200

> On 15 Dec 2021, at 16:14, Dmitry Belyavsky <[email-masked]> wrote:
> 
> Dear Taras.

Dear Dmitry

> 
> On Tue, Dec 14, 2021 at 8:13 PM Taras Heichenko <[email-masked]> wrote:
> The comment is in body.
> 
> Personally I don't think it is feasible to reject the contact registration/change if these records don't exist.

I just wanted to say that there are different ways to check the validity of an email address.
If some registry does such a check will it be contrary to the RFC? May we need a phrase that
allows wider Interpretation?

--
Taras Heichenko
[email-masked]

---

From: Dmitry Belyavsky <[email-masked]>
Date: Sun, 19 Dec 2021 19:11:31 +0100

> allows wider Interpretation?

I don't see it will be contrary, and so I don't think we need to specify
this in this document.
BTW, I've already removed the phrases about extra email limitations.

-- 
SY, Dmitry Belyavsky

---

From: Antoin Verschuren <[email-masked]>
Date: Mon, 20 Dec 2021 14:55:07 +0100

Dear WG,

This WGLC will end tonight, and so far we only have 2 explicit voices of support.
This is a bit low to declare consensus. Could more people voice their support?
Scott, can you confirm that the changes in version 05 address your initial concerns?

- -- 
Antoin Verschuren

Tweevoren 6, 5672 SB Nuenen, NL
M: +31 6 37682392

> Op 19 dec. 2021, om 19:11 heeft Dmitry Belyavsky <[email-masked]> het volgende geschreven:
> 
> 
> 
> On Sat, Dec 18, 2021 at 2:53 PM Taras Heichenko <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> > On 15 Dec 2021, at 16:14, Dmitry Belyavsky <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> > Dear Taras.
> 
> Dear Dmitry
> 
> > 
> > On Tue, Dec 14, 2021 at 8:13 PM Taras Heichenko <[email-masked] <mailto:[email-masked]>> wrote:
> > The comment is in body.
> > 
> > > On 13 Dec 2021, at 15:15, Hollenbeck, Scott <shollenbeck=[email-masked] <mailto:[email-masked]>> wrote:
> > > 
> > >> From: Gould, James <jgould=[email-masked] <mailto:[email-masked]>>
> > >> To: Hollenbeck, Scott <[email-masked] <mailto:[email-masked]>>;
> > >> ietf=[email-masked] <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> > >> Verisign.com <http://secure- <http://secure-/>
> > >> web.cisco.com/1bUEhaRz5CoSQPd4colm8eTGE5D6zPQvtrYPAzQf9pUSXnqD <http://web.cisco.com/1bUEhaRz5CoSQPd4colm8eTGE5D6zPQvtrYPAzQf9pUSXnqD>
> > >> [email-masked] <mailto:[email-masked]> on behalf of shollenbeck=[email-masked] <mailto:[email-masked]>>
> > >> wrote:
> > >> 
> > >> 
> I don't see it will be contrary, and so I don't think we need to specify this in this document.
> > > [email-masked] <mailto:[email-masked]>
> > > https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>
> > 
> > --
> > Taras Heichenko
> > [email-masked] <mailto:[email-masked]>
> > 
> > 
> > 
> > 
> > 
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>
> > 
> > 
> > -- 
> > SY, Dmitry Belyavsky
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>
> 
> --
> Taras Heichenko
> [email-masked] <mailto:[email-masked]>
> 
> 
> 
> 
> 
> 
> 
> -- 
> SY, Dmitry Belyavsky
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/regext <https://www.ietf.org/mailman/listinfo/regext>

---

From: "Thomas Corte (TANGO support)" <[email-masked]>
Date: Mon, 20 Dec 2021 15:23:19 +0100

Hello,

> This is a bit low to declare consensus. Could more people voice their 

+1

-- 
TANGO REGISTRY SERVICES®
Knipp Medien und Kommunikation GmbH                    Thomas Corte
Technologiepark                             Phone: +49 231 9703-222
Martin-Schmeisser-Weg 9                       Fax: +49 231 9703-200
D-44227 Dortmund                      E-Mail: [email-masked]
Germany

---

From: Rick Wilhelm <[email-masked]>
Date: Mon, 20 Dec 2021 19:33:17 +0000

I support.
Thanks
Rick

From: regext <[email-masked]> on behalf of Antoin Verschuren <ietf=[email-masked]>
Date: Monday, December 20, 2021 at 8:55 AM
To: [email-masked] <[email-masked]>
Subject: [EXTERNAL] Re: [regext] WG LAST CALL: draft-ietf-regext-epp-eai-04
CAUTION: This email came from outside your organization. Don’t trust emails, links, or attachments from senders that seem suspicious or you are not expecting.
________________________________
Dear WG,

- --
Antoin Verschuren

Op 19 dec. 2021, om 19:11 heeft Dmitry Belyavsky <[email-masked]<mailto:[email-masked]>> het volgende geschreven:

On Sat, Dec 18, 2021 at 2:53 PM Taras Heichenko <[email-masked]<mailto:[email-masked]>> wrote:

> On 15 Dec 2021, at 16:14, Dmitry Belyavsky <[email-masked]<mailto:[email-masked]>> wrote:
>
> Dear Taras.

Dear Dmitry

>
> On Tue, Dec 14, 2021 at 8:13 PM Taras Heichenko <[email-masked]<mailto:[email-masked]>> wrote:
> The comment is in body.
>
> > On 13 Dec 2021, at 15:15, Hollenbeck, Scott <shollenbeck=[email-masked]<mailto:[email-masked]>> wrote:
> >
> >> From: Gould, James <jgould=[email-masked]<mailto:[email-masked]>>
> >> To: Hollenbeck, Scott <[email-masked]<mailto:[email-masked]>>;
> >> ietf=[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> >> [email-masked]<mailto:[email-masked]> <applewebdata://13890C55-AAE8-4BF3-A6CE-
> >> B4BA42740803/[email-masked]<mailto:B4BA42740803/[email-masked]>>
> >>
> >> 703-948-3271
> >> 12061 Bluemont Way
> >> Reston, VA 20190
> >>
> >> Verisign.com<http://Verisign.com> <http://secure-<http://secure-/>
> >> web.cisco.com/1bUEhaRz5CoSQPd4colm8eTGE5D6zPQvtrYPAzQf9pUSXnqD<http://web.cisco.com/1bUEhaRz5CoSQPd4colm8eTGE5D6zPQvtrYPAzQf9pUSXnqD>
> >> 4Rl06BQIL8B8k/http%3A%2F%2Fverisigninc.com<http://2Fverisigninc.com>%2F>
> >>
> >> [email-masked]<mailto:[email-masked]> on behalf of shollenbeck=[email-masked]<mailto:[email-masked]>>
> >> wrote:
> >>
> >>

> > [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
>
>
>
>
>
> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

--
Taras Heichenko
[email-masked]<mailto:[email-masked]>

--
SY, Dmitry Belyavsky
_______________________________________________
regext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/regext

---

From: Roger D Carney <[email-masked]>
Date: Mon, 20 Dec 2021 19:46:08 +0000

+1

________________________________
From: regext <[email-masked]> on behalf of Antoin Verschuren <ietf=[email-masked]>
Sent: Monday, December 20, 2021 7:55 AM
To: [email-masked] <[email-masked]>
Subject: Re: [regext] WG LAST CALL: draft-ietf-regext-epp-eai-04

You don't often get email from ietf=[email-masked]. Learn why this is important<http://aka.ms/LearnAboutSenderIdentification>
Caution: This email is from an external sender. Please do not click links or open attachments unless you recognize the sender and know the content is safe. Forward suspicious emails to isitbad@.

Dear WG,

- --
Antoin Verschuren

Dear Dmitry

> >> Verisign.com<https://nam10.safelinks.protection.outlook.com/?url=http%3A%2F%2Fverisign.com%2F&data=04%7C01%7Crcarney%40godaddy.com%7Cb87ed08c77164d698a0308d9c3c0609e%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637756053745807971%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=LefyPGdVfhMstAcRxGtnropqJvw2WK84PD8txgr6obo%3D&reserved=0> <http://secure-<http://secure-/>
> >> web.cisco.com/1bUEhaRz5CoSQPd4colm8eTGE5D6zPQvtrYPAzQf9pUSXnqD<https://nam10.safelinks.protection.outlook.com/?url=http%3A%2F%2Fweb.cisco.com%2F1bUEhaRz5CoSQPd4colm8eTGE5D6zPQvtrYPAzQf9pUSXnqD&data=04%7C01%7Crcarney%40godaddy.com%7Cb87ed08c77164d698a0308d9c3c0609e%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637756053745807971%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=mMNC4FXzTFZ%2FLZsE78G%2F1AFzyfl1Q2jCW%2FIlK8RwNXA%3D&reserved=0>
> >> 4Rl06BQIL8B8k/http%3A%2F%2Fverisigninc.com<https://nam10.safelinks.protection.outlook.com/?url=http%3A%2F%2F2fverisigninc.com%2F&data=04%7C01%7Crcarney%40godaddy.com%7Cb87ed08c77164d698a0308d9c3c0609e%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637756053745817966%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=mlpGPoejSHY6R0lIunqMiGkD8EX7HMYWvlbsXMrFwAE%3D&reserved=0>%2F>
> >>

> > https://www.ietf.org/mailman/listinfo/regext<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext&data=04%7C01%7Crcarney%40godaddy.com%7Cb87ed08c77164d698a0308d9c3c0609e%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637756053745827964%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=SkQzRE9uzkwokC5TQF83CB%2Br0xfIT30L47kqr4t18NQ%3D&reserved=0>
>
> --
> Taras Heichenko
> https://www.ietf.org/mailman/listinfo/regext<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext&data=04%7C01%7Crcarney%40godaddy.com%7Cb87ed08c77164d698a0308d9c3c0609e%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637756053745827964%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=SkQzRE9uzkwokC5TQF83CB%2Br0xfIT30L47kqr4t18NQ%3D&reserved=0>
>
>
> --
> SY, Dmitry Belyavsky
> https://www.ietf.org/mailman/listinfo/regext<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext&data=04%7C01%7Crcarney%40godaddy.com%7Cb87ed08c77164d698a0308d9c3c0609e%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637756053745837969%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=9MIH22PnrDTkqSWyQjxijbQKgDNl5B56ijqOObUZqVU%3D&reserved=0>

--
SY, Dmitry Belyavsky
_______________________________________________
regext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/regext<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext&data=04%7C01%7Crcarney%40godaddy.com%7Cb87ed08c77164d698a0308d9c3c0609e%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637756053745847949%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=tYzCCLOn2iRJBmHN8LrIjruiH3tr4h1dyhmtVISTbDs%3D&reserved=0>

---

From: Jody Kolker <[email-masked]>
Date: Mon, 20 Dec 2021 20:55:46 +0000

+1

To: [email-masked]

You don't often get email from ietf=[email-masked]<mailto:ietf=[email-masked]>. Learn why this is important<http://aka.ms/LearnAboutSenderIdentification>
Caution: This email is from an external sender. Please do not click links or open attachments unless you recognize the sender and know the content is safe. Forward suspicious emails to isitbad@.

Dear WG,

- --
Antoin Verschuren

Dear Dmitry

> >> Verisign.com<https://nam10.safelinks.protection.outlook.com/?url=http%3A%2F%2Fverisign.com%2F&data=04%7C01%7Cjkolker%40godaddy.com%7Cb87ed08c77164d698a0308d9c3c0609e%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637756053298104386%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=SeJADm1p8BCWJorBXlzSwNMCoaUJymYQPlUGuFezG5A%3D&reserved=0> <http://secure-<http://secure-/>
> >> web.cisco.com/1bUEhaRz5CoSQPd4colm8eTGE5D6zPQvtrYPAzQf9pUSXnqD<https://nam10.safelinks.protection.outlook.com/?url=http%3A%2F%2Fweb.cisco.com%2F1bUEhaRz5CoSQPd4colm8eTGE5D6zPQvtrYPAzQf9pUSXnqD&data=04%7C01%7Cjkolker%40godaddy.com%7Cb87ed08c77164d698a0308d9c3c0609e%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637756053298104386%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=Xb05bLTnetPCJsnTaPJMlMpesBpe2Sv%2BW%2FG0ADqBy7Y%3D&reserved=0>
> >> 4Rl06BQIL8B8k/http%3A%2F%2Fverisigninc.com<https://nam10.safelinks.protection.outlook.com/?url=http%3A%2F%2F2fverisigninc.com%2F&data=04%7C01%7Cjkolker%40godaddy.com%7Cb87ed08c77164d698a0308d9c3c0609e%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637756053298104386%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=lTi0fMUFNScSaKDminyMg94T%2FM6Cse%2Fp2bYIfXkzC7E%3D&reserved=0>%2F>
> >>

> > https://www.ietf.org/mailman/listinfo/regext<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext&data=04%7C01%7Cjkolker%40godaddy.com%7Cb87ed08c77164d698a0308d9c3c0609e%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637756053298104386%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=ybjfIOVDlc5Dy7xf8BoYsNoaCwFJsR6WHsuWIEEQEOo%3D&reserved=0>
>
> --
> Taras Heichenko
> https://www.ietf.org/mailman/listinfo/regext<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext&data=04%7C01%7Cjkolker%40godaddy.com%7Cb87ed08c77164d698a0308d9c3c0609e%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637756053298104386%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=ybjfIOVDlc5Dy7xf8BoYsNoaCwFJsR6WHsuWIEEQEOo%3D&reserved=0>
>
>
> --
> SY, Dmitry Belyavsky
> https://www.ietf.org/mailman/listinfo/regext<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext&data=04%7C01%7Cjkolker%40godaddy.com%7Cb87ed08c77164d698a0308d9c3c0609e%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637756053298104386%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=ybjfIOVDlc5Dy7xf8BoYsNoaCwFJsR6WHsuWIEEQEOo%3D&reserved=0>

--
SY, Dmitry Belyavsky
_______________________________________________
regext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/regext<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext&data=04%7C01%7Cjkolker%40godaddy.com%7Cb87ed08c77164d698a0308d9c3c0609e%7Cd5f1622b14a345a6b069003f8dc4851f%7C0%7C0%7C637756053298104386%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=ybjfIOVDlc5Dy7xf8BoYsNoaCwFJsR6WHsuWIEEQEOo%3D&reserved=0>

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 21 Dec 2021 16:14:52 +0000

From: regext <[email-masked]> On Behalf Of Antoin Verschuren
Sent: Monday, December 20, 2021 8:55 AM
To: [email-masked]
Subject: [EXTERNAL] Re: [regext] WG LAST CALL: draft-ietf-regext-epp-eai-04

Caution: This email originated from outside the organization. Do not click
links or open attachments unless you recognize the sender and know the
content is safe. 

Dear WG,

This WGLC will end tonight, and so far we only have 2 explicit voices of
support.

This is a bit low to declare consensus. Could more people voice their
support?

Scott, can you confirm that the changes in version 05 address your initial
concerns?

[SAH] Not yet fixed completely:

Section 6 still doesn't explain why "Registries SHOULD validate the domain
names syntax in the provided email addresses". I suggested this text in an
earlier note:

"Registries SHOULD ensure that the provided email addresses are
syntactically valid to reduce the risk of future usability errors."

The IANA Considerations section still uses "eai-0.3". It should be
"eai-1.0".

Scott

---

From: Dmitry Belyavsky <[email-masked]>
Date: Thu, 23 Dec 2021 12:05:31 +0100

Dear Scott,

Many thanks for your nitpicking!
I've addressed your concern about Section 6 using your words, many thanks!

As for the namespace version, as James wrote before, we are going to update
it after the WGLC.

Merry Christmas and Happy New Year!

On Tue, Dec 21, 2021 at 5:15 PM Hollenbeck, Scott <shollenbeck=
[email-masked]> wrote:

>
>
> *From:* regext <[email-masked]> *On Behalf Of *Antoin Verschuren
> *Sent:* Monday, December 20, 2021 8:55 AM
> *To:* [email-masked]
> *Subject:* [EXTERNAL] Re: [regext] WG LAST CALL:
> draft-ietf-regext-epp-eai-04
>
>
>
> *Caution:* This email originated from outside the organization. Do not
> click links or open attachments unless you recognize the sender and know
> the content is safe.
>
> Dear WG,
>
>
>
> *[SAH] Not yet fixed completely:*
>
>
>
> *Section 6 still doesn’t explain why “Registries SHOULD validate the
> domain names syntax in the provided email addresses”. I suggested this text
> in an earlier note:*
>
>
>
> *"Registries SHOULD ensure that the provided email addresses are
> syntactically valid to reduce the risk of future usability errors."*
>
>
>
> *The IANA Considerations section still uses “eai-0.3”. It should be
> “eai-1.0”.*
>
>
>
> *Scott*

-- 
SY, Dmitry Belyavsky

---

From: Antoin Verschuren <[email-masked]>
Date: Thu, 23 Dec 2021 22:59:09 +0100

And with this, this WGLC is now formally closed.
The chairs count enough support for this draft (+6 not counting document authors and shepherds) to be able to declare consensus.

However, this draft changed from version 04 to version 06 during WGLC, and we need a confirmation from the document shepherd in his review that only editorial and no substantive changes were made, and all concerns during WGLC are addressed in version 06.
Protocol dictates us that when substantive changes were made to a document during WGLC, we need to issue a second WGLC before we can declare consensus and submit it to the IESG.

The document shepherd for this document is Jody Kolker.
Jody, when you have done your review, please let us know the result.
When there were no substantive changes during WGLC, you can start the shepherd writeup for version 06.

Regards,

Jim and Antoin

> Op 23 dec. 2021, om 12:05 heeft Dmitry Belyavsky <[email-masked]> het volgende geschreven:
> 
> Dear Scott,
> 
> As for the namespace version, as James wrote before, we are going to update it after the WGLC.
> 
> On Tue, Dec 21, 2021 at 5:15 PM Hollenbeck, Scott <shollenbeck=[email-masked] <mailto:[email-masked]>> wrote:
>  
> 
> From: regext <[email-masked] <mailto:[email-masked]>> On Behalf Of Antoin Verschuren
> To: [email-masked] <mailto:[email-masked]>
> Caution: This email originated from outside the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe. 
> 
> Dear WG,
> 
>  
> 
> Section 6 still doesn’t explain why “Registries SHOULD validate the domain names syntax in the provided email addresses”. I suggested this text in an earlier note:
> 
>  
> 
> "Registries SHOULD ensure that the provided email addresses are syntactically valid to reduce the risk of future usability errors."
> 
>  
> 
> The IANA Considerations section still uses “eai-0.3”. It should be “eai-1.0”.
> 
>  
> 
> Scott
>

---

From: Dmitry Belyavsky <[email-masked]>
Date: Tue, 28 Dec 2021 18:34:52 +0100

Dear Antoin,

If everything is fine, the -07 version will be published with the only
change - namespace version will be 1.0

On Thu, Dec 23, 2021 at 10:59 PM Antoin Verschuren <ietf=
[email-masked]> wrote:

> The chairs count enough support for this draft (+6 not counting document
> authors and shepherds) to be able to declare consensus.
>
> However, this draft changed from version 04 to version 06 during WGLC, and
> we need a confirmation from the document shepherd in his review that only
> editorial and no substantive changes were made, and all concerns during
> WGLC are addressed in version 06.
> Protocol dictates us that when substantive changes were made to a document
> during WGLC, we need to issue a second WGLC before we can declare consensus
> and submit it to the IESG.
>

-- 
SY, Dmitry Belyavsky