Subject: Re: [regext] John Scudder's No Objection on draft-ietf-regext-rfc7484bis-04: (with COMMENT)

From: Marc Blanchet <[email-masked]>
Date: Tue, 25 Jan 2022 17:22:25 -0500

> Le 1 déc. 2021 à 21:05, John Scudder via Datatracker <[email-masked]> a écrit :
> 
> John Scudder has entered the following ballot position for
> draft-ietf-regext-rfc7484bis-04: No Objection
> 
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
> 
> 
> Please refer to https://www.ietf.org/blog/handling-iesg-ballot-positions/
> for more information about how to handle DISCUSS and COMMENT positions.
> 
> 
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-regext-rfc7484bis/
> 
> 
> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> Thanks for the useful and easy to follow spec. I have a few questions and
> comments below, I hope some of them are helpful.
> 
> 1. In §5 you write,
> 
>                       The longest match is done the same way as for
>   routing:
> 
> I might prefer “… same way as for packet forwarding“. It isn’t a big deal,
> though.
> 

<MB>Done in -05</MB>

> 2. In §5.1 you write,
> 
>   The latter is chosen by the client given the longest match.
> 
> I suggest “because it is” instead of “given“. (Similar in §5.2)

<MB>Done in -05</MB>

> 
> 3. In §5.3 you write,
> 
>                                                              The array
>   always contains two AS numbers represented in decimal format
> 
> Don’t you mean, “each array element always contains…“? Also, it appears what it
> really contains is two ASNs *separated by a hyphen*.

<MB>Yes.</MB>

> 
> 4. Again with respect to §5.3, is there no need for most-specific match
> semantics for ASNs? I’m imagining that presented with the choices of a larger
> or smaller range to match a given query, the smallest matching range would be
> used. E.g., given a query of 65501 and two entries, one for 65500-65535 and
> another for 65501-65501, the latter would be chosen. No?

<MB>Added a sentence in -05 to the effect that ranges must not overlap. </MB>

> 
> 5. In §6 you mention a “fully referenced URL”. Do you mean “fully-qualified “?

<MB>Done in -05</MB>

THanks, Regards, Marc.

---

From: John Scudder <[email-masked]>
Date: Tue, 25 Jan 2022 22:46:41 +0000

Hi Marc,

Thanks, I just had a look at the diff. I have one further point to follow up on.

> On Jan 25, 2022, at 5:22 PM, Marc Blanchet <[email-masked]> wrote:
> 
[…trimmed…]
>> really contains is two ASNs *separated by a hyphen*.

05 still has the text as quoted above. I’m not sure if that was deliberate, or an oversight. In case it wasn’t clear, I was suggesting something along these lines: 

OLD:
   served by the base RDAP URLs found in the second element.  The array
   always contains two AS numbers represented in decimal format that
   represents the range of AS numbers between the two elements of the
   array, where values are in increasing order (e.g. 100-200, not
   200-100).  A single AS number is represented as a range of two

NEW:
   served by the base RDAP URLs found in the second element.  Each
   element of the array
   contains two AS numbers represented in decimal format, 
   separated by a hyphen, that
   represents the range of AS numbers between the two AS numbers
   (inclusive), where values are in increasing order (e.g. 100-200, not
   200-100).  A single AS number is represented as a range of two

(While I was at it I changed “between the two elements of the array”, which I think was just wrong, and added “inclusive”.)

If the text in 05 is exactly the way you want it, that’s OK, I think that for practical purposes the ambiguity is unlikely to be a problem, especially given the example (which is what I relied on to understand the meaning). I’m just pointing this out in case it was an oversight.

Regards,

—John

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 25 Jan 2022 18:41:23 -0500

> Le 25 janv. 2022 à 17:46, John Scudder <[email-masked]> a écrit :
> 
> Hi Marc,
> 

Was not an oversight. I thought you were looking for an answer to your comment, so I responded “yes” ;-)

Thanks for the text, I’ll add it to the -06, which I need to do anyway because I left two topics that need further discussion in the working group/ADs.

Thanks, Marc.