Subject: Re: [regext] CALL FOR ADOPTION: draft-flanagan-regext-datadictionary

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 4 Jan 2022 13:45:34 +0100

On Mon, Dec 20, 2021 at 09:27:43AM -0500,
 James Galvin <[email-masked]> wrote 
 a message of 18 lines which said:

> This is the formal adoption request for DNS Data Dictionary:
> 
> 	https://datatracker.ietf.org/doc/draft-flanagan-regext-datadictionary/

OK for adoption, since this is a real issue and this draft is a good
starting point. But I share George Michaelson's concerns: many words
are very policy-loaded and it can be difficult to capture a standard
definition for them. Also, I agree that the title should refer to
domain names, not the DNS protocol (see draft-lewis-domain-names).

Also:

> This is the domain name in an EPP [RFC5731] domain object 

I see no reason to refer to EPP (domain names existed long before EPP).

> and it MUST be in A-Label format.

Why? The international version (U-label) seems more inclusive.

> Individual names MAY be provided in either UTF-8 [RFC3629] or a
> subset of UTF-8 that can be represented in 7-bit ASCII,

Is the goal to describe semantics of a data element or also to specify
its syntax? (In the last case, we need to specify the Unicode
normalisation.)

---

From: Michele Neylon - Blacknight <[email-masked]>
Date: Tue, 4 Jan 2022 13:23:02 +0000

This draft seems to be rather confused about what its purpose is.
As others have pointed out it talks about “DNS”, but in reality its focus seems to be on domain names and their registrants.
It says it’s merely a “dictionary” but then goes on to make very clear policy decisions eg. 2.30
It also includes terms that are not in anyway standard as if they were eg. 2.8, 2.9, 2.11

Regards

Michele

--
Mr Michele Neylon
Blacknight Solutions
Hosting, Colocation & Domains
https://www.blacknight.com/
https://blacknight.blog/
Intl. +353 (0) 59  9183072
Direct Dial: +353 (0)59 9183090
Personal blog: https://michele.blog/
Some thoughts: https://ceo.hosting/
-------------------------------
Blacknight Internet Solutions Ltd, Unit 12A,Barrowside Business Park,Sleaty
Road,Graiguecullen,Carlow,R93 X265,Ireland  Company No.: 370845

From: regext <[email-masked]> on behalf of James Galvin <[email-masked]>
Date: Monday, 20 December 2021 at 14:28
To: Registration Protocols Extensions <[email-masked]>
Subject: [regext] CALL FOR ADOPTION: draft-flanagan-regext-datadictionary
[EXTERNAL EMAIL] Please use caution when opening attachments from unrecognised sources.

Please review this draft to see if you think it is suitable for adoption by REGEXT and comment to the list, clearly stating your view.

This Call For Adoption will close on Monday, 10 January.

If there are no objections, the chairs will consider this document adopted.

Thanks,

Your REGEXT co-chairs Antoin and Jim

_______________________________________________
regext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/regext

---

From: Steve Crocker <[email-masked]>
Date: Tue, 4 Jan 2022 09:42:22 -0800

Stephane, Michele, et al,

Thanks for your comments.  We're looking forward to adjusting the
descriptions, removing any policy bias, etc., etc.  We were advised to wait
until the WG adoption decision has been made, hopefully fairly soon.

Steve

On Tue, Jan 4, 2022 at 5:23 AM Michele Neylon - Blacknight <michele=
[email-masked]> wrote:

> As others have pointed out it talks about “DNS”, but in reality its focus
> seems to be on domain names and their registrants.
>
> *From: *regext <[email-masked]> on behalf of James Galvin <
> [email-masked]>
> *Date: *Monday, 20 December 2021 at 14:28
> *To: *Registration Protocols Extensions <[email-masked]>
> *Subject: *[regext] CALL FOR ADOPTION:
> draft-flanagan-regext-datadictionary
>
> Please review this draft to see if you think it is suitable for adoption
> by REGEXT and comment to the list, clearly stating your view.
>

---

From: Sarah Wyld <[email-masked]>
Date: Wed, 5 Jan 2022 11:47:04 -0500

Hi all,

Re Section 3, my understanding is that this section is intended to describe how new data elements would be created for use across the entire domain system, as opposed to describing how a specific data element is populated for a given domain. 

If that is correct (it is for creating new data elements), could some further explanation be added to section 3 “IANA Considerations”? And if not, please let me know.

Thanks,

-- 
Sarah Wyld, CIPP/E

Policy & Privacy Manager
Pronouns: she/they

[email-masked] 
+1.416 535 0123 Ext. 1392

From: James Galvin
Sent: December 20, 2021 9:28 AM
To: Registration Protocols Extensions
Subject: [regext] CALL FOR ADOPTION: draft-flanagan-regext-datadictionary

Thanks,

---

From: James Galvin <[email-masked]>
Date: Mon, 17 Jan 2022 09:55:36 -0500

This CALL FOR ADOPTION is now closed.  There were no objections and 6 indications of support from Stephane Bortzmeyer, Tim Wicinski, Jiankang Yao, George Michaelson, Dmitry Belyavsky, and John Levine, therefore the document is adopted for work by REGEXT.

During the call for adoption there were a number of details highlighted for review that will need to be addressed, as well as the following broad topic.  The scope of the work - this document seems to suggest that it is limited to just DNS registration data and the discussion during the call for adoption suggests that the data dictionary has broader applicability.  This is a significant issue and should be addressed as the first item for this document in REGEXT.

With this message the chairs ask the authors to submit version 00 of a working group document, that is the same as the current document, using the following draft name:

draft-ietf-regext-datadictionary

The document authors must also identify a document shepherd.  If you would like to volunteer please let them know.

Work can begin as soon as the 00 is published.

Thanks,

Antoin and Jim