Subject: Re: [regext] Francesca Palombini's No Objection on draft-ietf-regext-rfc7484bis-04: (with COMMENT)

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 1 Feb 2022 16:51:08 -0800

On Tue, Jan 25, 2022 at 4:05 PM Marc Blanchet <[email-masked]>
wrote:

> > 1. -----
> >
> > FP: Please replace references to RFC 7234 with
> draft-ietf-httpbis-cache-19.
>
> <MB>I have a hard time thinking to replace an RFC reference to a draft in
> a document that would become an Internet Standard. Moreover, I think the
> reference is more about “please look at ways to cache data” more than a
> hard requirement. So I disagree with your proposal. The new -05 do not
> contain any change in that regard. So I’m looking for your reply if you
> still want me to change the reference</MB>
>

Since draft-ietf-httpbis-cache has been approved by the IESG, I think
Francesca's suggestion is appropriate.  Otherwise, this Internet Standard
will be published with a reference to a document we already know to be
obsolete, which seems like an odd choice.  Changing the reference won't
delay publication of this document since the referenced document is already
in the RFC Editor queue anyway; it'll ship before this one does.

I can have the RFC Editor make this change prior to AUTH48 rather than
delay it since it's otherwise an approved document.

-MSK

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 1 Feb 2022 19:55:21 -0500

> Le 1 févr. 2022 à 19:51, Murray S. Kucherawy <[email-masked]> a écrit :
> 
> On Tue, Jan 25, 2022 at 4:05 PM Marc Blanchet <[email-masked] <mailto:[email-masked]>> wrote:
> > 1. -----
> > 
> > FP: Please replace references to RFC 7234 with draft-ietf-httpbis-cache-19.
> 
> <MB>I have a hard time thinking to replace an RFC reference to a draft in a document that would become an Internet Standard. Moreover, I think the reference is more about “please look at ways to cache data” more than a hard requirement. So I disagree with your proposal. The new -05 do not contain any change in that regard. So I’m looking for your reply if you still want me to change the reference</MB>
> 
> Since draft-ietf-httpbis-cache has been approved by the IESG, I think Francesca's suggestion is appropriate.  Otherwise, this Internet Standard will be published with a reference to a document we already know to be obsolete, which seems like an odd choice.  Changing the reference won't delay publication of this document since the referenced document is already in the RFC Editor queue anyway; it'll ship before this one does.
> 
> I can have the RFC Editor make this change prior to AUTH48 rather than delay it since it's otherwise an approved document.
> 

Fine by me!

Marc.