Subject: [regext] Fwd: New Version Notification for draft-loffredo-regext-epp-over-http-00.txt

From: Mario Loffredo <[email-masked]>
Date: Wed, 2 Mar 2022 12:45:24 +0100

Hi folks,

Just posted a draft about EPP over HTTP.  It aims to define rules for 
the EPP implementations leveraging HTTP due to its simplicity and ease 
of use.

The proposal preserves EPP commands semantics as HTTP is used merely for 
transportation.

The appendix includes possible strategies about how to implement load 
balancing in this context.

Even if EPP is largely implemented over TCP, some HTTP based 
implementations exist and a standardization would be advisable.

Feedback is welcome and appreciated.

Best,

Mario

-------- Messaggio Inoltrato --------
Oggetto: 	New Version Notification for 
draft-loffredo-regext-epp-over-http-00.txt
Data: 	Wed, 02 Mar 2022 03:16:34 -0800
Mittente: 	[email-masked]
A: 	Jan Romanowski <[email-masked]>, Lorenzo Luconi Trombacchi 
<[email-masked]>, Lorenzo Trombacchi 
<[email-masked]>, Marcin Machnio <[email-masked]>, Mario 
Loffredo <[email-masked]>, Maurizio Martinelli 
<[email-masked]>

A new version of I-D, draft-loffredo-regext-epp-over-http-00.txt
has been successfully submitted by Mario Loffredo and posted to the
IETF repository.

Name: draft-loffredo-regext-epp-over-http
Revision: 00
Title: Extensible Provisioning Protocol (EPP) Transport over HTTP
Document date: 2022-03-02
Group: Individual Submission
Pages: 15
URL: 
https://www.ietf.org/archive/id/draft-loffredo-regext-epp-over-http-00.txt
Status: 
https://datatracker.ietf.org/doc/draft-loffredo-regext-epp-over-http/
Htmlized: 
https://datatracker.ietf.org/doc/html/draft-loffredo-regext-epp-over-http

Abstract:
This document describes how the Extensible Provisioning Protocol
(EPP) is mapped over the Hypertext Transfer Protocol (HTTP). This
mapping requires the use of the Transport Layer Security (TLS)
protocol to protect information exchanged between an EPP client and
an EPP server.

The IETF Secretariat

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 2 Mar 2022 14:30:24 +0000

If there are implementations out there, I think this is worth doing.

Scott

From: regext <[email-masked]> On Behalf Of Mario Loffredo
Sent: Wednesday, March 2, 2022 6:45 AM
To: [email-masked]
Subject: [EXTERNAL] [regext] Fwd: New Version Notification for draft-loffredo-regext-epp-over-http-00.txt

Caution: This email originated from outside the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe.

Hi folks,

Just posted a draft about EPP over HTTP.  It aims to define rules for the EPP implementations leveraging HTTP due to its simplicity and ease of use.

The proposal preserves EPP commands semantics as HTTP is used merely for transportation.

The appendix includes possible strategies about how to implement load balancing in this context.

Even if EPP is largely implemented over TCP, some HTTP based implementations exist and a standardization would be advisable.

Best,

Mario

-------- Messaggio Inoltrato --------

Oggetto:

New Version Notification for draft-loffredo-regext-epp-over-http-00.txt

Data:

Wed, 02 Mar 2022 03:16:34 -0800

Mittente:

[email-masked]<mailto:[email-masked]>

A:

Jan Romanowski <[email-masked]><mailto:[email-masked]>, Lorenzo Luconi Trombacchi <[email-masked]><mailto:[email-masked]>, Lorenzo Trombacchi <[email-masked]><mailto:[email-masked]>, Marcin Machnio <[email-masked]><mailto:[email-masked]>, Mario Loffredo <[email-masked]><mailto:[email-masked]>, Maurizio Martinelli <[email-masked]><mailto:[email-masked]>

Name: draft-loffredo-regext-epp-over-http
Revision: 00
Title: Extensible Provisioning Protocol (EPP) Transport over HTTP
Document date: 2022-03-02
Group: Individual Submission
Pages: 15
URL: https://www.ietf.org/archive/id/draft-loffredo-regext-epp-over-http-00.txt<https://secure-web.cisco.com/1sOCqFMpy9yFeA5WPoh48hJYV0AXHuiNWTz2l9-gPRju4fBVithDO_xaxSB8dutTvCw8RQRadxrrywJNEGTc0A04D-LAuAqozJOxHWuxjOvFYIBrsAPMHqGRz234otLEdcSIQacb7MAhF-FtoxqhhP80zNJl3DRy3GtBdkNvqkmpfYFhCvZfZZ6v85woFPGU9hP3_Qq8x0wY1157yBbHeVxCrnHEjo35mZ4bJVyGxGsWqLKX6qoXwDaDZVdlczCWM/https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-loffredo-regext-epp-over-http-00.txt>
Status: https://datatracker.ietf.org/doc/draft-loffredo-regext-epp-over-http/<https://secure-web.cisco.com/1b5KQeFMXcbxx5gTEaVV2fvtc7Qo9APovuzlnCMvpqltG-l51Gb4wEulyZae7fR4LFP0s7TLK0-9mSL8kFnGQKCeZ5c75UKGObQDI-T1ue1YVF5wDxvot9MnVs-1qmbdVTVqcaG2dcFDNaP48Emi9blwHjoMibTZi58tr47p9lDgHGUhgG7JgHlsbUd4yATl_x1Y8mivJL4XqbflHKMMvY4IcnIBU9tesyn0Rgr7WzqC7UwbXEwBY5GwdRV0DOGyJ/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-loffredo-regext-epp-over-http%2F>
Htmlized: https://datatracker.ietf.org/doc/html/draft-loffredo-regext-epp-over-http<https://secure-web.cisco.com/1hfb58nMIoEfQtaSBcFGodXTOsWhyO3QwZAGPf9uNJCq_TAGtGWyCh0bJH9v5rAFrNU7eqZ_qNg8xsJ5ukEkaLQUxKLzqGHjxwhRxWQVKWoqIqdDvrgxv6FF2wbOeywEHFbZ3L9-tsR1r0XHSgRqYvFe09Q-0O576vN_8hOPjmkaw2tgHa7_n1E_TQzutVS7NQLqxLb-CAycXiT6Cfl6jn_vOPb6QMgHorTkSTlfQedx0suDQvJWcf56VPuuhCkll/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-loffredo-regext-epp-over-http>

Abstract:

The IETF Secretariat

---

From: Tobias Sattler <[email-masked]>
Date: Sat, 5 Mar 2022 15:28:40 +0100

Hi Mario,

Thanks for this draft and your feedback on the other threads.

While I understand the need for standardization (and I support that), even if EPP over HTTP is not widely used, I wonder if the future could not be REST API considering that new APIs are mostly built that way? I don’t suggest doing it that way, but out of curiosity and a look into the further future.

Best,
Tobias

> On 2. Mar 2022, at 12:45, Mario Loffredo <[email-masked]> wrote:
> 
> Hi folks,
> 
> Oggetto:	New Version Notification for draft-loffredo-regext-epp-over-http-00.txt
> Mittente:	[email-masked] <mailto:[email-masked]>
> A:	Jan Romanowski <[email-masked]> <mailto:[email-masked]>, Lorenzo Luconi Trombacchi <[email-masked]> <mailto:[email-masked]>, Lorenzo Trombacchi <[email-masked]> <mailto:[email-masked]>, Marcin Machnio <[email-masked]> <mailto:[email-masked]>, Mario Loffredo <[email-masked]> <mailto:[email-masked]>, Maurizio Martinelli <[email-masked]> <mailto:[email-masked]>
> 
> 
> URL: https://www.ietf.org/archive/id/draft-loffredo-regext-epp-over-http-00.txt <https://www.ietf.org/archive/id/draft-loffredo-regext-epp-over-http-00.txt>
> Status: https://datatracker.ietf.org/doc/draft-loffredo-regext-epp-over-http/ <https://datatracker.ietf.org/doc/draft-loffredo-regext-epp-over-http/>
> Htmlized: https://datatracker.ietf.org/doc/html/draft-loffredo-regext-epp-over-http <https://datatracker.ietf.org/doc/html/draft-loffredo-regext-epp-over-http>
> 
> 
> Abstract:
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext

---

From: Mario Loffredo <[email-masked]>
Date: Mon, 7 Mar 2022 10:21:22 +0100

Hi Tobias,

thanks for your interest in this topic.

Il 05/03/2022 15:28, Tobias Sattler ha scritto:
> While I understand the need for standardization (and I support that), 
> even if EPP over HTTP is not widely used, I wonder if the future could 
> not be REST API considering that new APIs are mostly built that way? I 
> don’t suggest doing it that way, but out of curiosity and a look into 
> the further future.

If you are suggesting to start the discussion about a radically change 
of EPP to make it more compliant with REST API principles (I mean, 
replacing XML with JSON, using different authentication mechanisms, 
distinguishing endpoints based on the operations), I would be happy with 
that but I imagine that such a process would take considerable time and 
should be supported by large consensus within the WG.

IMO, just the transition to a schemaless command/response format would 
bring more flexibility and a significant reduction of the implementation 
effort.

This proposal aims only at definining rules for the existing (and 
possible future) implementations.  Its main goal is to map EPP over HTTP 
without altering the EPP semantics.

Best,

Mario

>> the EPP implementations leveraging HTTP due to its simplicity and 
>> ease of use.
>>
>> A: 	Jan Romanowski <[email-masked]>, Lorenzo Luconi 
>> Trombacchi <[email-masked]>, Lorenzo Trombacchi 
-- 
Dr. Mario Loffredo
Technological Unit “Digital Innovation”
Institute of Informatics and Telematics (IIT)
National Research Council (CNR)
via G. Moruzzi 1, I-56124 PISA, Italy
Phone: +39.0503153497
Web:http://www.iit.cnr.it/mario.loffredo