Subject: [renum] Renumbering BOF?

From: Brian E Carpenter <[email-masked]>
Date: Thu, 06 Jan 2011 10:33:13 +1300

Hi,

Back to work...

Does anyone have the feeling that we have enough to chew on to justify
a renumbering BOF in Prague? I'd need at least one significant topic
to discuss, and a volunteer to produce a draft in the near future -
the ADs are unlikely to approve a BOF without any sign of a draft.

So far, our discussions have been a bit discursive, apart from
Fred's proposal to develop a management model for site renumbering:
http://www.ietf.org/mail-archive/web/renum/current/msg00035.html

Are we interested in developing such an approach? If so, there isn't
much time to do so:

2011-01-31 (Monday): Cutoff date for BOF proposal requests to Area Directors at 17:00 PT

-- 
Regards
   Brian Carpenter

---

From: Sheng Jiang <[email-masked]>
Date: Thu, 06 Jan 2011 08:59:18 +0800

Hi, Brian,

We are already starting to work on a problem statement draft. It should be possible to submit a
primary version by the end of this month. Of course, we would like to work with you and anybody
interested.

Now, the first important question is what kind of direction we want to choice, or we just list all
of possibilities in the draft? Are we going to fix the current minor issues one by one (we have
located several minor issues that need to modify or extend current protocols) or propose a big new
model to solve most issues together? Personally, I am hesitating to choose the latter since it
would be difficult to deploy such new and big mechanism in the current mature networks.

Regards,

Sheng

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Brian E Carpenter
> Sent: Thursday, January 06, 2011 5:33 AM
> To: [email-masked]
> Subject: [renum] Renumbering BOF?
> 
> Hi,
> 
> Back to work...
> 
> Does anyone have the feeling that we have enough to chew on 
> to justify a renumbering BOF in Prague? I'd need at least one 
> significant topic to discuss, and a volunteer to produce a 
> draft in the near future - the ADs are unlikely to approve a 
> BOF without any sign of a draft.
> 
> So far, our discussions have been a bit discursive, apart 
> from Fred's proposal to develop a management model for site 
> renumbering:
> Are we interested in developing such an approach? If so, 
> there isn't much time to do so:
> 
> _______________________________________________
> renum mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/renum

---

From: Fred Baker <[email-masked]>
Date: Wed, 5 Jan 2011 17:35:21 -0800

I'm up for a BOF.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 06 Jan 2011 16:37:26 +1300

Fred, are you up for a draft on your approach, too?

With two drafts in prospect I could make a BOF proposal,
but it will not be a WG-forming BOF, in all probability.

Regards
   Brian

---

From: Eliot Lear <[email-masked]>
Date: Thu, 06 Jan 2011 15:00:27 +0100

Brian,

I like the idea of having a concrete proposal that we can discuss as to
whether useful work can proceed.  I'm not sure a BoF is needed for such
a proposal, but it might be a nice forcing function to see how this
group can focus.

Eliot

---

From: Tim Chown <[email-masked]>
Date: Thu, 6 Jan 2011 14:18:29 +0000

I recall we tried proposing a renumbering BoF some 3 or 4 years ago, but there wasn't interest then.   At that time we'd had some results from applying Fred's RFC4192 methodology, and we had a bunch of thoughts and issues captured in http://tools.ietf.org/html/draft-chown-v6ops-renumber-thinkabout-05.   Since then of course we have more recent work by Brian and others.   But as at least part of a BoF it's definitely worth reviewing the past work, which of the concerns and issues are still valid, and what could/should be done about that.    Maybe there's piecemeal work to be done along the lines Sheng suggests.

I think Fred's recent post/suggestion is also certainly interesting in that it takes a more strategic approach; to me it's not just about renumbering a network, it's about numbering/provisioning its IP configuration in general.   A model should then allow coexistence of and transition between states, and support validation that processes being applied are producing the correct states.   Or maybe that's too broad a problem to consider here?

Tim

---

From: Scott Brim <[email-masked]>
Date: Thu, 06 Jan 2011 11:14:38 -0500

I'd say the only way to know if it's worth doing is to try to make it
happen.

---

From: Fred Baker <[email-masked]>
Date: Thu, 6 Jan 2011 16:45:42 -0800

> I think Fred's recent post/suggestion is also certainly interesting in that it takes a more strategic approach; to me it's not just about renumbering a network, it's about numbering/provisioning it…

That's more or less what I was getting at, and I'll argue that provisioning addresses is part of "provisioning". I'm quite happy to design some sort of schema that allows for address management. Care to collaborate?

---

From: Sheng Jiang <[email-masked]>
Date: Fri, 07 Jan 2011 11:15:31 +0800

> On Behalf Of Tim Chown
> Sent: Thursday, January 06, 2011 10:18 PM
> To: [email-masked]
> Subject: Re: [renum] Renumbering BOF?
> 
> I recall we tried proposing a renumbering BoF some 3 or 4 
> years ago, but there wasn't interest then.   At that time 
> we'd had some results from applying Fred's RFC4192 
> methodology, and we had a bunch of thoughts and issues 
> captured in 
> http://tools.ietf.org/html/draft-chown-v6ops-renumber-thinkabo
> ut-05.   Since then of course we have more recent work by 
> Brian and others.   But as at least part of a BoF it's 
> definitely worth reviewing the past work, which of the 
> concerns and issues are still valid, and what could/should be 
> done about that.    Maybe there's piecemeal work to be done 
> along the lines Sheng suggests.

Hi, Tim,

Thanks for your information. I just had a quick review for your draft. It contains many valuable
information. Many issues may still exist. We will re-examine these issues carefully and summary
them into our PS draft. Are you interesting to work with us on the PS draft? My plan is to produce
a very first draft by Jan 20 for a small range reviewing so that we can have a primary version
submitted this month.

Regards,

Sheng
 
> I think Fred's recent post/suggestion is also certainly 
> interesting in that it takes a more strategic approach; to me 
> it's not just about renumbering a network, it's about 
> numbering/provisioning its IP configuration in general.   A 
> model should then allow coexistence of and transition between 
> states, and support validation that processes being applied 
> are producing the correct states.   Or maybe that's too broad 
> a problem to consider here?
> 
> Tim
> 
> but it will 
> > not be a WG-forming BOF, in all probability.
> > 
> > Regards
> >   Brian
> > 
> >>> We are already starting to work on a problem statement draft. It 
> >>> should be possible to submit a primary version by the end of this 
> >>> month. Of course, we would like to work with you and 
> anybody interested.
> >>> 
> >>> Now, the first important question is what kind of 
> direction we want 
> >>> to choice, or we just list all of possibilities in the 
> draft? Are we 
> >>> going to fix the current minor issues one by one (we have located 
> >>> several minor issues that need to modify or extend current 
> >>> protocols) or propose a big new model to solve most 
> issues together? Personally, I am hesitating to choose the 
> latter since it would be difficult to deploy such new and big 
> mechanism in the current mature networks.
> >>> 
> >>> Regards,
> >>> 
> >>> Sheng
> >>> 
> >>>> From: [email-masked] [mailto:[email-masked]] On 
> >>>> Behalf Of Brian E Carpenter
> >>>> Does anyone have the feeling that we have enough to chew on to 
> >>>> justify a renumbering BOF in Prague? I'd need at least one 
> >>>> significant topic to discuss, and a volunteer to produce 
> a draft in 
> >>>> the near future - the ADs are unlikely to approve a BOF 
> without any 
> >>>> sign of a draft.
> >>>> 
> >>>> Are we interested in developing such an approach? If so, there 
> >>>> isn't much time to do so:
> >>>> 
> >>>> 2011-01-31 (Monday): Cutoff date for BOF proposal 
> requests to Area 
> >>>> Directors at 17:00 PT
> >>>> 
> >>>> --
> >>>> Regards
> >>>>  Brian Carpenter
> >>>> 
> >>>>

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 24 Jan 2011 08:47:39 +1300

Hi everybody,

FYI, to get AD support for a BOF we really, really need the two
proposed I-Ds within one week at the most.

> 1. Problem statement (Sheng Jiang, Liu Bing) - this would be more focussed
> that RFC 5887, and I expect will concentrate on IPv6.
...
 > 2. A management model for systematic renumbering (Fred Baker).

Regards
   Brian Carpenter

---

From: Sheng Jiang <[email-masked]>
Date: Mon, 24 Jan 2011 04:02:04 +0800

>> that RFC 5887, and I expect will concentrate on IPv6.

The very first version has been finished and in private reviewing. It 
would be ready for submission soon.

Sheng

---

From: Ralph Droms <[email-masked]>
Date: Wed, 26 Jan 2011 10:10:46 +0100

FYI, please see http://trac.tools.ietf.org/bof/trac/ and http://www.rfc-editor.org/rfc/rfc5434.txt for more info on proposing a BoF.  Note that the BoF request deadline for IETF 80 is 1/31/2011.

Seems to me there are opportunities for a WG with deliverables ranging from Fred's thoughts about renumbering in the abstract to addressing specific problems raised in docs like RFC 4192, RFC 5887, draft-chown-v6ops-renumber-thinkabout, draft-jiang-ipv6-site-renum-guideline, etc.  The problem statement might be borrowed almost verbatim from the introduction to RFC 5887.  The biggest issue I see is focusing the WG in a target-rich environment, balancing system design against solutions for specific renumbering problems.

Here is a draft of a problem statement, with acknowledgments to the authors of RFC 5887 for reuse of their well-drafted text:

   Renumbering, especially for medium to large sites and networks, is
   widely viewed as an expensive, painful, and error-prone process,
   and is therefore avoided by network managers as much as possible.
   Some would argue that the very design of IP addressing and routing
   makes automatic renumbering intrinsically impossible.  In fact,
   managers have an economic incentive to avoid having to renumber,
   and many have resorted to private addressing and Network Address
   Translation (NAT) as a result.  This has the highly unfortunate
   consequence that any mechanisms for managing the scaling problems
   of wide-area (BGP4) routing that require occasional or frequent
   site renumbering have been consistently dismissed as unacceptable.
   However, renumbering is sometimes unavoidable.  The <renumbering>
   working group is identifying specific renumbering problems in the
   context of system-wide renumbering and developing point solutions
   and system solutions to address those problems.

   It is certainly to be expected that as the pressure on IPv4 address
   space intensifies in the next few years, there will be many
   attempts to consolidate usage of addresses so as to avoid wastage,
   as part of the "end game" for IPv4, which necessarily requires
   renumbering of the sites involved.  However, strategically, it is
   more important to implement and deploy techniques for IPv6
   renumbering, so that as IPv6 becomes universally deployed,
   renumbering becomes viewed as a relatively routine event.  In
   particular, some mechanisms being considered to allow indefinite
   scaling of the wide-area routing system might assume site
   renumbering to be a straightforward matter.

- Ralph

On Jan 23, 2011, at 9:02 PM 1/23/11, Sheng Jiang wrote:

> The very first version has been finished and in private reviewing. It would be ready for submission soon.
> 
> Sheng
> 
>> Regards
>>    Brian Carpenter
>> 
>> 
>> 
>>

---

From: Sheng Jiang <[email-masked]>
Date: Fri, 28 Jan 2011 12:21:36 +0800

Hi, Ralph,

Thanks for your email. It is really encourage. :) We are working on the 
BoF request. It will meet the deadline for sure.

Cheers,

Sheng

于 2011/1/26 17:10, Ralph Droms 写道:
>     However, renumbering is sometimes unavoidable.  The<renumbering>