Subject: [Revampers] Revamp of the www.ietf.org website - next steps

From: Russ Housley <[email-masked]>
Date: Tue, 1 Aug 2017 09:56:52 -0400

Thank you to everyone who took time to review and provide comments on the beta.ietf.org website. Based on feedback received, there seem to be a few key items requiring attention before taking the next steps to move the revamped public-facing website to production:

A. Provide a landing page dedicated to current IETF participants

That page will include links to:
  - items on the left-side at www.ietf.org (or a subset thereof)
  - information about the next IETF meeting 
  - links to functions at datatracker.ietf.org 

Ideally this would also be:
  - viewable in a single screen on a desktop/laptop display
  -  reachable via a short, memorable URL
    without images

A draft is currently posted at https://beta.ietf.org/links/

This page can be updated further based on input from the IETF community. There were also some suggestions received that revisions to datatracker.ietf.org might meet this need. While that is out of scope for this project, suggestions have been noted by the tools team.

B. Ensure WCAG 2.0 compliance

This is a requirement of the SOW and we are working with the developer to ensure it is implemented. The baseline goal is to improve upon the status of the current www.ietf.org site. Furthermore, improving accessibility will continue to be an area of focus for the revamped website.

C. Conduct review with other key audiences, especially potential participants and non-participants

Based on the project SOW (https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf) and the results of initial research (https://iaoc.ietf.org/documents/Torchbox_ETFUserresearch.pdf) additional interviews with members of the key audiences will be conducted to gather input. The results of those interviews will be incorporated into the project via issues noted at: https://github.com/ietf/www.ietf.org/issues  

D. Improve data use and load times

Load time and data usage was noted as being higher than the current www.ietf.org site. The expectation is that load times will improve as the beta site moves to production and is deployed on the CDN used by www.ietf.org. In addition, content elements such as images will be adjusted to improve performance. In particular, some of the potential participants and non-participants reviewers will be in locations with less robust connectivity and their input on this aspect of the revamped site will be sought out. This is an aspect called out in the SOW and will have ongoing attention.

Over the next few weeks, the project team will be working through these and some other issues, such as filling out content and moving to the the most current version of the open source Wagtail CMS. There will be ongoing efforts to improve the revamped site, so your ongoing input is encouraged. Feedback can be sent to  [email-masked] or issues can be raised at:

https://github.com/ietf/www.ietf.org/issues

Thanks again to all those who have provided input so far. I expect to be in touch again as we take final steps to move the site to production.

Sincerely,
  Russ Housley
  IETF Website Revamp Project Manager

---

From: Barry Leiba <[email-masked]>
Date: Tue, 1 Aug 2017 11:21:43 -0400

> A draft is currently posted at https://beta.ietf.org/links/

A good start.  One first comment:
Please, please, please get rid of the pale-blue-on-grey colour scheme
and stick with full-black on full-white.  This is for frequent fliers,
so let's make sure we can all read it clearly on all devices, and no
fall into the insane low-contrast trend that too many web sites are
using.

Barry

---

From: Ben Campbell <[email-masked]>
Date: Tue, 1 Aug 2017 10:30:08 -0500

> On Aug 1, 2017, at 10:21 AM, Barry Leiba <[email-masked]> wrote:
> 

+1, both on “good start” and “low-contrast trend”.

---

From: Greg Wood <[email-masked]>
Date: Thu, 10 Aug 2017 16:38:34 -0400

Hi Ben and Barry,

Thank you for the review.

Apologies for the delay in responding.

I’ve opened an issue on low contrast concern. (I suspect this will be addressed as part of finalizing WCAG 2.0 compliance.)

-Greg

> On Aug 1, 2017, at 11:30 AM, Ben Campbell <[email-masked]> wrote:
> 
>>