Subject: [rfc-i] Epub format tools

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 22 Nov 2016 10:10:19 -0500

The W3C has just absorbed the ebook publishing standards forum.

Since what they are doing is maintaining a subset of HTML and a packaging
format, wouldn't that be an appropriate basis for the upload format?
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Tue, 22 Nov 2016 15:48:29 +0000

Download format definitely.

I don’t see it as an upload format though.

                Tony Hansen

From: rfc-interest <[email-masked]> on behalf of Phillip Hallam-Baker <[email-masked]>
Date: Tuesday, November 22, 2016 at 10:10 AM
To: "[email-masked]" <[email-masked]>
Subject: [rfc-i] Epub format tools

Since what they are doing is maintaining a subset of HTML and a packaging format, wouldn't that be an appropriate basis for the upload format?

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 22 Nov 2016 11:22:30 -0500

They seem to have already done all the work on deciding what HTML features
to use. And they have a well developed tool chain.

Why reinvent the wheel?

On Tue, Nov 22, 2016 at 10:48 AM, HANSEN, TONY L <[email-masked]> wrote:

> *From: *rfc-interest <[email-masked]> on behalf of
> Phillip Hallam-Baker <[email-masked]>
> *Date: *Tuesday, November 22, 2016 at 10:10 AM
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *[rfc-i] Epub format tools
>
>
>

---

From: Julian Reschke <[email-masked]>
Date: Tue, 22 Nov 2016 17:27:59 +0100

On 2016-11-22 17:22, Phillip Hallam-Baker wrote:
> They seem to have already done all the work on deciding what HTML
> features to use. And they have a well developed tool chain.
>
> Why reinvent the wheel?

What problem do you want to solve exactly? Is this an attempt to undo 
the work on the new RFC format?

Best regards, Julian

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 22 Nov 2016 11:54:41 -0500

On Tue, Nov 22, 2016 at 11:27 AM, Julian Reschke <[email-masked]>
wrote:

> What problem do you want to solve exactly? Is this an attempt to undo the
> work on the new RFC format?
>
> Best regards, Julian
>

​We don't seem to be getting there very fast. ​At the current rate of
progress and given the resources currently available, I don't expect to be
able to use the new format till 2020.

The epub folk have a fully developed infrastructure supported by a mature
tool chain that is designed by people with experience of actually solving
these issues.

When it comes to code, I am utterly ruthless about consigning my own code
to the bit bucket when there is something better available. And I am even
more willing to drop other people's.

But in this case, it looks to me as if quite a few of those tools already
solve gaps in the system. How we organize composite documents for upload
for example. I don't see any reason for the IETF upload format to look any
different to the epub format with an XML2RFC document in place of the XHTML
files.
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Julian Reschke <[email-masked]>
Date: Tue, 22 Nov 2016 18:13:41 +0100

On 2016-11-22 17:54, Phillip Hallam-Baker wrote:
> On Tue, Nov 22, 2016 at 11:27 AM, Julian Reschke <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     What problem do you want to solve exactly? Is this an attempt to
>     undo the work on the new RFC format?
>
>     Best regards, Julian
>
>
> progress and given the resources currently available, I don't expect to
> be able to use the new format till 2020.

I agree it's too slow. That said, I'm already using big parts of it.

> The epub folk have a fully developed infrastructure supported by a
> mature tool chain that is designed by people with experience of actually
> solving these issues.
>
> When it comes to code, I am utterly ruthless about consigning my own
> code to the bit bucket when there is something better available. And I
> am even more willing to drop other people's.
>
> But in this case, it looks to me as if quite a few of those tools
> already solve gaps in the system. How we organize composite documents
> for upload for example. I don't see any reason for the IETF upload
> format to look any different to the epub format with an XML2RFC document
> in place of the XHTML files.

Ok, so yes, a ZIP file (that's what an epub file is) sounds like a good 
approach.

Best regards, Julian

---

From: Leonard Rosenthol <[email-masked]>
Date: Tue, 22 Nov 2016 21:18:46 +0000

We should be careful about exactly what happened.

The memberships of the IDPF and the W3C have both agreed to merge the organizations with the intent of developing FUTURE technology around the Open Web Platform and publications.  Existing standards (eg. EPUB 3.1) will continue to be NON-W3C standards, due to IP concerns.

There is work ongoing in the W3C to develop a new/modern publication technology set for the OWP as part of the DPUB initiative – however, it will be some time before that is more than just ideas.

Bottom line – Investment in EPUB (as we know it today) is a backwards approach.  Following the work of the DPUB community (of which both Heather and myself are active participants) will indeed be a good idea for this community as well.

Leonard

From: rfc-interest <[email-masked]> on behalf of Phillip Hallam-Baker <[email-masked]>
Date: Wednesday, November 23, 2016 at 1:10 AM
To: "[email-masked]" <[email-masked]>
Subject: [rfc-i] Epub format tools

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 30 Nov 2016 15:34:50 -0500

On Wed, Nov 30, 2016 at 3:25 PM, Joe Hildebrand <[email-masked]> wrote:

> > On Nov 22, 2016, at 9:54 AM, Phillip Hallam-Baker <[email-masked]>
> wrote:
> >
> The RFP is out for bid, and we expect a vendor selection imminently.
> Starting over with any other (even existing) toolset will certainly set us
> back by at least 2 years, perhaps more.
>
> -1 to starting over from scratch at this point.
>
​
I never said 'start from scratch'.

There is a lot of stuff there that we could take. In particular a tool
chain that already does much of what is needed.

It is also possible to move in the opposite direction. I already have a
tool chain for managing RFC format from Word document or Markdown source.
Adding ePub format to the tool is not a lot of work and gets me a vastly
larger audience.​
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Wed, 30 Nov 2016 14:57:03 -0800

On 11/30/16 12:34 PM, Phillip Hallam-Baker wrote:
> 
> 
> On Wed, Nov 30, 2016 at 3:25 PM, Joe Hildebrand <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     > On Nov 22, 2016, at 9:54 AM, Phillip Hallam-Baker <[email-masked] <mailto:[email-masked]>> wrote:
>     >
>     > ​We don't seem to be getting there very fast. ​At the current rate of progress and given the resources currently available, I don't expect to be able to use the new format till 2020.
> 
>     Starting over with any other (even existing) toolset will certainly
>     set us back by at least 2 years, perhaps more.
> 
> tool chain for managing RFC format from Word document or Markdown
> source. Adding ePub format to the tool is not a lot of work and gets me
> a vastly larger audience.​
>  
> 

EPUB was one of the formats I had hoped we would offer as one of the
outputs, but I have not found anyone willing to write the requirements
spec for it. I'm still open to the idea of having EPUB as an output
format at some point.

As for whether it's accepted as an Internet Draft input format, I
hesitate to add more input formats if we can avoid them, at least in
terms of what the RFC Editor accepts. I am trying to control cost and
complexity on our end, and limiting what is sent on to the editors to
just TXT and XML is definitely easier for us to manage.

-Heather