Subject: [rfc-i] xref to "References" section

From: Carsten Bormann <[email-masked]>
Date: Wed, 23 Nov 2016 06:08:06 +0100

There is an interesting issue on kramdown-rfc:

https://github.com/cabo/kramdown-rfc2629/issues/31

<references> does not allow an `anchor` attribute in RFC 7749, and XML2RFC enforces this.
In any case, use of this attribute would allow xrefs to “Informative References”/“Normative References”, but not to “References”, a section that is now generated automatically.

Any idea how to solve this with RFCXML?

Grüße, Carsten

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Julian Reschke <[email-masked]>
Date: Wed, 23 Nov 2016 07:37:44 +0100

> Any idea how to solve this with RFCXML?

I don't see an obvious way that wouldn't also make the XML invalid (in 
the sense of DTD/RNG).

Best regards, Julian