Subject: [rfc-i] rfc-editor: XML tagging question

From: Toerless Eckert <[email-masked]>
Date: Mon, 18 Dec 2017 06:03:03 +0100

Hi,

If this is not the RFC-XML helpline, i would appreciate if you could provide me with a pointer to a more appropriate list.

I am trying to create xref to entries in my documents list of terms/acronyms and am dissatisfied with the results. Hopefully there is a better way in RFC-XML to handle this:

I have some acronym definition thats has a reference to another acronym:

<t hangText="ACP address:">An IPv6 address assigned to the ACP node. It is stored in the domain information field of the <xref target="domcert-def">ACP domain certificate</xref>.</t>

This is the reference:

<t hangText="ACP Domain Certificate:" anchor="domcert-def">A provisioned certificate (LDevID) carrying the domain information field which is used by the ACP to learn its address in the ACP and to derive and cryptographically assert its membership in the ACP domain.</t>

xml2rfc turns the acronym definition into:

ACP address:  An IPv6 address assigned to the ACP node.  It is stored in the domain information field of the ACP domain certificate (Paragraph 21).  

The html conversion is fine, it converts to "ACP domain certificate" hotlink.

The PDF conversion also creates the silly "Paragraph 21" (that is crazy, why not the same hotlink as HTML ?).

Instead of "Paragraph 21", i would like to see something like the following in the text version (where obviously threre are no real hotlinks):

...field of the ->ACP domain certificate.
...field of the ->"ACP domain certificate".
...field of the (->ACP domain certificate).

etc. pp.

Any chance to achieve this - and also get corect hotlinks in HTML / PDF ?

If not... whats best practice here ?

Thanks!
    Toerless
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Julian Reschke <[email-masked]>
Date: Mon, 18 Dec 2017 06:25:00 +0100

> ...field of the (->ACP domain certificate).

Well, links to paragraphs are indeed severely limited wrt what text is 
generated.

Vocabulary-wise, using "format='title'" (in the <<ref>) might be closed 
to what you want - but I doubt any of the xml2rfc processors will use 
the hangText as title - but it might be an improvement you may want to 
ask for.

> ...

Which PDF conversion are you trying?

Best regards, Julian

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 18 Dec 2017 12:58:43 +0100

On Mon, Dec 18, 2017 at 06:25:00AM +0100, Julian Reschke wrote:
> Well, links to paragraphs are indeed severely limited wrt what text is generated.
> 
> Vocabulary-wise, using "format='title'" (in the <<ref>) might be
> closed to what you want - but I doubt any of the xml2rfc processors
> will use the hangText as title - but it might be an improvement you
> may want to ask for.

'title' leaves an empty title in text output:

  <xref target="domcert-def" format="title">->"ACP domain certificate"</xref>
  ->"ACP domain certificate" ()

'none' seems to work fine:
  ->"ACP domain certificate"

The PDF converters are pretty bad (https://xml2rfc.tools.ietf.org/)

The PDF text is just a PDF conversion of the traditional text format with
courioer font. Nice. But without any hyperlinks. Bad.

The PDF HTML conversion is PDF version of the HTML, but the hyperlink
for above source does not work. It does work in the HTML, and it does
when i convert HTML to PDF myself. Wonder where to send the bug report to..

This still leaves the question what RFC editor would say about above
proposed formatting for references to terminology definitions. Don't
want to add a bunch of them only to get after IESG feedback the
comment from RFC editor that they do not like that format.

Cheers
    Toerless

---

From: Julian Reschke <[email-masked]>
Date: Mon, 18 Dec 2017 13:08:14 +0100

>    ->"ACP domain certificate"

Please open a ticket at 
<https://trac.tools.ietf.org/tools/xml2rfc/trac/timeline>.

(FWIW, rfc2629.xslt already does this correctly).

 > courioer font. Nice. But without any hyperlinks. Bad.

Have a look at 
<https://www.greenbytes.de/tech/webdav/rfc2629xslt/rfc2629xslt.html#output.pdf>.

Best regards, Julian