Subject: [rfc-i] RFC template for new write up

From: Saravanan Arumugam <[email-masked]>
Date: Sat, 6 Jan 2018 14:24:54 +0530

Hi,

I would like to create a draft for a proposal in routing area(networking).

I have gone through "How to Write an RFC" PPT and helps me to understand
few things(publication processes, DOs and DONTs, other tools etc). But I
would like to get a template to fill my proposal which makes its more
simple, also to avoid any format related issues. Could you please help me
on this.

Thanks,
Saravanan
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Robert Sparks <[email-masked]>
Date: Mon, 8 Jan 2018 12:35:54 -0600

If you haven't seen it already, please look at

<https://www.rfc-editor.org/pubprocess/tools/>

In particular, take a look at kramdown-rfc2629 and the programs like it. 
It (and xml2rfc) takes care of the formatting for you, letting you focus 
on content.

RjS

On 1/6/18 2:54 AM, Saravanan Arumugam wrote:
> I have gone through "How to Write an RFC" PPT and helps me to 
> understand few things(publication processes, DOs and DONTs, other 
> tools etc). But I would like to get a template to fill my proposal 
> which makes its more simple, also to avoid any format related issues. 
> Could you please help me on this.
>
> Thanks,
> Saravanan
>
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 9 Jan 2018 07:46:55 +1300

> It (and xml2rfc) takes care of the formatting for you, letting you focus 

And if you want to use xml2rfc directly instead of kramdown, make sure
to install a decent xml editor rather than using a plain text editor.
(I use "XML Copy Editor" on Windows, but there are various alternatives.)

   Brian

---

From: Julian Reschke <[email-masked]>
Date: Mon, 8 Jan 2018 19:48:06 +0100

> It (and xml2rfc) takes care of the formatting for you, letting you focus 

Wow, that's really out-of-date. It still refers to RFC 2629...

Best regards, Julian

---

From: Sandy Ginoza <[email-masked]>
Date: Wed, 10 Jan 2018 17:58:30 -0800

Hi Julian,

> On Jan 8, 2018, at 10:48 AM, Julian Reschke <[email-masked]> wrote:
> 
>> In particular, take a look at kramdown-rfc2629 and the programs like it. It (and xml2rfc) takes care of the formatting for you, letting you focus on content.
>> RjS
> 
> Wow, that's really out-of-date. It still refers to RFC 2629…

Good point - we have updated the page to refer to RFC 7749.

Thanks,
Sandy

---

From: Ronald Tse <[email-masked]>
Date: Thu, 11 Jan 2018 05:01:26 +0000

Hi Saravanan,

You could consider using AsciiRFC (AsciiDoc for RFC) if you don’t want to deal with formatting and XML:

https://tools.ietf.org/html/draft-ribose-asciirfc-04

We’ve put up a simple and complete template of using AsciiRFC here, that you can just clone and start away:

https://github.com/riboseinc/rfc-asciirfc-template

A real-life example of using AsciiRFC for your reference:

https://github.com/riboseinc/rfc-crypto-sm4<https://github.com/riboseinc/rfc-crypto-sm3>
(and a funny one) https://github.com/riboseinc/rfc-camelot-holy-grenade

Kind regards,
Ron

_____________________________________

Ronald Tse
Ribose Inc.

On Jan 6, 2018, at 4:54 PM, Saravanan Arumugam <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

I have gone through "How to Write an RFC" PPT and helps me to understand few things(publication processes, DOs and DONTs, other tools etc). But I would like to get a template to fill my proposal which makes its more simple, also to avoid any format related issues. Could you please help me on this.

Thanks,
Saravanan
_______________________________________________
rfc-interest mailing list
[email-masked]<mailto:[email-masked]>
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Julian Reschke <[email-masked]>
Date: Thu, 11 Jan 2018 08:38:39 +0100

> Good point - we have updated the page to refer to RFC 7749.

Thanks!

Could you please also add:

"rfc2629.xslt (Julian Reschke)

     Converts XML to HTML or PDF; HTML conversion can happen directly in 
the web browser when opening the XML."

...and link that to 
<https://www.greenbytes.de/tech/webdav/rfc2629xslt/rfc2629xslt.html>?

Best regards, Julian