Subject: [rfc-i] Finding contributors

From: Brian E Carpenter <[email-masked]>
Date: Wed, 7 Feb 2018 14:04:08 +1300

Hi,

> On 03/02/2018 05:28, Michael H. Behringer wrote:
> ...
>>> Side question: how are contributors associated with an RFC in the datatracker? I mean if I search on the datatracker with someone's name, will the RFC where he has been contributors appear?
>> I believe contributors are not "found", on official searches. (Like the 
>> RFC editor page).

Do people think that RFC contributors (as described in RFC 7322) should
be "findable"?

(I'm raising the question here first. If people think the answer is yes,
it might also become a feature request for the IETF data tracker.)

   Brian
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 6 Feb 2018 20:17:57 -0500

Personally, I would not put much effort into making contributors 
findable.  We could discuss it again after we showed we cared about 
making authors findable by doing more than putting the then-current 
contact information in the RFC.
Yours,
Joel

---

From: Ronald Tse <[email-masked]>
Date: Wed, 7 Feb 2018 01:19:52 +0000

I agree that contributors should be made locate-able through datatracker.

If this is accepted, it would be best to extend the RFC XML structure to accept contributors as metadata with the role “contributor”, just like “editor” and “author” now. 

I wonder if the RFC XML v3 format could be updated to allow this?

Ron

_____________________________________

Ronald Tse
Ribose Inc.

> On Feb 7, 2018, at 9:04 AM, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi,
>

---

From: "John Levine" <[email-masked]>
Date: 6 Feb 2018 20:48:01 -0500

>contact information in the RFC.

On the rare occasion when I wonder to what RFCs Joe Blow might have
contributed, I find that grep works just fine.

The text of all RFCs published since the beginning of time is about
430 megabytes which these days is not a lot.  On my vintage 2012
laptop I can grep through them all in about 6 seconds.

R's,
John

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 7 Feb 2018 11:26:39 -0500

Even if you don’t have all of the RFCs available for a grep search, I’ve
found that Google works quite well, using a search like:

site:rfc-editor.org "Andrew Malis”

(or whoever else you’re looking for).

Cheers,
Andy

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 7 Feb 2018 18:57:16 +0100

XML, Web pages, Data-bases/tracker... gee, all this modern stuff.
You never know what depends on which if you are not on the inside
of that mesh. And given how RFC editor is not publishing normative
XML files for RFC, you can not use the source material (RFCs themselves)
in a reasonable fashion to get the information (too much text parsing
and potentially inconsistent across the staack).

IMHO, the primary source of truth is this: 

  ftp://ftp.rfc-editor.org/in-notes/rfc-index.txt

If contributors show up there (figure out a format extension to separate
from authors), i have the highest confidence that they will show up
in all representations the RFC editor has and short of an authoritative
rfc-index.xml, its IMHO actually authoritative.

Cheers
    Toerless

On Wed, Feb 07, 2018 at 01:19:52AM +0000, Ronald Tse wrote:
> If this is accepted, it would be best to extend the RFC XML structure to accept contributors as metadata with the role ???contributor???, just like ???editor??? and ???author??? now. 
> 

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 7 Feb 2018 21:27:07 +0100

RFCs should not bother to dynamically update author information
about they are published. But authors should be given good
choices to find them with the information put into the RFC,
but i would not put that burden on the RFC-editor infra.

But, The RFC-editor for example could ask during Auth48
(into the template text sent to authors).

-> Do you think your contact information is valid long term,
   across change of association ? If not:
   - you can ask us to add additional emails (after XML phase).
   - You can also provide a URI via your XML or txt draft,
     eg: your web/social-network site or the like.

Of course it would be nice if IETF wold give authors some
permanent email or URL, but thats a separate question IMHO,
especially because that would not necessarily apply to individual
submission stream RFCs.

Cheers
    Toerless

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 7 Feb 2018 16:58:12 -0500

Toerless,

> permanent email or URL

The ITU-T just ended their email service, I think the expenses were too
high.

The only SDO I’m aware of that still does that is the IEEE, and they charge
an annual membership fee.

Cheers,
Andy

---

From: Bob Hinden <[email-masked]>
Date: Wed, 7 Feb 2018 14:02:38 -0800

Brian,

> On Feb 6, 2018, at 5:04 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi,
> 
> be "findable”?

I think it depends somewhat on what you mean by “findable”.  If it’s their name, then a grep like solution or a new search item on the advanced search feature on rfc-editor.org would be fine.  If it is a current way to actually contact them, i.e. working email, postal address, etc., then I don’t think it will be maintainable.  It’s hard enough for actual authors.  Even these sometimes go stale between the time that the last draft is published and AUTH48.  Over time only it gets worse.

I think it’s only useful if it’s to find their names across multiple RFCs.  Putting more contact information in a database seems like a lot of work with little usefulness over time.

Bob

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 7 Feb 2018 23:31:15 +0100

Right. i was too terse:

Q: Whats my datatracker account profile good for, and who has access to it or even
   uses it ? Like my biography or address ? I couldn't figure out how to read
   somebody elses profile information. 

N: If the datatracker information was publically readable, i would just suggest
   to put a "Contact URL"  fields into the profile, and then we can simply
   put our datatracker profile URL into the RFC author URI field.
   And when i later change associations, i just need to update my datatracker profile page
   with new contact URL(s).

N: For email, i was not imagining an actual ietf email, but rather
   a proxy service, something like this:
   - add email to profile.
   - publically shown only: email address exists, last update <date>
   - proxy email service:
     - creates email forwarder <username>@proxy.ietf.org
     - mails would be forwarded, aka: new header, so sender can not
       figure out recipient address (from bounced emails etc..)
   - If proxy email service is attacked, protect sending emails
     from attacks:
     - to send emails to <username>@proxy.ietf.org:
     - send $1 payment to [email-masked], receive token number
       valid for 5 emails. Must include token into subject.
       Insert originator email from paypal
       transaction into proxied email.
     - make charges so large it pays for the service but not larger so
       that you don't have to bother about taxing income ;-)

Something like this. protected enough to run automatically without
more than initial dev work.

Cheers
    Toerless

On Wed, Feb 07, 2018 at 04:58:12PM -0500, Andrew G. Malis wrote:
> The only SDO I???m aware of that still does that is the IEEE, and they charge

---

From: Sarah B <[email-masked]>
Date: Thu, 8 Feb 2018 15:46:51 -0800

I agree with Joel. I take the information I put into the Authors section as "a point in time". Who works for the same company 30 years later? I'm sure the answer is "some people" but the vast majority of the use case is "none of us" and hence, the company info and/or email are subject to change. As an author, I take that into consideration, and I choose to use an email against a domain I own. Plenty of others don't. To each their own. :)

</2 cents>
Sarah

> On Feb 6, 2018, at 5:17 PM, Joel M. Halpern <[email-masked]> wrote:
> 
> Personally, I would not put much effort into making contributors findable.  We could discuss it again after we showed we cared about making authors findable by doing more than putting the then-current contact information in the RFC.
> Yours,
> Joel
>