Subject: [rfc-i] Embed SVG into i-d

From: Hirotaka NAKAJIMA <[email-masked]>
Date: Wed, 10 Oct 2018 09:15:00 +0900

Hi,

I’m not sure here is right to place to ask so I’m so sorry if here is not a right to place.

If I understand correctly, RFC7996 allows internet-draft to embed SVG drawings.
I’m currently composing this draft[0] with SVG drawings but I don’t know how to embed into XML.

I found embedded RFC[1] but I’m not sure how to post though datatracker.ietf.org since they only accept XML format.

Does anyone know how to embed SVG xml into I-D’s xml?
(I tried to embed this drawings[2] into xml formatted I-d but it doesn’t work)

[0] https://tools.ietf.org/html/draft-vcgtf-crypto-assets-security-considerations
[1] https://www.cs.auckland.ac.nz/~nevil/SVG_RFC_1.2/RFC%207996%20with%20SVG%20diagrams.html
[2] https://www.cs.auckland.ac.nz/~nevil/SVG_RFC_1.2/rfc4321-fig3.svg
--
Hirotaka NAKAJIMA
Senior Research Engineer, Mercari, Inc.
[email-masked]

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Jim Schaad <[email-masked]>
Date: Tue, 9 Oct 2018 17:36:19 -0700

In order to embed SVG, you will need to use the xml2rfc v3 schema.  Currently only v2 schema is being accepted although it is hoped that this will change soon.

Jim

> -----Original Message-----
> From: rfc-interest <[email-masked]> On Behalf Of Hirotaka
> NAKAJIMA
> Sent: Tuesday, October 9, 2018 5:15 PM
> To: [email-masked]
> Subject: [rfc-i] Embed SVG into i-d
> 
> Hi,
> 
> I found embedded RFC[1] but I’m not sure how to post though
> datatracker.ietf.org since they only accept XML format.
> 
> [1]
> https://www.cs.auckland.ac.nz/~nevil/SVG_RFC_1.2/RFC%207996%20with%20S
> VG%20diagrams.html

---

From: Hirotaka NAKAJIMA <[email-masked]>
Date: Wed, 10 Oct 2018 09:39:02 +0900

Hi Jim,

Thank you so much for this information.
I will take a look with xml2rfc v3 schema.

Many thanks!

Hiro

> On Oct 10, 2018, at 9:36, Jim Schaad <[email-masked]> wrote:
>